Jump to content

Kerbal Space Program 1.10: "Shared Horizons” Grand Discussion Thread


Recommended Posts

Well i am gonna wait then, i can handle few bugs but i am kinda disapointed something ''obvious'' like parts not obeying pressure limits(maybe even g limits) wasnt noticed before release.

Also if there are drag issues i for sure hope they are minor....not like before where you couldn't even get to orbit with the same vessel....

 

Link to post
Share on other sites
On 7/14/2020 at 12:57 PM, Boyster said:

Anyone else noticed parts not breaking due to pressure limits? Or its my save only.

On 7/14/2020 at 5:36 PM, Boyster said:

Its not just solar panels, its antennas, its everything.

And i am starting to think its even the g force break as well.

what how is this not discussed in these forums, these are major bugs...

 

I have been trying to follow this up, but the solar panels and other parts are imploding OK under enough pressure on my end

screenshot66.png


I have to ask, are you sure you have pressure limits turned on?
image.png

And are you using mods??
Can you provide the save you're having issues with?

Link to post
Share on other sites
7 hours ago, Just Jim said:

solar panels and other parts are imploding OK under enough pressure on my end

I think @Boyster means the problem with solar panels and antennae failing to be ripped off on re-entry reported here (link) and not the crushing controlled by the pressure-limits option.

The strange survival of solar panels through re-entry is not publicly visible on the bug-tracker yet, but mentioned as a 'known bug' up-thread.  Do you see it in your view or does it need a report?

Link to post
Share on other sites
1 hour ago, OHara said:

I think @Boyster means the problem with solar panels and antennae failing to be ripped off on re-entry reported here (link) and not the crushing controlled by the pressure-limits option.

The strange survival of solar panels through re-entry is not publicly visible on the bug-tracker yet, but mentioned as a 'known bug' up-thread.  Do you see it in your view or does it need a report?

OK... I see it now. Can someone please toss a bug report in for that?

Edited by Just Jim
Link to post
Share on other sites

New save, new install, no mods(Steam, all dlcs, verified files, cloud save is disabled).

A high TWR stock rocket: 

https://imgur.com/a/dn4vCmV

My difficulty settings are turned on(Even checked the persistent file to see if they are true there).

Its not only about re entry, its also when you launch,

Nothing is getting destroyed in 1.10 but in 1.9.1 after few seconds of launch anything that is left open(solar panels etc) is getting destroyed as normal pretty fast.

Also i tried some high g turns but not enough testing on that to see if wings rip apart.

Is it really only me that experiences this?

58 minutes ago, Just Jim said:

OK... I see it now. Can someone please toss a bug report in for that?

2 hours ago, OHara said:

I think @Boyster means the problem with solar panels and antennae failing to be ripped off on re-entry reported here (link) and not the crushing controlled by the pressure-limits option.

The strange survival of solar panels through re-entry is not publicly visible on the bug-tracker yet, but mentioned as a 'known bug' up-thread.  Do you see it in your view or does it need a report?

36 minutes ago, Bej Kerman said:

Check your difficulty settings

 

Edited by Boyster
Link to post
Share on other sites
1 hour ago, Boyster said:

othing is getting destroyed in 1.10 but in 1.9.1 after few seconds of launch anything that is left open(solar panels etc) is getting destroyed as normal pretty fast.

 

Known and reported bug

Link to post
Share on other sites
13 hours ago, Just Jim said:

Can someone please toss a bug report in for that?

I still can't find a report on the tracker, so I made one.

I can still break off wings in version 1.10.0 the same as with 1.7.3 (haven't tried in between)

The pictures in @Boyster's imgur link show the "destroyed by aero forces" message that marks when the force of the relative wind (a.k.a. dynamic pressure) breaks fragile parts (in versions other than 1.10.0) not the static pressure 
--- so to get the behaviour that @Boyster wanted you do not need to enable 'pressure limits' in versions before 1.10.0, and hopefully versions after.

Most people, I think, will not want to enable the options that Just Jim put in his image, unless they have a mod that makes them interesting.
The tolerance to static pressure for every single stock part is 4MPa = 40 atmospheres = 400 meters under water.   So all this option does is prevent submarines in hard mode.
The 'part G-force limits' are 50Gs, the same for every part; they might make it more difficult to protect lithobraking probes with sacrificial shells.

By contrast 'Kerbal G-force limits' just below these, is quite fun to have enabled.

Edited by OHara
don't need 'part pressure limits' option
Link to post
Share on other sites

I seem to have found weirdness with resource transfers.  Docked a craft to a space station.  Moved monoprop from one ship tank to a station tank, worked as usual.  Tried to move monoprop again after that, from the ship tank to a different tank on the station and nothing...  try again from any tank to any tank (intra-ship, intra-station, or between docked craft) and while the buttons go from IN/OUT to STOP as usual, nothing moves. :(

 

Edited by tg626
Link to post
Share on other sites

Awesome. Yay. Thanks for the half-resolution textures and unfixed 8 month old bug SQUAD. Good work, this is only the third update in a row (this time around) where you've failed to get the most basic features working. *Slow clap*

Thought I'd check in on the latest update, but it's just more  of the same not actually fixing things crap. Another .0 release, another bunch of new bugs, another 6 months waiting for the old ones to be completely ignored.

Is it really so hard to save application settings these days or what?
Oh, wait, it's SQUAD. They're just [snip] completely incapable of any engine-related programming. :rolleyes:

I'm going to go play something else now.

Edited by Vanamonde
Link to post
Share on other sites
31 minutes ago, Bej Kerman said:

Let's pray that Intercept can maintain their game better without introducing years worth of technical debt

That one's not even maintenance, it's a flat-out entry-level regression introduced in 1.8. Not fixing these is either gross incompetence or a-grade apathy.
It's not the usual "parachutes don't work" epic-level level QA fail either, basement-level functionality like settings actually being applied when the game starts up are things that should not break.

I knew how to load settings from disk reliably when I was 12, how can this possibly be broken? :confused:  Better yet, how can anyone think it's reasonable to leave it broken?

I can only conclude that the official release procedure at SQUAD is to select 3 checkboxes, click "build", then shoot yourself in the head. I give up. I'm done. I've been waiting seven years and this amateurish garbage is still being shipped.
 

Edited by steve_v
Link to post
Share on other sites
3 minutes ago, steve_v said:
32 minutes ago, Bej Kerman said:

Let's pray that Intercept can maintain their game better without introducing years worth of technical debt

That one's not even maintenance, it's a flat-out entry-level regression introduced in 1.8. Not fixing these is either gross incompetence or a-grade apathy.
It's not the usual "parachutes don't work" epic-level level QA fail either, basement-level functionality like settings actually being applied when the game starts up are things that should not break.

I can only conclude that the official release procedure at SQUAD is to select 3 checkboxes, click "build", then shoot yourself in the head. I give up. I'm done. I've been waiting seven years and this amateurish garbage is still being shipped.
 

If you dig around, there's probably some bugs old enough to not eat small parts that have yet to be fixed. 

Link to post
Share on other sites
  • 1 month later...

How come KSP 1.10 ESA update file is coming to my PS4! This is quite concerning. I am on 1.2 (when Maneuver nodes where introduced) when will this be fixed. I am a little disappointed and upset. Please fix this as soon as possible. I have also heard other people complain about this.

Link to post
Share on other sites
3 hours ago, Dr. Kerbal said:

How come KSP Enhanced Edition is. 5 Updates behind from the PC version?

Because after Squad makes a version, they hand it over to the company that converts it to the console version. That takes time. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...