Jump to content
  • 0

1.10 fuel transfer issue?


Question

Hello, it's been a while since I posted yet I've been playing!

 

Today my KSP updated to 1.10 and I'm not able to transfer fuel a second time or between more than one tank. The very first two tanks I select will do. But if I select one of those tanks and a third, the "out" will select and the "stop" button will show up but no fuel transfer will begin. The "in" won't do a thing.

 

 

Okay. I don't know what's going on but I tried to post this 3 times and without an error it takes me back to my post in progress missing images and some of the text. I don't get it.  I'll try to send this thread without screenshots.

Regards

 

 

Link to post
Share on other sites

19 answers to this question

Recommended Posts

  • 1
15 hours ago, Boyster said:

i hope its fixed soon

With history as my guide... I predict not.

Just install ShipManifest and forget about about stock fuel transfer for a while, it'll probably stay broken for the next nine months, like all the other bugs.

Edited by steve_v
Link to post
Share on other sites
  • 1
On 8/19/2020 at 2:22 PM, steve_v said:

With history as my guide... I predict not.

Just install ShipManifest and forget about about stock fuel transfer for a while, it'll probably stay broken for the next nine months, like all the other bugs.

Well, the bug is classified to have "low" severity in the tracker, so my best guess is that they are actively trying to introduce it into the KSP2 code base as well...

Link to post
Share on other sites
  • 0

have the same , takes over 30 minutes to refill tanks because i have to switch screens after ever transfer ( fuel , mono propellant , Ore )

going eva then back to station doesnt work ( guess , Same object ) , does work switching to other object ( sat or station ) and then back

Greetz Sixer

Link to post
Share on other sites
  • 0

I came here to report this issue, but I also have a potential workaround. I find that if I have two docked vessels, I can only transfer fuel one time. However, if after that transfer I close all fuel windows, pause the game, and unpause it, I can transfer fuel again one additional time. So in order to transfer fuel between multiple tanks, I have been double tapping escape between every transfer, which "resets" the bug and lets me transfer fuel between two more tanks.

Link to post
Share on other sites
  • 0
On 8/11/2020 at 8:29 AM, BlackholeKS said:

I came here to report this issue, but I also have a potential workaround. I find that if I have two docked vessels, I can only transfer fuel one time. However, if after that transfer I close all fuel windows, pause the game, and unpause it, I can transfer fuel again one additional time. So in order to transfer fuel between multiple tanks, I have been double tapping escape between every transfer, which "resets" the bug and lets me transfer fuel between two more tanks.

Aha. Excellent. I bet I accidentally did that before I pinned the fuel tanks.

Link to post
Share on other sites
  • 0
3 hours ago, steve_v said:

With history as my guide... I predict not.

Just install ShipManifest and forget about about stock fuel transfer for a while, it'll probably stay broken for the next nine months, like all the other bugs.

Hopefully not...i am sure they taking some off time after the last releases...so it might take a bit longer...but i hope its coming...

Link to post
Share on other sites
  • 0

I have found that sometimes it will and sometimes it won't allow me to transfer fuel.

When it doesn't I have to close the transfer windows and try again, sometimes starting with the other tank.

Usually after a few frustrating attempts it goes ahead and starts the transfer.

D.

 

 

Link to post
Share on other sites
  • 0

@HansAcker posted the easiest/fastest workaround for this bug!

  

3 hours ago, HansAcker said:

For the fuel transfer, the same workaround still applies that helped me in earlier versions where interrupted transfers wouldn't resumed: open the PAW of another part containing some resources (or just quickly mouse over the resource panel). That resets the fuel transfer.

 

 

Edited by Boyster
Link to post
Share on other sites
  • 0

hmm, I am able to transfer monoprop, but not fuel.

An no, there are no crossfeed rules I am missing.

Both types of fuel are welded together at the same point of my ship, they all have to go through the same dockingport (and thermal shield) to the station were both the monoprop and fueltank are also welded together.

Still, monoprop is transfered, fuel isn't.

 

wierd bug!!

5 minutes ago, EasyAce said:

hmm, I am able to transfer monoprop, but not fuel.

An no, there are no crossfeed rules I am missing.

Both types of fuel are welded together at the same point of my ship, they all have to go through the same dockingport (and thermal shield) to the station were both the monoprop and fueltank are also welded together.

Still, monoprop is transfered, fuel isn't.

 

wierd bug!!

https://imgur.com/a/TwITFZS

Link to post
Share on other sites
  • 0
35 minutes ago, EasyAce said:

Not sure with all the clipping and the thingies but i think you missing a crossfeed rule or having a side effect of clipping.

Maybe you could try putting a fuel tank onto that docking port and see if it works(I mean back on ground, do some simple testing).

Sry i am a bit tired but something is off in those pictures, maybe someone can be more specific.

Edited by Boyster
Link to post
Share on other sites
  • 0
13 minutes ago, Boyster said:

Not sure with all the clipping and the thingies but i think you missing a crossfeed rule or having a side effect of clipping.

Maybe you could try putting a fuel tank onto that docking port and see if it works(I mean back on ground, do some simple testing).

Sry i am a bit tired but something is off in those pictures, maybe someone can be more specific.

Nothing is off in the pictures :) The only clipping done here are the monoprop tanks I attached to the ship engine, turned 90 degrees and slided inside the stock fairing. No physical clipping, but codewise it might. The other thing I clipped are the pistons on the station. Those are moved inside so the only thing moving outside the station is the movable part. The panels stays on the outside at any point.

 

Either way... both these parts are outside the flow of fuel. The monoprop, clipped or not must go through the fueltanks and the dockingport.

The monoprop must run through the fuel tank on the ship, through the docking port, and through the fueltank on the station. It works.

The fuel though... that only needs to pass the docking port, does not. No clipped part involved.

Link to post
Share on other sites
  • 0
9 hours ago, EasyAce said:

The fuel though... that only needs to pass the docking port, does not. No clipped part involved.

Sorry, was really tired.

Thermal shield is blocking the fuel flow.It only allows monoprop.

I don't know why monoprop is allowed, bug or by design.

A well written quote i found:

Heat shields do not allow fuel crossfeed, and so you cannot transfer fuel across them if "Resource Transfer Obeys Crossfeed rules" is enabled.

With it disabled engines still won't be able to draw across them, but you will be able to manually pump fuel across.

Edited by Boyster
Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...