Jump to content

[1.12.x] L-Tech Continued Release


linuxgurugamer
 Share

Recommended Posts

On 9/12/2020 at 3:29 AM, hemeac said:

I've been running into an issue where my experiments with the Skylab can be repeated above what should be possible.  To give an example, the Plant Growth experiment has a base value of 50, science cap of 100, and biomeMask of 0 (so no biome specific results).  Remaining in high orbit around the Mun which has a science multiplier of 2 combined with a labBoostScalar of 10 in Skylab, that should give a maximum of 2000 science in that situation.  There seems to be an implicitly defined xmitDataScalar value set to 0.7, so every time I run the experiment yields about 700 experience (all good).  Yet I can run the experiment more than 3 times yielding over 2100 science (I stopped after this).  At best, I should be able to transmit 1400 and have to return the results of the experiment for the remaining 600. 

It appears that unlike stock science experiments, these experiments do not appear to be registering that they have completed.  Let me know if you need any more information. Here's my KSP log: Google Drive (zip)

bDEhoaPh.png

 

13 minutes ago, linuxgurugamer said:

Details, please

It's kind of what I've been discussing with @hemeac - you can see it clearly on his screenshot in the above post. L-Tech SkyLab experiments are biome-specific, but they don't provide the feedback of "Plant Growth experiment <situation>" in the results window. It doesn't keep it from working, per se, but it results in the confusion they're currently having.

Link to comment
Share on other sites

1 hour ago, etmoonshade said:

 

 

It's kind of what I've been discussing with @hemeac - you can see it clearly on his screenshot in the above post. L-Tech SkyLab experiments are biome-specific, but they don't provide the feedback of "Plant Growth experiment <situation>" in the results window. It doesn't keep it from working, per se, but it results in the confusion they're currently having.

 

Ok.  I did a little test with a crew report and mystery goo.  The stock experiments have the location specified after the name of the experiment in the report.

I'll figure out what's missing and get it fixed in the next few days.

Link to comment
Share on other sites

@linuxgurugamer and @etmoonshade.  Did a test with 0.5.1.6 with placing the vessel in a stationary orbit around Kerbin to maintain the same biome across several experiments.  It does appear that the science is transmitting correctly and are biome specific as I tested first in high orbit over the water and then again in high orbit over the desert.  One thing that I've noticed is that the experiments are visible in the science archives and when I did the last report, I did not see them.  Perhaps that was fixed due to the new update or the cleaner install (LTech w/ dependencies, HyperEdit, and Kerbal Engineer to verify the biome).

However, the issue remaining is that according to the science definitions in Resources/Skylab_ScienceDefs.cfg, the Skylab experiments should NOT be biome specific.  The config files all have a biomeMask = 0 and that should indicate that they should have only one report available per situation.  This does lead to a theoretical possibility with one station in low orbit and one in high orbit, you can research all nodes in Tiers 1 through 9 in the Community Tech Tree with only the microGrav experiment.  You can get 400 science multiplied by the 10x multiplier on the station module per biome x 9 biomes.  With the remaining experiments, you could research all nodes without ever landing on the mun or minmus.   

Link to comment
Share on other sites

13 hours ago, hemeac said:

However, the issue remaining is that according to the science definitions in Resources/Skylab_ScienceDefs.cfg, the Skylab experiments should NOT be biome specific.  The config files all have a biomeMask = 0 and that should indicate that they should have only one report available per situation.  This does lead to a theoretical possibility with one station in low orbit and one in high orbit, you can research all nodes in Tiers 1 through 9 in the Community Tech Tree with only the microGrav experiment.  You can get 400 science multiplied by the 10x multiplier on the station module per biome x 9 biomes.  With the remaining experiments, you could research all nodes without ever landing on the mun or minmus.

Ill try to look at that in a few days.  Could be that i fixed the wrong thing regarding the reporting

Edit:  I've poked at it a bit, and yes, that is what is supposed to happen (not related to biome). So the issue of Skylab experiments showing biome-specific messages was a red herring, and I'll revert that change when I get this bug fixed

Edited by linuxgurugamer
Link to comment
Share on other sites

New beta, 0.5.1.7

Available here:  https://github.com/linuxgurugamer/L-Tech/releases/tag/0.5.1.7

  • Reverted experiment report for the Skylab experiments, they are not biome specific
  • Added vessel situation to the experiment report for the Skylab experiments
  • Added vessel situation to Skylab menu
  • Improved experiment report for Skylab, to indicate InSpaceLow or InSpaceHigh
  • Fixed bug where science values were getting nerfed after saving and then reviewing
  • Added ModuleCommand to Skylab part (eliminates need for command module or probe core)
  • Added individual xmitDataScalar values for each experiment
  • Added automatic stop warp when completed
  • Added setting to make the autostop default always or not
  • Fixed max amounts for the seed containers
     

Note:  The value of the experiments have been reduced to approximate the values that Station Science provides.

If no issues arise, I'll change this into the full release in a few days

Link to comment
Share on other sites

  • 4 weeks later...
  • 3 months later...
  • 4 months later...

@linuxgurugamer may I ask you a question? Was item (IIRC any statics, inkluding KK bases were generating own report from foto) detection wiped completely or it just became tricky? I recieve only empty/standart situation reports from camera.

Saw in an old post:

Quote

The camera appeared to work fine, though we'll see if I still get the old anomaly bug that used to happen (take a picture of a planet from high up, and if there's an anomaly on that side of the planet you get 100 science instead of like, 4 - if I remember the bug correctly.)

I'm not sure that was a bug, maybe only imbalanced amount of science. But for now camera is cosplaying cheap standart experiment with burden from camera switch and screenshots spam. I hoped to get something like Tarsier, but for statics, not planets. Am i missing something in the process of foto-shoot or this aspect was removed? BTW - there used to be patch which adds Ltech foto-shoot to HullCamVDS cameras, now it's gone too...

Link to comment
Share on other sites

@linuxgurugamer May I suggest to add the ability to make science foto without entering cam view, directly from PAW, and without screenshot this way too. So that both actions will be possible - raw "quickshot" if we don't care about exact content of what's in view plus option to take carefully prepared shot through cam view, both result in the same science report. Sorry if I'm asking too much, I know there is quite  a pile of mods that you maintain, and Ltech is not top priority, I guess.

Link to comment
Share on other sites

On 6/16/2021 at 12:36 PM, Warro said:

Saw in an old post:

I'm not sure that was a bug, maybe only imbalanced amount of science.

Nah, it was a "WaitWhat" experiment type - it was either an anomaly, or a "this should never happen" type of bug. 100 science is reasonable (IMO) for an anomaly, but you could trigger it pretty much anywhere.

Link to comment
Share on other sites

3 minutes ago, etmoonshade said:

Nah, it was a "WaitWhat" experiment type - it was either an anomaly, or a "this should never happen" type of bug. 100 science is reasonable (IMO) for an anomaly, but you could trigger it pretty much anywhere.

Yes, WaitWhat was an anomaly, true, but proper reports for anomalies also used to be in mod, but now they're either gone or hard to achieve. I can remember how I've made Ltech reports for KerbinCity's airport and the city itself. Yes, it was when it was not abandoned yet, pretty far in the past...

Link to comment
Share on other sites

16 minutes ago, Warro said:

Yes, WaitWhat was an anomaly, true, but proper reports for anomalies also used to be in mod, but now they're either gone or hard to achieve. I can remember how I've made Ltech reports for KerbinCity's airport and the city itself. Yes, it was when it was not abandoned yet, pretty far in the past...

Hey, I'm surprised this was able to be resurrected in the first place, and we should be happy it even mostly works. If I remember correctly, this mod started back in 0.23. :D

Link to comment
Share on other sites

  • 3 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...