Jump to content

[1.8.1-1.11]R-T-B's Kopernicus Unified "Bleeding Edge" Branch


Recommended Posts

2 hours ago, R-T-B said:

No, because for whatever reason, these rogue ECs aren't measurable in code in any form I can find.  CalculateTracking is a void, it doesn't return any information.  You only discover the ECs after you launch the game and it's literally added every star twice, once with stock math, once with mine.  And the stock math can be crazy off in multistar situations...

Aww. I was hoping I made a useful suggestion. :D

Hmmmmmm. Could it be useful to look at KSPI-E and see how it does its radiator tracking code? They sort of... track the sun with their sides, and if they happen to be using the same function, maybe the issue is solved there? Again, spitballing here. :)

(I can totally stop suggesting stuff if you want, just let me know :P)

Link to post
Share on other sites
15 hours ago, etmoonshade said:

Aww. I was hoping I made a useful suggestion. :D

Hmmmmmm. Could it be useful to look at KSPI-E and see how it does its radiator tracking code? They sort of... track the sun with their sides, and if they happen to be using the same function, maybe the issue is solved there? Again, spitballing here. :)

(I can totally stop suggesting stuff if you want, just let me know :P)

No, being at a loss, any spitballs are helpful.  Hopefully one will hit something lol.

Another thought:  Kerbalism rolls its own panel code.  Maybe I can sort something out there.

 

Edited by R-T-B
Link to post
Share on other sites
9 hours ago, R-T-B said:

Another thought:  Kerbalism rolls its own panel code.  Maybe I can sort something out there.

Of course Kerbalism doesn't support multiple stars.  Can't hurt to try though.

Link to post
Share on other sites
On 8/2/2020 at 8:40 AM, R-T-B said:

We now only warn about the Ultra Shader being the only supported shader, we don't force it.

BE_191 warning persists in all scenes. Kinda annoying. Hot to make it go away? Beyond Home, shader quality high. https://yadi.sk/d/dFz50lmy3gKUyA

BTW anomalies fix seems to be working well

Edited by Hohmannson
Link to post
Share on other sites

I just ran into an issue, not sure if it's OPM or Kopernicus related, but I *think* it is, so I figure i'll drop it in here.

I noticed after I installed bleeding edge release 9 and OPM (was running stock solar system before that), that I stopped getting asteroid spawns. There were a few in orbit of Sarnus, but that's all I could find, and my SENTINEL scope in orbit below Kerbin wasn't finding anything either.

Checked the console after warping a while in the tracking station and there's a ton of NRE spam in the console. I backed up my save and pulled Kopernicus, MFI, and OPM out, and fired KSP up and went into the tracking station, fired up time warp, and pretty much immediately a bunch of new unknown objects spawned in around Kerbin, and there's no more NREs in the console.

Link to post
Share on other sites
On 8/3/2020 at 5:13 PM, Hohmannson said:

BE_191 warning persists in all scenes. Kinda annoying. Hot to make it go away? Beyond Home, shader quality high. https://yadi.sk/d/dFz50lmy3gKUyA

BTW anomalies fix seems to be working well

Yeah, there is a bug right now with the warning code.  It'll be fixed very soon here, my PC's old HDD crashed (hence my recent silence) so I'm doing a reinstall on a new SSD drive.

A good upgrade, just bad timing.  Will be back and looking at bugs in a moment.  But due to these delays, an honest true bugfix release is probably a day or two away.  Thanks for understanding.

6 hours ago, ddr3gamer said:

I just ran into an issue, not sure if it's OPM or Kopernicus related, but I *think* it is, so I figure i'll drop it in here.

I noticed after I installed bleeding edge release 9 and OPM (was running stock solar system before that), that I stopped getting asteroid spawns. There were a few in orbit of Sarnus, but that's all I could find, and my SENTINEL scope in orbit below Kerbin wasn't finding anything either.

Checked the console after warping a while in the tracking station and there's a ton of NRE spam in the console. I backed up my save and pulled Kopernicus, MFI, and OPM out, and fired KSP up and went into the tracking station, fired up time warp, and pretty much immediately a bunch of new unknown objects spawned in around Kerbin, and there's no more NREs in the console.

This is likely due to the new code for the anomalies fix.  It's been known to remove objects it should not (like in 1.10.1, it removes the main menu click points so you can't click buttons, lol).  We'll improve it shortly, if that's the origin.

Edited by R-T-B
Link to post
Share on other sites

I just finished my reinstall of my primary coding rig.
Given the hour, there probably won't be a bugfix until tomorrow, but we are back up and running.  In the meantime, could those of you experiencing issues with asteroids spawning in 1.10.1 please post logs?  I need more data to work on a fix there properly.

 

Link to post
Share on other sites
Bugfix fresh out of the oven!  No more frozen main menus or annoying warnings!

@R-T-B R-T-B released this now

This is R-T-B's "Bleeding Edge" branch of Kopernicus, intended to support the latest features, KSP editions, and also the latest bugs. Please keep in mind this branch may be more buggy than Prestja's mainline Kopernicus branch, but it also supports more KSP versions and has more features implemented for testing reasons. Many features that make it into mainline Kopernicus are born, tested, and trialed by fire here.

This is release 10. It contains the following changes:

1.) Fixed the "Ultra shader warning" sticking even after the main menu.

2.) Fixed the main menu freezing in some instances in 1.10.1, requiring arrow keys to navigate.

3.) Fixed ultra settings still being used despite being turned off, in some instances.

Known Bugs:

1.) Multistar packs are still buggy with regards to EC generation and lighting. Otherwise pretty bug free, I think.

Please download the right output zip for your version. "191" zips are for 1.9.1, "1101" for 1.10.1, etc.

Thanks and as always, report bugs!

-RTB

Link to post
Share on other sites
13 hours ago, R-T-B said:

In the meantime, could those of you experiencing issues with asteroids spawning in 1.10.1 please post logs?  I need more data to work on a fix there properly.

What's up with asteroids?  Back in June I did a bunch of experimentation with asteroids and wrote down my results.  Maybe it will help.

https://www.dropbox.com/s/lag8opde3zimjqc/KopernicusAsteroids.pdf?dl=0

Link to post
Share on other sites
1 hour ago, OhioBob said:

What's up with asteroids?  Back in June I did a bunch of experimentation with asteroids and wrote down my results.  Maybe it will help.

https://www.dropbox.com/s/lag8opde3zimjqc/KopernicusAsteroids.pdf?dl=0

People were reporting they weren't spawning in 1.10.1.  I have no idea if that's a real issue or isolated to a bad mod install though.

Link to post
Share on other sites

I'm seeking feedback on the templated-world fixes.

Are templates working properly now?  Monoliths not be cloned to templates, etc?  Main menu works in 1.10.1 with JNSQ and other mods?  If it's testing out good, it's probably time to push that to stable branch.

Link to post
Share on other sites
7 hours ago, R-T-B said:

I'm seeking feedback on the templated-world fixes.

Are templates working properly now?  Monoliths not be cloned to templates, etc?  Main menu works in 1.10.1 with JNSQ and other mods?  If it's testing out good, it's probably time to push that to stable branch.

Is it necessary to clean Kopernicus cache and start a new game to check it? If not - i see them on UBE-10.

UPD: Anomalies not fixed, warning is fixed.

Edited by Hohmannson
Link to post
Share on other sites
2 hours ago, R-T-B said:

I'm seeking feedback on the templated-world fixes.

Are templates working properly now?  Monoliths not be cloned to templates, etc?  Main menu works in 1.10.1 with JNSQ and other mods?  If it's testing out good, it's probably time to push that to stable branch.

I'm probably an hour or so from firing up KSP again - I'll put on BE10 and see what's up since I'm around Slate right now.

Link to post
Share on other sites
3 hours ago, R-T-B said:

Are templates working properly now?  Monoliths not be cloned to templates, etc?  Main menu works in 1.10.1 with JNSQ and other mods?  If it's testing out good, it's probably time to push that to stable branch.

I confirm the main menu fix is working in 1.10.1 with JNSQ.

Link to post
Share on other sites
6 hours ago, etmoonshade said:

I'm probably an hour or so from firing up KSP again - I'll put on BE10 and see what's up since I'm around Slate right now.

lol an hour that totally worked as expected

@R-T-B

On the plus side, randoliths are now placed not-at-the-poles! I'm not sure if OPM includes any hand-placed anomalies, but I'm going to take a look on one of the other planets around Sarnus.

On the minus side, I think that randoliths aren't giving science still. I can't tell for sure, because the randolith on Slate is on the side of a 20 degree mountain slope that's in the dark right now, so my landing attempt near it failed hard* - I have no clue if I was even close enough to trigger the random science bit, not that the vessel survived long enough to notice. :V

* as expected, to be fair, and I had a quicksave - a 1100t lander can't exactly land on a slope like that with 0.8g...

Link to post
Share on other sites
7 hours ago, Hohmannson said:

Is it necessary to clean Kopernicus cache and start a new game to check it? If not - i see them on UBE-10.

UPD: Anomalies not fixed, warning is fixed.

Thank you for the report.  What pack do you see them in?  I don't think they should persist across a save game but it is possible, unfortunately.  Coupled with this report:

 

14 minutes ago, etmoonshade said:

On the plus side, randoliths are now placed not-at-the-poles!

I think a new save may be required to get that fix.  Darn, was hoping we could avoid that.  Oh well.

14 minutes ago, etmoonshade said:

On the minus side, I think that randoliths aren't giving science still. I can't tell for sure, because the randolith on Slate is on the side of a 20 degree mountain slope that's in the dark right now, so my landing attempt near it failed hard* - I have no clue if I was even close enough to trigger the random science bit, not that the vessel survived long enough to notice. :V

Dang, but that was kind of expected, I never addressed the science part of the bug.  That'll probably be next on the list.

5 hours ago, Leprechaun said:

I confirm the main menu fix is working in 1.10.1 with JNSQ.

Good, thought I got that one in testing but could not remember.  Thanks for the confirmation.

Bottom line, I think this is overall a good set of fixes without drawbacks that can go to standard branch, probably tomorrow.  Thanks for the help everyone.

Edited by R-T-B
Link to post
Share on other sites
Just now, R-T-B said:

I think a new save may be required to get that fix.

I started a new save. After Kerbin. Similar to BH, most of its bodies are Removeallpqsmods=true, but sadly i see Tylo cave on Tylo-templated bodies in logs and on Scansat.

Link to post
Share on other sites
Just now, Hohmannson said:

I started a new save. After Kerbin. Similar to BH, most of its bodies are Removeallpqsmods=true, but sadly i see Tylo cave on Tylo-templated bodies in logs and on Scansat.

Maybe I only fixed Randoliths, based on the above comment.  If so, that's going to be interesting.  Anyone have any idea what to try next to fix non randoliths?  lol.  I'll need to think on it.

Link to post
Share on other sites
2 minutes ago, R-T-B said:

Maybe I only fixed Randoliths, based on the above comment.  If so, that's going to be interesting.  Anyone have any idea what to try next to fix non randoliths?  lol.  I'll need to think on it.

[LOG 00:06:33]:       Cave (UnityEngine.GameObject)
[LOG 00:06:33]:        >>> Components <<< 
[LOG 00:06:33]:        Cave (UnityEngine.Transform)
[LOG 00:06:33]:        Cave (PQSCity)
[LOG 00:06:33]:        >>> ---------- <<< 
[LOG 00:06:33]:           Big Cave (UnityEngine.GameObject)
[LOG 00:06:33]:            >>> Components <<< 
[LOG 00:06:33]:            Big Cave (UnityEngine.Transform)
[LOG 00:06:33]:            Big Cave (UnityEngine.MeshFilter)
[LOG 00:06:33]:            Big Cave (UnityEngine.MeshRenderer)
[LOG 00:06:33]:            Big Cave (UnityEngine.MeshCollider)
[LOG 00:06:33]:            >>> ---------- <<< 
[LOG 00:06:33]:       Randolith (UnityEngine.GameObject)
[LOG 00:06:33]:        >>> Components <<< 
[LOG 00:06:33]:        Randolith (UnityEngine.Transform)
[LOG 00:06:33]:        Randolith (PQSCity)
[LOG 00:06:33]:        Randolith (PrefabSpawner)
[LOG 00:06:33]:        >>> ---------- <<< 
[LOG 00:06:33]:           monolith01 (UnityEngine.GameObject)
[LOG 00:06:33]:            >>> Components <<< 
[LOG 00:06:33]:            monolith01 (UnityEngine.Transform)
[LOG 00:06:33]:            monolith01 (UnityEngine.MeshFilter)
[LOG 00:06:33]:            monolith01 (UnityEngine.MeshRenderer)
[LOG 00:06:33]:            monolith01 (UnityEngine.Animation)
[LOG 00:06:33]:            monolith01 (UnityEngine.MeshCollider)
[LOG 00:06:33]:            >>> ---------- <<< 

 

Link to post
Share on other sites
2 minutes ago, Hohmannson said:
[LOG 00:06:33]:       Cave (UnityEngine.GameObject)
[LOG 00:06:33]:        >>> Components <<< 
[LOG 00:06:33]:        Cave (UnityEngine.Transform)
[LOG 00:06:33]:        Cave (PQSCity)
[LOG 00:06:33]:        >>> ---------- <<< 
[LOG 00:06:33]:           Big Cave (UnityEngine.GameObject)
[LOG 00:06:33]:            >>> Components <<< 
[LOG 00:06:33]:            Big Cave (UnityEngine.Transform)
[LOG 00:06:33]:            Big Cave (UnityEngine.MeshFilter)
[LOG 00:06:33]:            Big Cave (UnityEngine.MeshRenderer)
[LOG 00:06:33]:            Big Cave (UnityEngine.MeshCollider)
[LOG 00:06:33]:            >>> ---------- <<< 
[LOG 00:06:33]:       Randolith (UnityEngine.GameObject)
[LOG 00:06:33]:        >>> Components <<< 
[LOG 00:06:33]:        Randolith (UnityEngine.Transform)
[LOG 00:06:33]:        Randolith (PQSCity)
[LOG 00:06:33]:        Randolith (PrefabSpawner)
[LOG 00:06:33]:        >>> ---------- <<< 
[LOG 00:06:33]:           monolith01 (UnityEngine.GameObject)
[LOG 00:06:33]:            >>> Components <<< 
[LOG 00:06:33]:            monolith01 (UnityEngine.Transform)
[LOG 00:06:33]:            monolith01 (UnityEngine.MeshFilter)
[LOG 00:06:33]:            monolith01 (UnityEngine.MeshRenderer)
[LOG 00:06:33]:            monolith01 (UnityEngine.Animation)
[LOG 00:06:33]:            monolith01 (UnityEngine.MeshCollider)
[LOG 00:06:33]:            >>> ---------- <<< 

 

Yeah, that's been in the logs since the update to 1.9.1...  I never caught that it was talking about PQS's though.  Good catch.  I have no idea what generates that long string or what it means, but it's a clue I'm sure.  Thanks.

Did you actually see the big cave etc?  Because these could be logs claiming it's removing them if not.

Edited by R-T-B
Link to post
Share on other sites
7 minutes ago, R-T-B said:

I don't think they should persist across a save game but it is possible, unfortunately.

 

2 minutes ago, R-T-B said:

Maybe I only fixed Randoliths, based on the above comment.  If so, that's going to be interesting.  Anyone have any idea what to try next to fix non randoliths?  lol.  I'll need to think on it.

Actually, I had already scanned the randolith, and it was at the poles before I did the update to BE10. I'm about to land on Ovok, which is a much less dicey proposition for this lander - I'll see if that Minmus munolith (minmolith?) is still floating above the terrain in the same spot.

Taking this lander to Sarnus was really dumb. All the bodies are either high gravity or too bumpy. :mad:

(I guess I'll hit Eeloo next - at least I know that one's relatively flat and has plenty of biomes to snag science on...)

Link to post
Share on other sites
1 minute ago, etmoonshade said:

 

Actually, I had already scanned the randolith, and it was at the poles before I did the update to BE10. I'm about to land on Ovok, which is a much less dicey proposition for this lander - I'll see if that Minmus munolith (minmolith?) is still floating above the terrain in the same spot.

Taking this lander to Sarnus was really dumb. All the bodies are either high gravity or too bumpy. :mad:

(I guess I'll hit Eeloo next - at least I know that one's relatively flat and has plenty of biomes to snag science on...)

I really appreciate the real-game tests.  God speed test-lander.

Link to post
Share on other sites
Just now, R-T-B said:

I really appreciate the real-game tests.  God speed test-lander.

Oh no, this isn't a test lander. This is a long-range full-science lander from my existing game. It's got everything but the kitchen sink, and that's only because there's not a mod for that as far as I know.

It's also excessively heavy, but has ion-based engines so the dV is absurd (and now that I think of it, my TWR was probably REALLY low for landing on Slate anyway...)

As for the testing - just finished my scansat of Ovok, and I do see an anomaly in a spot similar to where it was last time - I'm betting that's the minmolith that shouldn't be there.

Your choice - do you want me to check out the randolith for science first, or do you want me to verify the minmolith? :P

Link to post
Share on other sites
2 minutes ago, R-T-B said:

Did you actually see the big cave etc?

On Scansat only - that moon is rocky an i think it`s sunken into mountains. I started a new game and same thing. And - the home planet is configured to remove Pyramids(and their mapdecal), and then i could see them. Even landed there. It was in the middle of ocean, definitely not meant to be there.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...