Jump to content

[1.9.1+] OPT Spaceplane Continued 3.1.1 [Mar 06, 2021]


JadeOfMaar
 Share

Recommended Posts

On 1/15/2022 at 12:08 AM, Folkhoer said:

Can I make this mod compatible with Tweakscale?

I'd rather you did not, as some tank switch providers that OPT is compatible with, are themselves not compatible with Tweakscale (as far as I know).

@planeticegaming Your question is inside the quote. Made me think your post was empty. Ignoring that... the wheels are Restocked.

Link to comment
Share on other sites

On 10/24/2021 at 6:51 AM, Lightlaw said:

Hello, just a quick question about OPT parts and their control surfaces and wings. When I try to use any with my planes none of them seem to have any effect on aerodynamics. I have both OPT files and the OPT Config files, is there something I'm missing or are they still suppose to be broken and only for looks?

I have tried the parts set with FAR and they work, but I would rather not play with that mod installed on KSP.

Edit: Updating to 1.12.2 from 1.11.1 seems to have fixed the parts. I think I've solved my problems for now.

Hello, I have exactly the same problem. All OPT parts no longer have any aerodynamic characteristics. This from version 1.11.1 of the game (and all subsequent versions).
In version 1.10.1, parts regain their lift, but shutters and other moving elements still cannot be configured.
I mistakenly installed "Ferram Aerospace Research Continued" along with a few other mods ("recommended mods" were enabled under CKAN during an update and it screwed up). I removed "Ferram" but since then the OPT parts no longer work.
I completely deleted and reinstalled the three OPT mods, but nothing helped, my ships are no longer good for more than bricks for catapults.
Does anyone have a miracle procedure to solve the problem?
Thank you very much in advance!

2puCTOf.jpg

Edited by Hira
Link to comment
Share on other sites

1 hour ago, Hira said:

PS: how to add a screenshot directly here? I don't have any options for this in the compose window other than the "insert image from URL" button.

Can't link directly. Have to go here. https://imgur.com/

Click "new post", green button top left. Drag your screenshot onto that page to upload there. Then click on the 3 dots top right of your image when you hover over it, then "get share links, then click green "copy Link" next to the BB entry to get the link. Open your comment here, click "insert image from URL", paste in the link, remove the square brackets and their img contents from each end and then submit. No need to join imgur or register. Sadly that is the simplest way known to get your pics up here.

Good Luck.

Link to comment
Share on other sites

@Hira By chance do you still have an empty FerramAerospaceResearch folder? Or do you have a config somewhere (in some other mod) that contains :FOR[FerramAerospaceResearch] ? If either is true then MM thinks that FAR is still installed. It might help to delete GameData/ModuleManager.ConfigCache as sometimes this cache can be poisoned or can fail to update after some mods are added or removed.

Link to comment
Share on other sites

On 1/15/2022 at 1:08 AM, Folkhoer said:

Can I make this mod compatible with Tweakscale?

Yes!!

https://github.com/net-lisias-ksp/TweakScaleCompanion_OPT/releases

Keep an eye on the TweakScale Companion Program's Thread for news about 3rd Party support!

Edited by Lisias
Fixing a double post merged by Forum...
Link to comment
Share on other sites

On 1/20/2022 at 12:18 AM, JadeOfMaar said:

@Hira By chance do you still have an empty FerramAerospaceResearch folder? Or do you have a config somewhere (in some other mod) that contains :FOR[FerramAerospaceResearch] ? If either is true then MM thinks that FAR is still installed. It might help to delete GameData/ModuleManager.ConfigCache as sometimes this cache can be poisoned or can fail to update after some mods are added or removed.

Thank you very much for the help! I deleted the ModuleManager.ConfigCache, as well as a Custom_FARAeroData.cfg lying around in GameData, reinstalled ModuleManager clean and the problem is solved! :-D

Link to comment
Share on other sites

For some reason all my OPT engines suddenly are in need of propellium as a resource but I don't have even have propellium in my stock tanks. I have Cryo Tanks installed and all my OPT files are up to date. Some help would be very much appreciated.

Link to comment
Share on other sites

@MrLibeRation Does the path GameData/WildBlueIndustries/ClassicStockResources/ exist? If it does, be sure to delete it and not have any other WBI mods installed in Classic Stock mode (easily dealt with via CKAN). It should aslo help to open GameData/WBIPlayMode.cfg and change its name value from "Classic Stock" to "CRP" (no quotes).

If the issue persists I'll need to see your KSP/Logs/ModuleManger/ logs, so I can spot the config, if it exists, which contains :FOR[ClassicStock]

@Stone Blue "OPT Reconfig CryoEngines" is an extras/ config. Doesn't require B9PS or OPT Reconfig.

Edited by JadeOfMaar
Link to comment
Share on other sites

Hey guys, i got a problem here with the vtol engines.

If you guys could help it would be greatly appreciated.

Sorry if this error was posted again, please link me to the solution if it has been resolved.

in Vtol mode the engines cannot pitch correctly if i press S ( raise nose/ pitch up the engines go the opposite way vectoring the thrusters to pitch my nose down - notice the flaps movements for reference). If i press W nothing happens.

Maybe i am missing something here ?

in normal mode everything seems fine. I tried rotating them, inverting them, switching the deployment angles and nothing helps. It seems to be an easy fix maybe flip the controls when in VTOL mode.

Any help is greatly appreciated since i use this for my work :)

Thank you.

tl;dr: vtol engines work the opposite way in vtol mode and only in one direction

https://www.dropbox.com/s/m7sdd49kohva9dn/ice_capture_20220129-234500_KSP_x64.avi?dl=0

 

P.S.

These are the mods installed:

OPT_reconfig

OPT

BDArmory

B9Part Switch

Edited by ikarus
details
Link to comment
Share on other sites

I tried removing the BDA stuff but its still the same.

It has something to do with the deployment angle limiting the angle of pitch. If i set it to 60 degrees it is able to pitch both ways ( still reversed tho) but we don't want that since it's not pointing straight down. When i set it to 90 so that it points straight down it only pitches in one way (again, the controls still being reversed).

 

Thanks for the reply tho.

Link to comment
Share on other sites

  • 2 months later...
On 4/14/2022 at 5:22 AM, Netruny_Black145 said:

tnx for creating this piece of art , im running the mod 1.12.3 and i dont have the irradiance engine , how i can fix it?

I only adopted it, though I've added to it. OPT is a bunch of three mods. The folder names are OPT, OPT_Legacy (these two are parts) and OPT_Reconfig.

If you're missing certain parts then they're likely in Legacy.

Link to comment
Share on other sites

2 hours ago, BlueBirdAzurite said:

I don't know how to fix this, but the fuel tank parts doesn't hold any fuel and doesn't give any any choices of fuel, it acts basically as a structure.

 

Do you have all of the dependencies installed? Are you lacking B9 part switch? Or Community Resource pack?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...