Jump to content

[1.9.1+] OPT Spaceplane Continued 3.1.1 [Mar 06, 2021]


JadeOfMaar
 Share

Recommended Posts

1 hour ago, RevKefira said:

Hi,
do I understand correctly that the problem with some of the details from release 3.0 is still relevant? I am using KSP 1.12 and have encountered spawn of the listed parts at a height of two kilometers.

Yeah, that's still there. Those aren't getting fixed anytime soon, sorry.

Link to comment
Share on other sites

  • 2 weeks later...

Hello Jade of Maar.

I have 2 questions.

1/ What is that Atmosphere convertor that I see on some of the Intakes ?      And does it work on Duna  where there is no Oxygen but Atmosphere is ?

2/ I want to confirm my folders for OPT :

Kerbal Space Program\GameData\Opt

Kerbal Space Program\GameData\Opt_Legacy

Kerbal Space Program\GameData\Opt_Reconfig

 

Is it OK or I should delete or merge some of those folders ? 

Thank you

Link to comment
Share on other sites

@Jovzin No, that folder structure is correct... all three should be their own folder in GameData

As to question #1, there may be a deeper issue youre seeing, but make sure you have Community Resource Pack installed, as well.... It is a dependency for OPT Reconfig.

Edited by Stone Blue
Link to comment
Share on other sites

Hello, I'm attempting to use OPT in this career and Im finding if I put any of the OPT rear cargo ramp parts on my craft seems to detonate on load sending parts out of the Kerbin system from as far as I can tell faster than 1c.  I have tried adding world stabilizer to the mod list but it doesnt appear to help in any way.  Any ideas would be great thank you.

Link to comment
Share on other sites

@Stone Blue   Thank you I enabled the CRP option in WBI  and now I see and can change the Fuel to use IntakeAtm too. And looks like that Atmosphere Convertor is not working too :)

 

But I have one more problem. Not sure if you experienced it.  When I save a game with some OPT plane in orbit. And when I load the game and return back to that plane suddenly the VTOL engines are running. They are in shutdown mode , even the fuel is disabled. But somehow the animation and sound of for example OPT-E VT "Valkyrie" Tilt Engine   is running.    I see the speed is not increasing and the engine is shutdown but somehow the animation and sound is playing in a loop.  Was trying to reload the save and reload the game but still the same. 

 

 

Link to comment
Share on other sites

On 11/3/2022 at 5:27 AM, Jovzin said:

But I have one more problem. Not sure if you experienced it.  When I save a game with some OPT plane in orbit. And when I load the game and return back to that plane suddenly the VTOL engines are running. They are in shutdown mode , even the fuel is disabled. But somehow the animation and sound of for example OPT-E VT "Valkyrie" Tilt Engine   is running.    I see the speed is not increasing and the engine is shutdown but somehow the animation and sound is playing in a loop.  Was trying to reload the save and reload the game but still the same.

My guess is some plugin mod must be misbehaving (I'm cautious of mods not rated for KSP 1.8 or newer) or your save somehow corrupted. Create a new save and test the same plane(s) in it. If this started after you updated your KSP to 1.12.4 (assuming you did) then try copying your save and modlist back to 1.12.3 or 1.12.2.

 

9 hours ago, 17141 said:

Hi there, been having some trouble with my k size modules as most of the show only the k spaceplane cockpit, is there a solution to this?

You have these paths to take. Each one requires more work than the previous:

  1. If you have a highly modded install and only recently installed OPT then re-download it. Chances are good that your download is corrupted.
  2. Purge your mods and reinstall them all fresh. I assume you take the liberty of using CKAN.
  3. If you've had OPT around earlier and you installed a few mods or individual patches after it and then this problem started, assume that there's a low quality patch mod somewhere and it broke OPT. Remove recent mods (a few at a time, helps you isolate the offender) until the problem goes away. If you find the offender I can look into it and point out the syntax errors.

 

Link to comment
Share on other sites

Reply to JadeOfMaar

In case if I wasn't clear, I was meaning that the interior on most of the k fuselage like the K science lab and the K passenger fuselage, as well as the avatar cockpit showing only the normal k cockpit.

Sorry if I don't have any picture of it, but I hope you know what you mean.

 

 

Link to comment
Share on other sites

On 11/8/2022 at 6:34 AM, 17141 said:

Reply to JadeOfMaar

Oh and I got the mod from space dock, could you try and put the continued up on github please

it *IS* on github... *all* three OPT mods are in the same repo, here:
https://github.com/StoneBlue/OPT_Streamlined

"Continued" is the /OPT/ folder

Edited by Stone Blue
Link to comment
Share on other sites

On 11/8/2022 at 3:50 AM, 17141 said:

like the K science lab and the K passenger fuselage

I don't make IVAs (yet, anyway) so these have placeholder just so you can see kerbal portraits when kerbals are in there. The original part maker made the IVAs.

On 11/8/2022 at 3:50 AM, 17141 said:

avatar cockpit showing only the normal k cockpit

That might be by design. The Avatar body was previously the K body... Unless there's an Avatar cockpit where the K cockpit IVA is misaligned or has very different window hole shapes.

Link to comment
Share on other sites

@Jovzin  (That might be by design. The Avatar body was previously the K body... Unless there's an Avatar cockpit where the K cockpit IVA is misaligned or has very different window hole shapes.)

It is actually in the original mod

Edited by 17141
Link to comment
Share on other sites

@17141 Hi. You might want to put more effort into spelling my username correctly. I'm not "Jozvin."

Sorry, I don't have any guesses to why only the OPT wings  become non-functional. Perhaps delete this file GameData/ModuleManager.ConfigCache and let KSP regenerate it.

Link to comment
Share on other sites

  • 2 weeks later...
On 11/16/2022 at 9:45 AM, 17141 said:

@Jovzin 

Hi

I've been having trouble with the wings in the mod recently as they now won't register lift in the hanger and in flight, they don't operate at all yet the stock wings work perfectly fine.

Is there a solution please?

I have the same issue for OPT craft. for me it is either not lifting or the whole aircraft YAWs suddenly. I am confused if it is either due to wings or engines. I guess wings cuz when using stock engines the same spinning mid air happens.

 

I reckon you found the fix, can you please tell me how did you do that?? Thanks!

I mean it happens when I use OPT parts to make the craft either the craft dosen't generate lift or it spins mid air uncontrollably 

 

Here is the full log file

https://drive.google.com/file/d/1aw45yNzZBft9RA6ppzOvdM5E2JJNfsM1/view?usp=share_link

Link to comment
Share on other sites

I know it is funny but for some reason OPT fuel tanks stopped working, like there is no fuel in them. I freshly installed both game and the mod but the fuel tanks are static objects now for me!

 

A help or idea would be great! thanks....

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...