Jump to content

[1.9.1+] OPT Spaceplane Continued 3.1.1 [Mar 06, 2021]


Recommended Posts

Jade you are the greatest for adding RO support! I have missed your mods but can't play without RO now.

Is there anything need for the RP tech tree or will I need to make a MM patch for it?

Link to post
Share on other sites

I don't know if it's a bug or not, but the science container (using restock) has ~560 units of dark science in it, but there is no slider to adjust it anywhere, nor does it show it in the right click menu.

Link to post
Share on other sites
7 hours ago, KIMCHI said:

Jade you are the greatest for adding RO support! I have missed your mods but can't play without RO now.

Is there anything need for the RP tech tree or will I need to make a MM patch for it?

Heck yes! :D I can't promise that it's complete or great, though. I would like to write TestFlight configs but I don't play RO or career mode at all. And I think the thermal upgrades are disabled because I don't know what to do about that with concern for DRE.

RP tech tree is absolutely supported. 

 

Link to post
Share on other sites

Ill play around with some Testlite configs and thermal upgrades. If they are good Ill post them up. I can't for your new engines too. The RP tech tree needs some futuristic tech.

Link to post
Share on other sites

Question Jade where are the RO configs located? I am going to start messing with Testlite and OPT. I can't see them on the tech tree, so Im reinstalling the mod just in case I did something wrong.

Link to post
Share on other sites

@KIMCHI The RO configs are:

  • GameData\OPT_Reconfig\OPT_DRE.cfg (the DRE config shipped by DRE itself or RO only covers about half of OPT's total parts. Reconfig finishes it.)
  • GameData\OPT_Reconfig\OPT_RO.cfg
  • GameData\OPT_Reconfig\CRP\OPT_RO_*.cfg (3 files)
  • GameData\OPT_Reconfig\TechTree\OPT_RP0.cfg

With DRE installed, the thermal upgrades (PARTUPGRADE definitions and B9 modules that facilitate choosing heat limits and whether the Ablator resource is there) are disabled and the parts are set to a static state: Ablator always present for the ablator module + the heat limits expected of parts under DRE. You shouldn't need to a surgeon's eyes and hands to get the thermal upgrades patch working as normal under DRE. It's not particularly complicated like, say, the cryo engines patches.

  • GameData\OPT_Legacy\Patches\OPT_DropTank_Thermals.cfg (contains Ablator and B9 modules)
  • GameData\OPT_Reconfig\OPT_Upgrades.cfg (contains the PARTUPGRADE definitions)
  • GameData\OPT_Reconfig\OPT_Upgrades_NoseHeat.cfg (contains Ablator and B9 modules)

Oh yes, there's also a config that provides for fuel options for the (fuel cells) OPT Power Spheres (the "Tidal Force" ones, not the "Dark Energy" ones. Currently the only selections are LH2O and MMH + NTO. GameData\OPT_Reconfig\CRP\OPT_RO_PowerSphereFusionSelect.cfg If having other fuel options for those is desired let me know their names and ratios and I'll handle the tooltip info and throughput scaling.

Link to post
Share on other sites
35 minutes ago, JadeOfMaar said:

@KIMCHI The RO configs are:

  • GameData\OPT_Reconfig\OPT_DRE.cfg (the DRE config shipped by DRE itself or RO only covers about half of OPT's total parts. Reconfig finishes it.)
  • GameData\OPT_Reconfig\OPT_RO.cfg
  • GameData\OPT_Reconfig\CRP\OPT_RO_*.cfg (3 files)
  • GameData\OPT_Reconfig\TechTree\OPT_RP0.cfg

With DRE installed, the thermal upgrades (PARTUPGRADE definitions and B9 modules that facilitate choosing heat limits and whether the Ablator resource is there) are disabled and the parts are set to a static state: Ablator always present for the ablator module + the heat limits expected of parts under DRE. You shouldn't need to a surgeon's eyes and hands to get the thermal upgrades patch working as normal under DRE. It's not particularly complicated like, say, the cryo engines patches.

  • GameData\OPT_Legacy\Patches\OPT_DropTank_Thermals.cfg (contains Ablator and B9 modules)
  • GameData\OPT_Reconfig\OPT_Upgrades.cfg (contains the PARTUPGRADE definitions)
  • GameData\OPT_Reconfig\OPT_Upgrades_NoseHeat.cfg (contains Ablator and B9 modules)

Oh yes, there's also a config that provides for fuel options for the (fuel cells) OPT Power Spheres (the "Tidal Force" ones, not the "Dark Energy" ones. Currently the only selections are LH2O and MMH + NTO. GameData\OPT_Reconfig\CRP\OPT_RO_PowerSphereFusionSelect.cfg If having other fuel options for those is desired let me know their names and ratios and I'll handle the tooltip info and throughput scaling.

Perfect! I am not seeing the parts in the tech tree. I am using the RP-1 part config tool right now but nothing is showing up. If I need to add them I will just wanted to make sure I didn't screw anything up. I have all 3 OPT's installed.

Thanks again for tackling RO and RP-1 I know it can be a PITA.

Link to post
Share on other sites

@KIMCHI Ah, well, I guess RP-1 has its own mod folder in GameData. I wouldn't know. I've only seen an RP-0 folder when I installed RO through CKAN. It's easy as pie to update the RP0 tech tree config to recognize RP-1... I just hope that the trees aren't different between the two.

Link to post
Share on other sites

Yeah there is a part configurator python app but I've had mixed success using MM patches. Let me see if I can get them to work with the part config app.

Link to post
Share on other sites

Jade I noticed files are missing from the zip.

  • GameData\OPT_Reconfig\OPT_RO.cfg
  • GameData\OPT_Reconfig\CRP\OPT_RO_*.cfg (3 files)
  • GameData\OPT_Reconfig\TechTree\OPT_RP0.cfg
Edited by KIMCHI
Link to post
Share on other sites

Hey Jade I downloaded the source files from Git and loaded up RP-1 and everything is working perfectly and priced well. Great job!!!! Im playing aroud with Testlight right. If you decide to add these later go with Testlight not Testflight as most of us have moved to Testlight. Thanks agaiin my friend and I can't wait to see your other mods in RO/RP.

Link to post
Share on other sites
On 1/15/2021 at 2:16 PM, Kilo60 said:

Thanks!

Seems like its the new big waves.

Not sure if its a mod or the stock game but the new beautiful rough waves are not letting me land or take off in the water anymore with any space plane even stock...

If it's the Scatterer waves, you need to tone those WAY down to have a realistic chance of landing. I can't remember how to tweak those, but it's it not in the usual settings. It might be in-flight settings where you can tweak the ocean.

Link to post
Share on other sites
22 hours ago, KIMCHI said:

Jade I noticed files are missing from the zip.

  • GameData\OPT_Reconfig\OPT_RO.cfg
  • GameData\OPT_Reconfig\CRP\OPT_RO_*.cfg (3 files)
  • GameData\OPT_Reconfig\TechTree\OPT_RP0.cfg

I think not. Just in case, OPT Reconfig is its own mod, is not a parts pack, and is not included in the parts downloads.

CrW6mg6.png4u54RHc.pngpA4ZO8l.png

Edited by JadeOfMaar
Link to post
Share on other sites
8 hours ago, Beetlecat said:

If it's the Scatterer waves, you need to tone those WAY down to have a realistic chance of landing. I can't remember how to tweak those, but it's it not in the usual settings. It might be in-flight settings where you can tweak the ocean.

Toning them down helped but FAR was the main culprit!

 

Thanks!

Link to post
Share on other sites
3 hours ago, Kilo60 said:

Toning them down helped but FAR was the main culprit!

 

Thanks!

Oh, man. Yeah -- FAR and water interaction is beyond functional at this point. :( I'm having the same issue. I really want to use it, but not sure it's doable.  Craft will sometimes get stuck in place, unable to move at all, then suddenly bounce up and out of the water.

 

But-- back to OPT--- "OPT is great!"   :D

Link to post
Share on other sites

Small note: there's a missing opening curly brace on the second patch (@PART[opt_vtol_jumpa*|opt_vtol_bubble*|opt_vtol_egg|opt_vtol_heli*]:NEEDS[KerbalActuators]) in GameData\OPT_Legacy\Patches\KerbalActuators.cfg, just FYI!

EDIT: Additionally, there's a double " or" bar in this patch: @PART[AAengine|turboRamJetj_60d||opt_vtol_lpr1]:NEEDS[RP-0] in GameData\OPT_Reconfig\TechTree\OPT_RP0.cfg.

Edited by AccidentalDisassembly
Link to post
Share on other sites

Good morning all,
Beginner player on KSP 1.10.1 I have a small problem and despite my research (perhaps incomplete), I cannot find the solution.
I have stored KSP parts in the "advanced part toolbox mode" and am delighted to be able to organize my own part layout.
Unfortunately, "OPT, Near Future Launch Vehicle and Tundra Exploration" adds a new coin icon to me every time the game is launched. So I end up with a bunch of identical parts icons.
I delete these icons every time, but nothing helps, I tried deleting them directly in "GameData / Squad / Partlist / PartCategories.cfg", but it is useless.
Is there a workaround to keep only one icon of these mods in the "advanced parts toolbox mode"?
Thank you for your advice and for taking the time to read me. Good game everyone.

screenshot50.jpg                            screenshot49.jpg

Link to post
Share on other sites

Could I make a part suggestion? And apologies if it's been suggested before: An H form factor docking port. 

It would just be very handy to have a deployable docking port that could fit onto a KH vehicle, as the only ones currently in the mod are J shape. And I suggest it in the H shape because that would be easy to attach to the outer parts of a K body vehicle, would work well with the H crew compartment, and add a little more use to the very cool modular setup of the KH shape which feels underutilised with only really extra fuel and seating as options for the H sections atm. I'm aware you could just put a shielded docking port on it, but it just doesn't feel the same. 

Edited by Dep_Opt
Link to post
Share on other sites
  • 3 weeks later...

Found a bug. The cfg file for the OPT K Mobile Lab LP4 (k_3m_lab) is missing the module ModuleScienceContainer.

This resulted in some unexpected behavior in-game.

  • The Clean Experiments button does not show how many experiments need cleaning, nor does any percentage appear when it is clicked.
  • The laboratory cannot transmit science. It appears to transmit, and it shows done, but the amount of science already processed is never removed and then added to the space center. The whole lab needs to be recovered to obtain it.

I managed to fix this by altering the cfg file a bit.

Quote

    MODULE
    {
        name = ModuleScienceLab
        containerModuleIndex = 0
        dataStorage = 1050
        crewsRequired = 1
        canResetConnectedModules = True
        canResetNearbyModules = True
        interactionRange = 5
        SurfaceBonus = 0.1
        ContextBonus = 0.25
        homeworldMultiplier = 0.1
        RESOURCE_PROCESS
        {
            name = ElectricCharge
            amount = 10
        }
    }

I added this code above it:

Quote

    
    MODULE
    {
        name = ModuleScienceContainer
        reviewActionName = Review Data
        storeActionName = Store Experiments    
        collectActionName = Take Data
        evaOnlyStorage = True
        storageRange = 2
        allowRepeatedSubjects = True
    }
    

Then, I changed the containerModuleIndex of ModuleScienceLab from 0 to 1. This fixed the problem.

I didn't check the other labs to see if they have the same issue, but it might be worth double-checking.

Link to post
Share on other sites
7 hours ago, GNO-SYS said:

missing the module ModuleScienceContainer

Thanks for spotting that. The other science labs won't have this problem as they've existed forever. I recently made the K lab so it was prone to error like this one. I will release this fix soon.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...