Jump to content

[1.9.1+] OPT Spaceplane Continued 3.1.1 [Mar 06, 2021]


Recommended Posts

  • 2 weeks later...

Hia @JadeOfMaar

First of all, thanks again, and again for the amazing work your doing on OPT.

Having an issue here with the OPT K Mobile Lab LP4

KSP: 1.11.1 Windows 64bit

Problem: Science Generated but not transmitted

Mods installed:

modpack-5825b53.png

Reproduction steps:

Build a simple craft, get some science Data, and start research to generate some science point.

Try Transmit, nothing happens.

I've tried the same with a full clean and neat install of KSP with only OPT dependencies installed.

before-5825af1.png

after-5825af5.png

Let me know if you want this logged in GH.

On another hand, Magpie stuff seems to be failing for some parts :
context-5825aed.png

But honestly, this is secondary...

Hope you'll be able to help :)

 

Edited by Demcrew
Link to post
Share on other sites
  • 2 weeks later...
Posted (edited)

OPT Spaceplane 3.1

  • Added missing science module to K lab, without which, science operations and transmission were broken.

OPT Reconfig 3.1

  • Added kOS Processor to all drone cores.
  • Added a system so you can turn off B9 feature switching to cure Tweakscale problems with these parts. See OPT_Reconfig/OPT_00Tweak.cfg
  • Added Far Future Tech derived system:
    • Dark Drive now uses OPT Black Hole resource instead of Dark Goo.
    • Dark Drive is now a true interstellar grade engine derived from Kugelblitz sci-fi engine. No longer useful in atmosphere.
    • Dark Drive is useless without OPT Reconfig as Reconfig contains Black Hole resource definition.
    • Enabled OPT bodies to hold FFT propellants including Antimatter and to carry the containment module.
  • Fixed RO antenna patch to detect RealAntennas and not RO.
  • Revised "Dark Energy" power sphere fuel options.
  • Revised Dark Goo system:
    • "Dark Energy" power spheres hold this by default and not XenonGas.
    • Dark Goo is its own fusion fuel option and no longer a component of all other fusion fuel options.
    • Phased out Dark Science.
  • Tiny fixes.
  • Updated Tweakscale configs to be less likely to be overlapped by foreign Tweakscale modlets which then cause fatal exceptions.
  • Updated file names and NEEDS concerning CRP vs Classic Stock to reduce likelihood of fatal issues concerning WBI play mode switcher.
  • Updated detection concerning stock inventory system.

DOWNLOAD CONTINUED :: SPACEDOCK :: GITHUB

DOWNLOAD RECONFIG :: SPACEDOCK :: GITHUB

Edited by JadeOfMaar
Link to post
Share on other sites

Thanks for this update @JadeOfMaar :)

I've got the following issue since I've applied it:

2021-03-07_11-54-21-582bfa7.png

While not affecting my 'test' install (the one carrying only mods I need to check), I've tried to investigate.

I've reinstalled B9PartSwitch (CKAN), with not effect.

I can share the log file, but it is around 13Mb, let me know if this is needed.

Below is an example of the exception reported:

[WRN 12:21:38.473] Warning on PartSubtype Ore on module ModuleB9PartSwitch (moduleID='DarkMassInput') on part engine.darkDrive: Could not find matching module
[EXC 12:21:38.480] Exception: Could not find matching module
	B9PartSwitch.ModuleMatcher.FindModule (Part part) (at <b85eabe067044bcb9aeabe863954a5ce>:0)
	B9PartSwitch.ModuleModifierInfo+<CreatePartModifiers>d__10.MoveNext () (at <b85eabe067044bcb9aeabe863954a5ce>:0)
	B9PartSwitch.PartSubtype.Setup (B9PartSwitch.ModuleB9PartSwitch parent, System.Boolean displayWarnings) (at <b85eabe067044bcb9aeabe863954a5ce>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:LogException(Exception)
	B9PartSwitch.PartSubtype:Setup(ModuleB9PartSwitch, Boolean)
	B9PartSwitch.ModuleB9PartSwitch:InitializeSubtypes(Boolean)
	B9PartSwitch.ModuleB9PartSwitch:GetInfo()
	PartLoader:CompilePartInfo(AvailablePart, Part)
	<CompileParts>d__56:MoveNext()
	UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

As usual, thanks for your help!

D

Link to post
Share on other sites
Posted (edited)
2 hours ago, Demcrew said:

I've got the following issue since I've applied it:

This is due to System Heat and its generic extras patch that changes -all- compatible resource converter modules into system heat converters. Unfortunately I cannot provide for both cases at once where users do and do not install that extra config so for the time being, you must install that for yourself to relieve this problem. 

You're welcome BTW :D

Edited by JadeOfMaar
Link to post
Share on other sites
8 hours ago, RandomKerbal said:

Is the name OPT from The Miracle Of Endymion? There is a company that has the same name in it.

Yes. Many of the parts also have reference to that movie.

ZDWXTb6.png

58INLX5.png

Link to post
Share on other sites
  • 2 weeks later...

Love the mod. Thank you for keeping it updated!

However, I have a little problem with fuel types. I don't like having several different fuels, vanilla "liquid+oxy" suits me perfectly. But I did want some nice futuristing engines, so I downloaded OPT, OPT Reconfig, and Kerbal Atomics.
Kerbal Atomics has its own little patch (called Liquid Fuels Only) that switches all its engines from LH2 to LF. And that works. But for some reason, OPT's engines now also use LH2 (I distinctly remember they used LF). I don't know if that's intended, or if OPT changes fuel type if Kerbal Atomics is installed.  Is there a way to change the fuel types for OPT engines? Or extend KA's LFOnly patch to OPT's engines?

Link to post
Share on other sites

Well, this is weird.  B9PartSwitch isn't working.  Digging through the log, nothing from OPT_B9PS.cfg ends up being applied to the parts.  It seems like the nodes do end up matching at some level, but the module itself is never added.  The best I could muscle out is that HAS[#moduleID[]] is perhaps unsatisfied since I couldn't find where these module ids are applied and they didn't seem to be part of the base parts.  Of course, digging through all the configs looking for it I might just have missed something.  Nevertheless, the result is that none of the structural pieces or wings have tanks added to them when using B9PartSwitch.  Other mods are properly apply it to their parts, so the part switcher is installed correctly, these parts just aren't having it added.

VNsoOfZ.png

Edit: nope, tried to just brute force add the module by getting rid of the HAS and it did not work.  Something else is afoot.

Edited by Hyomoto
Link to post
Share on other sites

do you have one of the mods specified in the NEEDS installed?

also, you *do* need CRP *or* a WBI mod installed...either is a dependency of OPT Reconfig

Edited by Stone Blue
Link to post
Share on other sites

Well this was weird.  I found the culprit.  Digging through the files we can see the base attributes are applied by OPT_00Clean.cfg, and then OPT_B9PS.cfg is used to add the switch module using those attributes.  That is really clever.  I don't know if there's a way to inspect parts to see if the first patch is applied, but assuming it is then the issue lies here:

// =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  =  
// Create fuel module
@PART:HAS[#manufacturer[OPT*Division],#refVolume[*],~TankTag[OPTlab]]:NEEDS[B9PartSwitch,!ConfigurableContainers/Parts,!Pathfinder,!ModularFuelTanks,!RealFuels]
{
	MODULE
	{
		name = ModuleB9PartSwitch
		moduleID = #$../TankTag$
		switcherDescription = OPT Tank
		switcherDescriptionPlural = Tank Selections
		switchInFlight = True
		baseVolume = #$../refVolume$
	}
}

Well, MM never calls this out so NEEDS, as far as I can tell, are being satisfied.  All the other blocks that fail the test are culled.  So, we're left with the HAS block.  If the first config is properly applied, which its at least safe to assume it is, then all these tags are correct except for one, the manufacturer tag:

	title = #LOC_OPT_j_2m_tanks_title
	manufacturer = #LOC_OPT_manufacturerA
	description = #LOC_OPT_j_2m_tanks_desc

As far as I can tell, that won't pattern match.  But, that's because if this is meant to do localization, it's not applied.  Check the screenshot above.  Interesting.  So, what does the localization file say?  That the tag is not defined.  Which, leads me to believe that localization is applied before these MM does its patching, and that would explain why it's not matching.  So, where is that definition?  I checked legacy and it's not there, and I even went back to the original OPT which didn't have localization files at all.  Checking the git history, this name wasn't in the original commit either.  It was added to OPT Reconfig in October 2020, but it's not present in OPT branch so what bugged ass release did I download?  Apparently the github link on the main page leads to the wrong file and that file happens to be missing this string.

GchAT2E.png

This week has just been a "How does KSP work" week for me a I guess.  So in short, if you do use the GitHub link, you have to go to the repository and download the latest release.

Link to post
Share on other sites
On 3/25/2021 at 2:27 PM, Hyomoto said:

This week has just been a "How does KSP work" week for me a I guess.  So in short, if you do use the GitHub link, you have to go to the repository and download the latest release.

I just fixed that. I believe I fixed that in the other OPT thread but didn't think to check this one. Thanks for spotting.

9 hours ago, adamgerd said:

Which version of the mod do you use for KSP 1.10?

Doesn't matter.

Link to post
Share on other sites
4 hours ago, adamgerd said:

So both the 1.9 and 1.11 KSP versions  work for 1.10?

Yes. OPT is just parts and configs. There's nothing in it that can be extremely sensitive to what KSP version is installed. The advanced B9-powered features might need to be removed, and the stock inventories thing too, but otherwise, OPT as it is now will work just fine back to KSP 1.5. (The engine plumes will break if you go back further.)

Link to post
Share on other sites
5 hours ago, JadeOfMaar said:

Yes. OPT is just parts and configs. There's nothing in it that can be extremely sensitive to what KSP version is installed. The advanced B9-powered features might need to be removed, and the stock inventories thing too, but otherwise, OPT as it is now will work just fine back to KSP 1.5. (The engine plumes will break if you go back further.)

Ok. Another error is just a lot of the parts especially in legacy but also 2 in the main part seem to give errors with B9 PartSwitch. Seems someone else had it though the error is different there, decided to just use the CKAN version in the end which seems to be 1.9 just for ease so maybe it was patched recently but doesn't seem to be in the changelog. Apologies if it was already fixed but so in case it isn't, here is the error for OPT for reference:

qREyt0t.png

 

 

Edited by adamgerd
Link to post
Share on other sites
  • 3 weeks later...
On 4/2/2021 at 1:27 PM, adamgerd said:

qREyt0t.png

 

I was having the same issue. I installed OPT with CKAN, and OPT will not load.

Link to post
Share on other sites
Posted (edited)
3 hours ago, NPT156 said:

I was having the same issue. I installed OPT with CKAN, and OPT will not load.

Let me see your:

  • KSP.log (next to KSP_x64.exe)
  • Logs/ModuleManager/ModuleManager.log
  • GameData/ModuleManager.ConfigCache

But before you do, make sure that you have everything OPT v3.1 or newer. I recently installed DRE for myself and did not see these problems.

Edited by JadeOfMaar
Link to post
Share on other sites
2 hours ago, JadeOfMaar said:

But before you do, make sure that you have everything OPT v3.1 or newer. I recently installed DRE for myself and did not see these problems.

I had changed compatibilty to get a mod, i think i might have downloaded the wrong version. :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...