Jump to content

[1.11.x] Waterfall - a framework for continuous, mesh-driven engine effects (Feb 25)


Recommended Posts

5 hours ago, Knight of St John said:

Well, the whole point of making a full flow staged combustion cycle engine is that you can react all of your fuel, to get the maximum amount of energy out of your fuel mass, and therefore the max isp.
and for that you need a stoichometric mix.

This paper investigates a hydrogen engine using a mixture ratio that’s variable but still pretty near the common 6:1 oxidiser/fuel mix for hydrogen, which isn’t stoichometric.  But a FFSC engine is still investigated, compared to a fuel-rich SC engine, where it shows no benefits in specific impulse, but instead says the benefits are in avoiding needing really high-performance helium seals and taking some of the load off of the higher-power fuel turbopump and transferring it to the lower-power oxidiser turbopump, and (I think as a result) the maximum pressure in any turbopump is lower. 
I was under the impression the reason SpaceX went with FFSC for the Raptor because they wanted those lower pressures, more reliable and reusable seals, and, because gas-gas mixes better than gas-liquid, you can have a shorter combustion chamber for the same combustion efficiency.
 

But perhaps most importantly to this discussion, Raptor runs fuel-rich, not stoichiometric, anyway. Its O/F mixture ratio (by mass) is about 3.5, and the stoichiometric ratio by mass is 4:1.

Edited by RyanRising
Link to post
Share on other sites
17 hours ago, RyanRising said:

I was under the impression the reason SpaceX went with FFSC for the Raptor because they wanted those lower pressures, more reliable and reusable seals, and, because gas-gas mixes better than gas-liquid, you can have a shorter combustion chamber for the same combustion efficiency.

Just looked up some info, and it looks like I had it wrong in my head :confused:
running fuel rich improves ISP because the methane has lower molecular weight, even though you get less energy produced per kg of fuel expended.

Anyways...
According to those 2 pictures I posted of methalox engine tests, there is at least some cyan visible in the flame.
So I guess I'll keep my vac-plumes cyan-ish, unless of course someone has better info on that.

Link to post
Share on other sites
42 minutes ago, Knight of St John said:

Anyways...
According to those 2 pictures I posted of methalox engine tests, there is at least some cyan visible in the flame.
So I guess I'll keep my vac-plumes cyan-ish, unless of course someone has better info on that.

I have no objections...

I just hope you make a PR to WFRS! The RAPIER plume especially looks awesome :D

Link to post
Share on other sites

I noticed that the Waterfall plume for the Emancipator in Kerbal Atomics doesn't have any visible exhaust for the two small side nozzles (the ones the description mentionas as being used for roll control). Also, there's no config for the NFA Pr. Eeloo's closed-cycle mode. Are there any plans on adding either of those?

Link to post
Share on other sites
20 hours ago, Apelsin said:

I noticed that the Waterfall plume for the Emancipator in Kerbal Atomics doesn't have any visible exhaust for the two small side nozzles (the ones the description mentionas as being used for roll control). Also, there's no config for the NFA Pr. Eeloo's closed-cycle mode. Are there any plans on adding either of those?

I'm sure there are.

Waterfall 0.5.0

  • Rewrote effect application backend with a few enhancements
    • SUBTRACT, ADD modifier modes actually work properly now
    • Performance improvements overall
    • Even more major performance issues when effects are fully transparent
  • Somewhat changed how atmospheric depth is calculated, result should be fairly in line with SmokeScreen/RealPlume implementation for better compatibility
  • Fixed an issue where effects would occasionally not be reloaded correctly on game load if there was more than one ModuleWaterfallFX on a part
  • Improved light color controllers
  • Shaders
    • Updated Additive (Dynamic) shader with a few bug fixes for HDR
    • Updated Alpha (Directional) shader to work sgnificantly better in general
    • Addded Alpha (Dynamic) shader which is broadly the same as Addtive but alpha
    • Added some manual z-sorting handling to deal with alpha/additive transparency sorting issues
  • Templates:
    • Major template update from Zorg with dozens of new templates and many fixes/improvements
    • New RS-25 template by KnightOfStJohn
    • Updates and improvements to existing garbo Nertea templates

WaterfallRestock 0.2.0

  • Major update with new Waterfall templates applied to all previous engines
  • Support Restock 1.3.1's RCS blocks
  • Support Restock 1.3.1's spot, flood and ground lights
  • Added Twitch, Spark plumes
Link to post
Share on other sites
29 minutes ago, Nertea said:

SUBTRACT, ADD modifier modes actually work properly now

oh hey thanks for that!
 

31 minutes ago, Nertea said:

Updates and improvements to existing garbo Nertea templates

I won't contradict this, but the fact that they were "garbo" did motivate me to learn to work with your mod.
So I guess you were unconsciously thinking 2 universes ahead there ;-)

Link to post
Share on other sites
1 hour ago, Nertea said:

Fixed an issue where effects would occasionally not be reloaded correctly on game load if there was more than one ModuleWaterfallFX on a part

I did not know this was possible.
So if i wanted to, i could for instance add 2 waterfall modules to an engine, one for the main plume, and one for the gas generator plume? this way i can reuse the same gas generator plume for different engines, and scale/position them easily, without having to mess with individual effects? Does this method impact performance more though?

Link to post
Share on other sites

 

1 hour ago, Knight of St John said:

I won't contradict this, but the fact that they were "garbo" did motivate me to learn to work with your mod.
So I guess you were unconsciously thinking 2 universes ahead there ;-)

The plan was always to bootstrap by providing a few effects to get it out there, then slowly replace them with better ones as people with the time and motivation came along. Seems to be working! Happy to only deal with specialty effects for my specialty engines. 

15 minutes ago, Knight of St John said:

So if i wanted to, i could for instance add 2 waterfall modules to an engine, one for the main plume, and one for the gas generator plume? this way i can reuse the same gas generator plume for different engines, and scale/position them easily, without having to mess with individual effects? Does this method impact performance more though?

Yes this will have a performance overhead impact, so avoid it if you can, but it shouldn't be huge.

Eventually I will support multiple templates on one module and things like that, but that'll be a while coming

Link to post
Share on other sites
3 minutes ago, Nertea said:

Eventually I will support multiple templates on one module and things like that, but that'll be a while coming

heh, this is actually how i did it. stacking templates works, as long as you give them the same transforms (scale, position, rotation)
but it does mean i have to make new engine bell cores for every single engine.

Link to post
Share on other sites
2 hours ago, Nertea said:

Updated Alpha (Directional) shader to work sgnificantly better in general

Wow, this actually works now. basic cylinder with an alpha dynamic shader.
smoke effects here we come!

unknown.png

Although, you can't simulate trailing smoke, that stays behind and marks your path.
for that, we still have to use the stock particles or smokescreen.

Link to post
Share on other sites

I think I've already previewed most of the new plumes added to Waterfall over past few days. So here's the methalox stuff just rolled out with the CryoEngines release. (in first pic these are on other engines I used as test beds).

screenshot149.png?width=873&height=763

vernier, vacuum, BE4 sea level, Raptor Sea level, BE4U vac, Raptor Vac.

screenshot15.png?width=1359&height=764

screenshot71.png?width=1359&height=764

screenshot36.png?width=1359&height=764

Like most of the new templates they feature some fun deep throttle effects that appear below 20-30% throttle.

GIF_26-02-2021_03-17-42.gif

 

 

Edited by Zorg
Link to post
Share on other sites
16 minutes ago, Zorg said:

throttle effects that appear below 20-30% throttle.

 

I wonder if effects could be applied randomly under certain conditions. 
For example, could the Raptor plume turn green when throttled down, as an Easter egg. Obviously this wouldn’t happen all the time, maybe 1/100, but it would be funny if the plume randomly turned engine-green. :P

Link to post
Share on other sites
2 minutes ago, Spaceman.Spiff said:

I wonder if effects could be applied randomly under certain conditions. 
For example, could the Raptor plume turn green when throttled down, as an Easter egg. Obviously this wouldn’t happen all the time, maybe 1/100, but it would be funny if the plume randomly turned engine-green. :P

If you had a part failure mod that could feed into it as a custom controller you can do this. Not by default though.

Link to post
Share on other sites

Heya, Recently I've been having a rather odd issue where it appears like there is a part in the skybox while console is being spammed with "[Waterfall][ModuleWaterfallFX] Couldn't SetControllerValue for id"; It seems like it only happens after I reload a quicksave or switch vessel. Figured I should post this bug report here seeing as it seems to be an issue with waterfall itself.LUpVUZt.png

Link to post
Share on other sites
1 hour ago, Sky The Heck said:

Heya, Recently I've been having a rather odd issue where it appears like there is a part in the skybox while console is being spammed with "[Waterfall][ModuleWaterfallFX] Couldn't SetControllerValue for id"; It seems like it only happens after I reload a quicksave or switch vessel. Figured I should post this bug report here seeing as it seems to be an issue with waterfall itself.LUpVUZt.png

I don't recognize those parts so I can't say what's happening. What part is using Waterfall there? Can you provide basic debug things, like a modlist, a log copy?

Edited by Nertea
Link to post
Share on other sites
1 hour ago, Nertea said:

I don't recognize those parts so I can't say what's happening. What part is using Waterfall there? Can you provide basic debug things, like a modlist, a log copy?

Parts on the craft that are using Waterfall are From Restock and Blueshift, Specifically the Warp Ring and The Nuclear engine.
Modlist: B9 Aerospace + Legacy
     Parallax + Stock Config
     KSPIE
     WBI BlueShift
     Restock + Waterfall Config
     Kopernicus (Bleeding Edge) + Galaxies Unbound
     EVE + AVP + GU Config
     Scatterer
     StationPartsExpansionRedux
     Singularity
     ModuleManagerWatchDog
     SmokeScreen
Log: https://drive.google.com/file/d/1O9YAonmdZ6D9deDllMAp9GPm56kk_zVV/view?usp=sharing

Edit: I went ahead and tested it ingame, when removing all parts that use waterfall the issue appeared to go away, though when adding back the Nerva engine, the issue didn't appear; only when I readded the Warp Ring did the issue come back.

Edited by Sky The Heck
Link to post
Share on other sites
9 hours ago, Sky The Heck said:

Parts on the craft that are using Waterfall are From Restock and Blueshift, Specifically the Warp Ring and The Nuclear engine.
Modlist: B9 Aerospace + Legacy
     Parallax + Stock Config
     KSPIE
     WBI BlueShift
     Restock + Waterfall Config
     Kopernicus (Bleeding Edge) + Galaxies Unbound
     EVE + AVP + GU Config
     Scatterer
     StationPartsExpansionRedux
     Singularity
     ModuleManagerWatchDog
     SmokeScreen
Log: https://drive.google.com/file/d/1O9YAonmdZ6D9deDllMAp9GPm56kk_zVV/view?usp=sharing

Edit: I went ahead and tested it ingame, when removing all parts that use waterfall the issue appeared to go away, though when adding back the Nerva engine, the issue didn't appear; only when I readded the Warp Ring did the issue come back.

Hmm, might need to summon @Angel-125 - he's using waterfall to run his warp effects and it's possible something in .5.0 broke his workflow (if you're using 0.5.0 that is)

Link to post
Share on other sites
2 hours ago, Nertea said:

Hmm, might need to summon @Angel-125 - he's using waterfall to run his warp effects and it's possible something in .5.0 broke his workflow (if you're using 0.5.0 that is)

@Sky The Heck It's an issue in Blueshift. It'll get fixed this weekend with the next update. And cool, new Waterfall release! :)

Link to post
Share on other sites

Is it possible to apply a "Impact effect' that shows up at the impact point of the plume on an object (like another rocket or the ground) that changes according to the distance with thrustTransform? right now the plume just go through whatever is on the way and looked unrealistic

Link to post
Share on other sites

@Nertea, I think I found a visual bug in WaterfallRestock. 

One layer of the engine plume for the ReStocked LV-T45 Swivel, closest to the nozzle, is visible through spacecraft structures when the engines are surface attached, not node attached, to a part. The LV-T30 Reliant is not visible, as expected, but I haven't checked all other engines. I'm running KSP x64 Win 10 with Waterfall 0.5.0, WaterfallRestock 0.2.0, EngineLightRelit 1.6.3, and ReStock 1.3.1.  I confirmed the problem is fixed when WaterfallRestock is removed. I have not verified if there's a similar problem with Stock Waterfall Effects by @Knight of St John.

Craft to replicate (all ReStocked): 1x Mk 1 Cmd Pod, 1x S3-3600 tank, 2x LV-T45 surface attached to bottom.  I dropped an Issue in the WaterfallRestock GitHub.

EDIT for additional info: confirmed this also happens when attaching LV-T45 engines to multi-nodes on engine plates.

BTW, the plume effects are beautiful.  I love the Mach diamonds on the Methalox cryo engines....

EDIT 2: Removed Engine Light from the equation.  Also, the effect is most visible in the dark, but other enviro or FX mods amplify the effect (haven't narrowed down which).

Edited by KSPrynk
Added engine light mod to list
Link to post
Share on other sites

The Restock+ Pug plume seems to be rotated 90 degrees:

Spoiler

HWMiO3Y.png

 

Also, the plume for the Restock+ Valiant looks to me like it is located too high on the model, it is coming from above the engine bell instead of from inside the engine bell.

Edit: The Restock Terrier has the same issue as the pug with the plume rotated 90 degrees. I have the latest versions of Restoc and Waterfall

Edited by CDSlice
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...