Jump to content

[1.12.x] Waterfall - a framework for continuous, mesh-driven engine effects (Aug 2)


Nertea
 Share

Recommended Posts

3 hours ago, RyanRising said:

What engines are you using? Mecripp was saying you may be using engines that haven’t been patched to use Waterfall. Some part mods will include their own patches, some will not. Patches, in this context, are modifications to existing things in KSP. ModuleManager is the thing that handles them, and they come in the form of .cfg files. In this case, the patches delete the particles and sound coming from an engine in KSP and add new sounds and the Waterfall plumes to them. 
 

If you’re just using the stock engines, the patches you want will need to be downloaded separately from Waterfall. That’s StockWaterfallEffects if you don’t have Restock installed and WaterfallRestock if you do. They’re available from links at the bottom of the first post of this thread.

Okay, that makes much more sense! Thank you so much! I am using all stock engines. (Do the engines in the making history DLC count as stock??)

I will try getting the StockWaterfallEffects thing to work, but I am a little lost on module managers. Is there a specific one that I need to use? Or are they all the same?

 

Thanks for the help!

Link to comment
Share on other sites

50 minutes ago, Lucas_R said:

Okay, that makes much more sense! Thank you so much! I am using all stock engines. (Do the engines in the making history DLC count as stock??)

I will try getting the StockWaterfallEffects thing to work, but I am a little lost on module managers. Is there a specific one that I need to use? Or are they all the same?

 

Thanks for the help!

There's only one ModuleManager:

It does have different versions, but you should be fine using the latest one, 4.1.4 at time of writing. It's a .dll you can drop in your GameData folder.

Link to comment
Share on other sites

3 hours ago, RyanRising said:

There's only one ModuleManager:

It does have different versions, but you should be fine using the latest one, 4.1.4 at time of writing. It's a .dll you can drop in your GameData folder.

So I tried it, and nothing changed. When I clicked on the waterfall button while on the launch pad, it said something like "no modules" and then something about configuration. What should I do?

Link to comment
Share on other sites

35 minutes ago, mateusviccari said:

Hi guys, I'm trying to put waterfall in the stock SRBs. I didn't get far but I got somewhere. But of course there are no smoke trails since waterfall cannot do this. Is there a way to put the stock smoke trail effects together with waterfall?

You can, though it's very difficult to make it look good while the rocket is moving. I've got a stationary setup working, that's about it. There's really nothing special to be done, just add a RealPlume or stock effect like you normally would. This is what my attempt looks like:

Spoiler

This looks fine...

unknown.png?width=1337&height=610

...but it all falls apart if you actually try to launch it.

unknown.png

@Nertea, I don't mean to be pushy, but could you take a look at https://github.com/post-kerbin-mining-corporation/Waterfall/pull/80 when you have the time? Thanks!

Link to comment
Share on other sites

4 hours ago, Lucas_R said:

So I tried it, and nothing changed. When I clicked on the waterfall button while on the launch pad, it said something like "no modules" and then something about configuration. What should I do?

You’re likely installing the mods incorrectly. What does your GameData look like, and can you provide a screenshot of the lack of plumes?

Link to comment
Share on other sites

17 hours ago, RyanRising said:

You’re likely installing the mods incorrectly. What does your GameData look like, and can you provide a screenshot of the lack of plumes?

Yeah I can. And just to clarify, you want a screen shot of my Gamedata folder correct?

Link to comment
Share on other sites

57 minutes ago, Mitohnesprudel said:

Hi, I am trying to write a config, the sound is working but the plume isn't. I hope I can get help here. I've read the documentation but it didn't help. What files should I add here to get help?

If you can post the cfg of the engine before and after you edit it would help

Link to comment
Share on other sites

15 hours ago, Mecripp said:

If you can post the cfg of the engine before and after you edit it would help

The mod that I am trying to add the config to has everything in one part.  As a test I am just trying to add the Vector engine config to it.

The first stage before edit

Spoiler


PART
{
	name = NewShepard
	module = Part
	author = Matheo G
	MODEL
	{
		model = NewShepard/Core/NewShepardCore
		scale = 1.0, 1.0, 1.0
	}
	scale = 1.0
	rescaleFactor = 1
	node_stack_top = 0.0, 6.5, 0.0, 0.0, 1.0, 0.0, 3
	mass = 10
	dragModelType = default
	maximum_drag = 0.2
	minimum_drag = 0.2
	angularDrag = 2
	crashTolerance = 60
	breakingForce = 200
	breakingTorque = 200
	maxTemp = 1400
	TechRequired = advMetalworks
	entryCost = 45000
	cost = 18000
	category = Pods
	subcategory = 0
	title = New Shepard
	manufacturer = Blue Origin
	vesselType = Ship
	description = test.
	attachRules = 1,1,1,1,0

	MODULE
	{
		name = ModuleDataTransmitter
		antennaType = INTERNAL
		packetInterval = 1.0
		packetSize = 2
		packetResourceCost = 12.0
		requiredResource = ElectricCharge
		antennaPower = 5000
		optimumRange = 2500
		packetFloor = .1
		packetCeiling = 5
	}
	MODULE
		{
			name = kOSProcessor
			diskSpace = 10000
		}
	MODULE
	{
		name = ModuleCommand
		minimumCrew = 0
		RESOURCE
		{
			name = ElectricCharge
			rate = 0.08
		}
		hasHibernation = False
	}
	RESOURCE
	{
		name = ElectricCharge
		amount = 200
		maxAmount = 200
	}
	MODULE
	{
		name = ModuleReactionWheel
		PitchTorque = 9
		YawTorque = 9
		RollTorque = 9
		RESOURCE
		{
			name = ElectricCharge
			rate = 0.9
		}
	}
	RESOURCE
	{
		name = LiquidFuel
		amount = 2250
		maxAmount = 2250
	}
	RESOURCE
	{
		name = ElectricCharge
		amount = 80
		maxAmount = 80
	}
		RESOURCE
	{
		name = Oxidizer
		amount = 2750
		maxAmount = 2750
	}


MODULE
{
	name = ModuleAnimateGeneric
	animationName = brake2
	startEventGUIName = Deploy_Speedbrakes
	endEventGUIName = Retract_Speedbrakes
	isOneShot = false 	
}

MODULE
{
	name = ModuleAnimateGeneric
	animationName = legs2
	startEventGUIName = Deploy_legs
	endEventGUIName = Retract_legs
	isOneShot = false 	
}


	
	MODULE
	{
		name = ModuleEnginesFX
		thrustVectorTransformName = flammes
		exhaustDamage = False
		minThrust = 0
		maxThrust = 561
		heatProduction = 40
		ignitionThreshold = 0.1
		fxOffset = 0, 0, 0
		EngineType = LiquidFuel
		runningEffectName = running1
		

		PROPELLANT
		{
	       	ratio = 0.9
			name = LiquidFuel
			DrawGauge = True
		}
		PROPELLANT
		{
			name = Oxidizer
	       	ratio = 1.1
			DrawGauge = True
		}
		
		atmosphereCurve
	 	{
	   	 key = 0 370	
	  	 key = 1 320
	 	}
	}
	
	EFFECTS
	{
		running1
		{
			AUDIO
			{
				channel = Ship
				clip = sound_rocket_spurts
				volume = 0.0 0.0
				volume = 1.0 0.5
				pitch = 0.0 0.5
				pitch = 1.0 1.0
				loop = true
			}
			MODEL_MULTI_PARTICLE
			{
				modelName = Squad/FX/afterburner_shock
				transformName = flammes
				emission = 0.0 0.0
				emission = 0.4 0.8
				emission = 1.0 1.0
				speed = 0.0 0.8
				speed = 1.0 1.0
				//localOffset = 0, 0, 1
			}
		}	
		engage
		{
			AUDIO
			{
				channel = Ship
				clip = sound_vent_soft
				volume = 1.0
				pitch = 2.0
				loop = false
			}
		}
		flameout
		{
			PREFAB_PARTICLE
			{
				prefabName = fx_exhaustSparks_flameout_2
				transformName = flammes
				oneShot = true
			}
			AUDIO
			{
				channel = Ship
				clip = sound_explosion_low
				volume = 1.0
				pitch = 2.0
				loop = false
			}
		}	
	}
}

The first stage after edit:

Spoiler
PART
{
	name = NewShepard
	module = Part
	author = Matheo G
	MODEL
	{
		model = NewShepard/Core/NewShepardCore
		scale = 1.0, 1.0, 1.0
	}
	scale = 1.0
	rescaleFactor = 1
	node_stack_top = 0.0, 6.5, 0.0, 0.0, 1.0, 0.0, 3
	mass = 10
	dragModelType = default
	maximum_drag = 0.2
	minimum_drag = 0.2
	angularDrag = 2
	crashTolerance = 60
	breakingForce = 200
	breakingTorque = 200
	maxTemp = 1400
	TechRequired = advMetalworks
	entryCost = 45000
	cost = 18000
	category = Pods
	subcategory = 0
	title = New Shepard
	manufacturer = Blue Origin
	vesselType = Ship
	description = test.
	attachRules = 1,1,1,1,0

	MODULE
	{
		name = ModuleDataTransmitter
		antennaType = INTERNAL
		packetInterval = 1.0
		packetSize = 2
		packetResourceCost = 12.0
		requiredResource = ElectricCharge
		antennaPower = 5000
		optimumRange = 2500
		packetFloor = .1
		packetCeiling = 5
	}
	MODULE
	{
		name = ModuleCommand
		minimumCrew = 0
		RESOURCE
		{
			name = ElectricCharge
			rate = 0.08
		}
		hasHibernation = False
	}
	RESOURCE
	{
		name = ElectricCharge
		amount = 200
		maxAmount = 200
	}
	MODULE
	{
		name = ModuleReactionWheel
		PitchTorque = 250
		YawTorque = 2500
		RollTorque = 2500
		RESOURCE
		{
			name = ElectricCharge
			rate = 0.9
		}
	}
	RESOURCE
	{
		name = LiquidFuel
		amount = 2250
		maxAmount = 2250
	}
	RESOURCE
	{
		name = ElectricCharge
		amount = 1000
		maxAmount = 80
	}
		RESOURCE
	{
		name = Oxidizer
		amount = 2750
		maxAmount = 2750
	}


MODULE
{
	name = ModuleAnimateGeneric
	animationName = brake2
	startEventGUIName = Deploy_Speedbrakes
	endEventGUIName = Retract_Speedbrakes
	isOneShot = false 	
}

MODULE
{
	name = ModuleAnimateGeneric
	animationName = legs2
	startEventGUIName = Deploy_legs
	endEventGUIName = Retract_legs
	isOneShot = false 	
}


	
	MODULE
	{
		name = ModuleEnginesFX
		engineID = BE3
		runningEffectName = running1
		thrustVectorTransformName = flammes
		exhaustDamage = True
		ignitionThreshold = 0.1
		minThrust = 0
		maxThrust = 561
		heatProduction = 40
		fxOffset = 0, 0, 0
		EngineType = LiquidFuel
		PROPELLANT
		{
	       	ratio = 0.9
			name = LiquidFuel
			DrawGauge = True
		}
		PROPELLANT
		{
			name = Oxidizer
	       	ratio = 1.1
		}
		atmosphereCurve
	 	{
	   	 key = 0 370	
	  	 key = 1 320
	 	}
	}
	
	EFFECTS
	{
		running1
		{
			AUDIO
			{
				channel = Ship
				clip = sound_rocket_spurts
				volume = 0.0 0.0
				volume = 1.0 0.5
				pitch = 0.0 0.5
				pitch = 1.0 1.0
				loop = true
			}
			MODEL_MULTI_PARTICLE
			{
				modelName = Squad/FX/afterburner_shock
				transformName = flammes
				emission = 0.0 0.0
				emission = 0.4 0.8
				emission = 1.0 1.0
				speed = 0.0 0.8
				speed = 1.0 1.0
				//localOffset = 0, 0, 1
			}
		}	
		engage
		{
			AUDIO
			{
				channel = Ship
				clip = sound_vent_soft
				volume = 1.0
				pitch = 2.0
				loop = false
			}
		}
		flameout
		{
			PREFAB_PARTICLE
			{
				prefabName = fx_exhaustSparks_flameout_2
				transformName = flammes
				oneShot = true
			}
			AUDIO
			{
				channel = Ship
				clip = sound_explosion_low
				volume = 1.0
				pitch = 2.0
				loop = false
			}
		}	
	}
}

The waterfall config:

@PART[NewShepard]
{
  !EFFECTS {}
	EFFECTS
	{
		engage
		{
		  AUDIO
		  {
			channel = Ship
			clip = sound_vent_medium
			volume = 1.0
			pitch = 2.0
			loop = false
		  }
		}
		disengage
		{
		  AUDIO
		  {
			channel = Ship
			clip = sound_vent_soft
			volume = 1.0
			pitch = 2.0
			loop = false
		  }
		}
		flameout
		{
		  PREFAB_PARTICLE
		  {
			prefabName = fx_exhaustSparks_flameout_2
			transformName = smokePoint
			oneShot = true
		  }
		  AUDIO
		  {
			channel = Ship
			clip = sound_explosion_low
			volume = 1.0
			pitch = 2.0
			loop = false
		  }
		}
		running1
		{
			AUDIO
			{
				channel = Ship
				clip = Waterfall/Sounds/EnsouSounds/Loop_Liquid_Heavy_High_2
				volume = 0.0 0.0
				volume = 0.05 0.6
				volume = 1.0 1.5
				pitch = 0.0 0.7
				pitch = 1.0 1.0
				loop = true
			}
		}
	}
	MODULE
	{
		name = ModuleWaterfallFX
		moduleID = BE3FX
		engineID = BE3
		CONTROLLER
		{
			name = atmosphereDepth
			linkedTo = atmosphere_density
		}
		CONTROLLER
		{
			name = throttle
			linkedTo = throttle
			engineID = BE3
		}
		CONTROLLER
		{
			name = randomshock1
			linkedTo = random
			noiseType = perlin
			scale = 1
			minimum = 0
			speed = 5
			seed = 1
		}
		CONTROLLER
		{
			name = randomshock2
			linkedTo = random
			noiseType = perlin
			scale = 1
			minimum = 0
			speed = 8
			seed = 10
		}
		CONTROLLER
		{
			name = randomshock3
			linkedTo = random
			noiseType = perlin
			scale = 1
			minimum = 0
			speed = 5
			seed = 100
		}
		CONTROLLER
		{
			name = randomshock4
			linkedTo = random
			noiseType = perlin
			scale = 1
			minimum = 0
			speed = 8
			seed = 1000
		}
		TEMPLATE
		{
			templateName = waterfall-hydrolox-rs25-1
			overrideParentTransform = fxTransformCore
			scale = 1,1,1
			rotation = 90,0,0
			position = 0,-2,0
		}
	}
}

 

 

Edited by sjwt
Added spoilers
Link to comment
Share on other sites

4 hours ago, Lucas_R said:

Yeah I can. And just to clarify, you want a screen shot of my Gamedata folder correct?

Might help me see some stuff that's obviously wrong if so, but honestly it's probably not necessary. As long as you have the folders Squad, Waterfall, StockWaterfallEffects, and the file ModuleManager.4.1.4.dll in there it should work, assuming you don't have Restock. I'd more like to see a screenshot of the plumes not showing up, cause that would tell me what engine you're using. I still might not be able to fix your problem, but it could point me to something else.

Link to comment
Share on other sites

7 hours ago, Mitohnesprudel said:

It also gives me this error:

 

You need to specify the parent transform properly. Your template says

TEMPLATE
		{
			templateName = waterfall-hydrolox-rs25-1
			overrideParentTransform = fxTransformCore
			scale = 1,1,1
			rotation = 90,0,0
			position = 0,-2,0
		}
	}

However, i doubt you have fxTransformCore in your model. You will need to find the right transform to attach to, which is covered a few posts above yours. luckily, from your other post, I can see 

		thrustVectorTransformName = flammes

Which is probably the correct one to use. 

Link to comment
Share on other sites

19 hours ago, RyanRising said:

Might help me see some stuff that's obviously wrong if so, but honestly it's probably not necessary. As long as you have the folders Squad, Waterfall, StockWaterfallEffects, and the file ModuleManager.4.1.4.dll in there it should work, assuming you don't have Restock. I'd more like to see a screenshot of the plumes not showing up, cause that would tell me what engine you're using. I still might not be able to fix your problem, but it could point me to something else.

Okay, that sounds good. I do have all of those folders in what I believe to be the correct places, but when I try and play KSP, the loading screen (with the pictures and yellow bar at the bottom) does not move at all. 

I will get those screen shots to you soon!

Thanks again.

Link to comment
Share on other sites

1 hour ago, mateusviccari said:

I want to link the plume strength to the SRB's current rated thrust, since throttle is always at 100%. The SRB's rated thrust is constantly varying because I'm using real fuels with a throttle curve. Is it possible?

https://github.com/post-kerbin-mining-corporation/Waterfall/wiki/Controllers#thrust-controller

Link to comment
Share on other sites

I'm using the 1.11 version of WaterfallReStock with 1.12.1 and I'm getting no sound from engines, and explosions are very quiet (but I don't know if this is due to Waterfall), please update WaterfallRestock to 1.12.1

Link to comment
Share on other sites

On 5/16/2021 at 2:57 PM, lemon cup said:

What I would do is just install it normally like any other mod. HOWEVER, if you’ve also got Restock installed, none of the engine effects will show up in game because all of the StockWaterfallEffect .cfgs contain a written command line that tell them not to function if Restock is present.

Little late to the party but anyway, also wanted to add Stock Waterfall Effects for Bobcat, Cheetah and the jet engines to my game, so I downloaded the stock effects from CKAN with Restock & Waterfall Restock already installed and at least the two rocket engines had the Waterfall plume. Any idea why & what to do now?

Link to comment
Share on other sites

6 minutes ago, Neebel said:

Little late to the party but anyway, also wanted to add Stock Waterfall Effects for Bobcat, Cheetah and the jet engines to my game, so I downloaded the stock effects from CKAN with Restock & Waterfall Restock already installed and at least the two rocket engines had the Waterfall plume. Any idea why & what to do now?

You’re saying the Bobcat and Cheetah, etc, engines do not have Waterfall plumes correct?

Navigate to the following folder in your KSP directory: [GameData/StockWaterfallEffects/EngineConfigurations]

Open the .cfg files for the engines that ReStock does not touch, the very top line should read as follows:

@PART[LiquidEngineLV-TX87]:NEEDS[Waterfall&!ReStock]:FINAL

Erase the text that I bolded and underlined, and save the file. That will enable the plumes!
 

Link to comment
Share on other sites

17 minutes ago, lemon cup said:

You’re saying the Bobcat and Cheetah, etc, engines do not have Waterfall plumes correct?

No, sorry if my text was hard to understand,  I'm not a native speaker. I did not have to change anything in the cfg files, the plumes for Bobcat & Cheetah were just there, all other plumes seemed to overlap with the ones from Waterfall Restock. I'll quickly reinstall everything and see if it happens again

Link to comment
Share on other sites

21 minutes ago, Neebel said:

No, sorry if my text was hard to understand,  I'm not a native speaker. I did not have to change anything in the cfg files, the plumes for Bobcat & Cheetah were just there, all other plumes seemed to overlap with the ones from Waterfall Restock. I'll quickly reinstall everything and see if it happens again

Oh, I see what you mean now! That is unexpected, and could be an issue related to downloading from CKAN. I couldn't say for sure why you are having that issue though (I manually download/install mods), so hopefully soon you may get a better answer from Nertea or @Knight of St John. If not, you could ask in the dedicated CKAN thread.

EDIT: Quickly did some research and found out that the latest release of Stock Waterfall Effects no longer conflicts with Restock! 

But if you are having issues with double plumes overlapping when the engines are running, I think the latest version of WaterfallRestock might fix this. If not, you may want to delete the .cfgs inside the StockWaterfallEffects folder for all of the ReStock engines (Reliant, Swivel, Poodle, etc.).

Edited by lemon cup
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...