Jump to content

[1.12.x] Waterfall - a framework for continuous, mesh-driven engine effects (Aug 2)


Nertea
 Share

Recommended Posts

  • 2 weeks later...
On 1/29/2022 at 5:11 PM, intelliCom said:

I've been having a problem for a while now. I'm not 100% certain if it's Waterfall FX that does this, but a lot of audio tends to cut out after a while from starting up the game. What used to be the rumbling thunder from a Mastodon just becomes silence when I use the same engine later. It remains like this until restarting the game, where the same thing happens: I hear the audio for a while, but then it decides to stop making sound. What's going on here?

For more specific notes on what's happening, I have listed everything I can note down below:

  • Audio that still works:
    • Staging audio (Pressing spacebar/ pressing spacebar with no stages left)
    • Ambient audio (Moving at high speeds through atmospheres, VAB audio)
  • Audio that fails after some arbitrary amount of time (could be consistent, could be inconsistent, I'm not too sure) (All of these fail at once, not one at a time):
    • All Engine/RCS audio
    • Explosion audio
    • Parachute deployment audio

Update, I've found that it tends to happen when switching between map view and flight view. When it happens enough, the noise cuts out.

Edited by intelliCom
Link to comment
Share on other sites

3 hours ago, intelliCom said:

Update, I've found that it tends to happen when switching between map view and flight view. When it happens enough, the noise cuts out.

This is highly unlikely to have anything to do with Waterfall.

Link to comment
Share on other sites

Just now, Al2Me6 said:

This is highly unlikely to have anything to do with Waterfall.

Apologies. Could I be redirected to the mod that changes the audio of engines from stock effects to more realistic and "powerful" effects?

Link to comment
Share on other sites

  • 4 weeks later...

Hi!  I am using Waterfall,  Plume Party and EVE  (don't know if that changes anything)  and I am trying to rescale an engine, well mutiple engines.   It's from Benjee's Shuttle mod.   I changed the rescaleFactor to 1.75, but now my engine plumes are 3/4 too small.     

 

I saw something earlier on about the Waterfall engine configurator, but when I open it is says "Couldn't find any effect modules on this craft, add modules via config before using the editor."   I am assuming that  this means Waterfall cant help me, but better safe then sorry.

 

So basically, what do I have to do to rescale the engine plumes and effects so they are the same size as the engines?

 

 

Spoiler

t8Qy1Mt4Zb-HHFWmGaiiRD-INEvH7wZRC9v_khRMuKkNmAB1GtQyY0A1dIcd_FN-3IB73gfY251QoCr9eM_CaEuTHBFUCSKbN1ClEcCGhjBHpP-IrCGpnPpqEabtlVRBAiM3lAcR5B0A2E4gmxwjt2K8HfNX9G6lHpYmT-RBsnaTp-CJhbV5fV3FZGYRcUS1V3eXslxGDqp5Za33qv-s7s78zv-OgE5owH4Y9fk692RawJnMaS-NmkW8VSBEdRWpNlN64tQzVFk-6KeX

 

Edited by Tundra
Link to comment
Share on other sites

  • 3 weeks later...

Question for anyone who knows about the setting up Controllers, specifically "Engine Event" controllers:

I would like to link a series of Effects to play when an engine flames out, Basically, the end result I am looking for is that a booster engine continues to look like it is still "spewing" after burnout - but I cannot get the controller to trigger.  Here is how I wrote the Controller:

Quote

CONTROLLER
      {
         name = Burnout
         linkedTo = engineEvent
         eventName = flameout
         eventDuration = 600
         eventCurve
         {
            key = 0 0
            key = 600 1
         }
      }

I placed it in the config and it displays properly in the in-game editor. But oddly, when I go to edit the Controller in game, it shows that it has defaulted to be linked to "Ignition" instead of "Flameout" even though it is specified in the CONTROLLER setting. However, even manually switching it over to "Flameout" and then running the engine to fuel-depletion, it still does not trigger the effects. 

ALSO: smaller issue but still odd:
when specifying the "Duration" of an Engine Event Controller, I have found that (even though the wiki said it is time measured in seconds) the Controller seems to be using some different unit of time. For example, in the above CONTROLLER, you can see I wrote 600. That should indicate 600 seconds, but actually in-game this starts and stops in the span of about 30 seconds. If I were to put a "30" in the Duration block, the animation would only last a second or two. This happens no matter how I scale the curve.

@Knight of St John @Zorg Asking the pros :blush:

EDIT: Pinging @Knight of St John and @Zorg again just to be sure the mystery is real. Feel free to berate me as you see fit. ^_^

Edited by lemon cup
Link to comment
Share on other sites

Would it be possible to implement something that mimics plume-plume interaction with intersecting meshes, kind of like how a few mods do lightning, ie when two meshes overlap that have different origins, they would glow a bit brighter in that intersecting area? 

Link to comment
Share on other sites

  • 1 month later...
  • 2 weeks later...

Hello, I'm having an issue with my plume that's built on waterfall.

During sunset, at an instantaneous time that I assume the game registers as night, the plume disappears. It reappears in the day but instantly vanishes only during the night.

How do I fix this?

Link to comment
Share on other sites

On 5/12/2022 at 5:35 PM, Fossilized said:

Hello, I'm having an issue with my plume that's built on waterfall.

During sunset, at an instantaneous time that I assume the game registers as night, the plume disappears. It reappears in the day but instantly vanishes only during the night.

How do I fix this?

That's not a lot of information to go on, but I haven't heard of this before.

On 5/1/2022 at 12:34 PM, Iso-Polaris said:

If I  use waterfall alongside with KSPI-E , the engines with WF config would lose it's ability to tweakscale.

KSPIE question, KSPIE thread. 

On 3/20/2022 at 11:22 AM, lemon cup said:

Question for anyone who knows about the setting up Controllers, specifically "Engine Event" controllers:

I would like to link a series of Effects to play when an engine flames out, Basically, the end result I am looking for is that a booster engine continues to look like it is still "spewing" after burnout - but I cannot get the controller to trigger.  Here is how I wrote the Controller:

I placed it in the config and it displays properly in the in-game editor. But oddly, when I go to edit the Controller in game, it shows that it has defaulted to be linked to "Ignition" instead of "Flameout" even though it is specified in the CONTROLLER setting. However, even manually switching it over to "Flameout" and then running the engine to fuel-depletion, it still does not trigger the effects. 

ALSO: smaller issue but still odd:
when specifying the "Duration" of an Engine Event Controller, I have found that (even though the wiki said it is time measured in seconds) the Controller seems to be using some different unit of time. For example, in the above CONTROLLER, you can see I wrote 600. That should indicate 600 seconds, but actually in-game this starts and stops in the span of about 30 seconds. If I were to put a "30" in the Duration block, the animation would only last a second or two. This happens no matter how I scale the curve.

@Knight of St John @Zorg Asking the pros :blush:

Those two are the ones who would know, perhaps Knight has used these but I don't think many others have used the Event controllers before, they might be broken.

On 3/5/2022 at 5:05 AM, Tundra said:

Hi!  I am using Waterfall,  Plume Party and EVE  (don't know if that changes anything)  and I am trying to rescale an engine, well mutiple engines.   It's from Benjee's Shuttle mod.   I changed the rescaleFactor to 1.75, but now my engine plumes are 3/4 too small.     

 

I saw something earlier on about the Waterfall engine configurator, but when I open it is says "Couldn't find any effect modules on this craft, add modules via config before using the editor."   I am assuming that  this means Waterfall cant help me, but better safe then sorry.

 

So basically, what do I have to do to rescale the engine plumes and effects so they are the same size as the engines?

 

 

  Reveal hidden contents

 

The real problem you have is that neither of those engines pictured use Waterfall plumes. They both use stock FX :)

Link to comment
Share on other sites

34 minutes ago, Nertea said:

Those two are the ones who would know, perhaps Knight has used these but I don't think many others have used the Event controllers before, they might be broken.

Ignition controller works as expected, it is the "Flameout" controller that does indeed seem broken. 

I'll ping those two again just for gits and shiggles, worst they can do is berate me which is really quite alright.

Link to comment
Share on other sites

Posted (edited)
On 5/13/2022 at 11:04 PM, Nertea said:

That's not a lot of information to go on, but I haven't heard of this before.

KSPIE question, KSPIE thread. 

Those two are the ones who would know, perhaps Knight has used these but I don't think many others have used the Event controllers before, they might be broken.

The real problem you have is that neither of those engines pictured use Waterfall plumes. They both use stock FX :)

https://streamable.com/lawmts

Clip of it happening, including all my settings for one of the segments

The light and distortion effects don't disappear, only the volumetric pieces

New effects added during night stay during the entire day cycle

Edited by Fossilized
Link to comment
Share on other sites

3 hours ago, zakkpaz said:

I'm having an issue with z fighting on the inside of engines and some other mods. has this been happening to anyone else?

That's a scatterer bug, have a look over there.

Link to comment
Share on other sites

Quick question, love the mod, spectacular work :)
Is it intended to not have smoke after the Waterfall-modified engines (such as stock Skipper, Reliant, and NearFuture compatible ones like Erebus liquid methane etc)?
I get that it wont use the particle plumes, but im thinking there still ought to be smoke when launching and some distance behind the engine, no?
Or am i suffering from some compatability issue?

Running these versions;
Waterfall_0_8_1
StockWaterfallEffects_0_6_3
SmokeScreen-2.8.14.0
SRB_Waterfall_Effects_SWE-1.4.1_HOTFIX
RealPlume_v13.3.2
RealPlume-Stock_v4.0.8
Engine_Lighting_Relit-1.6.3.2

Link to comment
Share on other sites

1 hour ago, kerbmario said:

Does it work with jet engines? when yes, could you share screenshots?

Works with any engine, if you have a mod that adds effects to them! Here's one that adds Waterfall effects to the stock engines, including the jet engines:

Link to comment
Share on other sites

hi, im having a bug where the flameout sparks on the engines shoot out perpendicular to the engines and not straight out of the engine bell.

i'll provide more info if this isnt a known bug yet. im using restock configs.

Link to comment
Share on other sites

15 minutes ago, woodbyte said:

If I am playing with just Restock and Waterfall, should I get both the Restock and Stock configs for Waterfall or just the Restock ones? Thanks.

Both.

Link to comment
Share on other sites

  • 2 weeks later...

Hey, has anybody else had a problem with the plume sounds completely cutting off randomly into the game? I'm in a rush rn, so I don't have the time to look thru the threads at all 'cause I'm lazy.
Any help appreciated! :)

Link to comment
Share on other sites

I really love this mod. It has revolutionarized an important part of the game design and the impact on the computer resources seems to be smaller than with ugly stock plumes. I'll never understand why developers cling to obsolete stuff. This should become stock.

Anyway, I'd appreciate if KSPX's LV-NB ("Sisyphus" Atomic Rocket Motor) got a Waterfall plume. If I remember well, it was the first non-stock nuclear engine, a 2.5 m workhorse. I used it extensively for my Kron missions. It got a a RealPlume configuration, but it would be nice if Waterfall had one, too.

Link to comment
Share on other sites

First off, I just want to echo how  amazing Waterfall is at what it does, it really is a step up from the particle-based system stock uses.

Moving on, I've been trying to get a custom mesh working for an engine I'm working on, but I can't seem to get the full mesh to display in-game. Been trying to use the bundled meshes as an example but it's just not clicking in my head at the moment. See screenshots below for the progress I have at the moment. Any help would be really appreciated!

Spoiler

unknown.png

unknown.png


I also have a question regarding how the face culling works for the deform meshes. Having read the discussion here and the documentation on the GitHub, I gather that most people mainly use the simple cylinder mesh to get good plumes from all angles, especially looking from straight behind, but I wonder if there's a way to enable that kind of behavior on the deform meshes as well, as being able to better control the shape of the plume is something that sounds really appealing.
It might be possible but I haven't found it yet, once again if there's something I missed do tell.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...