Jump to content

[1.9-1.12] EVE-Redux: Performance-enhanced EVE + maintenance (v1.11.5.1 - 07/11/2021)


blackrack
 Share

Recommended Posts

Could anyone help me, Im trying to get 3D auroras, such as in this picturedAaZ1eP.jpgIm not really sure where I could start but im assuming EVE would be a good place

Link to comment
Share on other sites

I don't know why the game is stuck on the loading page at startup after I install this mod.

When I removed other mods and only run this mod alone, the problem is still exist.

Could anyone help me?

%E5%B1%8F%E5%B9%95%E6%88%AA%E5%9B%BE%202

%E5%B1%8F%E5%B9%95%E6%88%AA%E5%9B%BE%202

Link to comment
Share on other sites

  • 3 weeks later...
On 9/3/2021 at 9:49 PM, Virtualgenius said:

I to have no clouds there are no other visual mods except EvE and Scatterer but I have beautiful sunset launches

quYhQpK.png

ETFgjDS.png

Very nice photos!

You’ll need a configs pack like SVE, Spectra, or AVP

Link to comment
Share on other sites

Is the 1,8 version still valid? I noticed that clouds haven't been creating surface shadows for as long as recent memory. Possibly since using this Redux version. Ive got the full suite of visual mods with AVP 8k. No tufx. I remember years ago clouds created shadows on the ground. And every now and then I see Reddit posts of images containing said shadows. Makes me wonder why they're missing from my install. Maybe just an AVP thing?

Link to comment
Share on other sites

How clouds are born:

LeadingImmediateBobcat-size_restricted.g

https://gfycat.com/leadingimmediatebobcat

On 9/9/2021 at 4:20 AM, Motokid600 said:

Is the 1,8 version still valid? I noticed that clouds haven't been creating surface shadows for as long as recent memory. Possibly since using this Redux version. Ive got the full suite of visual mods with AVP 8k. No tufx. I remember years ago clouds created shadows on the ground. And every now and then I see Reddit posts of images containing said shadows. Makes me wonder why they're missing from my install. Maybe just an AVP thing?

Check if AVP has not disabled those cloud shadows on purpose (they used to be super slow pre-redux). With that said the cloud shadows work in this version and you shouldn't use the 1.8 version.

Link to comment
Share on other sites

  • 2 weeks later...

Got an EXC when loading on KSP 1.12.2 Win10, before the main menu:

Spoiler

[LOG 02:53:21.100] [AddonLoader]: Instantiating addon 'GlobalEVEManager' from assembly 'EVEManager'
[LOG 02:53:21.149] [AddonLoader]: Instantiating addon 'ShaderLoaderClass' from assembly 'ShaderLoader'
[LOG 02:53:21.150] [AddonLoader]: Instantiating addon 'ShaderProperties' from assembly 'Utils'
[LOG 02:53:21.151] [AddonLoader]: Instantiating addon '_BuildManager' from assembly '_BuildManager'
[EXC 02:53:21.159] NotSupportedException: The invoked member is not supported in a dynamic module.
    System.Reflection.Emit.AssemblyBuilder.get_Location () (at <9577ac7a62ef43179789031239ba8798>:0)
    _BuildManager._BuildManager+<>c__DisplayClass2_0.<logVersion>b__0 (System.Reflection.Assembly x) (at <e4b5582dab1d42df871d52053423f128>:0)
    System.Linq.Enumerable+WhereSelectArrayIterator`2[TSource,TResult].ToList () (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
    System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable`1[T] source) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
    _BuildManager._BuildManager.logVersion () (at <e4b5582dab1d42df871d52053423f128>:0)
    _BuildManager._BuildManager.Awake () (at <e4b5582dab1d42df871d52053423f128>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.GameObject:AddComponent(Type)
    AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
    AddonLoader:StartAddons(Startup)
    <LoadObjects>d__90:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    <CreateDatabase>d__71:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    GameDatabase:StartLoad()
    <LoadSystems>d__11:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    LoadingScreen:Start()

I'm cautions with exceptions... not going to use this mod until it's fixed or understood.

Link to comment
Share on other sites

On 9/22/2021 at 12:06 AM, Krazy1 said:

Got an EXC when loading on KSP 1.12.2 Win10, before the main menu:

  Hide contents

[LOG 02:53:21.100] [AddonLoader]: Instantiating addon 'GlobalEVEManager' from assembly 'EVEManager'
[LOG 02:53:21.149] [AddonLoader]: Instantiating addon 'ShaderLoaderClass' from assembly 'ShaderLoader'
[LOG 02:53:21.150] [AddonLoader]: Instantiating addon 'ShaderProperties' from assembly 'Utils'
[LOG 02:53:21.151] [AddonLoader]: Instantiating addon '_BuildManager' from assembly '_BuildManager'
[EXC 02:53:21.159] NotSupportedException: The invoked member is not supported in a dynamic module.
    System.Reflection.Emit.AssemblyBuilder.get_Location () (at <9577ac7a62ef43179789031239ba8798>:0)
    _BuildManager._BuildManager+<>c__DisplayClass2_0.<logVersion>b__0 (System.Reflection.Assembly x) (at <e4b5582dab1d42df871d52053423f128>:0)
    System.Linq.Enumerable+WhereSelectArrayIterator`2[TSource,TResult].ToList () (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
    System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable`1[T] source) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
    _BuildManager._BuildManager.logVersion () (at <e4b5582dab1d42df871d52053423f128>:0)
    _BuildManager._BuildManager.Awake () (at <e4b5582dab1d42df871d52053423f128>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    UnityEngine.GameObject:AddComponent(Type)
    AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
    AddonLoader:StartAddons(Startup)
    <LoadObjects>d__90:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    <CreateDatabase>d__71:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    GameDatabase:StartLoad()
    <LoadSystems>d__11:MoveNext()
    UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
    LoadingScreen:Start()

I'm cautions with exceptions... not going to use this mod until it's fixed or understood.

It's an old EVE bug that probably is not going to be fixed because anyone who understands why it happens is long gone.

The good news is it's harmless.  You can cease worrying about it. :)

Link to comment
Share on other sites

So I installed 1.11.3.1 on KSP 1.12.2 (ignoring the loading NRE) and it doesn't seem to do anything. I clicked the EVE icon and it says: "No config! Please add a config with the content of "EVE_CLOUDS{}" to populate." 

The OP doesn't have a "Dependencies" section. I used CKAN and it has several "recommendations" but no required extra mods or config thing. Doesn't it ship with a default config? 

Link to comment
Share on other sites

18 minutes ago, Krazy1 said:

So I installed 1.11.3.1 on KSP 1.12.2 (ignoring the loading NRE) and it doesn't seem to do anything. I clicked the EVE icon and it says: "No config! Please add a config with the content of "EVE_CLOUDS{}" to populate." 

The OP doesn't have a "Dependencies" section. I used CKAN and it has several "recommendations" but no required extra mods or config thing. Doesn't it ship with a default config? 

This doesn't come with a config, in the OP is the link to the original EVE configs, or you can use one from a visual pack (Spectra, AVP, etc)

Edited by Firebird989
Link to comment
Share on other sites

11 hours ago, Firebird989 said:

This doesn't come with a config,

Ok I loaded the stock EVE config with CKAN and now it works... very nice. Except for Eve. It's just a solid purple sphere. No land, clouds, oceans... nothing.  I'm having deva vu. I tried this mod a year ago and had the same problem. Nobody fixed this I guess? I'll check old posts.

Update: I can't find any old post about this Eve problem. Anybody know how to fix it?

Edited by Krazy1
Link to comment
Share on other sites

1 hour ago, Krazy1 said:

Ok I loaded the stock EVE config with CKAN and now it works... very nice. Except for Eve. It's just a solid purple sphere. No land, clouds, oceans... nothing.  I'm having deva vu. I tried this mod a year ago and had the same problem. Nobody fixed this I guess? I'll check old posts.

Update: I can't find any old post about this Eve problem. Anybody know how to fix it?

Screenshots and logs would likely let people better understand the problem you're having.

Link to comment
Share on other sites

Hi, I have an issue when both Scatterer and EVE are installed, I get flickering dark/light areas at the edges of Kerbin, like so:

p7bwc36do7n.png

 

While playing, they are a lot more obvious than the screenshot as the flickering area stretches over most of the space/planet edge, they start appearing approximately after climbing above 120km, but not when high enough for the clouds to change to the distant versions seen from high altitude.  If only EVE, or only Scatterer, are installed, this doesn't happen, the settings for both these mods are defaults, and my installed mods are:

d7ogcraxky9.png

 

Log file: https://drive.google.com/file/d/1MywcreV304L9dYeCjL5TCSPnnAv6Vm26/view?usp=sharing

 

 

Link to comment
Share on other sites

5 hours ago, S4qFBxkFFg said:

Hi, I have an issue when both Scatterer and EVE are installed, I get flickering dark/light areas at the edges of Kerbin, like so:

p7bwc36do7n.png

 

While playing, they are a lot more obvious than the screenshot as the flickering area stretches over most of the space/planet edge, they start appearing approximately after climbing above 120km, but not when high enough for the clouds to change to the distant versions seen from high altitude.  If only EVE, or only Scatterer, are installed, this doesn't happen, the settings for both these mods are defaults, and my installed mods are:

d7ogcraxky9.png

 

Log file: https://drive.google.com/file/d/1MywcreV304L9dYeCjL5TCSPnnAv6Vm26/view?usp=sharing

 

 

I get this too but I assumed it was because I was playing at 10x scale.

Link to comment
Share on other sites

21 hours ago, RyanRising said:

Screenshots and logs would likely let people better understand the problem you're having.

Just figured everyone "should" have the same issue with Eve. It's the stock config and I didn't change anything. 

KSP log

Kerbin good:

2KQ6vsP.png

Eve not good:

ttKysFr.png

Link to comment
Share on other sites

6 hours ago, Krazy1 said:

Just figured everyone "should" have the same issue with Eve. It's the stock config and I didn't change anything. 

KSP log

Kerbin good:

Eve not good:

That's just how the BoulderCo config of eve looks from orbit.

23 hours ago, S4qFBxkFFg said:

Hi, I have an issue when both Scatterer and EVE are installed, I get flickering dark/light areas at the edges of Kerbin, like so:

While playing, they are a lot more obvious than the screenshot as the flickering area stretches over most of the space/planet edge, they start appearing approximately after climbing above 120km, but not when high enough for the clouds to change to the distant versions seen from high altitude.  If only EVE, or only Scatterer, are installed, this doesn't happen, the settings for both these mods are defaults, and my installed mods are:

Log file: https://drive.google.com/file/d/1MywcreV304L9dYeCjL5TCSPnnAv6Vm26/view?usp=sharing

I can't tell much, can you post a video?

Link to comment
Share on other sites

13 hours ago, blackrack said:

That's just how the BoulderCo config of eve looks from orbit.

OK. Well, the "Invalid Name!" message is misleading. The cloud layer with that name has simply been loaded already. Suggest changing it to "Loaded" 

nSLjsNw.png

Opaque Eve clouds makes landing much more difficult...

Spoiler

Sort of changes the balance for Career missions to Eve. But it's an interesting challenge. An M700 resource scan doesn't help much.  Kerbnet doesn't give a persistent planet-wide view.  There's Scansat mod but I don't really want to add new parts and it still doesn't give a direct map overlay so it doesn't work with Trajectories. I can drop a bunch of pins in Kerbnet I guess.

New issue: I got exception spam in the Tracking Station when I clicked the EVE icon. I exited quickly so KSP didn't crash, but that's usually what happens when the log gets big enough.

[EXC 19:07:14.014] ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
	System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) (at <9577ac7a62ef43179789031239ba8798>:0)
	System.ThrowHelper.ThrowArgumentOutOfRangeException () (at <9577ac7a62ef43179789031239ba8798>:0)
	Utils.GUIHelper.DrawObjectSelector[T] (ConfigNode sourceNode, System.Int32& selectedObjIndex, System.String& objString, UnityEngine.Vector2& objListPos, UnityEngine.Rect placementBase, UnityEngine.Rect& placement, ConfigNode+Value filter) (at <6b55104f24e84d7fa591c88360adf8ba>:0)
	EVEManager.GenericEVEManager`1[T].DrawGUI (UnityEngine.Rect placementBase, UnityEngine.Rect placement) (at <74fbd85e6b8b4fc697081bc975e35fd8>:0)
	EVEManager.GlobalEVEManager.DrawMainWindow (System.Int32 windowID) (at <74fbd85e6b8b4fc697081bc975e35fd8>:0)
	UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <58f888e0d56a4620958c8e58a768c70d>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

KSP log

Edited by Krazy1
added exception report
Link to comment
Share on other sites

2 hours ago, Krazy1 said:

New issue: I got exception spam in the Tracking Station when I clicked the EVE icon. I exited quickly so KSP didn't crash, but that's usually what happens when the log gets big enough.

[EXC 19:07:14.014] ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.
Parameter name: index
	System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) (at <9577ac7a62ef43179789031239ba8798>:0)
	System.ThrowHelper.ThrowArgumentOutOfRangeException () (at <9577ac7a62ef43179789031239ba8798>:0)
	Utils.GUIHelper.DrawObjectSelector[T] (ConfigNode sourceNode, System.Int32& selectedObjIndex, System.String& objString, UnityEngine.Vector2& objListPos, UnityEngine.Rect placementBase, UnityEngine.Rect& placement, ConfigNode+Value filter) (at <6b55104f24e84d7fa591c88360adf8ba>:0)
	EVEManager.GenericEVEManager`1[T].DrawGUI (UnityEngine.Rect placementBase, UnityEngine.Rect placement) (at <74fbd85e6b8b4fc697081bc975e35fd8>:0)
	EVEManager.GlobalEVEManager.DrawMainWindow (System.Int32 windowID) (at <74fbd85e6b8b4fc697081bc975e35fd8>:0)
	UnityEngine.GUI.CallWindowDelegate (UnityEngine.GUI+WindowFunction func, System.Int32 id, System.Int32 instanceID, UnityEngine.GUISkin _skin, System.Int32 forceRect, System.Single width, System.Single height, UnityEngine.GUIStyle style) (at <58f888e0d56a4620958c8e58a768c70d>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

KSP log

Honestly I think you're a bit too worried about the exceptions, they're a fact of life for modded installs and most of the time they don't actually do anything.  Your game isn't at risk of crashing.

Link to comment
Share on other sites

5 hours ago, Krazy1 said:

OK. Well, the "Invalid Name!" message is misleading. The cloud layer with that name has simply been loaded already. Suggest changing it to "Loaded" 

Opaque Eve clouds makes landing much more difficult...

It's up to you, I don't make the BoulderCo configs and you can make your own configs with lighter coverage. As for the "invalid name", no idea what that's about, I will check it out next time.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...