Jump to content

[1.11.x] Hephaistos - Stockalike ULA Vulcan - Official Stand-alone BDB Expansion


Superpenguin160
 Share

Recommended Posts

On 9/11/2020 at 4:01 PM, Z3R0_0NL1N3 said:

This is a great addition to go alongside BDB, but it's a little bit confusing to assemble. Could you create a guide in the OP? And also perhaps one for the flight profile. I'm not sure at what altitude I should be dropping the ACES, or if I'm supposed to do a flyback to land near KSC.

Also, is it possible that we can get an optional config to switch the fuels to the standard Liquid/Oxidizer instead of Methalox? LH2 is fine because there's enough mods that support it (including BDB's centaur), but this is the only mod that I have that uses this fuel, and that reduces the versatility of the parts.

I might add a guide later on, but for now we also included craft files which can give you an impression on how to assemble the rocket. And like most KSP mods this mod is made like with customisation in mind, so no configuration is wrong. (Would love to see a three core Vulcan from someone :kiss:)
The flight profile for the Vulcan is just like any other rocket, the nice thing about S.M.A.R.T. reuse is that they don't need to keep fuel in the booster after stage separation, the engines will re-enter into the atmosphere and will then be picked up by a helicopter. Since that last step is a little hard to do in KSP, you can just land it in the ocean.
Using different fuels in the tanks is in the works!

23 hours ago, NateDaBeast said:

Dang, I'm on 1.8.1 JNSQ, would it be fine to just manually install it and run it on 1.8.1 or is 1.9 a hard dependency?

Most mods don't have a hard dependency, just make sure to back-up before you try though. This mod will probably work on 1.8, but there's no way to know for sure if you don't try it out yourself.

8 hours ago, feluxution said:

I somehow cant fire the engines (KE-4) when they are attached to to the engine Mount. when I attach them directly to the Tank they work. also when I use Idipendent thrust they somehow fire. but not with Main Thrust

I haven't seen this problem before, can you send me a list with all the mods you have installed? Maybe there's a mod that's interfering with this mod. And a clean install of KSP also never hurts.

Link to comment
Share on other sites

17 minutes ago, Superpenguin160 said:

 

I haven't seen this problem before, can you send me a list with all the mods you have installed? Maybe there's a mod that's interfering with this mod. And a clean install of KSP also never hurts.

I found out that it only happens when I controll the rocket via the Centaur Controll Unit. when I use other for example the Stock ones then it doesnt happen

Link to comment
Share on other sites

22 hours ago, Superpenguin160 said:

I might add a guide later on, but for now we also included craft files which can give you an impression on how to assemble the rocket.

I intend to replace the old Vulcan build guide on the unofficial BDB wiki with an update for this soon

Edited by Friznit
Link to comment
Share on other sites

On 9/12/2020 at 8:35 PM, feluxution said:

I found out that it only happens when I controll the rocket via the Centaur Controll Unit. when I use other for example the Stock ones then it doesnt happen

In that case I'm not sure what's wrong and I probably can't fix that. Do you know though that the ACES/Centaur V engine mount has a built in probe core, so you don't necessarily need an extra probe core.

On 9/13/2020 at 3:26 AM, Clamp-o-Tron said:

Did someone say Hephaistos HEAVY?

[image snip]

That looks great! That thing must be capable of some Eeloo missions.

20 hours ago, Friznit said:

I intend to replace the old Vulcan build guide on the unofficial BDB wiki with an update for this soon

That would be great, thanks for your effort. Just tell me when it's finished so I can put it in the main post.

Edited by Superpenguin160
Link to comment
Share on other sites

2 hours ago, Superpenguin160 said:

Version 1.1

HRBPg3y.png

KuO3bUo.png

  • There are multiple new textures for the main tank, install them from the extra's folder (Thanks to @Drakenex)
  • Fixed some bugs
  • The parafoil behaves like a parachute now (The ballute is missing, because it created an off centre force. I hope this will be fixed for the next update)

i already put the extras folder to the hephaistos folder but it gives me b9partswitch error, and how to fix missing parts FuelCell.ACES in Craft file?

Link to comment
Share on other sites

2 hours ago, llikooid said:

i already put the extras folder to the hephaistos folder but it gives me b9partswitch error, and how to fix missing parts FuelCell.ACES in Craft file?

As said before, those craft files are intended for standalone installations (no other mods like BDB or Re-Stock present). For that particular part, it just clones the stock fuel cell and changes  input resource to hydrolox, but if re-stock is present, the part isn't created (re-stock already includes a hydrolox capable fuel cell).

Can you please post the B9 error?

Link to comment
Share on other sites

50 minutes ago, Drakenex said:

not really, he's talking about 1.875 --> 3.125.

That's exactly what I'm talking about:

HfEc1rT.png

 

8 hours ago, llikooid said:

i already put the extras folder to the hephaistos folder but it gives me b9partswitch error

Looks like you've installed it wrong. You need to extract the Extras folder itself, not its contents. Your path should look like "Gamedata\Hephaistos\Extras", not "Gamedata\Hephaistos\Paintjobs".

Link to comment
Share on other sites

I provided a config for Filter Extension:

https://github.com/linuxgurugamer/FilterExtension/pull/33

Okay with that?

 

Edit: please provide better / dedicated 32x32 .dds files for Filter Extension - I only could derive the pics out of the resources inside the mod folder.

Edited by Gordon Dry
Link to comment
Share on other sites

On 9/14/2020 at 3:33 PM, Superpenguin160 said:

In that case I'm not sure what's wrong and I probably can't fix that. Do you know though that the ACES/Centaur V engine mount has a built in probe core, so you don't necessarily need an extra probe core.

 

Thats the Problem. when I use the Engine mounts Probe Core I cant control the Emgines

Link to comment
Share on other sites

16 minutes ago, Drakenex said:

new @Zorg Delta Small interstage fits even better

Oh I didn't realise a 3.125 to 1.875 was being discussed here :P I just added it in as a variant for the 3.125 to 1.5 adapter using the same textures since why not. Glad you find it useful.

On 9/14/2020 at 6:33 PM, Superpenguin160 said:

In that case I'm not sure what's wrong and I probably can't fix that. Do you know though that the ACES/Centaur V engine mount has a built in probe core, so you don't necessarily need an extra probe core.

 

8 minutes ago, feluxution said:

Thats the Problem. when I use the Engine mounts Probe Core I cant control the Emgines

This sounded like a familiar problem. The key ``vesselType = Probe`` needs to be added to the part cfg so that the engine mount/avionics unit can actually function independently. It often gets missed in testing due to the presence of a probe core on the payload. 

Spoiler

I know this because I once spent several hours trying to figure out why a Universal Storage probe core wasnt working, I now know to look for that field whenever a probe core seems to be missing command :P

 

Edited by Zorg
Link to comment
Share on other sites

16 minutes ago, Zorg said:

This sounded like a familiar problem. The key ``vesselType = Probe`` needs to be added to the part cfg so that the engine mount/avionics unit can actually function independently. It often gets missed in testing due to the presence of a probe core on the payload. 

  Hide contents

I know this because I once spent several hours trying to figure out why a Universal Storage probe core wasnt working, I now know to look for that field whenever a probe core seems to be missing command :P

 

Nice find! thanks

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...