• 0

Question

14 answers to this question

Recommended Posts

  • 0
1 hour ago, Hadron27 said:

i cant find my player.txt though

because since the game crashed while loading the assets,and not loading the Gameplay assets,like the rockets,vab,buildings,etc,the app didn't created the Player.log.duh

______________________________________________________________________________________Solution Border,duh_________________

Apparently in you KSP.Log,i found a TLA_Stack_Debug_leak:

[WRN 11:07:54.384] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 11:07:54.384] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 11:07:54.399] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 11:07:54.399] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 11:07:58.837] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 11:07:58.837] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations

Luckily,i found a Solution for this.

however,It's not a fix, it's a workaround to keep you playing - but it worths the try: On the Main Menu, Settings, Graphics, Set the Frame Rate Limit to 60 fps.

The hard part on all of this is to try to replicate the problem here on my machine - once I manage to do that, I will have something to sniff on.

E5qexmG.png

basically,that's what @Lisias said to Commodore_32 in this topic:

which he also had that TLA problem.

and another solution(in case changing the fps limits still doesn't work,or if you want to lower the posibility to get yelled by the tla) is changing the V-sync to Don't V-sync,which it's probably the best option to increase FPS,aka,lowering the possibilities to get a TLA_DEBUG_STACK_LEAK.

Edited by Kane Kerman
tyops!

Share this post


Link to post
Share on other sites
  • 0
4 hours ago, Kane Kerman said:

because since the game crashed while loading the assets,and not loading the Gameplay assets,like the rockets,vab,buildings,etc,the app didn't created the Player.log.duh

______________________________________________________________________________________Solution Border,duh_________________

Apparently in you KSP.Log,i found a TLA_Stack_Debug_leak:


[WRN 11:07:54.384] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 11:07:54.384] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 11:07:54.399] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 11:07:54.399] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 11:07:58.837] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 11:07:58.837] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations

Luckily,i found a Solution for this.

however,It's not a fix, it's a workaround to keep you playing - but it worths the try: On the Main Menu, Settings, Graphics, Set the Frame Rate Limit to 60 fps.

The hard part on all of this is to try to replicate the problem here on my machine - once I manage to do that, I will have something to sniff on.

E5qexmG.png

basically,that's what @Lisias said to Commodore_32 in this topic:

which he also had that TLA problem.

and another solution(in case changing the fps limits still doesn't work,or if you want to lower the posibility to get yelled by the tla) is changing the V-sync to Don't V-sync,which it's probably the best option to increase FPS,aka,lowering the possibilities to get a TLA_DEBUG_STACK_LEAK.

Thanks, I'll try not to crash while in settings.

By the way, Can we be friends?

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Hadron27 said:

Thanks, I'll try not to crash while in settings.

no problem!:wink:

Just now, Hadron27 said:

By the way, Can we be friends?

idk.:confused:

Share this post


Link to post
Share on other sites
  • 0

Being yelled at by a program's internal code is definitely not a first for me :D

Share this post


Link to post
Share on other sites
  • 0
14 minutes ago, Hadron27 said:

it crashed while i was in the editor

heres the new ksp.txt

http://www.mediafire.com/file/9ex5pk19k92yrhr/file

Still no player.txt

why does ksp hate me

damn

____________________________________Solution Border,duh___________________________________________________________________

well,in your ksp.log i don't see any TLA,that's good,but...

the last words of the ksp.log file is:

[ERR 16:13:41.523] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for b29cockpit

[ERR 16:13:41.523] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for airramp

[ERR 16:13:41.523] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.524] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.524] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.524] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.538] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for s2CargoRamp

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipTemplate]: Could not locate root part in b-24  liberator as 13 entries remain after eliminating all parts listed as children. This is probably wrong.

[ERR 16:13:42.632] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTke111

[ERR 16:13:42.632] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RFTank-I

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RFTank-I

[ERR 16:13:42.635] [ShipTemplate]: Could not locate root part in Boeing B-29 Superfortress as 38 entries remain after eliminating all parts listed as children. This is probably wrong.

[LOG 16:14:09.526] [KSPUpgradePipeline]: Goliath II HLV (Stock) updated from 1.9.0 to 1.10.1.
[LOG 16:14:09.773] Goliath II HLV loaded!

the most interesting thing is that they're marked as ERR,aka Error.

so,i might be wrong,but i think the problem is caused by... corrupted ships?

maybe some of the craft files needs mods,and i think some of these are:

RO,SXT,and some others that unfortunately i can't identifiy.

Edited by Kane Kerman
tyops!

Share this post


Link to post
Share on other sites
  • 0
2 minutes ago, Kane Kerman said:

damn.

___________________________________________________________________Solution Border,duh___________________________________________________________________________

well,in your ksp.log i don't see any TLA,that's good,but...

the last words of the ksp.log file is:


[ERR 16:13:41.523] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for b29cockpit

[ERR 16:13:41.523] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for airramp

[ERR 16:13:41.523] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.524] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.524] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.524] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.538] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for S2Hull

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for s2CargoRamp

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipConstruct]: Trying to load b-24  liberator - No AvailablePart found for duplexcyclone

[ERR 16:13:41.539] [ShipTemplate]: Could not locate root part in b-24  liberator as 13 entries remain after eliminating all parts listed as children. This is probably wrong.

[ERR 16:13:42.632] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTke111

[ERR 16:13:42.632] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RFTank-I

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.633] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTCargoBay1

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.634] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcWing-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for SXTPWR2800

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RO-B9ProcCS-Early

[ERR 16:13:42.635] [ShipConstruct]: Trying to load Boeing B-29 Superfortress - No AvailablePart found for RFTank-I

[ERR 16:13:42.635] [ShipTemplate]: Could not locate root part in Boeing B-29 Superfortress as 38 entries remain after eliminating all parts listed as children. This is probably wrong.

[LOG 16:14:09.526] [KSPUpgradePipeline]: Goliath II HLV (Stock) updated from 1.9.0 to 1.10.1.
[LOG 16:14:09.773] Goliath II HLV loaded!

the most interesting thing is that they're marked as ERR,aka Error.

so,i might be wrong,but i think the problem is caused by... corrupted ships?

maybe some of the craft files needs mods,and i think some of these are:

RO,SXT,and some others that unfortunately i can't identifiy.

Wait, what? Theres no way that could've crashed me. I didnt even try and load the save. By the way, I downloaded some craft file things a while back from one of those real rocketry mods and their save thingies wont go away even though their craft files dont even exist anymore

Wait, I still have the files,  i just dont know how to properly remove them.

I unsubscribed from all the steam crafts, but not sure how to remove the downloaded ones (non-stock)

Edited by Hadron27
forgot to add context

Share this post


Link to post
Share on other sites
  • 0

i looked further into the craft files and uhhhhh

i have 243 files in my VAB folder for crafts

 

also i hate how the exact same thing happened to another dude but he had mods and i have stock

Edited by Hadron27

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Kane Kerman said:

no problem!:wink:

can you help me i cant delete the Bluedog Design Bureau craft files they're not deleting when i fully remove the files

Share this post


Link to post
Share on other sites
  • 0
1 minute ago, Hadron27 said:

can you help me i cant delete the Bluedog Design Bureau craft files they're not deleting when i fully remove the files

ok.

there's 2 solutions:

1:Through KSP: start ksp and then go to your save file,and then play it,then go to the VAB building,click the saved ships,and delete all the crafts one by one.

2:Manual Deletion: go to the ksp Root Folder,aka,the ksp game folder ex:C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\Ships\VAB and then, delete all the files like Loadmeta and Craft.

i think that should help(?)

Share this post


Link to post
Share on other sites
  • 0
2 hours ago, Hadron27 said:

i looked further into the craft files and uhhhhh

i have 243 files in my VAB folder for crafts

 

also i hate how the exact same thing happened to another dude but he had mods and i have stock

Well, it could be argued that by downloading those craft files from that mod, you are no longer stock....

Share this post


Link to post
Share on other sites
  • 0
16 hours ago, Kane Kerman said:

ok.

there's 2 solutions:

1:Through KSP: start ksp and then go to your save file,and then play it,then go to the VAB building,click the saved ships,and delete all the crafts one by one.

2:Manual Deletion: go to the ksp Root Folder,aka,the ksp game folder ex:C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\Ships\VAB and then, delete all the files like Loadmeta and Craft.

i think that should help(?)

New KSP.TXT (crashed after 5 mins, i flew a rocket, i recovered it, went back into VAB and instantly crashed)

http://www.mediafire.com/file/ftxfvkycglzexds/file

Through KSP: They cannot be deleted, just like the "Stock" crafts that come with the game.

Manual deletion: They come back/They still show up in the "Load craft" section.

It seems TLA_DEBUG_STACK_LEAK strikes again.

Though, I wonder why TLA_DEBUG_STACK_LEAK decided to come back at me.

I found the part where it started!

[LOG 10:47:07.419] [UIApp] Adding Missions App to Application Launcher
[LOG 10:47:07.423] [UIApp] Adding EngineersReport to Application Launcher
[LOG 10:47:07.483] [ActionGroupsApp] OnAppStarted(): id: -751848
[LOG 10:47:07.484] [GenericAppFrame] Reposition 0.3715096 33091
[LOG 10:47:07.485] [UIApp] Adding DeltaVApp to Application Launcher
[LOG 10:47:07.489] [MissionsApp] OnAppStarted(): id: -751836
[LOG 10:47:07.489] MissionsApp does not execute in this game mode, destroying this instance
[LOG 10:47:07.489] [UIApp] OnDestroy: Missions App
[LOG 10:47:07.492] [GenericAppFrame] Reposition 0.3715096 33091
[LOG 10:47:07.580] [GenericAppFrame] Reposition 0.4515096 33092
[LOG 10:47:07.634] [UIApp] Adding KSPedia to Application Launcher
[WRN 10:47:07.895] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 10:47:07.895] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[LOG 10:47:07.932] [UIMasterController]: ShowUI
[WRN 10:47:07.975] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 10:47:07.975] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 10:47:08.008] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 10:47:08.008] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 10:47:08.077] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 10:47:08.080] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 10:47:08.139] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 10:47:08.140] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 10:47:08.174] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak
[WRN 10:47:08.174] To Debug, enable the define: TLA_DEBUG_STACK_LEAK in ThreadsafeLinearAllocator.cpp. This will output the callstacks of the leaked allocations
[WRN 10:47:08.232] Internal: JobTempAlloc has allocations that are more than 4 frames old - this is not allowed and likely a leak

 

hmm. "JobTempAlloc"?

Edited by Hadron27
whoops

Share this post


Link to post
Share on other sites
  • 0

Try this:

  • Go into saves folder, pick any save(s) you want to keep and copy the persistent.sfs files ONLY to an outside location, like your desktop.
  • Turn off steam cloud sync- right click KSP, click Properties, click the Updates tab then disable cloud synchronisation. Save the changes.
  • Completely uninstall KSP, delete any leftover files.
  • Reinstall KSP and make sure the ships/VAB and ships/SPH folders have only stock crafts in them- there should be 10-15 of each.
  • Create a new save game, then copy the folder, rename it to the same name as your existing save and replace the persistent.sfs file with the file you saved on the desktop; repeat for all the saves you want to keep.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.