Jump to content

[1.11.x] Parallax, A PBR Terrain Shader [1.2.1]


Recommended Posts

9 hours ago, Gameslinx said:

I will investigate. Is it spammed, or just once?

Spammed in the console.

EDIT : Incorrect installation on my side, this is fixed now.

GG, Great work \o/

7 hours ago, Gameslinx said:

My mistake, it missed me!

You need Kopernicus (for 1.10, use the bleeding edge kopernicus) https://forum.kerbalspaceprogram.com/index.php?/topic/195699-191-1101r-t-bs-kopernicus-unified-bleeding-edge-branch/

Actually we can see this in the log file (I had not installed Kopernicus the first time).
 

[WRN 10:18:30.937] AssemblyLoader: Assembly 'ParallaxBoi' has not met dependency 'Kopernicus' V1.0.0
[WRN 10:18:30.938] AssemblyLoader: Assembly 'ParallaxBoi' is missing 1 dependencies

 

Edited by OnlyLightMatters
Link to post
Share on other sites

It's really astonishing.

*201108122044977590.png

Still some fine tuning steps to be done but this is insanely gorgeous!

How is it possible to enlight the ground a little bit (and only the ground) ? The default parallax rendering is slightly darker than the stock one.
Ambiant light boost is already at +34% for this capture.

 

Link to post
Share on other sites
29 minutes ago, kylelander said:

Hi @Gameslinx, I have installed Parallax 1.1 Beta and the ground is white and is missing chunks. 

I have verified that I have installed the stock configs and Parallax itself, as well as Kopernicus  bleeding edge for 1.10.

Is there a way to fix this?

I encountered 3 problems. 

- when installing via ckan the textures were not copied to Gamedata

- I had not installed the kopernicus release described in the previous page

- when installing manually I put the parallax textures folders inside the parallax folder which was not a good idea (white textures). Moving the textures to gamedata solved the issue. 

Link to post
Share on other sites
32 minutes ago, kylelander said:

Hi @Gameslinx, I have installed Parallax 1.1 Beta and the ground is white and is missing chunks. 

I have verified that I have installed the stock configs and Parallax itself, as well as Kopernicus  bleeding edge for 1.10.

Is there a way to fix this?

In my experience, make sure your terrain quality is set to high and not ultra high

Link to post
Share on other sites
9 hours ago, Gameslinx said:

Its terrain textures will not work, because Parallax overrides them, but the rest will

SO, does that mean a pack's textures could be *removed*?... or do they still need to be there to be detected to be over-ridden?

atually, I guess I should as if they could be *removed completely*, or if they need to still be present to be detected, could tiny place-holders be used?

Edited by Stone Blue
Link to post
Share on other sites
8 minutes ago, Stone Blue said:

SO, does that mean a pack's textures could be *removed*?... or do they still need to be there to be detected to be over-ridden?

atually, I guess I should as if they could be *removed completely*, or if they need to still be present to be detected, could tiny place-holders be used?

They don't still need to be there. Parallax treats the terrain quads as gameobjects and overwrites their meshRenderers before giving it a new material. 

For example, if a visual pack (like Spectra) changes the terrain on Kerbin to its own textures, Parallax will overwrite it and use the terrain textures in the ParallaxTerrain.cfg

If the visual packs' terrain textures are removed, Kopernicus may throw an exception. Watch out for that :) 

Edited by Gameslinx
Link to post
Share on other sites
7 minutes ago, Gameslinx said:

If the visual packs' terrain textures are removed, Kopernicus may throw an exception. Watch out for that :) 

Hmmm... so smol placeholder textures may be the way to go, to keep Kop happy? ... gotcha ;)

Edited by Stone Blue
Link to post
Share on other sites
2 minutes ago, Stone Blue said:

Hmmm... so smol placeholder textures may be the way to go, to keep Kop happy? ... gotcha ;)

Either that, or I could try implementing my On-Demand solution for terrain textures with @R-T-B into Kopernicus so that if Parallax is present, they don't load at all

Link to post
Share on other sites
6 hours ago, MrAndroPC said:

Can you show me the differences with a displacementOffset = 0.2 and without it? Just I'm not download parallax yet and probably will have this problem.

 

Yes.

Default displacementOffset)

Spoiler

2fGQ9f7.png

Displacement 0.2 on Kerbin:

Spoiler

isxRwWh.png

I haven't tried other celestial bodies yet.

Edited by Agustin
Link to post
Share on other sites
3 hours ago, damonvv said:

In my experience, make sure your terrain quality is set to high and not ultra high

It is set on high

Quote
3 hours ago, OnlyLightMatters said:

I encountered 3 problems. 

- when installing via ckan the textures were not copied to Gamedata

- I had not installed the kopernicus release described in the previous page

- when installing manually I put the parallax textures folders inside the parallax folder which was not a good idea (white textures). Moving the textures to gamedata solved the issue. 

 

The Parallax textures and mod folders are separate and kopernicus is installed manually with the 1.10 release.

2 hours ago, Gameslinx said:

I need your KSP.log if the solutions posted above haven't helped :) 

No problem, this might take a while due to me uninstalling Parallax temporarily to see if it fixed it.(Also I have terrible wifi)

Link to post
Share on other sites
2 hours ago, Gameslinx said:

Either that, or I could try implementing my On-Demand solution for terrain textures with @R-T-B into Kopernicus so that if Parallax is present, they don't load at all

I'm just thining for those peeps that dont have much moar than minimum amount of RAM to actually *use* Parallax and a visual pac, would be nice not to have to have unused GBs of textures loaded in VRAM, & in /GameData :P

Edited by Stone Blue
Link to post
Share on other sites
3 hours ago, OnlyLightMatters said:

I encountered 3 problems. 

- when installing via ckan the textures were not copied to Gamedata

We are working on this. The metadata needs some updates to install the textures too. Unfortunately the textures are too big to fit on our CI's disk right now.

Also please keep in mind to report CKAN problems on CKAN's forum thread, don't bother mod authors with it.

Link to post
Share on other sites

@Gameslinx Thanks for fixing the jittery ground and zoom levels. There was banding I didn't like but now it's fixed and I'm very happy. Nice work.  I'll get some sick photos Soon™.

Edited by Arco123
Link to post
Share on other sites
1 hour ago, Flipper028 said:

I too am having the white terrain bug after installing Beyond Home for 1.10.1.  googledrive Log link

For Beyond Home you must use Parallax 1.0.1 until I release the next Beyond Home update.

Parallax Stock Textures are not required, as they are for the stock game and not Beyond Home

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...