Jump to content

[1.11.x] Parallax, A PBR Terrain Shader [1.2.1]


Recommended Posts

Just now, Gameslinx said:

I don't plan on supporting 1.8.1

K, thanks for confirming. I'll see about uplifting my install to the latest version of KSP, it's a mammoth 120 mod install including my own modifications to these mods and bespoke mods made to mesh these mods together, so it might take a while :P

Link to post
Share on other sites
On 11/8/2020 at 12:19 PM, OnlyLightMatters said:

It's really astonishing.

*201108122044977590.png

Still some fine tuning steps to be done but this is insanely gorgeous!

How is it possible to enlight the ground a little bit (and only the ground) ? The default parallax rendering is slightly darker than the stock one.
Ambiant light boost is already at +34% for this capture.

 

Wondering the same here. Everything works but the ground is quite a bit darker than stock.

Link to post
Share on other sites
2 minutes ago, SpacePixel said:

It would be nice to emphasize that Kopernicus is necessary in the original post

It says it in the github readme, the spacedock readme and the downloaded readme.

It also tells you that Kopernicus is installed/missing when you launch the game 

Link to post
Share on other sites

Congratulations, you made the whole squad company! You showed us that the game could be made great, but they just didn't want to try!
Probably the only thing that could still be done is to adjust the texture colors in accordance with the appearance of the planet on the map. For example Pol:

38z4A.jpg

But a little futher:

38z4B.jpg

Link to post
Share on other sites
15 minutes ago, Alexoff said:

Congratulations, you made the whole squad company! You showed us that the game could be made great, but they just didn't want to try!
Probably the only thing that could still be done is to adjust the texture colors in accordance with the appearance of the planet on the map. For example Pol:

38z4A.jpg

But a little futher:

38z4B.jpg

I'm currently redoing all of the planets from orbit as well using a new shader. They will match the terrain properly when I release that :) 

Link to post
Share on other sites
19 hours ago, Gameslinx said:

I don't plan on supporting 1.8.1

Hey so I've upgraded to 1.10.1, which turned out to be much more straight forward than I expected (and far easier than my upgrades from 1.3.1 to 1.6.1 and from 1.6.1 to 1.8.1), but I've noticed a couple of issues.

Spoiler

38zah.png

38zai.png

38zaj.png

38zak.png

 

1) The above pictures show black lines appearing on the terrain, which get progressively worse with increasing distance, this is on x10.625 Rescale. I tested it on normal scale also and the same issue is present there but because the distances are so much smaller, it's not so noticeable at all, with the far mountains having the same issues to the same extent as the nearest point that you can see the issue on x10.625 Rescale. 

2) At the furthest distances, the terrain stops rendering at all. Note that I have a bespoke Scaled Space fix* which increases the draw distance before rendering switches to Scaled Space (FarClipPlane: usually it's 750000m but I've increased it to 1400000), this works with other issues normally associated with Sigma Dimensions at high rescale factors but not with Parallax. 

*Associate Code is below, if you're wondering why it says Kerbal Chroma it's because I ripped out the camera editing section from that mod and edited it to just achieve the Scaled Space fix. 

Spoiler
using System.Collections.Generic;
using UnityEngine;
using System.Text.RegularExpressions;
 
namespace KerbalChroma
{
    [KSPAddon(KSPAddon.Startup.Flighttrue)]
    public class chromaMain : MonoBehaviour
    {
        private Camera[] cameras;
        private float screenDistance = 100;
 
        private float[] defaultFarClipPlane;
 
        public void Start()
        {
            if (HighLogic.LoadedSceneIsFlight)
            {
                cameras = new Camera[3];
                cameras[0] = GameObject.Find("Camera 00").GetComponent<Camera>();
                cameras[1] = GameObject.Find("Camera 01").GetComponent<Camera>();
                defaultFarClipPlane = new float[2];
                defaultFarClipPlane[0] = cameras[0].farClipPlane;
                defaultFarClipPlane[1] = cameras[1].farClipPlane;
            }
        }
 
        public void Update()
        {
            if (HighLogic.LoadedSceneIsFlight)
            {
                if (!MapView.MapIsEnabled)
                {
 
                    if (screenDistance < defaultFarClipPlane[0])
                    {
                        cameras[0].farClipPlane = 1400000;
                        cameras[1].farClipPlane = 1400000;
                    }
                    else
                    {
                        cameras[0].farClipPlane = defaultFarClipPlane[0];
                        cameras[1].farClipPlane = screenDistance;
                    }
 
                    cameras[2].enabled = false;
                }
                else
                {
                    cameras[0].farClipPlane = defaultFarClipPlane[0];
                    cameras[1].farClipPlane = defaultFarClipPlane[1];
 
                    cameras[2].enabled = true;
                }
            }
        }
    }
}

Any idea what I can do to fix these issues? Happy to delve into the code myself if need be. 

 

Many thanks. 

Edited by Decus91
Link to post
Share on other sites

got this really weird bug

https://imgur.com/EoxlDhR

 

Happened with the Beyond Home planet-pack, except the texture was completely white, not this weird green gradient. Here's my mod list currently:
https://imgur.com/yWgtJn5

After solving this, I got to find out why the Principia config on the Beyond Home forum post isn't working. How fun!

(Just realized Module Manager isn't in the list, but this happened with Module Manager installed as well)

Edited by Fundati
Link to post
Share on other sites
22 minutes ago, Gameslinx said:

Since I don't have access to a Linux or Mac PC, I can't test Parallax on those systems. I know that the shader doesn't like OpenGL, so that could be why. 

I'll try and look into it 

if it doesnt like opengl, and it isnt a vulkan shader, that would be why.

Link to post
Share on other sites
18 minutes ago, toric5 said:

if it doesnt like opengl, and it isnt a vulkan shader, that would be why.

It's written in UnityCG. It's excluded from OpenGL ES 2.0 because it uses non-square matrices. I'll see if that stops it working at all on OpenGL, and I'll stop using non square matrices 

Link to post
Share on other sites

I'm super glad the optimizations dropped the minimum requirements. Sadly, I'm still just barely above the minimum, since I only have a mobile GTX 1050. At least I have 16GBs of RAM, although my GPU would probably still bottleneck my system. Hopefully, it still runs okay!

Edited by Maple Kerman
Link to post
Share on other sites
On 11/9/2020 at 3:12 PM, The Kerman said:

Hello I Am Reporting An Issue With The Stock Textures! I Have Ran Into The Ground Being A Plain Solid Reflective Color unknown.png

Is this a universal issue on stable 1.9.1 version?  If it is, I should probably add it to my tracker for fixing.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...