Jump to content

[1.12.x] Parallax, A PBR Terrain Shader [1.3.0]


Gameslinx
 Share

Recommended Posts

My biggest problem is that it just takes forever to dampen anything. You send a rover to a planet, and then you wait like three minutes for the collisions to dampen-- and then as soon as you move, it needs to do it agian.

Link to comment
Share on other sites

10 minutes ago, Mr Betelgeuse said:

My biggest problem is that it just takes forever to dampen anything. You send a rover to a planet, and then you wait like three minutes for the collisions to dampen-- and then as soon as you move, it needs to do it agian.

 

If your frame rate is low, damping will take a while. I'll see if moving it over to the physics update instead of the update will help

Link to comment
Share on other sites

hi !

I found the culprit, it was my tiny agency icon (my planetool mod), which I had disguised as .truecolor (probably not good at all)

which caused this big white square, I can not believe, I redone the icon in DDS format and it's good .......

Without parallax there was no problem (with the icon defines in .truecolor), very strange.

It would be nice to detail some news info in the wiki ksp page, we would save time, (about this 1.11.1 version) :sad:.......

Steph.

Link to comment
Share on other sites

On 2/28/2021 at 1:31 AM, desert said:

Hi, I get pitch black terrain at night. With default config I even had KSC buildings black, but changing config to trueLighting = false made them visible. Terrain, however, remained absolutely black.

I have custom Minmus clouds for SVE and at night they are visible even when they are below the surface, so this darkness is somehow transparent. Removing Planetshine didn't help, Scatterer is recommended I guess, and its water is visible.

Some pictures: https://imgur.com/a/0tWDckv

And log: https://drive.google.com/file/d/1dK7BRDUeaP5kTf-D15kFwkY5Zbj7liyK/view?usp=sharing

I'm not sure if its some combination of settings and configs or some bug

Link to comment
Share on other sites

5 minutes ago, adriangm44 said:

Hey guys! What do you think I could combine Parallax with?

What's the best visual mod combination I could get?

It depends on your PC specs, but I personally run Parallax with Astronomer's Visual Pack + 8k textures.

Link to comment
Share on other sites

1 minute ago, Spaceman.Spiff said:

It depends on your PC specs, but I personally run Parallax with Astronomer's Visual Pack + 8k textures.

No problem with performance, is there a list of all parallax-compatible visual mods out there?

Link to comment
Share on other sites

1 minute ago, adriangm44 said:

No problem with performance, is there a list of all parallax-compatible visual mods out there?

AFAIK 

Most visual packs out right now mostly provide configs for EVE and Scatterer. They don't really mess with Parallax. 

As I said, I run AVP, but other popular packs include Spectra, SVE, Stock EVE/BoulderCo, and SciFi-VE

Link to comment
Share on other sites

Seems like I can't place ground experiment stations on mun with collision enabled. Stations placement preview used to be on feet level, but with collisions it goes under the surface and don't allow me to build any. Maybe this is because a box is lifting up kerbal internally and interfering with placement - if video you uploaded as collision demo is also applied to kerbals.

With collision off now I can place it, although it's buried underground visually. Parallax still says "Damping physics" with collision off for some reason.

Edited by jupiterbjy
Link to comment
Share on other sites

3 hours ago, lookolookthefox said:

Is there any way to get beyond home working with the collisions at this moment? 

 

If you look at the last few pages of the Beyond Home thread, you will see that Gameslinx is working on an update that will overhaul BH and add support for the latest parallax features. 

Link to comment
Share on other sites

I'm having problems with my fps when landing on bodies. As soon as I landed the fps drop massive and it says "damping" in the left corner. It used to do that faster, but somehow it changed.

Is this due to an update or am I doing something wrong?

My ParallaxGlobal.cfg looks like this:

TessellationSettings                        //Control quality of tessellation
    {
        edgeLength = 1                            //Default = 1 (Close). Set it to 1 for the best quality.
        range = 99                                //Default = 99 (First zoom level fade start)
        maxTessellation = 64                    //Default = 64 (Max = 64)
        tessellationQuality = Higher            //Default = Higher
                                                //Options are: Low / Normal / High / Higher
    }
    ReflectionSettings                            //Control quality of reflections
    {
        reflections = false                     //true or false
        refreshRate = 1                            //FPS value or "realtime"
        timeSlicing = IndividualFaces            //"Instantly", "AllFacesAtOnce", "IndividualFaces"
        resolution = 1024                            //64, 128, 256, 512, 1024, 2048
    }
    LightingSettings
    {
        tessellateLighting = true                //Flat lighting or accurate lighting
        tessellateShadows = true                //Flat shadows or accurate shadows
        tessellate = true                        //Turning this off will disable tessellation entirely
        
        trueLighting = adaptive                    //true, false or adaptive
    }                                            //false: ambient light everywhere
                                                //true: no ambient light - shadows are stronger, and night time is pitch black
                                                //adaptive: proper lighting - ambient light in atmosphere, pure black on vacuum planets
    CollisionSettings
    {
        collide = false
        flatMinmus = false

 

 

Link to comment
Share on other sites

20 minutes ago, Kamilo said:

I'm having problems with my fps when landing on bodies

Set your tessellationQuality in the global config to Normal - You currently have it set to the highest value 

The "damping" message is from the collisions - you have collisions turned off. I have some fixes on the way for them that will stop that from happening 

Link to comment
Share on other sites

Hi @Gameslinx. What would be possible, regarding a custom point of view, to lighten the ground textures?
The overall luminosity is very dark on some specific celestial bodies (Eve for instance), even with 100% enhancement in the options. Is there a setting regarding light management I can play with or is the best way to lighten the DDS textures themselves (influence.dds?)?

Link to comment
Share on other sites

Here's the log (if I shared it correctly), and a badly lit screenshot to illustrate the issue. I apologize for the gratuitous amount of parts mods spamming the log. If this isn't a Parallax issue, any help identifying the culprit would be much appreciated. (I've tried fresh saves to see if it had anything to do with leftover save data, no effect) It's worth noting that collision is correct on KSC turf (Runway, Launchpad, etc.), with wheels and boots visually touching the surface.

KSP.log

Spoiler

G7hzSz8.png

 

Link to comment
Share on other sites

On 3/9/2021 at 4:13 PM, desert said:

Some pictures: https://imgur.com/a/0tWDckv

And log: https://drive.google.com/file/d/1dK7BRDUeaP5kTf-D15kFwkY5Zbj7liyK/view?usp=sharing

I'm not sure if its some combination of settings and configs or some bug

Make sure you have Parallax 1.2.1.

Change trueLighting from false to Adaptive, then try again

1 hour ago, Zensei said:

Does anyone know what causes this issue? When I get close to a planet's surface, I get these large dark squares appearing. I've attached a screenshot for reference.

 

Can you send your KSP.log? It's likely that another mod is interfering with Parallax 

On 3/14/2021 at 1:47 AM, WindupHero7 said:

It's worth noting that collision is correct on KSC turf (Runway, Launchpad, etc.), with wheels and boots visually touching the surface.

I am confused what the issue you are describing is. The wheels in your screenshot are off the terrain, but it looks like the ladders are pushing them up

Link to comment
Share on other sites

3 hours ago, Zensei said:

Does anyone know what causes this issue? When I get close to a planet's surface, I get these large dark squares appearing. I've attached a screenshot for reference.

 

I had the same issue, for me it was setting the Performance in Planet Shine to Medium.
In particular the issue was having pixel mode instead of vertex mode turned on.

Link to comment
Share on other sites

2 minutes ago, jesterlol said:

I had the same issue, for me it was setting the Performance in Planet Shine to Medium.
In particular the issue was having pixel mode instead of vertex mode turned on.

PlanetShine has a lot of performance related problems, so I usually recommend not using it with Parallax. This bug can only be resolved by PlanetShine and requires it to affect objects on Layer 29, which is the layer I use for the close up terrain quads

Link to comment
Share on other sites

The ladders do not physically interact, they go straight through the surface. I had deployed them to help illustrate the difference between visible surface (where the ladders intersect) and physical surface (where Val's feet and the rover wheels are- they are both grounded in the screenshot). To further explain, in the above shot Val is standing perfectly still on the ground- she is not falling and she is not holding the ladder. The ladder passes through the physical ground right where she is standing and then passes through the visual ground about a half meter below. Shadows too will pass through the physical ground and cast on the visible ground further down.

I also noted this just earlier: There is a "ring" around the camera center where this issue is occurring. If I zoom the camera far enough that my rover is outside this ring, the visual and physical ground planes match back up- the visible ground is only lowered within a range around the camera.

Here are some better examples. All items are grounded, showing proper collision on the runway but "floating" above terrain. In the zoomed out pictures, note the barely-visible ring just behind/in front of the rover and the shadows being offset/correct on either side of it.

Spoiler

e8UDdSe.png

9JNf3AW.png

hjhdC1Q.png

cw3H1Uu.png

 

Edited by WindupHero7
Added example images
Link to comment
Share on other sites

8 hours ago, Gameslinx said:

PlanetShine has a lot of performance related problems, so I usually recommend not using it with Parallax. This bug can only be resolved by PlanetShine and requires it to affect objects on Layer 29, which is the layer I use for the close up terrain quads

Thank you for the suggestion. I uninstalled planetshine, and it seems to have resolved the issue. However, I'm now getting white circles/partial circles when I'm near the terrain.

Here is my KSP.log.

Link to comment
Share on other sites

13 hours ago, Gameslinx said:

Change trueLighting from false to Adaptive, then try again

It works on Kerbin, but its still dark on Minmus. I've looked through the source code and I think I found the problem, I've opened an issue at GitHub.

Link to comment
Share on other sites

Hello,

 

I am blown away by this mod! Oooo-Weee! Yeah, I have gone through the collisions on and off. On= experiments dance into the horizon. Off= Everything is knee deep in dirt. I get its in dev, just want to say I will be using it final!

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...