Jump to content

CKAN (The Comprehensive Kerbal Archive Network) - v1.30.0 Glenn


Recommended Posts

28 minutes ago, HebaruSan said:

I assume you're in ConsoleUI (and/or on a Mac). Ctrl-d doesn't install a mod, it just downloads the ZIP to CKAN's download cache. To install a mod, press "+" and then F9 on the main mod listing (these hotkeys should be displayed on the bottom line of the window).

I'm sorry, I'm a bit dumb. Thanks! Sorry for sounding angry.

Edited by MoonstreamInSpace
Link to post
Share on other sites
33 minutes ago, MoonstreamInSpace said:

Is there a redownload mod button

Do you mean redownload, or reinstall?

Redownload isn't necessary, since CKAN uses checksums to ensure downloads are correct before adding them to its cache. Reinstall can be done by uninstalling and then installing again.

33 minutes ago, MoonstreamInSpace said:

how can I display mods older than my current KSP version?

F10 → Select KSP install... → Pick your install → Press 'e' to edit → Tab a few times to get to the compatible version list

Link to post
Share on other sites
1 minute ago, HebaruSan said:

Do you mean redownload, or reinstall?

Redownload isn't necessary, since CKAN uses checksums to ensure downloads are correct before adding them to its cache. Reinstall can be done by uninstalling and then installing again.

Sorry, a bit of weird phrasing. In the old CKAN, you could right-click a manually downloaded mod, and then press redownload to have CKAN update it and add it to the database. Is that possible with Terminal?

Link to post
Share on other sites
25 minutes ago, MoonstreamInSpace said:

Sorry, a bit of weird phrasing. In the old CKAN, you could right-click a manually downloaded mod, and then press redownload to have CKAN update it and add it to the database. Is that possible with Terminal?

Looks like the Upgrade option is available for that:

Spoiler

Mod listing:

H0VOTtM.png

After pressing "+":

3Wz2KEY.png

After pressing F9:

KPTFrtH.png

Link to post
Share on other sites
4 minutes ago, MoonstreamInSpace said:

It's showing an infinity sign, not a ≥ sign. I'll send a screenshot in a sec.

Hmm, maybe CKAN doesn't consider the mod in question installable on your version.

Link to post
Share on other sites
1 minute ago, MoonstreamInSpace said:

A lot of my mods are 1-2 versions behind.

That would explain it. Setting those versions as compatible might help.

44 minutes ago, HebaruSan said:

F10 → Select KSP install... → Pick your install → Press 'e' to edit → Tab a few times to get to the compatible version list

Link to post
Share on other sites

How do I update the conflicts for my mod on CKAN

It incorrectly lists TechTreeKompacted as incompatible with UnkerballedStart and ProbesBeforeCrew, this is no longer the case.

Link to post
Share on other sites

I want to uninstall Ven's Stock Revamp and replace it with ReStock in my RP1 install. 

CKAN won't let me uninstall Ven's without uninstalling everything else. Do I just need to do that manually?

Link to post
Share on other sites
Posted (edited)
30 minutes ago, Cruesoe said:

How do I update the conflicts for my mod on CKAN

It incorrectly lists TechTreeKompacted as incompatible with UnkerballedStart and ProbesBeforeCrew, this is no longer the case.

You can either open an issue in our NetKAN repo to let us know, and we'll take care of it: https://github.com/KSP-CKAN/NetKAN/issues
Or you create a pull request yourself to edit the .netkan file, which takes some work from us, but it's not required.
Or you let us know via a forum post on this thread, just like you did now :)

Anyway, thanks for letting us know, already on it!

Edit: Done!

20 minutes ago, Spaceman.Spiff said:

I want to uninstall Ven's Stock Revamp and replace it with ReStock in my RP1 install. 

CKAN won't let me uninstall Ven's without uninstalling everything else. Do I just need to do that manually?

What is "everything else"?
There are two possible reasons for CKAN unsinstalling other mods along the one you want to remove:
1) The other mod depends on the one you want to remove; without the dependency satisfied it must be removed as well
2) The other mod has been installed as dependency of the one you want to remove; CKAN sees that no other mod depends on it anymore and stages it for removal as well, since you probably no longer want it.
     If you do want to keep it, uncheck the "Auto-Installed" checkbox (second column) for this mod.

In both cases CKAN tells you the reason in the changeset overview tab.

Edited by DasSkelett
Link to post
Share on other sites

I'm getting an error in CKAN trying to install Astronomer's Visual Pack, It says it's not compatible with my game version, but I'm running 1.11.2 which it definitely works with, as I have it installed through CKAN on another instance just fine. What am I doing wrong? Is there a file somewhere that might be outdated causing this?

I'm using the latest version of CKAN, and I'm on Windows using a standalone instance copied from my Steam version of KSP

 

Edit: I have gotten this solved. EVE has to be completely and totally removed first before CKAN will let you install AVP.

Edited by oniontrain
Link to post
Share on other sites
5 minutes ago, oniontrain said:

Is there a file somewhere that might be outdated causing this?

Do you have a conflict with another visual mod currently installed in the instance? That will prevent AVP from being loaded.

 

Link to post
Share on other sites
Just now, Caerfinon said:

Do you have a conflict with another visual mod currently installed in the instance? That will prevent AVP from being loaded.

 

Yeah that was the problem. I edited my post above, but I had to make sure EVE was completely deleted both from CKAN and from my KSP directory

Link to post
Share on other sites
  • 2 weeks later...

Hi, @DasSkelett,

That's the thing: some people (not unsurprisingly) are complaining about the need to install KSP-Recall even by not requiring it.

Since CKAN currently don't allow targeting specific versions of KSP for dependencies, how about different netkan files for the same add'on targetting them?

Using TweakScale and KSP-Recall as examples, how about three different netkan files:

  • TweakScale for 1.11.x, locked on KSP 1.11.x and requiring KSP-Recall
  • TweakScale for 1.9.x, locked on KSP 1.9.x and requiring KSP-Recall
  • The current TweakScale would so be the fallback option, targeting anything above 1.4.0 and only suggesting KSP-Recall (or not even that).

This is feasible? Would CKAN allow such a solution?

Link to post
Share on other sites
16 minutes ago, Lisias said:

how about different netkan files for the same add'on targetting them?

No, multiple netkans for one mod isn't a good idea. If a user upgrades from KSP 1.9 to KSP 1.10 or 1.11, they should be prompted to upgrade to the appropriate version, and separating the netkans would break that.

The complaint is just that your "recall" mod is required? Could you make the needed part of the "recall" mod integral to TweakScale?

Link to post
Share on other sites
5 hours ago, HebaruSan said:

The complaint is just that your "recall" mod is required?

No. The complain is that Recall is needed on KSP 1.11 and 1.9 due  bugs on KSP itself, but not on 1.10 - the version the user is using - where none of the bugs affects TweakScale.

 

5 hours ago, HebaruSan said:

 Could you make the needed part of the "recall" mod integral to TweakScale?

No. KSP Recall aims to fix or work around problems on specific KSP versions, something completely out of scope for TweakScale (that only aims to scale parts) as well any other add'on affected, as B9PS, FSFuelSwitch, Pay for Play, ODFC and the list goes on.

The problem is that different KSP versions break different Add'Ons differently - so Recall may be needed when you use a set of Add'Ons on 1.9, but not on 1.10 or 1.11, while the set of add'ons that need Recall on 1.10 and 1.11 are completely different than on 1.9 (or between 1.10 and 1.11).

Moreover, it's pretty dangerous to have more than one add'on trying to solve the same problem by themselves - or you will have the workaround being applied multiple times (something extremely undesirable when fixing the Refund problem on recovering vessels on KSP 1.11).

All I can do (and I'm doing) is to code warnings on TweakScale prompting the user to install KSP Recall on the KSP versions TS needs it - but I can do anything about Recall being installed when TS doesn't need it (please remember that Recall may be needed by another add'on, even when TweakScale doesn't need it on that KSP Version).

Yep, pretty messy.

 

5 hours ago, HebaruSan said:

No, multiple netkans for one mod isn't a good idea. If a user upgrades from KSP 1.9 to KSP 1.10 or 1.11, they should be prompted to upgrade to the appropriate version, and separating the netkans would break that.

 No if we have the "fallback" netkan (the current one, that would accept being installed anywhere) for new installs.

The replaced-by would not solve the problem? Once a new KSP version is released, the TweakScale-for-1.11 netkan would be updated with the replaced-by pinpointing TweakScale-for-1.12 . And since both TweakScale-for-1.11 and TweakScale-for-1.12 will be tagged to work only on that expecific KSP versions (using ksp_version_strict), we would have a solution for this problem - assuming these features work as I expect.

Edited by Lisias
better phrasing...
Link to post
Share on other sites
30 minutes ago, Lisias said:

The replaced-by would not solve the problem?

No, it wouldn't.

Let's take a step back here. We already looked into this when @DasSkelettfirst caught the missing dependency, and I thought the current dependency relationship was the agreed-upon compromise. I asked "The complaint is..." because I'm trying to figure out what changed since that time. It sounds like it's the same as before; has there been any actual change?

Link to post
Share on other sites
9 hours ago, Lisias said:

The replaced-by would not solve the problem? Once a new KSP version is released, the TweakScale-for-1.11 netkan would be updated with the replaced-by pinpointing TweakScale-for-1.12 .

Unfortunately not. For one, one netkan file per KSP release would be a maintenance nightmare. And replaced-by would break as soon as a user adds more KSP versions to the list of compatible ones, because...

9 hours ago, Lisias said:

And since both TweakScale-for-1.11 and TweakScale-for-1.12 will be tagged to work only on that expecific KSP versions (using ksp_version_strict), we would have a solution for this problem - assuming these features work as I expect.

It doesn't work as you expect. "ksp_version_strict" never really worked at all, it was an unfinished feature not thought through. You'd think it changes the compatibility checks to ignore user selection, but the only KSP versions it does something is with is KSP 1.0.3 and 1.0.4.

9 hours ago, Lisias said:

No. The complain is that Recall is needed on KSP 1.11 and 1.9 due  bugs on KSP itself, but not on 1.10 - the version the user is using - where none of the bugs affects TweakScale.

To make sure I understood the new problem: The issue is that users are confused why CKAN installs it all the time while the forum thread only says it's a dependency?
 

Also while we're on it: it looks like your last release on SpaceDock has a typo in its version number, it says "Version 0.1.08". I suspect it should be "Version 0.1.0.8" instead, as on GitHub and all the previous releases?
If you're changing back to the old format with the next release, it'll trigger an epoch bump PR, which needs to be merged manually. Thus there could be a small delay until it shows up in CKAN, depending on whether someone of the team is currently online or not.

Link to post
Share on other sites
2 hours ago, DasSkelett said:

To make sure I understood the new problem: The issue is that users are confused why CKAN installs it all the time while the forum thread only says it's a dependency?

More or less...

It's not a funcional problem, because Recall behaves and only activate what's needed on the host KSP version (so it doesn't even wastes CPU cycles), but some users (and I'm one of them) really hate installing things that are not needed (bloatware :) ).

The problem is that Recall is an indirect dependency for some add'ons on some KSP versions, and this relationship is tied to the KSP version, not to the add'on only. For example:

  • Any Add'On that customizes Resources needs Recall on KSP 1.9, but works fine on everything else
  • Any Add'On that customizes Cost needs Recall on KSP 1.11, but works fine on everything else
  • Some (few) Add'Ons have parts that blow up fiercely on spawning on KSP 1.10, but work fine on everything else.

And it's a soft dependency - Recall works behind the scenes. You only note it is installed because the problem goes away.

Installing KSP Recall on everything is an acceptable solution, but only installing when really needed would be an optimal solution (and this is whats being requested at the moment)

 

2 hours ago, DasSkelett said:

Also while we're on it: it looks like your last release on SpaceDock has a typo in its version number, it says "Version 0.1.08". I suspect it should be "Version 0.1.0.8" instead, as on GitHub and all the previous releases?

Ugh... Well, I think this is a good time to bump the versioning for 0.2... :) Thanks for the heads up!

Edited by Lisias
brute force post merge.
Link to post
Share on other sites
2 hours ago, HebaruSan said:

That's good, it sounds like we made the right choices to make this all work. Thanks for confirming.

Not a problem. May I redirect future requests from users to this thread so? 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...