Jump to content

CKAN (The Comprehensive Kerbal Archive Network) - v1.31.2 Juno


DasSkelett
 Share

Recommended Posts

Could we please get a way to hide mods that are listed as Any version? Kinda annoying having mods that haven't been updated for 5+ years and probably having dubious compatibility be listed no matter what.

Link to comment
Share on other sites

2 hours ago, Crimor said:

Could we please get a way to hide mods that are listed as Any version? Kinda annoying having mods that haven't been updated for 5+ years and probably having dubious compatibility be listed no matter what.

If you notice mods with inaccurate compatibility data, please report it:

Link to comment
Share on other sites

I'm trying to update the netkan file but I'm getting a "too many spaces inside braces" error

Fixes missing file issue by sswelm · Pull Request #8610 · KSP-CKAN/NetKAN (github.com)

How to fix this?

Edit. Fixed it. apperently CKAN is much more strict than it used to be .

 

 

Edited by FreeThinker
Link to comment
Share on other sites

3 hours ago, Davros_ADL_2 said:

Does CKAN now not show mods that don't support the selected version? I'm on Mac with Mono, so I'm running the terminal version, and I can't find Waterfall or ReStock or anything pre-1.12. Is there a way to change this?

You should change your compatibility settings. According to the pinned message on discord :

F10 → Select game instance... → Pick your install → Press 'e' to edit → Tab a few times to get to the compatible version list

I think you should be fine adding 1.10 and 1.11 , and maybe 1.8 and 1.9 , but I wouldn't go any lower.

Note, however, that some mods haven't updated yet: they are not marked compatible on purpose. For example, Restock hasn't been updated yet : even though it still works, there is some broken stuff.

Link to comment
Share on other sites

47 minutes ago, AlphaMensae said:

I need a CKAN dev to set the Modular Launch Pads Netkan to have the minimum KSP version be 1.8.1, please. Thank you.

Thanks for letting us know. This should be done now, and the dependencies are updated based on what the mod's forum thread says.

Link to comment
Share on other sites

My recent mod Kerbin Side Remastered - The Life Aquatic on SpaceDock has the wrong install path configured in CKAN.

The install path in CKAN is /GameData/KerbinSideRemasteredTLA

The install path from the ZIP in SpaceDock is /GameData/ContractPacks/KerbinSideRemasteredTLA

The contracts currently will not load correctly if installed via CKAN because the path is incorrect. If this could be corrected I would appreciate it very much. Thanks.

https://spacedock.info/mod/2808/Kerbin Side Remastered - The Life Aquatic

 

Link to comment
Share on other sites

43 minutes ago, Caerfinon said:

My recent mod Kerbin Side Remastered - The Life Aquatic on SpaceDock has the wrong install path configured in CKAN.

The install path in CKAN is /GameData/KerbinSideRemasteredTLA

The install path from the ZIP in SpaceDock is /GameData/ContractPacks/KerbinSideRemasteredTLA

The contracts currently will not load correctly if installed via CKAN because the path is incorrect. If this could be corrected I would appreciate it very much. Thanks.

Sorry for that. Should be fixed now.

Link to comment
Share on other sites

Coming back after a few months, and I can't use search any more. I used to set the filter to "Compatible" and then i could search for a mod and find it. Now when I do that I have to add an "or" filter which completely wrecks the usefulness for me. I get hundreds of results instead of a couple.  Any way to use an "And" filter? or even better is there any way to revert to the prior search functionality?

 

Link to comment
Share on other sites

  • 2 weeks later...

I'm unable to uninstall any mod from CKAN. They all was installed through CKAN!

Example:

About to remove:

 * VariantPersist 1.1
The following inconsistencies were found:
* D:/BARBA/Windows/Steam/steamapps/common/Kerbal Space Program/GameData/VariantPersist/VariantPersist.dll is registered to VariantPersist but has not been removed!
Error during installation!
If the above message indicates a download error, please try again. Otherwise, please open an issue for us to investigate.
If you suspect a metadata problem: https://github.com/KSP-CKAN/NetKAN/issues/new/choose
If you suspect a bug in the client: https://github.com/KSP-CKAN/CKAN/issues/new/choose

I need to manually delete the folder from my 'GameData' directory, and then click on the 'Retry'. After that, the mod shows um on CKAN as uninstalled!

Thanks.

Link to comment
Share on other sites

7 minutes ago, Dominiquini said:

I'm unable to uninstall any mod from CKAN. They all was installed through CKAN!

The following inconsistencies were found:
* D:/BARBA/Windows/Steam/steamapps/common/Kerbal Space Program/GameData/VariantPersist/VariantPersist.dll is registered to VariantPersist but has not been removed!

 

This usually means that KSP is still running. Make sure it's closed fully, also check the task manager. Try restarting your PC if you can't find a KSP process.

Link to comment
Share on other sites

3 hours ago, DasSkelett said:

This usually means that KSP is still running. Make sure it's closed fully, also check the task manager. Try restarting your PC if you can't find a KSP process.

I always change my mods with the game closed. Next time I'll verify if it is opened in the Task Manager!

* I checked and I have a bunch og KSP.exe remaining on my Task Manager. Appears that every time I start a game and close it, it not closes completely! But the game starts fine every time... After I killed the leftover tasks, CKAN works normaly!

Thanks.

Edited by Dominiquini
Link to comment
Share on other sites

2 minutes ago, Teilnehmer said:

CKAN shows many mods with ‘Max game version: 1.12.1’ as incompatible with 1.12.1.

What am I doing wrong?


The mods themselves are compatible with KSP 1.12.1, however (some of) their dependencies are not. For EditorExtensionsRedux, it depends on ClickThroughBlocker, which in turn depends on ZeroMiniAVC and ToolbarController. ToolbarController still has KSP 1.11.2 as max KSP version.

Since those mods very likely work perfectly fine, as they are dependencies of almost all of Linuxgurugamer's mods, and plenty of people installed them on KSP 1.12 already, you can install them regardless. Either by force-installing the outdated dependencies first, or by collectively telling CKAN to consider KSP 1.11 mods as compatible. Most people select KSP 1.8 and above there currently, as that was the last big update that broke a bunch of mods. However there are still mods that have broken since, so make sure to check the forum thread if in doubt.

Link to comment
Share on other sites

45 minutes ago, darthgently said:

I'm finally curious enough.  Are there any CKAN plugins?  If so, are there any plugins the average user might find useful?  Where would one find them? I keep seeing the menu option and have been wondering for awhile

There were a few, but they haven't been maintained and became incompatible some time ago; somewhat ironically, compatibility tracking was left out of the GUI plugin architecture. It's generally a better bet to add features to the main CKAN application rather than creating a separate DLL that will stop working in some future release, needs to be downloaded separately, etc. (and in fact there are now built-in features that do what the migration tool and mod hider used to).

 

Edited by HebaruSan
Link to comment
Share on other sites

2 hours ago, Kunosheru said:

how to fix it?

Set your Compatible Game Versions to all of the KSP versions of the mods you have installed. Then all of the AD items will have the upgrade option. Upgrade them all. When you do it will likely ask you if it's OK to overwrite whats currently there, respond yes in each case. This will sync CKAN up with the most current versions that it thinks are different.

Link to comment
Share on other sites

2 hours ago, Kunosheru said:

something absolutely broke. as a fix i tried to reinstall CKAN. It did not help. I have about 87 installed mods now. CKAN shows 37 with letters AD and 36 updatable. what is this? how to fix it?

With that little information it's impossible to say what happened and why it happened. Something happened to the registry.json, maybe it has been deleted, or it got corrupted. In the second case you should've gotten a message box with a help text saying what to do now.

Most importantly: your mods should still be installed, they're still working, CKAN just doesn't know about them anymore.
You can start with what @Caerfinon suggested, but be advised that this might not reinstall all of them, as CKAN can't detect every mod.
Alternatively, you can also import the "installed-<name>.ckan" file in the "<KSP>/CKAN" folder, which contains all mods installed by CKAN after the last change. If this file is already overwritten, because you might've already started the reinstallation process, you can also use one of the "installed-<name>-<date>.ckan" files in the "<KSP>/CKAN/history" folder, look for a recent one from before the incident.

Edited by DasSkelett
Link to comment
Share on other sites

Recently noticed the 1.30.4 release, so I downloaded the ckan.exe, and like usually, dropped in it KSP (replacing the old version) and ran it.

But all I get is the CMD window popup and a blinking underscore on the CMD window. Nothing else happens. I have to do an End Task in the task window to close it.

So I tried to find older versions on CKAN github to roll back to the old version I had. I cant seem to locate old versions are they there somewhere?

 

 

Edited by BlackHat
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...