Jump to content

CKAN (The Comprehensive Kerbal Archive Network) - v1.31.2 Juno


DasSkelett
 Share

Recommended Posts

8 minutes ago, Fendrin said:

I am suffering from the https://github.com/KSP-CKAN/CKAN/wiki/SSL-certificate-errors problem ever since the upgrade from Ubuntu 21.04 to 21.10.

None of the solutions found at the mentioned github page does any good regarding the issue.

That wiki page contains all of our knowledge about those errors, updated as each problem comes up. There's nothing we can tell you that isn't already on there.

Without having any of the details of the issue, my guess would be that something unrelated is happening and your guess that it's related to that page is not correct.

Edited by HebaruSan
Link to comment
Share on other sites

11 minutes ago, HebaruSan said:

That wiki page contains all of our knowledge about those errors, updated as each problem comes up. There's nothing we can tell you that isn't already on there.

Without having any of the details of the issue, my guess would be that something unrelated is happening and your guess that it's related to that page is not correct.

HebaruSan, thank you for the response.
Here is the output of CKAN executed on the CLI:

[email protected]:~$ ckan install UniversalStorage2
About to install:

 * Universal Storage II Finalized 4.0.0.4 (spacedock.info, 104,7 MiB)

Continue? [Y/n] 
Downloading "https://spacedock.info/mod/2960/Universal%20Storage%20II%20Finalized/download/4.0.0.4"
One or more downloads were unsuccessful:

Error downloading UniversalStorage2 4.0.0.4: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
  at /build/mono-6.12.0.147/external/boringssl/ssl/handshake_client.c:1132

What else can I provide?
Many thanks in advance.

Link to comment
Share on other sites

20 minutes ago, Fendrin said:

HebaruSan, thank you for the response.
Here is the output of CKAN executed on the CLI:

[email protected]:~$ ckan install UniversalStorage2
About to install:

 * Universal Storage II Finalized 4.0.0.4 (spacedock.info, 104,7 MiB)

Continue? [Y/n] 
Downloading "https://spacedock.info/mod/2960/Universal%20Storage%20II%20Finalized/download/4.0.0.4"
One or more downloads were unsuccessful:

Error downloading UniversalStorage2 4.0.0.4: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
  at /build/mono-6.12.0.147/external/boringssl/ssl/handshake_client.c:1132

What else can I provide?
Many thanks in advance.

I did have a problem like that. If it does an error again most likely you will have to install the mod manually which I do that when I need to.

Link to comment
Share on other sites

3 minutes ago, obnox twin said:

I did have a problem like that. If it does an error again most likely you will have to install the mod manually which I do that when I need to.

It happens for every mod which is only available from SpaceDock (otherwise CKAN falls back to an alternative host).
Sadly those are a lot of the over 100 mods I use...

Link to comment
Share on other sites

6 minutes ago, Fendrin said:

It happens for every mod which is only available from SpaceDock (otherwise CKAN falls back to an alternative host).
Sadly those are a lot of the over 100 mods I use...

Oh this could be a bug and it is pain to install 100 mods plus dependencies that are not on CKAN

Link to comment
Share on other sites

44 minutes ago, Fendrin said:

HebaruSan, thank you for the response.
Here is the output of CKAN executed on the CLI:

[email protected]:~$ ckan install UniversalStorage2
About to install:

 * Universal Storage II Finalized 4.0.0.4 (spacedock.info, 104,7 MiB)

Continue? [Y/n] 
Downloading "https://spacedock.info/mod/2960/Universal%20Storage%20II%20Finalized/download/4.0.0.4"
One or more downloads were unsuccessful:

Error downloading UniversalStorage2 4.0.0.4: Ssl error:1000007d:SSL routines:OPENSSL_internal:CERTIFICATE_VERIFY_FAILED
  at /build/mono-6.12.0.147/external/boringssl/ssl/handshake_client.c:1132

What else can I provide?
Many thanks in advance.

Since you didn't mention what steps you actually tried already: did you follow this and this?

Link to comment
Share on other sites

Just now, DasSkelett said:

Since you didn't mention what steps you actually tried already: did you follow this and this?

Yes. I tried everything mentioned there. Using mozroots and removed the X3 certificate.
I tried with the mono that came with the distribution and with both, stable and dev packages from the Mono project's PPA.
 

Link to comment
Share on other sites

18 minutes ago, Fendrin said:

Yes. I tried everything mentioned there. Using mozroots and removed the X3 certificate.
I tried with the mono that came with the distribution and with both, stable and dev packages from the Mono project's PPA.
 

Just to make sure, did you also run "update-ca-certificates" after editing "/etc/ca-certificates.conf"?

It's surprising that it doesn't fix it for you, as it definitely did for me and a lot of other people (on Ubuntu 21.10). There must be something different with your system that makes this bug stick around. But from distance it's hard to say what, of course.

Edited by DasSkelett
Link to comment
Share on other sites

On 2/3/2022 at 10:11 PM, DasSkelett said:

Just to make sure, did you also run "update-ca-certificates" after editing "/etc/ca-certificates.conf"?

Yes.

On 2/3/2022 at 10:11 PM, DasSkelett said:

It's surprising that it doesn't fix it for you, as it definitely did for me and a lot of other people (on Ubuntu 21.10). There must be something different with your system that makes this bug stick around. But from distance it's hard to say what, of course.

Well, the installation is about 5 years old. Maybe it's time for a fresh installation.

Link to comment
Share on other sites

CKAN messed up on me last night.  It has been working well since a new install for KSP Ver. 1.12.  It got stuck on the black DOS box.  I tried a new CKAN.exe and it was the same, then tried the autoupdate.exe and nothing changed.  Then came here and read the last 2 pages.  Went into the steam - KSP folder and deleted the CKAN folder, then started KSP.  Looked around and then left.  CKAN started working and asked for permission to install a bunch of stuff that had been "installed manually", except I use CKAN for all mods. 

Started KSP again and it seems like all mods are working except EVE, even the ones that CKAN now says are not installed.  Played for a while and there were some oddities like the grabbers not grabbing until an engineer tried to hook up a hose.  Then suddenly they worked again. 

Exited the game and now CKAN is taking a very long time to get past the black screen and start working.  I'm a humble end user so if you need more, please tell me how to get it.

dV4rmrr.jpg

Link to comment
Share on other sites

7 minutes ago, miklkit said:

asked for permission to install a bunch of stuff that had been "installed manually", except I use CKAN for all mods.

CKAN now says are not installed.

That was caused by this:

7 minutes ago, miklkit said:

Went into the steam - KSP folder and deleted the CKAN folder

Don't do that.

Link to comment
Share on other sites

1 hour ago, Climberfx said:

I open Ckan on Mac, and in the search I type Om, Omi, Omic, Omicron, and nothing appears.

Oh, that's because some of its has dependencies aren't compatible with whatever game version you have (I assume 1.12.3?).

w2JOxQY.png

Yes, we know we need to make this easier to figure out in ConsoleUI.
You can make the mod appear by telling CKAN to consider 1.11 compatible:

https://github.com/KSP-CKAN/CKAN/wiki/User-guide#choosing-compatible-game-versions-1

Link to comment
Share on other sites

How can I check which of my installed mods are available for a version of KSP higher than my current one?

I want to upgrade from my KSP 1.8...but I want to make sure that all my mods have an updated version that is compatible with a higher version of KSP.

Is this something that can be done with CKAN?

Link to comment
Share on other sites

17 minutes ago, strider3 said:

How can I check which of my installed mods are available for a version of KSP higher than my current one?

I want to upgrade from my KSP 1.8...but I want to make sure that all my mods have an updated version that is compatible with a higher version of KSP.

The "Max game version" column should give you that information.

Link to comment
Share on other sites

  • 2 weeks later...

Any hope of a modern replacement for Mono on Macs? I finally went to Big Sur on my Mac Pro, only to discover Mono is 32-bit and stopped working.

I basically had to go install KSP on my Windows partition just to be able to continue using this indispensable tool...

Link to comment
Share on other sites

2 hours ago, Hangdog said:

Any hope of a modern replacement for Mono on Macs? I finally went to Big Sur on my Mac Pro, only to discover Mono is 32-bit and stopped working.

If by "replacement for Mono" you mean a replacement for the entire Mono runtime, no, starting over in another programming language probably will never happen.

If by "replacement for Mono" you mean a UI that can run on Mac without 32 bit mode... we did that, it's called Console UI and it's already the default on those machines.

Link to comment
Share on other sites

I've noticed for the last couple weeks (roughly) when I launch CKAN it shows the black window with blinking cursor much longer than normal. I just timed it at 1 minute 29 seconds. That seems typical now. After that delay, the white GUI launches and it's totally normal, works great. Seems like some server timeout delay?  Thanks for maintaining this mod. It makes managing and troubleshooting mods so much easier. 

Sidenote for others that use CKAN exclusively... there are some mods that can't be installed with CKAN. One of them I just discovered is Sound Track Editor Forked. 

Link to comment
Share on other sites

13 hours ago, Krazy1 said:

I just timed it at 1 minute 29 seconds. That seems typical now. After that delay, the white GUI launches and it's totally normal, works great. Seems like some server timeout delay? 

Approximately a 5 secs load time after the console window appears for me, which suggests it's not a server problem but more likely something on your end?

Link to comment
Share on other sites

20 hours ago, HebaruSan said:

If by "replacement for Mono" you mean a replacement for the entire Mono runtime, no, starting over in another programming language probably will never happen.

If by "replacement for Mono" you mean a UI that can run on Mac without 32 bit mode... we did that, it's called Console UI and it's already the default on those machines.

Are you referring to the text mode UI that runs in the terminal window?

It is not quite the same feature set...

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...