Jump to content
  • 0

Docking ships breaks game - can't save, can't exit, can't recover



I dock two spacecraft in Munar orbit. Right up to the moment of docking, all works normally, I hit F5, the game freezes for a few seconds, and a savegame is created. I can switch to other vessels, etc., go to Tracking Station, all as normal.
Once I've docked, however, I can't.
Hitting F5 then does nothing.
Trying to save via the pause menu, I click save and the dialog box disappear, the game freezes - for two seconds or two minutes, it remains frozen until I hit escape. It runs again, but no savegame was created.
I cannot go anywhere via the GoTo mod.
I cannot go to KSC or Tracking station via pause menu.
I cannot exit the game - I get the exit confirmation, but clicking exit, no matter how often, does nothing.
I cannot switch to another vessel from map view. I can switch to other vessels in visible range through Easy Vessel Switch, but not from map view.
Undocking does not bring back normality. Switching between any visible vessels, including switching to one that had not been part of that docking maneuver, does not restore normal function, either.
If I fly my craft back to Kerbin and splash down, and even after the craft has settled down in the water (or has come to rest on land), spamming the Recovery Vessel button does nothing.
I have tried releasing input locks via the button, but that doesn't change anything, either.
I >can< load an earlier savegame, and as it's before the fateful docking maneuver, everything works then.
Until I try docking again.

Restarting the game changes nothing.
I had left the game running overnight, but it worked fine until I docked.
I just restarted, loaded the save I made immediately before the docking (the two were so close, once the game loaded, the magnets did all the work), docked. And same issue.

This is the third time this has happened. Every time, it's with a different pair of different ships, and different Kerbals on board. The first time, I spent some time testing it with different ships and had come to conclude that one of my Kerbal tourists must be cursed, since the problem kept happening with the same bunch of tourists aboard entirely different ships (used Kourageous Kerbals to transfer them from one lander to another without docking).
I had to resort to Hyperedit two or three times at this point just to bring my tourists back to the surface of Kerbin.
I do a lot of transferring crew, tourists, and fuel, in Munar orbit, a lot of docking, so this recurring problem makes the game somewhat unplayable for me.

Recreation in Vanilla is not feasible, as all my ships involve parts from mods, or parts modified by mods, or parts I modified with the aid of mods (TweakScale, etc.).
I have logs: https://drive.google.com/drive/folders/1mTmh7pXlKgq3xxBKBz_7bMKLk-MuMONB?usp=sharing
Previous log is a bit bloated, I had the game running for at least a day or so.
When I just went to my google drive, I found two older logs, from when the problem had manifested and refused any fixes I could come up with the first time. I had prepared to ask a question before I decided to try and make a Hyperedit workaround, hoping it was a one-off. Well, it wasn't. I've left those old logs in, prefixed "old".

Please, anyone who has any suggestions as to what the problem might be, or how I can fix it once it manifests, I would greatly appreciate it.
Any experimentation required to narrow the problem down I will do, any further information required I will provide.

Versions and addons:


KSP: 1.10.1 (Win64) - Unity: 2019.2.2f1 - OS: Windows 10  (10.0.0) 64bit
000_AT_Utils - 1.9.6
ClickThroughBlocker -
Filter Extensions - 3.2.6
Toolbar -
USI Tools - 1.2
ToolbarControl -
CommunityPartsTitles - 0.6.4
KSP-Recall -
Ablative-Airbrake - 1.0.1
AdvancedTextures - 1.8.1
Airplane Plus - 26.0.3
All Tweak!!! -
Animated Decouplers - 1.4.2
AnyRes - 2.0.4
AoA Tech - 1.4.1
Stock Inline Lights Patches (SILP) - 1.0
Astrogator - 0.10.1
AtmosphereAutopilot - 1.5.16
AugmentedReality -
B9 Part Switch - 2.17
Behemoth Aerospace Engineering Large Parts - 1.6.1
CritterCrawlerRetractingVectoringEngines - 1.3.6
Bluedog Design Bureau - 1.6.3
BurstAtomicThrustModule -
Camera Focus Changer - 1.1
CommNetAntennasExtension - 2.1.3
Community Category Kit - 5.1
Community Resource Pack - 1.4.1
CommunityTechTree - 3.4.2
ConfigurableContainers - 2.6.1
Contract Pack: Historical Progression - 0.9.2
CorrectCOL -
Crew Light - 1.19
CryoEngines - 1.1.4
CryoTanks - 1.5.2
DecouplerShroud - 0.7.2
DeployableBattery -
DeployableEngines - 1.2.2
AGExt -
RCSLandAid -
VerticalVelocityController -
DistantObjectEnhancement - 2.0
StructuralTubingRestructured -
DMagic Orbital Science - 1.4.3
CapCom Mission Control On The Go -
Contract Parser - 1.0.9
Progress Parser - 1.0.11
DockingCamKURS -
Draggable_Navball -
DynamicBatteryStorage - 2.1.9
Easy Vessel Switch - 2.1.7366.39779
EditorExtensionsRedux -
Eskandare Aerospace -
FairingFix - 1.0
Firespitter - 7.14
FShangarExtender - 3.6
Fuel Tanks Plus - 2.0.2
GravityTurn - 1.8.1
HeatControl - 0.5.2
IntegratedStackDecouplers - 0.1.5
Interstellar Fuel Switch - 3.18
JanitorsCloset - 0.3.7
JetSoundsUpdated -
JSIAdvTransparentPods - 0.1.22
RasterPropMonitor - 0.30.6
Kerbal Attachment System - 0.6.4
Camera Mode Persistence - 1.2
KerbalAtomics - 1.1.4
Kerbal Engineer Redux -
Kerbal Reusability Expansion - 2.8.6
HyperEdit - 1.5.8
KerbalTubes -
InlineBallutes -
KGEx -
Kerbal Inventory System - 1.26.7504.42051
Kourageous Tourists - 0.5.2
KSP-AVC Plugin -
KSPRescuePodFix -
KSPWheel -
KWRocketryRebalanced -
Landing Height - 2.3
Lithobrake Exploration Technologies - 0.4
Maeneuver Node Evolved - 1.0.5
MarkIVSystem - 3.1.2
MechJebForAll -
MoarFilterExtensionConfigs -
Modular Rocket Systems - 1.13.2
ModularFlightIntegrator - 1.2.7
Module Manager Watch Dog - 0.0.1
MunarIndustries Fuel Tank Expansion - 0.9.7
ZZZRadioTelescope - 1.0.5
NavBallDockingAlignmentIndicatorCE - 1.1
Docking Port Alignment Indicator - 6.9.1
NearFutureAeronautics - 2.0
NearFutureConstruction - 1.2.3
NearFutureElectrical - 1.1.3
NearFutureExploration - 1.0.10
NearFutureLaunchVehicles - 2.0.3
NearFutureProps - 0.6.3
NearFuturePropulsion - 1.2.2
NearFutureSolar - 1.2.3
NearFutureSpacecraft - 1.3.3
EVAHandrailsPackContinued -
NovaPunch Rebalanced -
One Window - 1.0.4
Orbital Colony - 1.1
Parking Brake - 0.3
PartWizardContinued -
PatchManager -
PEBKAC Launch Escape - 1.4.2
Airline Kuisine - 0.5
Precise Editor - 1.4
Precise Maneuver - 2.4.4
Procedural Fairings -
PWBFuelBalancerRestored -
QuickGoTo -
QuickRevert -
QuickSearch -
QuickStart -
RCS Build Aid - 0.10
RealPlume - Stock - 4.0.1
Real Scale Boosters - 0.16
RemoteTechRedevAntennas - 0.1.1
AmpYear - 1.5.7
DeepFreeze Continued... - 0.28
ReStock - 1.2.1
ReStockPlus - 1.2.1
RetractableLiftingSurface -
Real Scale Sea Dragon - 0.3.4
SCANsat - 1.20.4
Shangsheng Orbital - 0.3
Ship Manifest - 6.0.1
SmartDockingAid - 1.0
SmartParts - 1.9.16
SolverEngines - 3.7.5
SpaceY Expanded - 1.4
SpaceY Lifters - 1.17.2
StationPartsExpansionRedux - 1.3.6
StreamlineEnginesTanks - 1.2
Surface Mounted Lights - 1.16.7437.40107
SXTContinued -
TAC Fuel Balancer -
TankLock - 0.2.6
TarsierSpaceTechnology - 7.10
ThrottleControlledAvionics - 3.7.2
TAC Life Support - 0.15
ToadicusToolsContinued -
TokamakIndustries -
Tracking Station Evolved - 1.0.6
Trajectories - 2.3.4
Kerbal Alarm Clock - 3.13
Alternate Resource Panel - 2.10
Tundra Exploration - 2.1
Tundra Technologies - 2.0
TweakableEverything -
TweakScale -
TweakScale Companion for ReStockPlus - 1.1
WASDEditorCameraContinued -
WildBlueTools - 1.81.3
Kerbal Actuators -
Classic Stock Resources - 1.1.4
Deep Space Exploration Vessels - 3.5
Kerbal KIS Items - 2.1.7
Mark One Laboratory Extensions - 1.22.1
ZeroMiniAVC -


Edited by DerGolgo
Link to comment
Share on other sites

2 answers to this question

Recommended Posts

  • 0

So I've tried again.
Had three tourists in orbit, waiting to get to the Munar surface station where another three had just finished their stay. Had only transported three down because the Munar lander I had stationed in orbit is a three seater, and fuel availability had me limited the flights to and from the Munar surface. Docking that three seat lander to anything broke the game as describe.

So I launched another lander I had designed earlier, an 8 seater, flew it to the Mun (no Hyperedit), picked up the three tourists from orbit, landed, and had them all stick around until the station tours were complete.
Next, I built a new six-seater craft to bring them all home.
But once I launched the big new lander, carrying all six tourists, and docked it to the new six-seater craft, the game broke as before. I had to resort to Hyperedit to put the lander down on Kerbin.

Unfortunately, I failed to copy the log files there, but the problem is exactly the same as in the previous instances, for which logs are linked in the OP.

Help. Anyone?


Link to comment
Share on other sites

  • 0

You are getting a crash. Interestingly, the crash report  is being uploaded to somewhere!! :0.0:

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at Restock.ModuleRestockDeployableMeshHider.OnDestroy () [0x00007] in <ae8c8c31ff6242a3a85d638156a0e998>:0

(Filename: <ae8c8c31ff6242a3a85d638156a0e998> Line: 0)

NullReferenceException: Object reference not set to an instance of an object
  at Restock.ModuleRestockDeployableMeshHider.OnDestroy () [0x00007] in <ae8c8c31ff6242a3a85d638156a0e998>:0

(Filename: <ae8c8c31ff6242a3a85d638156a0e998> Line: 0)

NullReferenceException: Object reference not set to an instance of an object
  at Restock.ModuleRestockDeployableMeshHider.OnDestroy () [0x00007] in <ae8c8c31ff6242a3a85d638156a0e998>:0

ReStock is involved in the mess for sure, but it may be only the screaming victim, not the perpetrator.

Further digging on the problem, I also found:

Uploading Crash Report
  at (wrapper managed-to-native) UnityEngine.Component.GetComponentFastPath(UnityEngine.Component,System.Type,intptr)
  at UnityEngine.Component.GetComponent[T] () [0x00020] in <5aeafee3fea24f37abd1315553f2cfa6>:0
  at DialogCanvasUtil.get_DialogCanvasRect () [0x00027] in <c1858a3f77504bd1aaa946fdccf84670>:0
  at CrewHatchController.get_CrewHatchTooltip () [0x00065] in <c1858a3f77504bd1aaa946fdccf84670>:0
  at CrewHatchController.HideTooltip () [0x00000] in <c1858a3f77504bd1aaa946fdccf84670>:0
  at CrewHatchController.DespawnUIs () [0x00006] in <c1858a3f77504bd1aaa946fdccf84670>:0
  at CrewHatchController.OnDestroy () [0x00058] in <c1858a3f77504bd1aaa946fdccf84670>:0

And also

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at KSPPreciseManeuver.PreciseManeuverToolbar.OnDestroy () [0x00089] in <148a8ec2de454d9cbd6a3d0df7bebbc1>:0

(Filename: <148a8ec2de454d9cbd6a3d0df7bebbc1> Line: 0)

Uploading Crash Report
NullReferenceException: Object reference not set to an instance of an object
  at FlightGlobals.get_ActiveVessel () [0x00005] in <c1858a3f77504bd1aaa946fdccf84670>:0
  at KRASH.FlightModule.OnDestroy () [0x00000] in <13ef8314150d4696ac808140015c5bfd>:0


[SCANsat] Error in destroying planetary map overlay:
  at (wrapper managed-to-native) UnityEngine.GameObject.GetComponentInChildren(UnityEngine.GameObject,System.Type,bool)
  at UnityEngine.GameObject.GetComponentInChildren[T] (System.Boolean includeInactive) [0x00001] in <5aeafee3fea24f37abd1315553f2cfa6>:0
  at UnityEngine.GameObject.GetComponentInChildren[T] () [0x00003] in <5aeafee3fea24f37abd1315553f2cfa6>:0
  at SCANsat.SCAN_Unity.SCAN_UI_Overlay.removeOverlay (System.Boolean immediate) [0x00034] in <5a779e0d8edb4222b7a30eefe694c524>:0

and this is the first screaming victim I found on  your log:

Uploading Crash Report
XmlException: Root element is missing.
  at System.Xml.XmlTextReaderImpl.Throw (System.Exception e) [0x00027] in <b92efb6eef6e41b5abd458f107e6d92e>:0
  at System.Xml.XmlTextReaderImpl.ThrowWithoutLineInfo (System.String res) [0x00017] in <b92efb6eef6e41b5abd458f107e6d92e>:0
  at System.Xml.XmlTextReaderImpl.ParseDocumentContent () [0x0035d] in <b92efb6eef6e41b5abd458f107e6d92e>:0
  at System.Xml.XmlTextReaderImpl.Read () [0x0008c] in <b92efb6eef6e41b5abd458f107e6d92e>:0
  at System.Xml.XmlLoader.Load (System.Xml.XmlDocument doc, System.Xml.XmlReader reader, System.Boolean preserveWhitespace) [0x000a6] in <b92efb6e
  at System.Xml.XmlDocument.Load (System.Xml.XmlReader reader) [0x0002e] in <b92efb6eef6e41b5abd458f107e6d92e>:0
  at System.Xml.XmlDocument.Load (System.String filename) [0x00013] in <b92efb6eef6e41b5abd458f107e6d92e>:0
  at KSP.IO.PluginConfiguration.load () [0x0006a] in <c1858a3f77504bd1aaa946fdccf84670>:0
  at TweakableEverything.TDNProtoUpdater.OnDestroy () [0x00007] in <a73916ddc84c4aad97c4602d57fff7ce>:0

All of them are borking on the OnDestroy thingie. It makes sense, as when you dock a shipt, the game "merges" the former two into one big vessel. So, they are "destroyed" on memory and the big one "respawns" in their place.

All of this hints me that, indeed, they are all screaming victims of the real problem. So I kept digging and found this:

B9TankSettings: The tank type tundraSupplyAllSewage already exists

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

[ModuleManager] Post run call threw an exception in loading DSEVUtils, Version=, Culture=neutral, PublicKeyToken=null

(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)

Uploading Crash Report
ReflectionTypeLoadException: Exception of type 'System.Reflection.ReflectionTypeLoadException' was thrown.
  at (wrapper managed-to-native) System.Reflection.Assembly.GetTypes(System.Reflection.Assembly,bool)
  at System.Reflection.Assembly.GetTypes () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0
  at ModuleManager.MMPatchLoader+<ProcessPatch>d__31.MoveNext () [0x00cce] in <dd928f26aeed424cbf258e95a9937336>:0
UnityEngine.DebugLogHandler:Internal_LogException(Exception, Object)
UnityEngine.DebugLogHandler:LogException(Exception, Object)
ModuleManager.Logging.UnityLogger:Exception(String, Exception)
ModuleManager.Logging.ModLogger:Exception(String, Exception)
UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)

(Filename: <ad04dee02e7e4a85a1299c7ee81c79f6> Line: 0)

This one is the very first occurrence of the "Crash Report thingy". Apparently MM is borking while trying to load a thingy called DSEVutils.dll .

WELL, the first occurrence of the string "DSEVUtils" on your log is:

Load(Assembly): Notantares Space Industries/Notantares_Station_Parts/Plugins/DSEV_Transplants/DSEVUtils

So my first suspect is Notantares, but then I realised that DSEVUtils is a thingy made by Angel-125! 

So, it's a guess but I think this should work: delete DSEVUtils.dll (all the copies) on Notantares, and install DSEV . You are running KSP 1.10, and that DLL is pretty old - and most authors don't care about backwards compatibility. Byinstalling the newest DSEV, you will have all that DLLs updated to the latest version, that should work fine on KSP 1.10. But you need to delete the rogue old DLLs on your system too.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...