Jump to content
  • 0

BUG: spawns in air instead of on runway


dmav522
 Share

Question

7 answers to this question

Recommended Posts

  • 0
13 minutes ago, dmav522 said:

Vessels spawns at 1000m altitud instead of on ground and starts dropping from the sky. 

 

Sounds like an old bug, what version of the game are you playing, and what mods?  A log file (Player.log) would help, but there is a solution:

 

I think the mod you need is this:

 

Link to comment
Share on other sites

  • 0
39 minutes ago, dmav522 said:

Vessels spawns at 1000m altitud instead of on ground and starts dropping from the sky. 

 

You would not bechance be using the old Firespitter parts? The Landing gear has been known to cause this bug.

Link to comment
Share on other sites

  • 0

Old firespitter had that bug and Hooliganlabs did and I think the old version of opt. I think that it was caused by the part being massively tall physically but most of its hitbox is noncollieable so it spawns high in the air to avoid colliding with the surface despite it not being solid. I saw a thread when I was having this issue myself in 1.5.1 despite the thread being in 1.3.1 it had a universal solution, parachutes or if your feeling kerbalish retro rockets.

1 minute ago, GDJ said:

The Landing gear

It was the float landing gear.

 

Link to comment
Share on other sites

  • 0
28 minutes ago, Delta dart said:

It was the float landing gear.

In my game it was all landing gear. If the Firespitter landing gear wasn't used, the craft worked normally.

Link to comment
Share on other sites

  • 0
1 hour ago, Delta dart said:

Old firespitter had that bug and Hooliganlabs did and I think the old version of opt. I think that it was caused by the part being massively tall physically but most of its hitbox is noncollieable so it spawns high in the air to avoid colliding with the surface despite it not being solid. I saw a thread when I was having this issue myself in 1.5.1 despite the thread being in 1.3.1 it had a universal solution, parachutes or if your feeling kerbalish retro rockets.

It was the float landing gear.

 

yes I was using the floats

Link to comment
Share on other sites

  • 0

It seems to be the way KSP determines craft position, using bounds. Animated (deployable) parts (cuz of the colliders), seem to caue this. I've managed to fix a few parts that cause this, by adjusting object origins in the models.

But yeah, World Stabilizer seems to be viable band-aid fix for it.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...