Jump to content
  • 0

Fairing Lag


Question

My craft is just 214 parts, with 12 fairings ( with shells), and the game is lagging like i was controlling a 600+ parts craft. When all fairings deployed, the timer went from yellow to green.

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 1
4 hours ago, Sirius K said:

one 398 Vall base, one 355 part Eeloo Base

Somebody get this man not to part clip. Are you tryna lag out your game. Cause there is no reason for bases that size. Small bases are much better, easier to land, easier to get rid of, cheaper, etc. Put a MAX 100 part base down, room for like 10 Kerbals, a rover, science, ISRU, batteries, and solar panels, way to get away from said bases if Kraken hits you, and Lighting around the base, cause Kerbals on GEVA (Ground Extra Vehicular Activity) at work can see. I have a 78 part base on Duna that is more than enough for what I need, and if I want, I can send out a special rover to pick it up, and bring it to a new biome. I have two 83 part orbital stations, about 50 km away at there furthest, one for refueling, with a crew module, and a special fuel tug that comes to meet the fuel module I send up every so often. The other is for science and crew, it has space for 25 Kerbals, a space tug, an escape module, science lab, and everything else needed for a career save.

And I am in the process of bringing an ISRU based station, because I forgot about ISRU. Based off my fuel station, it has room for the fuel it makes, plenty  of ISRU converters, and ore tanks, a crew module, an ore tug, a space tug, and an escape module. Totals at about 114 parts.

Link to post
Share on other sites
  • 0

Do you happen to know the FPS you were hitting both with and without thr fairings?  What are the specs of your machine?  Have you tried alternate builds with the same or different success?

Link to post
Share on other sites
  • 0

To diagnose this people would need more information, such as your system specs, any mods you might be using, etc. 

And thread moved to Support. 

Link to post
Share on other sites
  • 0
1 hour ago, Vanamonde said:

To diagnose this people would need more information, such as your system specs, any mods you might be using, etc. 

And thread moved to Support. 

My laptop runs on 8GB RAM, x64 based processor, Intel(R) Core (TM) i7-3537U CPU @ 2.00GHZ 2.50 GHZ, all 5 year old.
When with no mods, the game can run a 500 parts craft before lags starts to get noticable. With mods it can run about 400 parts before lags starts to get noticable.

Mods: Scatterer, Dock Rotate, EVE, TUFX, Spectra, Better timewarp, Correct COL, Editor Extensions, Hangar extender, Reentry Particles, Trajectories (is off most of the time), KER, and the rest are mods dependencies like Click through blocker, Toolbar controller, Module Manager etc. 

Scatterer, EVE, Spectra only lags when I look at an Atmosphere or when I'm in the atmosphere, but the craft i have doesn't matter anywhere i look.

Reentry Particles and TUFX doesn't contribute much to the lag

I also have Distant Object Enhancement but remove because i thought it was the source of the lag but it wasn't, as removing that doesn't affect the lag at all.

 

10 hours ago, DunaManiac said:

Does it still cause lag with smaller vessels? Does it happen all the time?

no, all smaller vessels runs very smoothly, including this when all the fairing are deployed

11 hours ago, Popestar said:

Do you happen to know the FPS you were hitting both with and without thr fairings?  What are the specs of your machine?  Have you tried alternate builds with the same or different success?

I don't know the fps since I don't have any FPS revealing stuff, but I know before the fairings deploys, the game is very rough, un smooth. Spec are written in a Reply for Vananamode. I haven't tried alternate builds, but the fact that I have numerous crafts with about the same part count running at green timers should how that something is wrong.

Link to post
Share on other sites
  • 0
3 hours ago, Sirius K said:

My laptop runs on 8GB RAM, x64 based processor, Intel(R) Core (TM) i7-3537U CPU @ 2.00GHZ 2.50 GHZ, all 5 year old.
When with no mods, the game can run a 500 parts craft before lags starts to get noticable. With mods it can run about 400 parts before lags starts to get noticable.

Mods: Scatterer, Dock Rotate, EVE, TUFX, Spectra, Better timewarp, Correct COL, Editor Extensions, Hangar extender, Reentry Particles, Trajectories (is off most of the time), KER, and the rest are mods dependencies like Click through blocker, Toolbar controller, Module Manager etc. 

Those mods, that amount of fairings/parts and those specs, low RAM etc...i am gonna cast my vote and say that lag is your laptop crying for help.

 

 

Link to post
Share on other sites
  • 0
22 hours ago, Boyster said:

Those mods, that amount of fairings/parts and those specs, low RAM etc...i am gonna cast my vote and say that lag is your laptop crying for help.

 

 

all these mods doesn't affect much lag (except scatterer, but when in atmosphere), and the fairings lags my other vessel at 100+ parts, with just 4 fairings

Link to post
Share on other sites
  • 0
On 10/15/2020 at 12:03 PM, Boyster said:

Those mods, that amount of fairings/parts and those specs, low RAM etc...i am gonna cast my vote and say that lag is your laptop crying for help.

 

 

What about the fact that the 12 fairings hid inside a fairing has more performance than 12 fairings exposed

wait doesn't matter the lag is still the same

Edited by Sirius K
Link to post
Share on other sites
  • 0
On 10/18/2020 at 11:54 PM, Sirius K said:

What about the fact that the 12 fairings hid inside a fairing has more performance than 12 fairings exposed

wait doesn't matter the lag is still the same

WHY ARE YOU PUTING 12 FAIRINGS IN A FAIRING IN THE FIRST PLACE??

Link to post
Share on other sites
  • 0
18 hours ago, Mikenike said:

WHY ARE YOU PUTING 12 FAIRINGS IN A FAIRING IN THE FIRST PLACE??

6 domes (with flat fairings to allow kerbals to walk)? Also I found out the total amount of fairing on the base is 22, 3 long tubes, 1 spire, 6 branches to support solars

Edited by Sirius K
Link to post
Share on other sites
  • 0

 

On 10/15/2020 at 6:58 AM, Vanamonde said:

To diagnose this people would need more information, such as your system specs, any mods you might be using, etc. 

And thread moved to Support. 

Update, so the base is completed and landed, but here I am on a 138 part craft, with no fairings. But when I'm in flight, KSP uses 100% of my CPU, and in Map View or IVA view, KSP is only using 60%. On the clock, in flight it's yellow, and in Map view it's green. Reloading the craft seems to make it smooth, but the timer is still green and yellow flashing, I expected green when a craft is below 250 part.

My lander when landing near the base also went smooth when I don't look at the base, but lags when I do so.

In my save, there's two 21 part relays, one 281 part Tylo base, one 124 part space station in Tylo Orbit, one 398 Vall base, one 355 part Eeloo Base (that base I recently land), a 48 part Tylo Lander, and the 138 part craft I'm currently in. 16 saves are in the game, 70 VAB crafts, 74 SPH crafts and 83 subassemblies, as well as 5 auto generated backup saves.

Edited by Sirius K
Link to post
Share on other sites
  • 0
12 hours ago, Mikenike said:

Somebody get this man not to part clip. Are you tryna lag out your game. Cause there is no reason for bases that size.

Ah, because the bases are for Upsilon, these bases has more stock stuff like more habitations. In the case of the Vall bas, it has 4 stock launch pads (made from 2 wing E connector, one battery, one jr docking port, one circular light, and a fairing) with 4 shuttles.

  I was trying to have several bases in one save.

If i have several small crafts that their parts adds up to the amount the 2 bases part count add up, will it have the same amount of lag?

Edited by Sirius K
Link to post
Share on other sites
  • 0
10 hours ago, Sirius K said:

Ah, because the bases are for Upsilon, these bases has more stock stuff like more habitations. In the case of the Vall bas, it has 4 stock launch pads (made from 2 wing E connector, one battery, one jr docking port, one circular light, and a fairing) with 4 shuttles.

Ok, I thought you were running stock game for some reason. Makes a little more sense. I thought you were going for like a stratenbiltz size base, y'know,  like 100 kilatons to different celestial  bodies.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...