Jump to content
  • 1

Unable to load KSP


Go to solution Solved by James Kerman,

Question

Hello,

I've just purchased ksp via Steam and downloaded it, but the program won't load. (64-bit Windows, ver 1.10.1, build id = 02939, unmodded)

The program window itself opens, but only shows a black screen. All of the system requirements seem ok.

I've tried uninstalling / file check. I'm running it on my admin account as well.

What should I do?

https://imgur.com/a/YMstwu8 this is what the screen looks like.

 

Also, I can't change the 'read only' of the file. The dialogue says it's done, but when I open I it again the

setting 'read only' doesn't change. Can this be the problem?

 The dxdiag is pasted below.

------------------
System Information
------------------
      Time of this report: 10/15/2020, 21:30:02
          
              
         Operating System: Windows 10 Home 64-bit (10.0, Build 18362) (18362.19h1_release.190318-1202)
                 Language: Korean (Regional Setting: Korean)
      System Manufacturer: SAMSUNG ELECTRONICS CO., LTD.
             System Model: 900X5L
                     BIOS: P09AFX.046.180605.KS (type: UEFI)
                Processor: Intel(R) Core(TM) i5-6200U CPU @ 2.30GHz (4 CPUs), ~2.4GHz
                   Memory: 4096MB RAM
      Available OS Memory: 4014MB RAM
                Page File: 5835MB used, 3554MB available
              Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
      DX Setup Parameters: Not found
         User DPI Setting: 120 DPI (125 percent)
       System DPI Setting: 120 DPI (125 percent)
          DWM DPI Scaling: UnKnown
                 Miracast: Available, with HDCP
Microsoft Graphics Hybrid: Not Supported
 DirectX Database Version: Unknown
           DxDiag Version: 10.00.18362.0387 64bit Unicode

------------
DxDiag Notes
------------
      Display Tab 1: No problems found.
        Sound Tab 1: No problems found.
        Sound Tab 2: No problems found.
        Sound Tab 3: No problems found.
          Input Tab: No problems found.

--------------------
DirectX Debug Levels
--------------------
Direct3D:    0/4 (retail)
DirectDraw:  0/4 (retail)
DirectInput: 0/5 (retail)
DirectMusic: 0/5 (retail)
DirectPlay:  0/9 (retail)
DirectSound: 0/5 (retail)
DirectShow:  0/6 (retail)

---------------
Display Devices
---------------
           Card name: Intel(R) HD Graphics 520
        Manufacturer: Intel Corporation
           Chip type: Intel(R) HD Graphics Family
            DAC type: Internal
         Device Type: Full Device (POST)
         
       Device Status: 0180200A [DN_DRIVER_LOADED|DN_STARTED|DN_DISABLEABLE|DN_NT_ENUMERATOR|DN_NT_DRIVER] 
 Device Problem Code: No Problem
 Driver Problem Code: Unknown
      Display Memory: 2135 MB
    Dedicated Memory: 128 MB
       Shared Memory: 2007 MB
        Current Mode: 1920 x 1080 (32 bit) (60Hz)
         HDR Support: Not Supported
    Display Topology: Internal
 Display Color Space: DXGI_COLOR_SPACE_RGB_FULL_G22_NONE_P709
     Color Primaries: Red(0.674805,0.308594), Green(0.259766,0.663086), Blue(0.154297,0.065430), White Point(0.313477,0.329102)
   Display Luminance: Min Luminance = 0.500000, Max Luminance = 270.000000, MaxFullFrameLuminance = 270.000000
        Monitor Name: Generic PnP Monitor
       Monitor Model: unknown
       
         Native Mode: 1920 x 1080(p) (60.096Hz)
         Output Type: Internal
Monitor Capabilities: HDR Not Supported
Display Pixel Format: DISPLAYCONFIG_PIXELFORMAT_32BPP
      Advanced Color: Not Supported
      
 Driver File Version: 23.20.0016.4849 (English)
      Driver Version: 23.20.16.4849
         DDI Version: 12
      Feature Levels: 12_1,12_0,11_1,11_0,10_1,10_0,9_3,9_2,9_1
        Driver Model: WDDM 2.1
 Graphics Preemption: Triangle
  Compute Preemption: Thread
            Miracast: Supported
      Detachable GPU: No
 Hybrid Graphics GPU: Integrated
      Power P-states: Not Supported
      Virtualization: Not Supported
          Block List: No Blocks
  Catalog Attributes: N/A
   Driver Attributes: Final Retail
    Driver Date/Size: 2017-10-27 오전 9:00:00, 53357616 bytes
         WHQL Logo'd: Yes
     WHQL Date Stamp: Unknown

Edited by User_ksp
Additional questions and descriptions
Link to post
Share on other sites

6 answers to this question

Recommended Posts

  • 1
1 hour ago, User_ksp said:

What should I do?

Just a random guess but maybe your problem is with the game's/monitor's resolution, here are two posts THAT might help, but its a total guess from my side

https://forum.kerbalspaceprogram.com/index.php?/topic/186591-black-screen/

https://forum.kerbalspaceprogram.com/index.php?/topic/137472-11-fresh-install-black-screen/

or this Add -popupwindow to the start up Properties>Stet launch options

Again its just a random google search , hopefully thats your problem

Edited by Boyster
Link to post
Share on other sites
  • 0
35 minutes ago, James Kerman said:

Hmm, If you could link to copies of your output.log and player.log as described in the first post in this thread it will assist our friendly and knowledgeable members in narrowing down the problem.

Added them in the first thread. I am not sure how I can include the ksp_log file, though. The link shown in that link doesn't work. 

https://forum.kerbalspaceprogram.com/showthread.php/35464-Cant-find-your-save-files-Read-this

Edited by User_ksp
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...