Jump to content

[1.8.x, 1.9.x, 1.10.x] Steam Gauges Recalibrated


linuxgurugamer
 Share

Recommended Posts

SteamGauges 

Tired of all of those compact, precise, and easily interpretable digital readouts cluttering up your orbital maneuvers? Do you look back to days when needles arced gracefully across illegible numbers with irregularly spaced dividing lines? Then SteamGauges is the plugin for you! Bringing a variety of of instruments to a space program near you. 

History

 

sXYUeV6.png

 

SteamGauges is a plugin for KSP that adds a number of og-style gauges based mostly around aircraft instrumentation. Simply drop the SteamGauges folder into your GameData directory, and then click the gauge icon to bring up a menu of available gauges. Toggle on or off the gauges you want, then close the menu again. All the gauges are draggable, and remember their positions. Please note, as this is a plugin and not a part-based mod, all settings are global and not vehicle specific.

Dependencies

Availability

CKAN soon

 

 

8 minutes ago, linuxgurugamer said:

SteamGauges 

Tired of all of those compact, precise, and easily interpretable digital readouts cluttering up your orbital maneuvers? Do you look back to days when needles arced gracefully across illegible numbers with irregularly spaced dividing lines? Then SteamGauges is the plugin for you! Bringing a variety of of instruments to a space program near you. 

History

 

sXYUeV6.png

 

SteamGauges is a plugin for KSP that adds a number of og-style gauges based mostly around aircraft instrumentation. Simply drop the SteamGauges folder into your GameData directory, and then click the gauge icon to bring up a menu of available gauges. Toggle on or off the gauges you want, then close the menu again. All the gauges are draggable, and remember their positions. Please note, as this is a plugin and not a part-based mod, all settings are global and not vehicle specific.

Dependencies

Availability

CKAN soon

 

 

 

Link to comment
Share on other sites

I'm having an issue. The icon for this mod isn't showing up in my toolbar. Therefor I cant dictate which gauges I see, their transparency, or their size. The only power I have is to turn the HUD on and off with ALT+H. I looked in the Settings and Advanced Settings, and there are no options there either. To be clear, I have the dependencies properly installed.

Link to comment
Share on other sites

10 minutes ago, dylsh said:

I'm having an issue. The icon for this mod isn't showing up in my toolbar. Therefor I cant dictate which gauges I see, their transparency, or their size. The only power I have is to turn the HUD on and off with ALT+H. I looked in the Settings and Advanced Settings, and there are no options there either. To be clear, I have the dependencies properly installed.

Open the ToolbarController (yellow toolwrench) and check the settings.

Also, please provide a log file (Player.log).

Also, check that you’ve scrolled through the entire toolbar

Edited by linuxgurugamer
Link to comment
Share on other sites

On 10/23/2020 at 7:57 AM, linuxgurugamer said:

Open the ToolbarController (yellow toolwrench) and check the settings.

Also, please provide a log file (Player.log).

Also, check that you’ve scrolled through the entire toolbar

Thank you Sir. The SteamGauge mod doesnt show in my ToolBarController settings.

Here is my player.log

https://www.dropbox.com/s/kji2i4of4cywixn/Player.log?dl=0

Link to comment
Share on other sites

2 hours ago, dylsh said:

Thank you Sir. The SteamGauge mod doesnt show in my ToolBarController settings.

Here is my player.log

https://www.dropbox.com/s/kji2i4of4cywixn/Player.log?dl=0

Install ZeroMiniAVC.  Not sure if it's causing your problem, but the old MiniAVC.dll is broken, and I see at least one in the log file

Link to comment
Share on other sites

51 minutes ago, linuxgurugamer said:

Install ZeroMiniAVC.  Not sure if it's causing your problem, but the old MiniAVC.dll is broken, and I see at least one in the log file

Thank you for the good advice. Sadly my problem was not resolved.

Link to comment
Share on other sites

19 minutes ago, linuxgurugamer said:

A new log file, please

Thank you again for your help. I have provided a link to both a clean install with SteamGauges. I imagine that will help you greatly. But I also provided a link to my actual career game that has a lot of other mods.

https://www.dropbox.com/s/oasvuvhkziqdenc/Clean Install w Steam Gauges.log?dl=0

https://www.dropbox.com/s/1emxkbesvijfqmq/Modded Career Install w Steam Gauges.log?dl=0

Link to comment
Share on other sites

14 minutes ago, dylsh said:

Thank you again for your help. I have provided a link to both a clean install with SteamGauges. I imagine that will help you greatly. But I also provided a link to my actual career game that has a lot of other mods.

https://www.dropbox.com/s/oasvuvhkziqdenc/Clean Install w Steam Gauges.log?dl=0

https://www.dropbox.com/s/1emxkbesvijfqmq/Modded Career Install w Steam Gauges.log?dl=0

Ok.

You aren't running the latest version of the ClickThroughBlocker, you are one version behind

I can't tell if you have the latest SpaceTuxLibrary, please check that as well.

 

If this still doesn't help, then I'll have to get you a debug build to find out what's going on

Link to comment
Share on other sites

9 minutes ago, linuxgurugamer said:

Ok.

You aren't running the latest version of the ClickThroughBlocker, you are one version behind

I can't tell if you have the latest SpaceTuxLibrary, please check that as well.

 

If this still doesn't help, then I'll have to get you a debug build to find out what's going on

You were correct with the outdated ClickThroughBlocker. My SpaceTuxLibrary is up to date. But unfortunately the problem persists.

Link to comment
Share on other sites

22 minutes ago, dylsh said:

You were correct with the outdated ClickThroughBlocker. My SpaceTuxLibrary is up to date. But unfortunately the problem persists.

Ok, a final log of the clean install with all the updated mods, I'll try to get you a debug build tomorrow morning

Link to comment
Share on other sites

New release, 1.8.3

  • Added in accidently deleted ToolbarRegistration.cs
  • Updated registration for the individual gauges to bypass a bug in the ToolbarController

@dylsh This should fix your problem

New release, 1.8.3.1

  • Removed extra dll from plugin directory 
     
Edited by linuxgurugamer
Link to comment
Share on other sites

34 minutes ago, linuxgurugamer said:

New release, 1.8.3

  • Added in accidently deleted ToolbarRegistration.cs
  • Updated registration for the individual gauges to bypass a bug in the ToolbarController

@dylsh This should fix your problem

New release, 1.8.3.1

  • Removed extra dll from plugin directory 
     

Yes that worked! Thank you very much 

Link to comment
Share on other sites

  • 1 month later...
  • 3 months later...

I'm trying this out and I'm having issues with the HUD. On some saves it will not show the HUD at all.

I installed Steam Gauges and tried it out in my current game, everything seems to work fine except I can not get the HUD to show. On occasion I have seen it appear in the top left corner of the screen for a brief second or so when recovering craft.

As part of troubleshooting I created a new sandbox game and the HUD started to work for that save no issues. I was able to configure the HUD and try out many of its configurations.

So I decided to restart my main career game and created a third save, this time the HUD did not work. I have tried turning it on by pressing H, through the Steam Gauges settings window and using the toolbar button. None of these work. The HUD just does not show.

Whenever I activate any other gauge the toolbar button tooltip changes to indicate that the gauge is ON or OFF. But when I activate the HUD the tooltip does not change.

I've had a quick look through the logs and I can not see anything related to Steam Gauges, no errors and no other log messages.

But even so I have provided links to the log files below.

Logs:

KSP.log

Player.log

Steam Gauges Logs

Given I'm the only one having issues, I'm assuming it must be a conflict with one of my other mods but I'm hoping I wont need to start with a clean install and add my mods back one at a time (I use almost 200) just to get the HUD, so I'm hoping to get some clues where to start looking.

 

Link to comment
Share on other sites

  • 1 month later...

@Coyote21 You probably already figure it out but I'm posting anyway just if someone has the same problem. The hud in carreer mode is technology bound, I dind't found the exact technology but after some short testing its one in the column where "Nuclear propulsion" and "electronics" are (Using CTT).

Link to comment
Share on other sites

  • 2 months later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...