Jump to content

[1.10] Xingyun-2 Satellite | 2020.11.2


Akino
 Share

Recommended Posts

6d6a8e7098b43c4e5c260327ce2432a6.jpg

"Xingyun project" phase α experimental satellite, in the game can be used to build satellite communication networks.

 

DOWNLOAD

SPACEDOCK

INSTALLATION

1.Remove the older versions of this mod.
2.Put all contents of "GameData" into your "KSP/GameData"folder.

LICENSE

Creative Commons License
Xingyun-2 Satellite by Akino is licensed under a Creative Commons Attribution-ShareAlike 4.0 International License.

MEDIA

Review by @Kottabos

 

Spoiler

1a4fcfa88cf9b7851b2d293c00c86a41.png

75018887c9a61685537a110970601ca6.png

CHANGELOG

Spoiler

 

FAQ

Spoiler

 

 

Edited by Akino
Link to comment
Share on other sites

2 hours ago, miguelsgamingch said:

Looks Like You Copy And Pasted Lol.

Thanks for your reminder.:D

3 hours ago, miguelsgamingch said:

Wow, From Starllink Now To A Big China Satellite,

Well, this satellite is actually much smaller than starlink, and the single satellite is only 110kg, while starlink has 260kg.:)

Link to comment
Share on other sites

On 11/4/2020 at 10:51 PM, xTheCanadian said:

I am having trouble finding the satellite, I have the mod installed but cannot find it in game?

If you are on 1.10.1 then I can confirm that no, the sat won't show in game. I found two different issues that kept it out of mine, but have fixed them on my machine. If you are too impatient to wait for the mod author (like I was) I can help you with some temporary changes that at least get the part in game in the meantime. You just need to know how to edit a cfg file. Let me know if you're interested.

 

@Akino i'll leave my findings here in the spoiler in case it helps at all.

Spoiler

1. KSP 1.10.1 apparently requires an explicit drag cube in the cfg for parts with multiple modules. Without the dragcube declared, the part won't load.

2. Even with that fixed, it seems your part won't show up in career or science (maybe sandbox?) without a TechRequired tag.

SDkLY51.jpg

Got this to orbit on a vehicle that shall remain nameless as it was definitely not from the right country! :D

 

Link to comment
Share on other sites

8 minutes ago, OrbitalManeuvers said:

If you are on 1.10.1 then I can confirm that no, the sat won't show in game. I found two different issues that kept it out of mine, but have fixed them on my machine. If you are too impatient to wait for the mod author (like I was) I can help you with some temporary changes that at least get the part in game in the meantime. You just need to know how to edit a cfg file. Let me know if you're interested.

 

@Akino i'll leave my findings here in the spoiler in case it helps at all.

  Hide contents

1. KSP 1.10.1 apparently requires an explicit drag cube in the cfg for parts with multiple modules. Without the dragcube declared, the part won't load.

2. Even with that fixed, it seems your part won't show up in career or science (maybe sandbox?) without a TechRequired tag.

SDkLY51.jpg

Got this to orbit on a vehicle that shall remain nameless as it was definitely not from the right country! :D

 

Thanks for the heads up, I found it in Sandbox but not in my Career mode. I was going to try to make a craft file in Sandbox and move it to Career to see if it can load the satellite but I haven't tried it yet. I wish I knew how to fix it to make it show lol.

Link to comment
Share on other sites

1 minute ago, xTheCanadian said:

Thanks for the heads up, I found it in Sandbox but not in my Career mode. I was going to try to make a craft file in Sandbox and move it to Career to see if it can load the satellite but I haven't tried it yet. I wish I knew how to fix it to make it show lol.

oh if you have it in game at all, then you're past the hard part. To get it to show in career/science you can add "TechRequired=start" to the cfg file. This will make it available at the beginning, which probably isn't right, but at least it's there.

Link to comment
Share on other sites

3 minutes ago, OrbitalManeuvers said:

oh if you have it in game at all, then you're past the hard part. To get it to show in career/science you can add "TechRequired=start" to the cfg file. This will make it available at the beginning, which probably isn't right, but at least it's there.

Dude I was JUST about to launch my game and "pout" because I couldn't find it! I'm gonna do this first and then launch the game, thanks again bud!

Link to comment
Share on other sites

  • 4 weeks later...
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...