Jump to content
  • 0

[SOLVED - OpenGL update needed] Game fails at start - screen changes to bare background briefly, then game fails


Redchrome
 Share

Question

Hi there,

After several months hiatus while working hard at a new job, I'm trying to launch KSP again. Unfortunately, when I try to launch it (from Steam, CKAN, or the Linux command line) I see a bare wallpaper image  ever so briefly (as if the game is trying to set the graphics mode) and then I'm back to my usual desktop and the game isn't running.

I'm on Ubuntu 18.04, a GTX750 Strix video card, and 20GB RAM.

Direct rendering is working.

$ glxinfo |grep 'direct rendering'
direct rendering: Yes


I tried completely removing my KSP instance by renaming  ~/.local/share/Steam/steamapps/common/Kerbal Space Program
and letting Steam re-install it. So I believe I have a completely stock instance now, and it still crashes.

I don't see any logs generated, and I tried looking (unsuccessfully) for .dmp files.

I tried looking at the troubleshooting hints pinned in this subsection of the forum and didn't have any luck adding options to the launcher (hopefully I'm correctly guessing at what to do here). This is the most debugging output I've been able to get. Please tell me if there are any additional debugging steps I can do:

[email protected]:~/.local/share/Steam/steamapps/common/Kerbal Space Program$ ./KSPLauncher.x86_64 -disable-gpu-skinning -force-gfx-direct
Set current directory to /home/chrome/.local/share/Steam/steamapps/common/Kerbal Space Program
Found path: /home/chrome/.local/share/Steam/steamapps/common/Kerbal Space Program/KSPLauncher.x86_64
INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete
INTEL-MESA: warning: Ivy Bridge Vulkan support is incomplete
XIO:  fatal IO error 0 (Success) on X server ":0"
      after 288 requests (286 known processed) with 26 events remaining.

 

What's the next thing I should try to debug this?

Edited by Redchrome
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

  • 0

Solved it!

TL,DR: I needed to upgrade my graphics drivers.

Thanks to the *other* troubleshooting guide in this forum, I found the Player.log file.

cat ~/.config/unity3d/Squad/Kerbal\ Space\ Program/Player.log
Mono path[0] = '/home/chrome/.local/share/Steam/steamapps/common/Kerbal Space Program/KSP_Data/Managed'
Mono config path = '/home/chrome/.local/share/Steam/steamapps/common/Kerbal Space Program/KSP_Data/MonoBleedingEdge/etc'
Preloaded 'libkeyboard.so'
Preloaded 'liblingoona.grammar.kerbal.so'
Preloaded 'libsteam_api.so'
Preloaded 'ScreenSelector.so'
Display 0 'KJTHDMI2.0 32"': 3840x2160 (primary device).
Desktop is 3840 x 2160 @ 60 Hz
Unable to find a supported OpenGL core profile
Failed to create valid graphics context: please ensure you meet the minimum requirements
E.g. OpenGL core profile 3.2 or later for OpenGL Core renderer
No supported renderers found, exiting
 
(Filename: ./PlatformDependent/LinuxStandalone/main.cpp Line: 611)


However, it looked like my 'OpenGL core profile version' should be sufficient.

$ glxinfo |grep -i version
server glx version string: 1.4
client glx version string: 1.4
GLX version: 1.4
    Version: 19.2.8
    Max core profile version: 3.3
    Max compat profile version: 3.1
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
OpenGL core profile version string: 3.3 (Core Profile) Mesa 19.2.8
OpenGL core profile shading language version string: 3.30
OpenGL version string: 3.1 Mesa 19.2.8
OpenGL shading language version string: 1.40
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 19.2.8
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00

 

Obviously it wasn't tho.
 

So I spent several hours wrestling with getting my nVidia driver updated, kernel updated (turns out upgrading from 4.15 to 5.4 is not quite trivial), and getting all the driver versions to match. I haven't updated my kernel and drivers for some time because my last attempt resulted in crashes once a day.

In retrospect, I should have just made sure I had this Ubuntu PPA installed:

https://launchpad.net/~graphics-drivers/+archive/ubuntu/ppa

remove the nVidia .run package I had installed,

then run:

apt-get install nvidia-driver-455

but it took me a while to catch on to exactly what I needed to do. If I'd just been a user who installs the system and never does anything funky other than the occasional 'do-release-upgrade' I probably would have been fine.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...