Jump to content

Kerbal Space Program 1.11: "Some Reassembly Required" Grand Discussion Thread


Recommended Posts

restarted with 1.11 a few weeks back not that long after it came out, have to say I'm liking it for giving something to actually do when you get somewhere, and once you have a cluster of ground bits, a reason to go back and add more since they actually do stuff - and do stuff a probe cannot yet do.

note tried the on orbit assembly stuff as yet, but can see it being useful to upgrade older craft at a lower cost than sending a whole new module

Link to post
Share on other sites

Any E.T.A. on 1.11.1 ?! 

 

*Looking to the calender and the filled up bugtracker* Bugfixes required to enjoy the update 1.11. Actually it's a bit meeeeeeh.

Edited by Rakete
Link to post
Share on other sites

Dunno if this was already posted, but I have been testing the new EVA construction, aaaand I found it lacking (compared to KIS).

1) It can't deal with "heavy objects" in a celestial body (like Duna). While it makes sense, it also does KIS, requiring more nearby kerbals to do the job and actually doing it.

2) The parts you can store are few.

3) An EVA constructed sat will NOT fulfill contracts (won't check the "build a new unmanned blahblah"). Same as KIS, to be truthful.

4) Storage options are scarce.

 

It's in the right direction, but still lacking :/

Link to post
Share on other sites
17 hours ago, Rakete said:

Any E.T.A. on 1.11.1 ?! 

 

*Looking to the calender and the filled up bugtracker* Bugfixes required to enjoy the update 1.11. Actually it's a bit meeeeeeh.

In some places it's outright broken.  And I mean broken fundamentally. I see people constantly losing their satellites due to orbits being NAN after separation. And on top of that we have #27045 and #26961. Not great. 

Link to post
Share on other sites

IMO it seems like updates are coming out containing bugs that would be found if the QA team had properly and thoroughly tested all of the new features. And with the amount of these bugs that are subsequently fixed in the .1 patch, it's almost like SQUAD are just outsourcing most of their QA to the community. Come on guys, this is supposedly a fully released game, I don't think that's how bug testing generally works.

@Just Jim since you seem to be the only QA guy active on the forum, could you comment on this? Sorry for the mini-rant, I usually just report bugs to the tracker without complaining vocally, but I felt that this was something I should speak up about. I've really been enjoying the new stuff in 1.11, if that helps :)

Link to post
Share on other sites
1 hour ago, RealKerbal3x said:

IMO it seems like updates are coming out containing bugs that would be found if the QA team had properly and thoroughly tested all of the new features.

So, maybe they were found. Finding a bug doesn't automatically mean it will be fixed before release.

Link to post
Share on other sites
1 minute ago, HebaruSan said:

So, maybe they were found. Finding a bug doesn't automatically mean it will be fixed before release.

Maybe, but some stuff in 1.11 is both broken and fairly obvious if you do the right thing. Obviously not all bugs found before release will necessarily be fixed, but it does seem that some of the bugs in this case should have been.

Link to post
Share on other sites

But honestly: The amount of bugs in KSP and the amount of fixes is quite good, if you compare it e.g. with Elite Dangerous, where bugfixing policy is outright a real mess with returning bugs, that should have been fixed (The release of the new fleet carriers took 9 patches over 8 months and they are more broken than ever before). And most bugs don't ever get a look by the devs, as they need 10 or more confirmations and aren't even then set to the confirmed status by the bug managers. The issue tracker there is a real mess, too.

 

Back to KSP:

But the fix for 1.11 is really needed. Soon. And well packed with fixes. Apart from really really annoying visual disturbances like halfway opened housings of the retracted 2x3 and 1x6 solar panels (they really bother me visually) or the flags tipping over (making every landing not getting the satisfying plant the flag moment), there are many annoying gameplay issues, that really really get on my nerves: e.g. the orbital changes when a Kerbal is on a ladder or hatch on EVA.

Edited by Rakete
Link to post
Share on other sites
24 minutes ago, Rakete said:

But honestly: The amount of bugs in KSP and the amount of fixes is quite good, if you compare it e.g. with Elite Dangerous

If you compare it with bigger and more complex games yes. :)

On the other hand, comparing to some others, not that much... :P 

Different teams, different scopes, different models of revenue. It's hard to draw a parallel. Perhaps with Space Engineers or Empyrion?

 

24 minutes ago, Rakete said:

But the fix for 1.11 is really needed. Soon. And well packed with fixes. Apart from really really annoying visual disturbances like halfway opened housings of the retracted 2x3 and 1x6 solar panels (they really bother me visually) or the flags the tipping (making every landing not getting the satisfying plant the flag moment), there are many annoying gameplay issues, that really really get on my nerves: e.g. the orbital changes when a Kerbal is on a ladder or hatch on EVA.

Utterly needed. Launching vehicle with some older parts leads to Instantaneous Craft Annihilation (from now on, ICA) due heat (!!!). This can't be worked around with cheats, but KSP Recall 0.0.6 (currently beta) fixes it.

Launching pretty heavy vehicles (above 120 tons, my test bed uses a 500tons one) shoves the craft below any colliders on the launch point, placing it directly on the PQS ground level - also inducing ICAs. Worst, by switching scenes (or, better yet, by doing something that packs the craft), when  you switch back and the craft is unpack, if there's anything with a collider under the craft and on the ground, the craft is placed inside it and you have ICA again. This can be worked around with the Indestructible Cheat, but this is annoying on switching crafts. World Stabiliser cannot help on this, as it tries to fix another problem and not this new one.

Besides the panels, the landing lights on my crafts are always "lit" - but they only casts light with the lights on (U key).

All of these hints me they are failing in properly initialise something on craft launch (and/or on the unpack) what suggests a common root cause.

I hope they find and fix the root cause, instead of patching the effects where they we find them, what IMHO is the current M.O. around here and the underlying reason by so many bugs keep resurrecting  on every new release, as well some clearly related new ones being spawning when new features are created.

Edited by Lisias
Hit "save" too soon.
Link to post
Share on other sites

Yeah, the always active landing lights bother me too. It looks hilarious if they shine through the wings of my spaceplanes, when the gears are retracted.

I think we should get a .1 and a .2 and .3 version in order to fix a whole bunch of the most annoying bugs.  I'd prefer bugfixing instead of whole new features. Maybe 1.12 should only contain some few new parts (Space station parts would be nice!) and a huuuuuge list of fixes.

 

At the moment I stopped playing due to annoyance caused by bugs.

Edited by Rakete
Link to post
Share on other sites
1 hour ago, se5a said:

yeah not if I have to create yet another login

Try disabling the new option for ladders in settings, i can't really remember it, waiting for the next patch...

I read somewhere if you turn off that new ladder option(something like in the end of the ladder to stop)

it fixes problems like yours, give it a try...hopefully a patch comes soon, i am starting to miss Kerbal :rolleyes:

Edited by Boyster
Link to post
Share on other sites
18 hours ago, Rakete said:

Yeah, the always active landing lights bother me too. It looks hilarious if they shine through the wings of my spaceplanes, when the gears are retracted.

I think we should get a .1 and a .2 and .3 version in order to fix a whole bunch of the most annoying bugs.  I'd prefer bugfixing instead of whole new features. Maybe 1.12 should only contain some few new parts (Space station parts would be nice!) and a huuuuuge list of fixes.

 

At the moment I stopped playing due to annoyance caused by bugs.

Version 1.7 was the last one that received more than one fix, for some reason. They just stopped doing .2s and so on at one point. One patch is clearly not enough to fix every major bug. And if the version 1.11 receives just one fix as well - it better be darn good and packed with solutions, otherwise this version will stay broken until five or so months later, when they release 1.12, which by itself again will introduce way more bugs than it will fix from 1.11. It's just an endless loop at this point. 

Edited by dok_377
Link to post
Share on other sites

Reminds me way too much of 1.4. Took (at least for me) until 1.6 that KSP became playable again.

Bug tracker for 1.11 would make a good script for a horror movie :D 

Edited by VoidSquid
Link to post
Share on other sites

I just realized my daily routine now includes looking the downloads on Steam in case the patch drops.

Oohhhhhhh i am missing the game, haven't done that for any game for a while :D.

Edited by Boyster
Link to post
Share on other sites

It happened to someone???
The original SQUAD lights, Illuminator Mk1 and Illuminator Mk2 stopped working properly, can no longer be turned off or turned on.
All the Flags, which remind me of old Milestones, appear tilted on the ground and it is impossible to access what the plaque says.
Today I find the unpleasant novelty that I can not undock a claw from an asteroid, something that I had developed during version 1.8....

Link to post
Share on other sites

I think, it would be good, if squad would communicate more openly about E.T.A. on 1.11.1 and fix content to be expected. 

 

At the moment, the game is in a state that really really REALLY needs a whole bunch of fixes. Whole bugfixing orgies are required :D ...

Edited by Rakete
Link to post
Share on other sites

The copy pasting and and the use of subassemblies of robotics with the KAL is completely furbur.

I've been trying to make a walker, but its such a slow pain in the ass to create the tracks, which in itself is a pain, becomes stupidly annoying when you can't copy and paste a complete leg.

 

and sometimes mirror causes the hinges to rotate or angle the wrong direction or something

Edited by se5a
Link to post
Share on other sites
On 12/23/2020 at 7:03 PM, Neilski said:

Has anyone else noticed that stuff seems to get kinda stuck to the ground with this patch?

At first, I noticed that Kerbals didn't lift off immediately with EVA thrust, even on Minmus - it would take a good fraction of a second for them to leave the ground (and a waste of EVA propellant).  A tiny jump into the air beforehand speeds things up a lot, so I've been doing that for a few days.
Today I noticed that a craft I was testing on the pad at KSC didn't lift off its LT-2 struts in a "normal" (i.e. physical!) fashion when the damping was set to maximum. Instead of what I expected, which was that the feet would leave the ground while the legs were still compressed, the craft slowly lifted with the feet stuck down until the legs looked like they were fully extended, and then suddenly the craft "unstuck" and the acceleration leapt up (on the accelerometer reading) to what it should have been.
The two observations may be unrelated but I've not noticed either behaviour prior to 1.11...

For info, I've just tested both of these issues with 1.10.1.

Kerbals don't exhibit the "stuck to the ground" problem in 1.10.1.
However, the LT-2 struts (and perhaps others) do exhibit the issue above. I may download an earlier version and see if it shows up there.

However, both of these are pretty minor, as bugs go, so I'm not sure there's any point in reporting them at all given the severe bugs that are still awaiting repair. (Chief on my personal list: the asteroid mass bug which was actually made much worse by the latest fix.)

Speaking of other bugs, the "ship accelerates when Kerbal goes EVA" one bit me last night during a satellite repair mission. I think this was the first time I realised what was happening (on a previous occasion I thought the game just needed a restart). When I played about with it, I spotted that just after EVA, the Kerbal was a long way from the hatch on the Mk1 lander can (about a torso-length - I can't seem to paste an image into this post) and when I moved him up and down with W/S, he got rather closer to the ship; when he got to the "normal distance" (basically touching the ship) the buggy acceleration stopped entirely, having reduced somewhat as he got closer.

 

Link to post
Share on other sites

Do the devs or their community managers read this thread? Would be nice to get some feedback instead of silence and than: "Tadaaaa! Here's your fix. But it's small, but hey: You may tell us your fix wishes for the next major version in autumn" or so...

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...