Jump to content

Kerbal Space Program 1.11: "Some Reassembly Required" Grand Discussion Thread


Recommended Posts

On 2/17/2021 at 5:55 AM, MDPKH said:

The Place Anywhere 1 Linear RCS Port has a bug. It generates thrust in the wrong direction.

See this test craft: RCS Test.craft

12-rcs.jpeg

Note that all the RCS nozzles are pointing outwards, perpendicular to the vessel's longitudinal axis. They are also all set to "fore by throttle". With throttle at 100% and RCS on, this craft will lift off from the pad quite rapidly, because all those RCS ports actually generate thrust downwards instead of outwards, and activate accordingly. (With default placement, their thrust direction is upwards; I've rotated them in the test craft to more easily demonstrate the problem.)

Please fix this Squad! I am going to get KSP soon!

Edited by Dr. Kerbal
Eh. Lookz. I made a newz pagez.
Link to post
Share on other sites
17 minutes ago, Lisias said:

KSP 1.11.x broke irremediably (at least, under forum rules) TweakScale and probably every add'on that changes the value of the craft after launch (as add'ons that implement damages).

The IPartCostModifier interface is being ignored on recovering the craft, besides still being called on recovering the craft.

This is not an accident. The KSP Dev Team choose to fetch information from the PREFAB instead of using the value of the already called part's IPartCostModifier interface.

The full story is on TweakScale's thread and github.

Correct me if I am wrong, but this only affects recovered part costs. That is a far cry from "broke irremediably". I get it, you are upset, but hyperbole doesn't do anyone any good on getting the issue fixed.

Link to post
Share on other sites
33 minutes ago, MechBFP said:

Correct me if I am wrong, but this only affects recovered part costs. That is a far cry from "broke irremediably". I get it, you are upset, but hyperbole doesn't do anyone any good on getting the issue fixed.

This broke irremediably TweakScale on Career. You are now punished by using TweakScale by losing more Funds on recovery, instead of getting some back.

There's no way to fix TweakScale to cope with this, so it's irremediable for TweakScale (and any other add'on that changes the value of the part after launch) but I think I found a way to "exploit" Career again in a way to overcome the punishment.

TweakScale et all will still be broke on KSP 1.11.x, but perhaps I can counter-break them on KSP-Recall. What's not a fix, it will be a hell of a kludge - but it's what I think it can be done, as fixing the problem is beyound my reach if I want to keep TweakScale published on this Forum.

Everything, absolutely everything that does the right thing and uses IPartCostModifier should be being affected by this problem.

Edited by Lisias
And I'm not upset. I'm frustrated - again.
Link to post
Share on other sites
25 minutes ago, Lisias said:

This broke irremediably TweakScale on Career. You are now punished by using TweakScale by losing more Funds on recovery, instead of getting some back.

There's no way to fix TweakScale to cope with this, so it's irremediable for TweakScale (and any other add'on that changes the value of the part after launch) but I think I found a way to "exploit" Career again in a way to overcome the punishment.

TweakScale et all will still be broke on KSP 1.11.x, but perhaps I can counter-break them on KSP-Recall. What's not a fix, it will be a hell of a kludge - but it's what I think it can be done, as fixing the problem is beyound my reach if I want to keep TweakScale published on this Forum.

Everything, absolutely everything that does the right thing and uses IPartCostModifier should be being affected by this problem.

Well it is probably not going to get fixed without a post on the bug tracker.

Link to post
Share on other sites
36 minutes ago, MechBFP said:

Well it is probably not going to get fixed without a post on the bug tracker.

It's probably not going to be fixed on 1.11.x no matter what I do, so I will fix it myself the way I can.

Waiting for bug fixes after a x.y.1 version was issued is, historically, an exercise in futility - and I have users suffering from this problem NOW.

Link to post
Share on other sites
On 1/30/2021 at 2:21 AM, Richard Deckard said:

PERFECT!  Thanks @BeanThruster that worked perfectly.  I'll probably just write a script to return all of their gear since I'm definitely NOT flying missions out to all the planet, moons, asteroids, comets, and bases I have scattered around the system just to return their gear.  My save file is 15MB and I have way too many Kerbals to do by hand.  I'm assuming you got the "INVENTORY" tag data from another simple save file?

Thanks again!

Glad it worked out. Actually, I've got the inventory data from the same savefile. I've just sent a couple of kerbals I had in austronaut complex out on the launchpad and back, ensuring that they had their equipment.

Link to post
Share on other sites
15 hours ago, Lisias said:

It's probably not going to be fixed on 1.11.x no matter what I do, so I will fix it myself the way I can.

 

Dev vs Fan dedication to the game in a nutshell

Link to post
Share on other sites
6 hours ago, MechBFP said:

Ya, clearly that is the only difference in that comparison.

I want to point out that "dedication" is not the same as "professionalism" or even "intentions".

[Hired] Professionals have duties to fulfil, orders to carry on, schedules and goals to meet - they need to do what they are told to do, otherwise they risk losing the job.

I don't. ;)

Edited by Lisias
I'm a professional, damnit. I am just not hired here! =D =D
Link to post
Share on other sites
9 hours ago, MechBFP said:
18 hours ago, Bej Kerman said:

Dev vs Fan dedication to the game in a nutshell

Ya, clearly that is the only difference in that comparison.

Besides that, the fans have a lot less money to spend than Squad.

Link to post
Share on other sites

I am sorry if i sound too whiny but i tried so much to enjoy all this awesome free content we got but...

there are so many issues and bugs scattered all around the game that without using several mods and workarounds and even then...

I don't know...i do have countless hours so its not the only problem when i try to find some joy in the Kerbal universe.

For now i will wait, i want to play the game and yeah i wouldn't mind for a second to buy a new DLC.

Maybe that will help to get some more attention to squash all these annoying bugs that come up in almost every click...

Anyways again sorry for the negativity but i wanted to express how i feel about the state of the game right now.

Edited by Boyster
Link to post
Share on other sites

After trying out 1.11 for a couple of hours, I went back to my stable and for me perfectly fine working 1.10.1 installation (for the fuel transfer bug in 1.10.x, there are good established workarounds), maybe that's an option for you too?

Link to post
Share on other sites
17 minutes ago, VoidSquid said:

After trying out 1.11 for a couple of hours, I went back to my stable and for me perfectly fine working 1.10.1 installation (for the fuel transfer bug in 1.10.x, there are good established workarounds), maybe that's an option for you too?

That version was super solid but i am having a really hard time rolling back after i got a taste of the new construction/repairing stuff...

I never really delved into KIS/KAS so when we got this stock version of them i got so excited, i doubt i can ignore it.

Ofcourse if you using KIS/KAS then its like cherry on the top and not a deal breaker, at least thats how i see it.

Edited by Boyster
Link to post
Share on other sites

I see, a quite unfortunate situation for you then. For my own part, I never felt a big need to seriously engage in robotics as well as EVA construction, hence going back to 1.10.1 wasn't any loss at all for me.

Guess you'll have to wait then until the bugs hopefully get fixed soon. Or try out KAS/KIS, it might not offer everything 1.11 should, but it works.

Edited by VoidSquid
Link to post
Share on other sites
  • 2 weeks later...

1.11.2 introduces more issues than it supposedly resolves.

EVA construction is totally hosed, building out or removing parts on a craft is hopeless, explosions or a kerbal spinning off into darkness doesnt bode well ...

 

going to have to await the next iteration.

Link to post
Share on other sites
On 3/24/2021 at 11:59 AM, RW-1 said:

1.11.2 introduces more issues than it supposedly resolves.

EVA construction is totally hosed, building out or removing parts on a craft is hopeless, explosions or a kerbal spinning off into darkness doesnt bode well ...

 

going to have to await the next iteration.

It depends. Are you running any mods? I just upgraded from v11.0 to v11.2 and EVA construction works fine as in adding or removing parts from the active vessel.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...