Jump to content

Kerbal Space Program 1.11: "Some Reassembly Required" Grand Discussion Thread


Recommended Posts

6 minutes ago, Delbrutis said:

Well I will be looking into making a MM patch to move the Jet packs to a higher tech level. Early career mode EVA should be more challenging. Might move the small handlebar ladder down on tech tree so Jeb has something to hold on.  "Wont that be fun ":D   

Not a bad idea at all, my dude. (Please make this into a mod!)

Link to post
Share on other sites
1 hour ago, fourfa said:

Nope, I’m quite happy to have two slots. It will speed up establishing deployed science stations when they need to be out of right-click range of the ship. 

Have you tried this yet or is it just theoretical? Because the deployable parts all have too much mass to carry more than one of them at a time.

Link to post
Share on other sites
29 minutes ago, quazarz said:

Have you tried this yet or is it just theoretical? Because the deployable parts all have too much mass to carry more than one of them at a time.

Yep, you're right - can't be done.  My bad.

Link to post
Share on other sites

I wish unoccupied seats were an inventory slot. Or 3. :D

Load a Kerbal into a ship as an inventory item, and load their two inventory things in as the other 2 items. Or replace those things with all items and bam extra inventory.

I mean I toss the groceries on the passenger seat all the time.

Link to post
Share on other sites
39 minutes ago, Superfluous J said:

I wish unoccupied seats were an inventory slot.

+1.
And beds when nobody is sleeping.

39 minutes ago, Superfluous J said:

Load a Kerbal into a ship as an inventory item, and load their two inventory things in as the other 2 items.

+1

So, we can have Tourists of first class (one per seat, and in-flight drinks) and of economy class (3 per 2 chair, one of them perpendicularily).

***

Maybe a capsule should have a pre-start option: "pax only" (all seats and few cargo), "pax and cargo" (two seats disappear, inventory grows).

Edited by kerbiloid
Link to post
Share on other sites
2 hours ago, ridik58 said:

Hello

Sorry but I don't speak English very well.
I have a problem with the "EVA science experiment kit". how I can do an EVA experiment in flight

thank you in advance

It must be done by a Scientist. Have the EVA Science Experiment in inventory, along with a jetpack (assuming you are in flight & not landed). EVA and let go of the ship - it won't work if grabbing a ladder. Right-click the scientist and select "perform EVA science" (I think that's the right wording - don't have it in front of me right now).

Link to post
Share on other sites
7 hours ago, ridik58 said:

Hello

Sorry but I don't speak English very well.
I have a problem with the "EVA science experiment kit". how I can do an EVA experiment in flight

thank you in advance

Hi, and welcome to the forums! :D And don’t worry, your English is pretty good! Now, ad for the science experiment, @Bombaatu pretty much covered it. Cheers!

 

Link to post
Share on other sites

I use cranbe to build rocket on da Mun (no clean room there^^) and it looks like it turning on EVA VAB anywhere when grabing unit is conected end up later with tearing previously integrated pieces to tear apart when grabing is released. I realised it on orbit:

AD38FC85E5D2A180B498067A8F6BCEF08196B269

But only if they are disconected in wrong order :)

Edited by vv3k70r
Link to post
Share on other sites

Has anyone else noticed that stuff seems to get kinda stuck to the ground with this patch?

At first, I noticed that Kerbals didn't lift off immediately with EVA thrust, even on Minmus - it would take a good fraction of a second for them to leave the ground (and a waste of EVA propellant).  A tiny jump into the air beforehand speeds things up a lot, so I've been doing that for a few days.
Today I noticed that a craft I was testing on the pad at KSC didn't lift off its LT-2 struts in a "normal" (i.e. physical!) fashion when the damping was set to maximum. Instead of what I expected, which was that the feet would leave the ground while the legs were still compressed, the craft slowly lifted with the feet stuck down until the legs looked like they were fully extended, and then suddenly the craft "unstuck" and the acceleration leapt up (on the accelerometer reading) to what it should have been.
The two observations may be unrelated but I've not noticed either behaviour prior to 1.11...

Link to post
Share on other sites
15 hours ago, Neilski said:

The two observations may be unrelated but I've not noticed either behaviour prior to 1.11...

I haven't played this patch yet but this seem like a bad side effect of the more aggressive fix this patch had to reduce/stop sliding,

Is it very immersive breaking?

Edited by Boyster
Link to post
Share on other sites

Can we please get the undock option back for the actiongroups for dockingports? The remaining uncouple-option does not separate in space docked vehicles. Please give us the option back.

 

Alternatively: Fusion the both functionalities decouple and undock of dockingports into one function.

Edited by Rakete
Link to post
Share on other sites
On 12/20/2020 at 2:00 AM, Starhelperdude said:

I lik the update, but every time I place a flag at Vall it tips over ;.;

I"m having the same problem; and I can't place a standing worklight (on the Mun, at least). When I drop it, it's a foot or two off the ground; it drops to the ground, then tips over and falls flat, just like a flag. Deployed science packages do the same thing (minus the falling over): they appear 1 foot or so off the ground, then fall into place. 

Link to post
Share on other sites
10 hours ago, Boyster said:

I haven't played this patch yet but this seem like a bad side effect of the more aggressive fix this patch had to reduce/stop sliding,

Is it very immersive breaking?

Well, I'm still seeing sliding too :)

I wouldn't call either part of what I've observed particularly immersion-breaking but I'd be a bit concerned that whatever's going on under the hood (if they are linked) may have uglier consequences somewhere else.

Link to post
Share on other sites

One consequence of the tweak to mass around kerbals and jetpacks and anti-sliding boot glue: kerbals can only just barely fly on Duna now. Best to offload the parachute and get the EVA propellant quantity down first, then jump to defeat the sticky boots. Bring ladders - construction while hovering there is going to be difficult. 

Link to post
Share on other sites
On 12/21/2020 at 3:30 PM, Richard Deckard said:

I'm a purist, no mods just all the expansions and a long complex career mode.  With flights on the way to pretty much every body, I just rendezvoused with a comet, sent my scientist to collect a sample and he's now floating away with no jet pack.  Why didn't you provide default equipment to existing flights? Any way to roll back to an older version on steam?

Im like you... except I do use visual mods - I mean, why not enjoy real world plume right?

in answer to your question though... oversight. You might be able to rendezvous with the kerbal using the ship you got him there with, and get close enough to switch to the scientist and hit grab. Would be hella frustrating though lol

Link to post
Share on other sites
4 hours ago, Bizz Keryear said:

Is it already known that the lights forget their colors at random?

90% of the time when I go back to a ship or launch one where I have assigned a color to a light that is then gone. 10% of the time the game remembers.

Yes, it's a known bug.

Link to post
Share on other sites
17 hours ago, ridik58 said:

@Bombaatu 

Hello so I tried several ways but always the same result. thanks a lot for the help. PS: it's written (Impossible to carry out a scientific experiment in EVA)

 

Ah - I misunderstood the question, then. Atmospheric flight is not a valid situation for that experiment; you need to be in orbit or landed. Are you able to run them under those conditions?

Edited by Bombaatu
Link to post
Share on other sites

Great patch, couple small problems, well one pretty major and one small problem.

  1. The field construction stuff needs a lot of work. You grab a part from a ship and the whole thing goes flying off into space or just explodes. I have a rover that I put parts on temporarily to transport them, now I can't detach any of them, if I try I get rover RUD.  Also when you are in space floating around and you try to adjust something parts of it lock in place and parts continue to move so it's nearly impossible to adjust the position. When you click the widget to adjust it the whole screen should freeze in place.

2. The lights don't keep the color settings.

On 12/20/2020 at 4:00 AM, Starhelperdude said:

I lik the update, but every time I place a flag at Vall it tips over ;.;

yeah, I am having the same issue

Edited by Nuggzy
Link to post
Share on other sites
On 12/27/2020 at 12:10 AM, Nuggzy said:

Great patch, couple small problems, well one pretty major and one small problem.

  1. The field construction stuff needs a lot of work. You grab a part from a ship and the whole thing goes flying off into space or just explodes. I have a rover that I put parts on temporarily to transport them, now I can't detach any of them, if I try I get rover RUD.  Also when you are in space floating around and you try to adjust something parts of it lock in place and parts continue to move so it's nearly impossible to adjust the position. When you click the widget to adjust it the whole screen should freeze in place.

2. The lights don't keep the color settings.

yeah, I am having the same issue

And some more.

  • Kerbals on  a ladder accerlerate the vehicle in space. Change of orbit is the result. Makes repairs/field construction complicated/problematic https://bugs.kerbalspaceprogram.com/issues/26908 Please fix this, as it changes the precisely  chosen orbit of my lovely spacestation every time (yeah.... kinda mister Monk, if you know the tv series).
  • Hatches of the solarmodules (those with housing) are partially opened after every loading the vehicle (not in VAB/SPH, but in flight), (if they are retracted) - for me a real visual disturbance and a real immersion breaker (my beloved kerbals don't forget to close hatches properly and if hatches are halfway opened, things would boil inside during a hot ride from or to space).... PLEASE, PLEASE FIX THIS  IN 1.11.1  https://bugs.kerbalspaceprogram.com/issues/26879
  • The new lights don't remember their colorsetting and revert to white randomly, but very often.
  • Missing undock-option of dockingports in actionsgroups, so that i can't assign an action group to undock a vessel from a spacestation anymore (the remaining uncouple-option only sets parts free, which were connected to the port during construction!) This change was a mistake. Please revert this change. https://bugs.kerbalspaceprogram.com/issues/26887
  • And there are some mass issues on light physicless parts
  • Landinggear always lit up - another visual disturbance on me fleet of spaceplanes, as those lights even shine on through on retracted landing gear  https://bugs.kerbalspaceprogram.com/issues/26857

 

 

From my point of view these bugs are the most nasty / disturbing ones, that require a nice fix.

Edited by Rakete
Link to post
Share on other sites

Is there a way to transfer resources to/from parts that are in cargo?

On 12/17/2020 at 5:53 AM, UomoCapra said:

* EVA cylinder parts and Jetpacks are refilled when they are transferred back into a vessel from a kerbal.

This behavior breaks when kerbalEVA is patched to use a propellantResourceName other than "EVA Propellant". In some ways this is actually a good thing (we don't need the EVAfuel mod to stop the unlimited free magic refills of jetpack propellant) - but I don't see that it leaves any way to refuel jetpacks or extra canisters.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...