Jump to content

[1.12.x] Far Future Technologies - August 23: new engine!


Nertea
 Share

Recommended Posts

I'm trying to mess with the config for the nuclear smelter so I can add Deuterium and He3 as a recipe since I use Galileo's Planet Pack and Galaxies Unbound and I don't think they're properly configurated for those resources unlike stock (IE I get far less He3 on ceti than the mun or far less He3 on icarus than on moho). I can post the config modules I tried to add. 

Link to comment
Share on other sites

  • 2 weeks later...
  • 2 weeks later...
On 5/11/2021 at 3:48 AM, Apelsin said:

Boy, do I have good news for you lol - something I've been working on:

  Reveal hidden contents

bMeOuKT.pngyfUCRfJ.pngKEgBLkH.png

NFA Pr Eeloo for comparison. Note: stats are not finished.

There's still lots to work left to do but a pre-release is likely inbound within a couple of weeks :D

How's that "couple of weeks" treating you?

Link to comment
Share on other sites

4 hours ago, Angstinator said:

How's that "couple of weeks" treating you?

Haha yeah got sidetracked with other stuff but getting back into it now for final touch-ups, will try and get a release out before next week (after which I won't have as much free time). The scope got expanded a bit a while back so the mod has 4 engines and 5 fuel tanks.

Link to comment
Share on other sites

Little proposal for the next FFT release:

Make the Vulcan smelter drain Uranium from Nuclear fuel drums (not from engines!) (analogue to how IRSU drain Ore from storage containers), instead of having to refill the smelter over and over again, when producing fuels.

 

(why do I always think of fast fourier transformation, when I think of FFT :D)

Edited by Rakete
Link to comment
Share on other sites

@Nertea

I can't login to github somehow, that's why I post it here: I think I may have found a major issue:

I built a facility with antimatter production and a storage tank. (A-Cy1-25) But somehow it explodes at random (two times at arround 75% AM filling) with a big yellow overhearing glow, even if containment is enabled (and in case of the AM production facility also all cooling requirements are met.) Why does the station explode? The ingame description says, it only needs energy supply for containment, which is ensured by a big fat reactor, that's more than enough for this job (and also battery banks)... This happened during timewarp, to fill up the storages. Timewarp was several times stopped to refill the vulcan smelter of the production chain (uranium to pellets to antimatter) and reengaged. On the 7th or 8 refill the whole station blew up during reengaged timewarp, respectively on disengaging it again. By the way: Every cooling loop was at target temp when engaging timewarp.

Is this a bug, or have further containment requirements to be met, that are not mentioned ingame? Is there some kind of rounding issue during timewarp, that makes the station annihilate?

 

Here is also my logfile: https://www.filemail.com/d/inrygkbszalfrcg

 

Edit: After several tries nothing exploded in a yellow nasty heat glow. So I guess it's some kind of vulnerability against timewarp (rounding, truncation, stepsize?). The concerning station has several converters, every thing cooled correctly due to systemheat. All ran at the same time ; Uranium to fission pellets to anti matter - powered by a big fusion reactor. So missing energy or missing cooling of the converters was no issue.

 

 

 

Second Bug Report:

The bussard collector, does not collect, while vehicle is not focussed. (e.g. high timewarp in from tracking station). When focussed, than it collects.

 

Both tested on KSP 1.11.2

Edited by Rakete
Link to comment
Share on other sites

@Nertea

Added some more information on the speculative AM overheating/annihilation report above. (Sorry, that it's not in github. It does not let me in due to some nit working account verification issues). 

Edited by Rakete
Link to comment
Share on other sites

On 7/27/2021 at 4:31 AM, Apelsin said:

Haha yeah got sidetracked with other stuff but getting back into it now for final touch-ups, will try and get a release out before next week (after which I won't have as much free time). The scope got expanded a bit a while back so the mod has 4 engines and 5 fuel tanks.

Ah, scope bloat. Good luck with that!

Link to comment
Share on other sites

On 7/30/2021 at 10:51 AM, Rakete said:

The bussard collector, does not collect, while vehicle is not focussed. (e.g. high timewarp in from tracking station). When focussed, than it collects.

Version 0.4.2 of SpaceDust will resolve this (it was collecting, but at 1/10,000th of the focused rate ;) )

On 7/30/2021 at 10:51 AM, Rakete said:

I built a facility with antimatter production and a storage tank. (A-Cy1-25) But somehow it explodes at random (two times at arround 75% AM filling) with a big yellow overhearing glow, even if containment is enabled (and in case of the AM production facility also all cooling requirements are met.) Why does the station explode? The ingame description says, it only needs energy supply for containment, which is ensured by a big fat reactor, that's more than enough for this job (and also battery banks)... This happened during timewarp, to fill up the storages. Timewarp was several times stopped to refill the vulcan smelter of the production chain (uranium to pellets to antimatter) and reengaged. On the 7th or 8 refill the whole station blew up during reengaged timewarp, respectively on disengaging it again. By the way: Every cooling loop was at target temp when engaging timewarp.

I kinda need more than this. I tried to replicate this with this setup:

7zfg7iQ.png

Everything remained stable at all timewarps. If you can get more information on the actual case where it explodes i might be able to help more. 

Link to comment
Share on other sites

13 hours ago, Nertea said:

kinda need more than this.

Would a picture of the respective station help? It was considered as big refilling station for almost everything, that can generate many fuel types out of stored ore or enr. uranium. (it was some kind of big proof of concept in iirc. 500km (+- x) LKO for later deep space stations)

It consisted of 8 big nuclear fuel drums, four huge ore storage containers (SSPXr), one pellet storage for intermediate production products, one big De/He3-Tank. 

And the following cooling loops were implemented, which were not interconnected due to the heatexchanger interferring with the target temperatures like the coolant tanks (yeah you repaired it, but i am not on 1.12 yet).

One loop for the big fusion reactor with two expandable graphene radiators. Cooled to target temp.

One loop for Nova AM facillity (I think this one exploded) with 4 graphene expandable graphene radiators, cooled to target temp. Running in heavy elements mode all the time until explosion.

One loop for a IRSU cooled to target temp for resupplying docked classic vessels (cooled to target temp), but offline. 

One loop for the vulcan smelter, cooled to target-temp by 8 grey (HC) static fin radiators. Running on fission creation mode with cyclic leaving timewarp to refill the smelter and reengaging it.

And one loop for two bussard collectors harvesting some particles of kerbins AM cloud for testing/learning reasons. Also cooled to target temp.

One halo-solarpanel and some big batteries to ensure AM containment, even if the fusion reactor would be offline for maintenance (given that all converters and go offline)...

And the rest of the concerning station was just typical station parts from stock, SSPXr  like docking ports, some lights some, some controllroom for kerbals, little xenon tanks and four small VASIMIR-engines for orbital height corrections (which were offline).

 

The explosion happend during timewarp at once. No cumulative temperature rise was seen before. It just went "bang". everything normal, next frame all red, next frame all yellow and boom - whole station blown away. I don't know, if it happened during timewarp or on transition back to normal time. It happend several times and seemed a bit random, just like if you hit a doomed combination of current heat production, rejection (maybe solar exposure if this makes difference) and stepsize due to timewarp. As it was finally filled up with AM, i shut down the Nova facility and the vulcan smelter and it seems to be stable. The requirements for containment (60kW for the storage container and 2kW for the containment in the Nova itself should be more than met by the big fusion reactor on De/He3, which provides up to 20MW) :huh:

 

 

EDIT as i got back to my computer: Here is the respective safegame of  my Proof-of-concept-/debug-playground before I use new mod stuff in my main safe:

https://www.filemail.com/d/kvkrrduhtvdahhg

The explosive-happy station is the Cochrane-Facility (you know Zephram Cochrane, do you ? :cool: ) in LKO.

These mods are currently installed. I'll show them by zip-Archives so that you can see the version numbers of the packages:

  VX5osOm.jpg

Not more, not less. :D

KSP-Logfile: https://www.filemail.com/d/inrygkbszalfrcg

Basegame: KSP 1.11.2. I think, that's all the information I can deliver, exept from my meal during watching the unexpected explosions :cool::sticktongue:

Edited by Rakete
Link to comment
Share on other sites

Well I grabbed your save and spent 15 minutes turning things on/off, timewarping, etc... still couldn't do anything. Mind you I am running 1.12 and different versions of most of those mods (1.12 versions). So it's possible it was an artifact of something that was fixed in the 1.12 versions of DBS Space Dust, SH or FFT. I don't think this would be the case though, because most of the updates that were done there didn't change things related to this. 

Link to comment
Share on other sites

1 hour ago, Nertea said:

Well I grabbed your save and spent 15 minutes turning things on/off, timewarping, etc... still couldn't do anything. Mind you I am running 1.12 and different versions of most of those mods (1.12 versions). So it's possible it was an artifact of something that was fixed in the 1.12 versions of DBS Space Dust, SH or FFT. I don't think this would be the case though, because most of the updates that were done there didn't change things related to this. 

Thanks for your efforts. Maybe this is the case. Have you emptied the AM storages before, so that the Nova could run and produce heat? (Think the storages were unfortunately full in the save game) Anyway, I don't want to waste your precious time. Thanks for the effort. If someone else posts about exploding things you may pull out this save-file again, or if you want to test multi-loop builds - maybe it's nice to have some complex multiloop testrig ready on the hand.

Yeah, maybe it had to do with the oscillation thing, I that reported and you already fixed on the current version of system heat (maybe producing heat spikes on certain warp settings or something like this). I'll keep an eye on this, with the newer mod version when i upgrade to 1.12 (Oh squad, if they'd only fix those bugged wobbly drifting docking ports and broken engine sounds...). If it happens again then with 1.12 and the matching mod versions, I will provide a newer save and file a new report - or if someone else notices similar behavior, as I don't post this for my fun's sake, but to help.

Edited by Rakete
Link to comment
Share on other sites

On 8/1/2021 at 12:46 PM, Rakete said:

Thanks for your efforts. Maybe this is the case. Have you emptied the AM storages before, so that the Nova could run and produce heat? (Think the storages were unfortunately full in the save game) Anyway, I don't want to waste your precious time. Thanks for the effort. If someone else posts about exploding things you may pull out this save-file again, or if you want to test multi-loop builds - maybe it's nice to have some complex multiloop testrig ready on the hand.

Yeah, maybe it had to do with the oscillation thing, I that reported and you already fixed on the current version of system heat (maybe producing heat spikes on certain warp settings or something like this). I'll keep an eye on this, with the newer mod version when i upgrade to 1.12 (Oh squad, if they'd only fix those bugged wobbly drifting docking ports and broken engine sounds...). If it happens again then with 1.12 and the matching mod versions, I will provide a newer save and file a new report - or if someone else notices similar behavior, as I don't post this for my fun's sake, but to help.

Mmm so the only part that can produce 'real' KSP heat is the antimatter tank. it does that when it doesn't have any cooling (e.g. ship has no power). This can happen if DBS is not doing its compensation correctly or some power flow is not being detected correctly. This should be completely independent of SH. 

Also - just so you are aware, most if not all (maybe not restock) of my 1.12 mods are reverse compatible with 1.11.

Link to comment
Share on other sites

19 hours ago, Nertea said:

Also - just so you are aware, most if not all (maybe not restock) of my 1.12 mods are reverse compatible with 1.11.

So the new version of unity (i read of something like this?) that came with 1.12 does make no difference? Okay. Good to know. What happens to mod parts, that you updated targeted to 1.12 e.g. the circular dockingports in NFLV, NFC, etc? Will they work in 1.11.2 without crashing the game (just missing the rotation stuff?)... 

I thought your mods are compiled toward a certain target? Just for interest.

 

19 hours ago, Nertea said:

Mmm so the only part that can produce 'real' KSP heat is the antimatter tank. it does that when it doesn't have any cooling (e.g. ship has no power). This can happen if DBS is not doing its compensation correctly or some power flow is not being detected correctly. This should be completely independent of SH. 

Mhh... as nice as the interconnection between the mods are, I guess it turns debugging them into a nightmare for you. I really take my hat off to your efforts. (Is this a correct saying in english?).

Maybe it was some miscalculation of DBS as it kicks in during timewarp. This seems to be pausible. But with battery storages this big (sufficient for half an orbit without energy supply), i would not have expected this.

I tried yesterday again after draining the AM tanks. Couldn't reproduce it for half an hour, so i lost my bughunting mood, and went on.:D  Few days ago it exploded several times upon am tank filling by nova facility - same station, same save... It's kinda Schroedinger's explosion. It will detonate and will also not... KSP decides this upon try. ;):D I kinda reminds me of an iteration i did some years ago, that tended to refuse convergence under very special input values - it almost drove me nuts. Seemed to have had some singularities. In the end i had to exchange the whole algorithm... damn, was i frustrated... :D

Edited by Rakete
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...