Jump to content

[1.10.*] [KSP 1.9.0] MOAR [x] Science! - KSP Science report and checklist - BETA


Recommended Posts

1 hour ago, linuxgurugamer said:

How long did you wait?  For performance issues, it doesn't load immediately, I had to wait a little bit (seconds) before it loaded

There is always a small delay (1-2 seconds) before the window updates, but this isnt a question of loading time, I wait a minute and nothing changes. It doesnt load the completed science on the space center view at all on the first save loaded. If i go back to main menu and load another save, the completed science on the list is from the previous loaded save. The correct list is always restored once I fly a vessel.

1 hour ago, linuxgurugamer said:

I have to add a filter to block that.  ROC is special to Breaking Ground.

What did you do to get the ROC items to show?  I'm trying to replicate and can't.  If you could get me the save file, that would be helpful

It happens if I load a vessel with Breaking ground part (and also with Making history part). If I load a vessel without any dlc part it disappears. I cant reproduce it on the launch pad with the same vessel that produce the ROC in orbit.

One thing to note is that my save is years old and was created before the dlc, so I modified it in order to have the surface features appears by doing this:

2 hours ago, linuxgurugamer said:

How do you know they are unlocked?

The EVA experiment kit is unlocked in my tech tree, so it should list the EVA science experiment in the unlocked tab, but it doesnt. I try with a new save and it has the problem, the other science (science jr, etc.) works normally, they appear in unlocked as soon as the part is unlocked in the tech tree.

Link to post
Share on other sites
9 hours ago, kerbonaut23452345 said:

The new eva science from 1.11 appear only with the all filter, when they should appear in the unlocked experiment. I dont know if this is also the case for new saves.

I'm currently doing the work in 1.10.1, not 1.11.  See the thread subject.  It's good to know, and something I'll need to look at, but right now, I'm just working to get the same functionality in 1.10.1 as there was in earlier versions.

 

1 hour ago, kerbonaut23452345 said:

There is always a small delay (1-2 seconds) before the window updates, but this isnt a question of loading time, I wait a minute and nothing changes. It doesnt load the completed science on the space center view at all on the first save loaded. If i go back to main menu and load another save, the completed science on the list is from the previous loaded save. The correct list is always restored once I fly a vessel.

Have you done this same test using the older version, in a pre-1.11 install?

Link to post
Share on other sites
On 1/10/2021 at 2:53 PM, kerbonaut23452345 said:

The EVA experiment kit is unlocked in my tech tree, so it should list the EVA science experiment in the unlocked tab, but it doesnt. I try with a new save and it has the problem, the other science (science jr, etc.) works normally, they appear in unlocked as soon as the part is unlocked in the tech tree.

To follow up on this, I spent a few minutes looking into it.

If you look at the evaScienceKit, you will see that there is no ModuleScienceExperiment there.  EVA Science seems to be a special case, in that it's coded into the game and not in a config file.  Yes, you may need the EVA Experiments Kit, but that is just supplies, and does not do science on it's own.  It's listed in All Experiments since it does exists, but there is no part which makes it available.

I proved this by adding a ModuleScienceExperiment to the experiments kit part, and EVA Science then showed up as available.

evaScience DOES show up in the kerbalEVA.cfg files

 

Edit:  I think I know how to fix this, but won't do it until I have a 1.10 release, because the change requires new properties in 1.11 which don't exist in 1.10

Edited by linuxgurugamer
Link to post
Share on other sites

@linuxgurugamer Minor thing to note with x-science, toolbar controller gives the option to stick the buttons for it on the old blizzy toolbar, and seem to remove them from the stock toolbar, but I can't seem to actually add them to blizzy's they just literally don't show up as options to add. thought I'd mention it in case it was an oversight, but it might just be a bug on my end too. If it does work and it's just broken for me, sorry for bothering you. It's a minor issue and I can live with it either way. I just  like having a few key mods, including this type of mod on the non-stock one so it's always visible and I don't have to scroll for it.

Link to post
Share on other sites
3 hours ago, vardicd said:

@linuxgurugamer Minor thing to note with x-science, toolbar controller gives the option to stick the buttons for it on the old blizzy toolbar, and seem to remove them from the stock toolbar, but I can't seem to actually add them to blizzy's they just literally don't show up as options to add. thought I'd mention it in case it was an oversight, but it might just be a bug on my end too. If it does work and it's just broken for me, sorry for bothering you. It's a minor issue and I can live with it either way. I just  like having a few key mods, including this type of mod on the non-stock one so it's always visible and I don't have to scroll for it.

Thanks, I found the problem and working on it

 

Edit:  Fixed in next beta

Edited by linuxgurugamer
Link to post
Share on other sites
12 hours ago, linuxgurugamer said:

Thanks, I found the problem and working on it

 

Edit:  Fixed in next beta

Great, as a side note, I discovered if you set xscience to blizzy's or both through toolbar controller, and exit the game, when you restart the game, xscience becomes unresponsive and can not be opened. you have to set it back to stock toolbar, then uninstall and reinstall to get it working again. I assume this is caused by the same issue preventing it working with blizzy's toolbar, which you have fixed in the next release, but incase it's a separate issue, I thought I'd mention it just to be safe.

Link to post
Share on other sites

I just found about about the x Science mod, it's great to see that it's being resurrected and updated here! I was wondering if you could please make this available through CKAN?  I couldn't find it in the list, or the BETA in the repository so assuming it's not added on there yet? Cheers

Link to post
Share on other sites
1 hour ago, Kerb Your Enthusiasm said:

I just found about about the x Science mod, it's great to see that it's being resurrected and updated here! I was wondering if you could please make this available through CKAN?  I couldn't find it in the list, or the BETA in the repository so assuming it's not added on there yet? Cheers

You should read the thread before commenting.

The mod is in beta, currently targeted at 1.10.1 

When it's released, it will be in CKAN

I don't know what you were looking at, "BETA in the repository", you can get the latest from here:

https://github.com/linuxgurugamer/KSP-X-Science/releases

===========================================================================================================

New beta: 6.0.0.2

  • Fixed window not going away when clicking button 2nd time
  • Fixed buttons not showing up on the Blizzy toolbar
  • Added code to hide checklist window when game is paused
  • Fixed typo in "Suppress results window"
  • Updated .version file to only list 1.10.1 as compatible

Known Issue

  • Status window doesn't update sometimes

Note:  This is ONLY compatible with 1.10.1.  I will not address any issues which show up on 1.8 or 1.9, and am not yet ready to look at 1.11

Edited by linuxgurugamer
Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

not yet ready to look at 1.11

Quick note to put on the shelf:  If/when the time comes for that, ScienceAlert is better behaved under 1.11 so you may already have some solutions that xScience will need, e.g. EVA Report not showing up.

Link to post
Share on other sites
21 hours ago, OrbitalManeuvers said:

Quick note to put on the shelf:  If/when the time comes for that, ScienceAlert is better behaved under 1.11 so you may already have some solutions that xScience will need, e.g. EVA Report not showing up.

Umm, please be as specific as you can.

Link to post
Share on other sites

New beta, 6.0.0.3

  • Fixed Status window (Here & Now) update if it was opened more than a few seconds after checklist opening

Note:  This was a pre-existing bug which I was able to replicate.  The situation was immediately after opening the main (checklist) window, the status window was opened, occasionally it would not get a list of available experiments.  Hard to replicate on the older version, was fairly easy to replicate on my version.  This was a timing issue, possibly influenced by other installed mods. 

Beta available here:  https://github.com/linuxgurugamer/KSP-X-Science/releases

 

I would appreciate it if some tests were done using the DMagic experiments.  Please let me know either way, and the specific experiments that either worked or didn't work

Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

Umm, please be as specific as you can.

I'll keep a list of any more differences I see. The first was the EVA report which I see you've already addressed (I was away for a hot minute). I'll do some more side-by-side testing between xscience and sciencealert soon though.

Link to post
Share on other sites
1 hour ago, linuxgurugamer said:

I would appreciate it if some tests were done using the DMagic experiments.  Please let me know either way, and the specific experiments that either worked or didn't work

I believe correct answer would be "all of them".
DMagic experiments ignore clicking a button for running the experiment in the "here and now" window.
It has been that way in the previous versions and I tested it now in the 1.11. (I already have deleted my 1.10 installation for testing )

https://www.dropbox.com/s/v3quxe6cifqm04f/20210114-184606.124.mp4?dl=0

Link to post
Share on other sites
2 hours ago, flart said:

I believe correct answer would be "all of them".
DMagic experiments ignore clicking a button for running the experiment in the "here and now" window.
It has been that way in the previous versions and I tested it now in the 1.11. (I already have deleted my 1.10 installation for testing )

https://www.dropbox.com/s/v3quxe6cifqm04f/20210114-184606.124.mp4?dl=0

Ok, so as of now, the functionality that is in my version is the same as the previous version?  I'll look into the DMagic stuff next, followd by eventually work for 1.11

Link to post
Share on other sites

@linuxgurugamer So,  funny story, I have discovered a splashed at Kerbin's mountains biome, and xscience will show it as splashed down at mountains, but does not give the option to run any experiments. I'm not sure how that works, maybe it wasn't coded to recognize a splashed mountains as a science trigger, because to be fair, this is the first time I've ever stumbled onto this spot, and didn't know splashed mountain science was even possible. I just thought I'd report it, in case you know why, or want to change it, but It's probably a low priority, because I doubt I would have found this spot if I wasn't so OCD about getting 100% kerbin science. It's literally like 100 m square. I was flying over the lake at 260m/s and saw mechjeb's surface biome flicker for half a second, and couldn't believe my eyes,  thought I'd imagined it, and had to turn around to verify. I've been playing since KSP's early access first became available, and didn't think Kerbin could surprise me anymore. 

N5qZGP6.jpg

Link to post
Share on other sites
30 minutes ago, vardicd said:

@linuxgurugamer So,  funny story, I have discovered a splashed at Kerbin's mountains biome, and xscience will show it as splashed down at mountains, but does not give the option to run any experiments. I'm not sure how that works, maybe it wasn't coded to recognize a splashed mountains as a science trigger, because to be fair, this is the first time I've ever stumbled onto this spot, and didn't know splashed mountain science was even possible. I just thought I'd report it, in case you know why, or want to change it, but It's probably a low priority, because I doubt I would have found this spot if I wasn't so OCD about getting 100% kerbin science. It's literally like 100 m square. I was flying over the lake at 260m/s and saw mechjeb's surface biome flicker for half a second, and couldn't believe my eyes,  thought I'd imagined it, and had to turn around to verify. I've been playing since KSP's early access first became available, and didn't think Kerbin could surprise me anymore. 

N5qZGP6.jpg

Check your mod settings. There should be one to "Hide Difficult Science" or something similar.

Link to post
Share on other sites
3 minutes ago, Paaaad said:

Check your mod settings. There should be one to "Hide Difficult Science" or something similar.

oh, found it, didn't realize there were options there for that.

Link to post
Share on other sites

New BETA release, 6.0.0.4

  • Fixed DMagic experiments

https://github.com/linuxgurugamer/KSP-X-Science/releases/tag/6.0.0.4

Please test this, it worked on the experiments I tested, not sure if I got them all.  If you do find one not working, please be specific as to the non-working experiment

Link to post
Share on other sites

CKAN x-science, ksp 1.10.1, JNSQ.
"Here and now" doesn't show Island Airfield mini-biome experiments on the JNSQ, but after manual running, they are taken into account in the "x-science" window.
Also there is inconsistency in large biome name in the brackets — (Western Sea) in "Here and Now" window, and (Lowlands) in "x-science" window

Spoiler

rwc5rlU.jpeg

 

Edited by flart
Link to post
Share on other sites
2 hours ago, flart said:

CKAN x-science, ksp 1.10.1, JNSQ.
"Here and now" doesn't show Island Airfield mini-biome experiments on the JNSQ, but after manual running, they are taken into account in the "x-science" window.
Also there is inconsistency in large biome name in the brackets — (Western Sea) in "Here and Now" window, and (Lowlands) in "x-science" window

  Hide contents

 

 

Can you try the same with 1.8 and the previous maintainer's version?

Link to post
Share on other sites
11 hours ago, linuxgurugamer said:

Can you try the same with 1.8 and the previous maintainer's version?

I am talking about the last on the CKAN [x]-science v5.26. Are you asking to try the same on the v5.23 ?

UPD. xScienceContinued v5.26

Edited by flart
Link to post
Share on other sites
15 hours ago, flart said:

CKAN x-science, ksp 1.10.1, JNSQ.

Ummm, did you miss the fact that this was a beta, and NOT in CKAN?

I just updated the OP to make it very obvious that this is a beta, and not in CKAN.

Also, as posted in the previous thread (I just added this to the OP):

 

Link to post
Share on other sites
On 1/15/2021 at 8:23 AM, vardicd said:

So,  funny story, I have discovered a splashed at Kerbin's mountains biome, and xscience will show it as splashed down at mountains, but does not give the option to run any experiments.

On 1/15/2021 at 8:55 AM, Paaaad said:

Check your mod settings. There should be one to "Hide Difficult Science" or something similar.

On 1/15/2021 at 8:58 AM, vardicd said:

oh, found it, didn't realize there were options there for that.

@linuxgurugamer So I messed around with the settings options, and even with the option to filter difficult science flipped so it does show difficult science to get, xscience still does not seem to recognize splashed at highlands or splashed at mountains as biomes for science collection. I just got the building upgrade that allows me to get surface samples, and as I was flying around Kerbin collecting samples, I stopped at my splashed mountains and splashed Highlands markers, and was able to collect the samples there, but they never showed up in xscience, so, as far as I'm able to tell, it appears that xscience does have blinders for those two possible biomes.

https://www.dropbox.com/s/rxqkkum5vzp8zcm/Log for xscience.log?dl=0

here are screenshots from the splashed highlands area.

showing options, and available splashed experiments, filtered for [surface] samples:

UogJlBN.jpg

Collecting splashed sample, and showing that it does not count as a landed sample:

3Jfrylh.jpg

cOsfMVa.jpg

Edited by vardicd
Link to post
Share on other sites
4 hours ago, vardicd said:

@linuxgurugamer So I messed around with the settings options, and even with the option to filter difficult science flipped so it does show difficult science to get, xscience still does not seem to recognize splashed at highlands or splashed at mountains as biomes for science collection. I just got the building upgrade that allows me to get surface samples, and as I was flying around Kerbin collecting samples, I stopped at my splashed mountains and splashed Highlands markers, and was able to collect the samples there, but they never showed up in xscience, so, as far as I'm able to tell, it appears that xscience does have blinders for those two possible biomes.

So the real question is, does the previous version do the same thing?  

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...