Jump to content

[1.12.*] MOAR [x] Science! - KSP Science report and checklist


Recommended Posts

13 minutes ago, linuxgurugamer said:

It actually does, but in a limited way.  It doesn't interface with the TC at all, which is why the conflict.

 

A bug?  :-)

Please provide an exact sequence of steps which causes this (ie:  every button click, etc), will make it easier to find and fix

Yesterday: I installed this mod via CKAN, and dependencies were installed with it. Manually set the JC. Deleted all the mod cache files from the GameData folder, started the game. Everything. After the launch, the first CTB setup. Opened the TC menu, tried to disable the CTB mod buttons. But they don't switch off in any of the scenes. When you try to transfer buttons to a folder, they are simply duplicated in the folder, but are not transferred, except for the flight scene. You can transfer them there.

Today: Installed the KIS mod via CKAN. Cleared the GameData folder from the mod cache files(I always do this when I install a new mod). Launched the game. And then you know, an incomprehensible magic began immediately after loading the game when changing scenes and trying to move the buttons to a folder.

Link to comment
Share on other sites

7 hours ago, rebel-1 said:

Cleared the GameData folder from the mod cache files(I always do this when I install a new mod)

You shouldn't do that.  You are imposing additional load on the download sites, for no good purpose.    Each file has a checksum, CKAN will only install the correct one.

Link to comment
Share on other sites

6 minutes ago, linuxgurugamer said:

You shouldn't do that.  You are imposing additional load on the download sites, for no good purpose.    Each file has a checksum, CKAN will only install the correct one.

The number of mods has changed, and the game should index them again, I guess. So if I install a new mod, I delete the files "ModuleManager.ConfigCache", "ModuleManager.ConfigSHA", "ModuleManager.Physics" and "ModuleManager.TechTree" in the GameData folder. Although perhaps I am wrong, and it is not necessary to do this.

Link to comment
Share on other sites

35 minutes ago, rebel-1 said:

The number of mods has changed, and the game should index them again, I guess. So if I install a new mod, I delete the files "ModuleManager.ConfigCache", "ModuleManager.ConfigSHA", "ModuleManager.Physics" and "ModuleManager.TechTree" in the GameData folder. Although perhaps I am wrong, and it is not necessary to do this.

Those are ok to delete, I thought you were deleting the downloaded files.

Link to comment
Share on other sites

On 4/25/2021 at 11:25 PM, linuxgurugamer said:

so, any problems with this?

just that the bathymetry science is not recognizing it has been done. I can get the science first time fine. But every other time I am in the water it shows that it is not done. But when I run the science it shows zero science to collect.

Link to comment
Share on other sites

2 hours ago, IanCanberra said:

just that the bathymetry science is not recognizing it has been done. I can get the science first time fine. But every other time I am in the water it shows that it is not done. But when I run the science it shows zero science to collect.

Is it that THIS mod doesn't recognize the bathymetry, or that the bathymetry experiment itself isn't working?

Link to comment
Share on other sites

On 5/3/2021 at 6:24 AM, IanCanberra said:

just that the bathymetry science is not recognizing it has been done. I can get the science first time fine. But every other time I am in the water it shows that it is not done. But when I run the science it shows zero science to collect.

If I don't get any info, I can't do anything

Is it that THIS mod doesn't recognize the bathymetry, or that the bathymetry experiment itself isn't working?

Link to comment
Share on other sites

It reckonises the bathymetry but shows it always as still to be done. When you actually run the experiment it shows zero to be collected after you run it the first time.

Will get some logs up if you want. It only happens when you have it in splashdown and you only do it once.

So I would not worry about it but just note in case other items do the same is all.

Keep up the brilliant work

Link to comment
Share on other sites

I'm seeing similar behavior with experiments that use `DMModuleScienceAnimateGeneric` Triggering the experiment through [X] Science's Here & Now (H&N) window doesn't collect any science -- the experiment result window is displayed but no actual science is collected. Experiments with a limited number of repeats (e.g., some of Bluedog's cameras) are rendered entirely non-functional if triggered through H&N.

Link to logs and a test part that only requires stock and ModuleManager -- it's a cloned goo experiment with the stock modules replaced by DMModuleScienceAnimateGeneric. Other parts using the same module behave similarly. To  replicate start a new science or career game, launch a craft with the attached test part, and run the experiment via H&N. When recovering the craft you'll notice that no actual science has been collected and, if launching another craft with the same experiment, the experiment is repeatable in the same scenario. The experiment will run normally through the right click menu but, once it's been triggered through H&N, that instance of the experiment is no longer functional.

Let me know if you need any clarification, or further testing/info.

Link to comment
Share on other sites

  • 2 weeks later...
Posted (edited)
On 5/8/2021 at 7:00 PM, somnambulist said:

I'm seeing similar behavior with experiments that use `DMModuleScienceAnimateGeneric` Triggering the experiment through [X] Science's Here & Now (H&N) window doesn't collect any science -- the experiment result window is displayed but no actual science is collected. Experiments with a limited number of repeats (e.g., some of Bluedog's cameras) are rendered entirely non-functional if triggered through H&N.

Link to logs and a test part that only requires stock and ModuleManager -- it's a cloned goo experiment with the stock modules replaced by DMModuleScienceAnimateGeneric. Other parts using the same module behave similarly. To  replicate start a new science or career game, launch a craft with the attached test part, and run the experiment via H&N. When recovering the craft you'll notice that no actual science has been collected and, if launching another craft with the same experiment, the experiment is repeatable in the same scenario. The experiment will run normally through the right click menu but, once it's been triggered through H&N, that instance of the experiment is no longer functional.

Let me know if you need any clarification, or further testing/info.

This sounds similar to an age-old problem related to the Universal Storage/US2 science parts that utilize the 'DMModuleScienceAnimateGeneric' and activating those parts via the [X] Science! mod. If you trigger the parts using using Here&Now window, then they become completely unusable after the first instance. You can still trigger them directly from the PAW.

I seem to remember (don't quote me) it has to do more with the DMagic side than the parts themselves or the [X] Science! interface. Unfortunately, it's just one of those cross-mod incompatibilities that doesn't have the urgency/impetus behind it.

Edited by scottadges
Link to comment
Share on other sites

15 hours ago, scottadges said:

 If you trigger the parts using using Here&Now window, then they become completely unusable after the first instance. You can still trigger them directly from the PAW.

Similar but at least in my game experiments with a limited number of repeats can't even be triggered via the paw after you try using Here & Now. That said I should check if it also breaks the paw for unlimited-repeat experiments. 

Linuxgurugamer I know you're super busy but, when you look at this problem, would it also be possible to tweak Here & Now to ignore dmagic experiments that have had their run limits exhausted? As it is now Here & Now will list an experiment that's had its runs exhausted as runnable.

Link to comment
Share on other sites

25 minutes ago, somnambulist said:

can't even be triggered via the paw after you try using Here & Now

That's a good clarification. Yes, after you've used Here&Now on the experiment in question, I don't believe it can't be triggered again in the PAW *after* you've run it in H&N in that first instance. But, if you never use H&N to trigger said experiment, it will continue to work as per usual. Appreciate your point there.

Link to comment
Share on other sites

On 5/8/2021 at 9:29 AM, IanCanberra said:

It reckonises the bathymetry but shows it always as still to be done. When you actually run the experiment it shows zero to be collected after you run it the first time.

Will get some logs up if you want. It only happens when you have it in splashdown and you only do it once.

So I would not worry about it but just note in case other items do the same is all.

Keep up the brilliant work

As I recall, The Bathymetry science changes the biome to Water Shallow and Water Deep, similar to the way the Reconnaissance Telescope's do Northern and Southern hemispheres, this doesn't play well with Hear and now, and also the Archives in the stock game.

not sure if anything can be tweaked with H&N to support / ignore these science results.

Link to comment
Share on other sites

  • 1 month later...
12 hours ago, stoiansl said:

Hello with current version from CKAN and game update 1.12 KSP is not loading just stuck on loading screen

https://www.dropbox.com/s/ciuem8hw0lumtvq/KSP.log?dl=0

Welcome to the forums.

Note that, according to the OP, this mod is in beta and is not available on CKAN for 1.12 so you may have installed an incompatible mod.  The last version of this mod available through CKAN is for  KSP 1.9.

There is no evidence in your log that this mod is causing your problem.  What other mods have you installed?  Do you have all of this mod's dependencies installed (see the OP)?  If yes, I would suggest starting with a clean 1.12 install and ensure it runs successfully.  Then, add just this mod (from the GitHub repo, see the OP) and the 3 dependencies, and see if you encounter the error again.

Report back here on your success.  Others will be interested.

Lastly, check out this topic on how to report problems.

 

Edited by Brigadier
Added welcome.
Link to comment
Share on other sites

Does this recognice the new launch sites? Stil using the old one since it works for me. Only the new launch sites are not detected by the "here and now" window.

Link to comment
Share on other sites

Posted (edited)
11 hours ago, maculator said:

Does this recognice the new launch sites? Stil using the old one since it works for me. Only the new launch sites are not detected by the "here and now" window.

Not at present.  One of the reasons it's still in beta, I haven't had time to get to it 

Edited by linuxgurugamer
Link to comment
Share on other sites

Thanks for working on this.  You trying to get this working for the latest version (since it's in beta) which is now 1.12.1.3142 ?  That would be awesome.  I look forward to the release, and may try the beta soon here in a bit and let you know how it goes.

Cheers!

Edited by alekhinefan0
adding latest version number to be specific.
Link to comment
Share on other sites

20 minutes ago, alekhinefan0 said:

Thanks for working on this.  You trying to get this working for the latest version (since it's in beta) which is now 1.12.1.3142 ?  That would be awesome.  I look forward to the release, and may try the beta soon here in a bit and let you know how it goes.

Cheers!

It should work already

Link to comment
Share on other sites

Suggestion:

Join the two buttons into a single button. We can access one function or another by clicking with the right / left mouse button.
My toolbar is already too full!
Hahahaha
Thanks!

Link to comment
Share on other sites

2 hours ago, Dominiquini said:

Join the two buttons into a single button. We can access one function or another by clicking with the right / left mouse button.

It's already there, check settings

Link to comment
Share on other sites

Suggestion:

In the windows that this mod provides in the TrackingStation, that inform the resources each vessel contains, start to show also the amount of science that the labs have already converted!

Thanks.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...