Jump to content
  • 0

Crash game inverted fuel tank after undo


Question

Fresh install, unmodded, new sandbox game, version 1.11.0.3045 (WindowsPlayer x64) en-us / 1.6.0 Breaking Ground.

Game crashes instantly after the following occurs while within either the VAB or the SPH:
- New vehicle.
- Select Mk1 Command Pod to place it as origin component.
- Attach a TD-12 Decoupler to the bottom node of the pod.
- Attach a C7 Brand Adapter - 2.5m to 1.25m fuel tank in default orientation to the bottom node of the decoupler.
- Click on the placed fuel tank to "hold" it.
- Press Ctrl-Z to replace the fuel tank.
- Flip the held fuel tank upside down by tapping the W key twice.
- Place the held fuel tank on the bottom node of the replaced fuel tank.

This has also occured with the Kerbodyne ADTP-2-3 fuel tank. I have not tried every fuel tank, nor every game mode besides sandbox.

Link to post
Share on other sites

4 answers to this question

Recommended Posts

  • 0

Hello and welcome to the forum!

Same setup here, but with Making History instead of Braking Ground.

I've reproduced the issue. Although my game won't crash, it throws a Stack Overflow Exception. Flipping the tank is not necessary, and it also happens with other tanks and structural parts. Have you considered filing a bug report?

Link to post
Share on other sites
  • 0
On 1/13/2021 at 5:32 AM, Chemp said:

Hello and welcome to the forum!

Same setup here, but with Making History instead of Braking Ground.

I've reproduced the issue. Although my game won't crash, it throws a Stack Overflow Exception. Flipping the tank is not necessary, and it also happens with other tanks and structural parts. Have you considered filing a bug report?

Thank you Chemp for your response. I did not respond here right away because I was led to believe that this forum was where bugs were to be reported. Thank you for the helpful link, although once I read through the "ksp bug tracker wiki" I could not find an actual location to submit the report. Lots of useful formatting information, but no actual "submit bug here" info (unless I have missed it, in which case I apologize). Can you please expand on where to submit a bug report? Otherwise, I am glad that someone could re-produce this bug to prove that it needs fixing.

Link to post
Share on other sites
  • 0
On 1/21/2021 at 2:12 AM, Christopher MR said:

Can you please expand on where to submit a bug report?

You'll need to create an account on the site. Once logged in, a "New issue" button appears in the "Issues" header.

uAQ2g2p.png

I did see a similar issue once but that appeared to be constrained to BG parts. The stacktrace closely mirrored another report I read here in the past days, crashing in the Engineer's Report checks.

Edit: the KSP issues don't seem to be directly linked from the start page. I usually click through the Jump to a project/All projects/KSP/Issues path on the top right to get to https://bugs.kerbalspaceprogram.com/projects/ksp/issues

Edit2: I haven't yet reproduced the problem but I didn't really try, either

Edited by HansAcker
Link to post
Share on other sites
  • 0
On 1/21/2021 at 6:02 PM, HansAcker said:

You'll need to create an account on the site. Once logged in, a "New issue" button appears in the "Issues" header.

uAQ2g2p.png

I did see a similar issue once but that appeared to be constrained to BG parts. The stacktrace closely mirrored another report I read here in the past days, crashing in the Engineer's Report checks.

Edit: the KSP issues don't seem to be directly linked from the start page. I usually click through the Jump to a project/All projects/KSP/Issues path on the top right to get to https://bugs.kerbalspaceprogram.com/projects/ksp/issues

Edit2: I haven't yet reproduced the problem but I didn't really try, either

Thank you for your response HansAcker. I have successfully submitted the bug report, issue #27128. Thanks again for your help.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...