Jump to content
  • 0

Normal KSP behavior or faulty hardware?


Question

The last couple of days KSP started locking up or occasionally crashing, and I wondered if others have experienced  similar behavior.   It does the same thing with or without mods, so posting here.

I have 131 flights in progress, with a 'cluster' of 15 vessels  en-route to Jool, so they are on broadly similar trajectories, but still a long way apart.  When doing mid way maneuvers I select a vessel, place a maneuver node, focus on Jool and fine tune it, and perform the burn.  Then whatever method I use to select the next vessel the game gets 'stuck' and won't progress to either the new vessel  or Tracking  Station, forcing me to close it, or on occasion  the game crashes.  The PC itself doesn't seem to be affected, just the running KSP.

Could it be due to having a lot of active flights,  or a 'group' on similar trajectories giving it too much to work out?  Which doesn't feel right somehow, but seems possible.  Or, my 'gut feeling' is it may be  my GPU starting  to play up (4 to 5 year old  GTX 950), as it has recently started to lose connection to my second monitor during start up, but is then fine after a restart.

I have not had a save this busy, before so wondered if it's 'normal' or even 'common' and I need to be less ambitious, or whether I should look at replacing the GPU, which I'm ok with if it's needed, but I'd rather not as I was planning on a new machine in a year or two anyway.  I  updated the driver, but to no effect.

Any thoughts?

Edited by pandaman
Link to post
Share on other sites

3 answers to this question

Recommended Posts

  • 0

I'm running a 1.10.1 career with about 100 mods, and have 150 vessels in space, including a little fleet of about 15 en route to Jool. No such lockup, though it does take a minute or two to switch from one vessel to another. GTX 970 here, not that much difference.

If you switch and have that lockup, does the music still play? If yes, I'd point my fingers to the graphics card too.

Edited by VoidSquid
Link to post
Share on other sites
  • 0
52 minutes ago, pandaman said:

The last couple of days KSP started locking up or occasionally crashing,

No userland software should normally be able to cause a lockup.

In 99% of the cases it's either a driver issue or hardware.

Or something as easy as clogged up fans and/or heatsinks (esp if there's a cat in the house ...)

Link to post
Share on other sites
  • 0

Thanks for your help...

1 hour ago, VoidSquid said:

If you switch and have that lockup, does the music still play? If yes, I'd point my fingers to the graphics card too.

Yes background sounds still happen.  It feels like 'if I wait just a bit longer' it will work, but it doesn't (I tried that too).

50 minutes ago, Curveball Anders said:

something as easy as clogged up fans and/or heatsinks (esp if there's a cat in the house ...)

No pets, or kids at home, to blame, the fans etc. look clear, and no sign or 'vibes' of overheating.

Given it's age and what it's doing I'm reasonably confident a new GPU is probably the way to go.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...