Jump to content

Recommended Posts

Just did some orbital construction. My Kerbal didn't cause the ship to move while on the ladder, and I was able to move parts from one ship to another with ease, and with no phantom forces.

FANTASTIC. Thanks, Squad!

(Now can we get an in-flight re-root tool so I can remove that docking port that became the root part when I undocked it from the station?)

Link to post
Share on other sites

Now we can gather 5 000 assistants at once and build Great Pyramids by hands?!

A Kerbal-powered engine to build galleys with Kerbals chained to the oars is just required now!

P.S.
And a whip for the Engineer to rule them all.

Edited by kerbiloid
Link to post
Share on other sites
7 hours ago, Anth12 said:

@Shalfarincrease spring strength until the sliding stops.

Its something to do with the springs not engaging because of the lighter gravity.

@Anth12Thank you, that did it.  I should have realized since I know I have to do it with the landing legs.

Link to post
Share on other sites

A friend bought me the expansions, I should have said "No Thanks."
I was going to come here and rant about how mod makers writing expansions was a bad idea. That they would, like all their mods, either not work properly or break the game.

Some of the bugs I took in my stride. The latest one is a step too far.
I built a ship carrying 3 com sats end to end and sent it to the Mun.  Put it in a Hi-Lo polar orbit and selected a small decoupler and told it to decouple the first sat.
But it was broken. If I warped after the decouple the front sat simply vanished. An error in the Console says something about a NaN orbit.

If I switched to the detached ship instead of using warp, it moves away from the carrier and then just seems to sit above the Mun with no orbital information. The Console is spammed with errors.

I hoped that this new patch would allow me to continue my mission, but no, It's broken.

I didn't even use anything from the expansions (MODS) to create the ship. You have simply broken the base game.

I am not using any mods apart from the two expansion packs.

The worst part is that, just like the mods you lot have written, it will never properly work as it should again. Something will always be gamebrakingly broken about it. I'm an idiot because I KNEW what the result of installing them would be and went ahead and did it anyway.

Some good came of it though. I only installed Linux because of this game. Linux is now my main and preferred OS because of this game.

https://www.dropbox.com/s/2421jm5cu305rrr/quicksave.sfs?dl=0

 

D.

 

 

 

Link to post
Share on other sites
29 minutes ago, Daveroski said:

mod makers writing expansions

What? Modders didn't make the DLCs. They're official and made by SQUAD.

Either that or you're confusing DLCs with mods. 

Link to post
Share on other sites
19 hours ago, UomoCapra said:

Hello Kerbonauts! 

Kerbal Space Program 1.11.1 is live! 

...

Dang but that is an awesome changelist!  Well done guys!

Link to post
Share on other sites
7 minutes ago, MechBFP said:

Could this be the beginning of the return to the golden age of 1.3? We shall soon see!

For a few players KSP 1.3.1 is still the version of choice. (things like joystick support for Linux etc)

So maybe rather the end of the golden age of 1.3? One can but hope.

Link to post
Share on other sites
1 minute ago, Dafni said:

For a few players KSP 1.3.1 is still the version of choice. (things like joystick support for Linux etc)

I'm not a Linux player but I seem to remember joystick support for it being fixed a couple versions back. Correct me if I'm wrong.

Link to post
Share on other sites
1 hour ago, Rakete said:

So no fix for the partially opened hatches of the 1x6 and 3x2 solarpanels? Or did I overlook them?!  This bug really bothered me visually.

Okay, i checked... the hatches are still halfway opened.

https://bugs.kerbalspaceprogram.com/issues/26879 is not fixed, not even looked at. Why not? Fixing these kind of visual anoyances is more important, than introducing lighthousings in white. Sorry, but this visual bug really bothers me. Sorry to say so.

Edited by Rakete
Link to post
Share on other sites
6 minutes ago, RealKerbal3x said:

I'm not a Linux player but I seem to remember joystick support for it being fixed a couple versions back. Correct me if I'm wrong.

You are correct indeed. Somewhat fixed I would say. It was broken for a very long time though. Other inacceptable bugs got introduced too.

As for joysticks, multiple input devices still dont work properly on KSP, even on Windows. The mod AFBW is still a must for any serious joystick user IMO. KSP just labels the buttons in a numeric way, with no correlation to input device, leading to conflicts.

Obviously we all love the game, and a bugfix only release is what the community has been asking for since 1.0. Lets see if we are on the right way. Time will tell. It's nice that 1.11 got the hotifx now and is up for us to play around, history taught us to never mess with x.x.0 releases.

Link to post
Share on other sites
20 hours ago, UomoCapra said:

Hello Kerbonauts! 

Kerbal Space Program 1.11.1 is live! 

This patch includes a few improvements to the base game,  such as the ability to use multiple kerbals to assist engineers moving heavier parts in EVA Construction Mode. Additionally, the construction panel now shows the manipulation weight limit and the assistants count, which will be useful to embark in larger in-situ engineering projects, plus several other cool things - like a revamp to the MK1 and Mk2 spot lights. The patch is also packed with bugfixes, mostly related, but not exclusively,  to the 1.11 Some Reassembly Required update, among a handful of other neat surprises. 

Check out this patch's Changelog for further details:


=================================== v1.11.1 ============================================================
+++ Improvements
* Extend Science results UI delay for Dzhanibekov EVA experiment so player can see the effect better.
* Enable smaller SEQ parts to be usable in construction mode so they can be moved and adjusted. They cannot be stored inside inventry modules.
* A screen message will now appear when a non-engineer kerbal attempts to repair a part with the repair kit. Also, a Screen Message will also show if the repair kit amount was insufficient.
* Cargo parts filter now includes researched but not purchased parts, even allowing purchasing them from the filtered view.
* Added Thrust Limiter field to Kerbal Jetpacks so finer control is possible.
* Kerbals can now assist an Engineer in construction to move heavier parts.
* Construction panel now shows manipulation weight limit and assistants count.
* Reduce the wait time between dropping a part and when physics kicks in.
* Action group edit name button can now be accessed with arrows and axis inputs.
* Allow pickup of debris parts in EVA construction mode.
* Playing a science/sandbox game in which Kerbals are restricted to class traits but all probes have access to all SAS modes is now possible.

+++ Localization
* Numerous KSPedia fixes in multiple languages.
* Fix EVA Construction Mode KSPedia slide text overlap in Japanese.
* Fix Cargo Mode KSPedia slide title for Russian.
* Fix for a range of construction contract vessel names for all languages.
* Fix missing Japanese translation for Engine Stops Under in part description.
* Fix Spanish translation for vessel part requirements.
* Variable correction in spanish for Engineer on vessel requirement.

+++ Parts
* Place Anywhere 1 Linear RCS Port now has a shrouded variant.
* Revamped MK1 and Mk2 spot lights.
* Added new white variant for MK1 and MK2 spot lights.

+++ Bugfixes
* Fix background icon not appearing when first picking a part from inventory.
* Fix when detaching a part from a vessel keep it's orientation and don't reset it's orientation to the default position.
* Fixed some NREs when using menu navigation with directional arrows on the Action Groups panel.
* Fix waypoint marker for rover construction contracts disappearing.
* Fix orientations of parts in EVA construction mode including surface/detach and attachnode attach.
* Fixed issue causing parts to highlight red while cursor is on inventory PAWs.
* Fix UI in editor scene not showing that part autostruts are forced to grandparent when they are attached to dynamic nodes.
* Fixed bug causing weld animation to not play in some situations.
* Fix parts being anchored above the surface if lifted by robotics parts.
* Fix Editor getting stuck if you delete the root part when in cargo mode.
* Fix part stacking key from affecting all parts picked from the toolbox after its use.
* Fix Inventory part tooltip getting stuck when storing a part in the inventory from the Editor work area and immediately summoning it.
* Fix the editor cargo UI not scrolling when the mouse positionis in between slots.,
* Fix attaching parts in EVA construction mode within the range of a robot arm scanner.
* Fix AttachNodes not displaying when the root part of a vessel is outside the construction range, but the part is and shoudl be valid as an attachment.
* Fix partdatabase.cfg handling when running KSP from an alternate folder/location.
* Fix issues with parts that have trigger colliders when rotating/moving them in EVA construction mode.
* Fix deadline to include CB multiplier on vessel repair and construction contracts.
* Fix placed flags falling down.
* Fix extended tooltip not being updated on variant change for cargo part mass.
* Fix exploit that allowed to produce infinitely many stackable cargo parts using the stack logic.
* Fix for inventories for kerbals on command seats coming up twice in the Construction/Inventory UI in flight.
* Fix EVA kerbals on ladders generating phantom forces.
* Fix CoL marker positioning in EVA Construction/Flight Scene.
* Fix EVA construction losing detached parts and invalid highlighting when exiting EVA Construction with a detached part on the mouse.
* Fix Repair contracts not completing if they use the same craft as a previous contract of the same type in the same save game.
* Fixed an issue that locked up the game when kerbal tourists were passed out in command seats and the game was saved after landing.
* Fix satellite construction stock craft being created as debris, they will now be probes.
* Fix errors when using the rotate and move tool in EVA construction mode on wheels and landing legs.
* Fix EVA kerbals unable to use static ladders (Ladders on Launchpads and buildings, etc).
* Fix crew transfers out of a part does not update its PAW.
* Fix parts with variants in construction mode reverting back to the base variant when attached.
* Fix issue that occurs with Plant Flag being active during construction mode.
* Fix trajectory changes during rotation caused by MinRBMass being too high
* Fix error caused by symmetrical parts in KAL action set if parts get decoupled individually.
* Fix Jetpack andf EVACylinder refill only working with EVA Propellant.
* Fix Smoke FX on twin boar engine.
* Fix bug that caused individually dropped parts to slide on the ground.
* Fix Actions from Symmetry counterparts showing multiple times in the ActionGroup Editor.
* Fix an NRE and partial loss of VAB/SPH functionality occuring when selecting a Subassembly after placing the original part in any symmetry mode while the Save Subassembly window is open in the editors.
* Fix discarding merged craft throwing an NRE in Editors.
* Fix dropped parts being teleported to the ground when dropped in the air above the ground.
* Fix NRE when placing a part buried in the ground in EVA construction mode.
* Fix Placing wheels past the collider for the ground (half buried) will cause the craft to bounce uncontrollably during EVA construction mode.
* Fix Construction Mode Parts dropping causing immediately large physics effects on vessels.
* Fix parts during Eva Construction mode beingpicked up, dropped, or attached when a UI element is blocking the pointer. This was resulting in unwanted click-through.
* Fix Kerbals not falling off the bottom of the ladder when the Kerbal stop at the end of ladder option was set to false.
* Fix where activating the staging would fail if the vessel had no stage available and gained one after a new part was attached in EvaConstruction during flight.
* Fix kerbal jump force scaling to use their combined body mass and inventory mass and prevent death-inducing high jumps.
* Fix NRE that caused the game to lock up when a cargo container was the root part and it was re-rooted.
* Fix the deploy animation being played when taking a deployable part out of the inventory in the VAB/SPH.
* Fix the Communotron 88-88 appearing unbroken in satellite repair contracts.
* Fix Contract strings to clarify Base contract, Satellite Contract, Station Contract and Grand Tour contracts and specify that the new vessel must be built and launched complete (cannot be built in parts using EVA construction).
* Fix cargo parts being inconsistently rendered as 2D icons with no transparency when hovering the cursor over PAWs and Construction Panel.
* Fix selected cargo parts as icons getting stuck when hovering between cargo panel and a PAW inventory in the Editor Scene.
* Fix selected cargo parts during EVA Construction mode that were taken out from an inventory slot not being returned when closing the Construction mode while still holding them.
* Fix selected cargo part as a stack icon not blocking actions on other cargo part while holding the stack.
* Fix EVA kerbal occlusion inside fairings and cargo bays.
* Fix hatches being obstructed by the robotic arm range trigger, or it's front border.
* Fix lights playing their on/off animations when activating the "Turn Light On" and "Turn Light Off" action groups and the light was already in the target state.
* Fix shift-key bleed through to thrust the jetpack when placing or adjusting a part in construction mode.
* Fix out-of-context screen message when a part is attached to a dropped part in construction mode.
* Fix selecting color on lights placed in symmetry only affects one of the lights.
* Fix changing scenes resets light color.
* Fix lights reset to white after configuration.
* Fix light color doesn't persist on saved craft when the lights are Off.
* Fix lights emmisive textures do not update when adjusting RGB values with action groups or the KAL in flight mode.
* Fix the Clydesdale engine nozzle shining in the VAB.
* Fix attachment node size on SEQ-24 container.
* Fix node attach issue on Aerospike.
* Fix weld aim hitting the node instead of the attachment point when welding.
* Fix being unable to assign the Undock Action on Docking Ports. We have reverted the 1.11.0 fix in favor for a different solution in the future.

+++ Modding
* Allow reload of Tech Tree via static methods in any scene via cfg file reference or Database config nodes. LoadTechTree is now static.
* Ability to have Cargo parts be Construction-able. Note that ModuleCargoPart needs to be before ModuleInventoryPart for this to work.
* Added reinitResourcesOnStoreInVessel in moduleCargoPart and applied to Jetpack and EVAFuelCylinder. This flag controls whether the resources in the part will be reinitialized to full when the part is stored inside a vessels inventory modules.
* For parts using ModuleLight, the light turning on/off is controlled by code now, instead of using an animation.
* Fix setting light color via part cfg was being ignored.

=================================== Making History v1.11.1 ================================
+++ Bugfixes
* Fix the servicemodules shielding antennae on launch when the shrouds are turned off.
* Fix KAL being unselectable in action pane in the mission builder.
* Fix the missing Robotics icon category in the action pane.
* Fix surface attachment issues with the LV-Tx87 Bobcat.

=================================== Breaking Ground 1.6.1 ===================================
+++ Improvements
* Added screen message when dropping Deployed Science parts in EVA Construction mode to clarify how to deploy.

+++ Localization
* Added translation and fix for message that appears when repair kit quantity is not enough.

+++ Bugfixes
* Fix issue impeding Kerbal to fall after picking up ROC sample.

Tonight at 6PM EST EJ_SA will be hosting @JPLRepo and @Maxsimal on his stream! Tune in to take a look at the 1.11.1 patch and have some fun :cool:

Remember that you can help us find bugs/issues by reporting them into our bugtracker and that you can also upvote reports to make them more visible.

Happy launchings! :)

When is this coming to consoles? Can’t wait!

Link to post
Share on other sites
8 hours ago, Rakete said:

So no fix for the partially opened hatches of the 1x6 and 3x2 solarpanels? Or did I overlook them?!  This bug really bothered me visually.

No fixes for a lot of stuff. Important stuff, actually.

1.  Struts that were installed in eva construction disconnecting after scene reload? No fix. What is the point in orbital construction or construction in general when one of the first things people want to do is reinforce their ships and that doesn't work? Even the EVA Struts mod for KIS doesn't work for some reason. So you basically have nothing.
2.  Mk 1-3 capsule breaking the game when you leave the render range and come back? No fix. That would literally make a lot of missions impossible

3.  NAN spam in console and complete wreckage of the orbit after you decouple a craft with a cubic octagonal strut as a root part? Nope. Physicsless parts should receive physics when they are a root part. In 1.10 this works perfectly. In 1.11 - it doesn't. And people are confused because they don't understand why the game behaves differently on the same craft. 

4. Shift-clicking the container (which is basically all the parts with crew capacity now) to move the entire craft will make that craft disappear after you release it? NO! It's not like a majority of people does it on daily bases.

I could just go on and on, but my rant is long enough already and I only wanted to rant about more serious bugs.  1.11 still needs some work, but we will probably never see 1.11.2, the developers will just move to 1.12, which is going to release no earlier than summer. Until then you either have to play an older version or just pray to Jeb that you never see any of the above. Good lord. 

Edited by dok_377
Link to post
Share on other sites

One thing I have noticed since 1.11.1, which I don't believe happened in 1.11.0, is that now even my very basic probe cores have all the auto-pilot options enabled on the left side of the nav ball.

Now I already had that functionality with them because I have MechJeb installed; maybe this change is really just that the probe core is now smart enough to recognize that capability from Mechjeb and display it?

Link to post
Share on other sites
On 1/29/2021 at 9:42 PM, Superfluous J said:

Try turning off vsync and/or updating your graphics card drivers.

Its not that, this is like a known problem for a while now....i am sad to see this is still happening :( 

Multiple confirmed bug reports for this problem...

https://bugs.kerbalspaceprogram.com/projects/ksp/search?utf8=✓&scope=subprojects&issues=1&q=flickering

Most use scatterer mod to fix it but i don't use it Edit Anth12 solution seems to work just fine.

Edited by Boyster
Link to post
Share on other sites
22 hours ago, PocketBrotector said:

This is good news, as it makes it possible to use other resources such as Nitrogen for EVA propellant.

Ideally there’d be a way to disable “free refills” and instead transfer resources into parts in cargo. Then we’d even have conservation of mass!

There is a way to do the no free refills and I need to add the details to that original bug report now weve released. In short what we did was add a flag to the parts that should reinit their resources (as opposed to refill) when they are stored. the KSPField is reinitResourcesOnStoreInVessel in ModuleCargoPart and can be added/changed using cfg editing ofr MM Patching. Transferring into cargo parts is a nice idea - do you know if its in th etracker for feedback already? Id certainly upvote it

 

18 hours ago, Yellowburn10 said:

I actually had a thought the other day that it would be pretty neat if you could move heavier parts in EVA construction with the more kerbals you had in the vicinity, but somehow you guys read my mind! Is there a limit to how many kerbals can help? To see the equivalent of a large mass of kerbals carrying the recently detached wing of a large plane for reattachment would be pretty neat.

The limit is a range that can be found in the settings.cfg its called EVA_CONSTRUCTION_COMBINE_ENABLED and is in meters from the engineer

Link to post
Share on other sites
2 hours ago, chd said:

One thing I have noticed since 1.11.1, which I don't believe happened in 1.11.0, is that now even my very basic probe cores have all the auto-pilot options enabled on the left side of the nav ball.

Now I already had that functionality with them because I have MechJeb installed; maybe this change is really just that the probe core is now smart enough to recognize that capability from Mechjeb and display it?

Correction -- actually it looks like all those hold options are only present when warping. Go figure...

Link to post
Share on other sites
3 hours ago, chd said:

One thing I have noticed since 1.11.1, which I don't believe happened in 1.11.0, is that now even my very basic probe cores have all the auto-pilot options enabled on the left side of the nav ball

Indeed. In a new stock sandbox (no mods), the option "All SAS modes on all probes" appears to be ignored. It doesn't happen in a career save (the option is only available in sandbox):

Spoiler

UaO5H08.jpg
nlrrzeo.jpg

I haven't checked the bugtracker, yet. It didn't happen in 1.11.0. Not an important bug for me, tbh, just new.

Edited by HansAcker
Link to post
Share on other sites
1 hour ago, TriggerAu said:

There is a way to do the no free refills and I need to add the details to that original bug report now weve released. In short what we did was add a flag to the parts that should reinit their resources (as opposed to refill) when they are stored. the KSPField is reinitResourcesOnStoreInVessel in ModuleCargoPart and can be added/changed using cfg editing ofr MM Patching. Transferring into cargo parts is a nice idea - do you know if its in th etracker for feedback already? Id certainly upvote it

This is great! Looking forward to the documentation. 

I've added the "transfer into cargo" feature request on the bugtracker here (#27183). 

Link to post
Share on other sites
8 hours ago, Anth12 said:

@stephm

I put a fix in there

@Anth12

OK it's work thanks!  (merci !)

I re-post your solution to this problem:

SHADOWS_FLIGHT_PROJECTION = 1
SHADOWS_KSC_PROJECTION = 1
SHADOWS_TRACKING_PROJECTION = 1
SHADOWS_EDITORS_PROJECTION = 1
SHADOWS_MAIN_PROJECTION = 1
SHADOWS_DEFAULT_PROJECTION = 1

Steph.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...