Jump to content

[1.8.0-1.12.3] Kopernicus Stable branch (Last Updated August 12th, 2022)


R-T-B
 Share

Recommended Posts

14 minutes ago, OhioBob said:

Are you sure it's not just loading an outdated mesh from cache?  If you haven't already done so, delete the .bin files for the planet pack you are running.  These are typically in a cache folder inside the planet pack folder, or if not there, inside the Kopernicus folder.

That certainly improved it; had to find the cache in SigmaDimensions. However its still off:

8MUs4ZC.png

Link to comment
Share on other sites

Update on above, I found a pretty critical error in my textures so I'm redoing the whole thing anyway, so hopefully it works out better. Seems like the normal map may have been messing with this too. But the bigger problem is that Olympus shouldn't be a crater lmao

Link to comment
Share on other sites

Posted (edited)
6 hours ago, G'th said:

Update on above, I found a pretty critical error in my textures so I'm redoing the whole thing anyway, so hopefully it works out better. Seems like the normal map may have been messing with this too. But the bigger problem is that Olympus shouldn't be a crater lmao

Hello @G'th,

I'm a big fan of your work.  In particular, I use Ad Astra in my own playthrough.  I apologize for your experience on the Kopernicus discord server, despite being given admin, I don't moderate there because I'd quickly go insane (as you indeed found it's hard to deal with some of the locals) and likely be rendered unable to code, but I just want you to know if you need any support you are welcome tor reach out to me directly.  Please don't let the young kids there get you down.  FWIW I have instructed the mods we do have to try to establish more clear policies with regards to the toxicity there...

That aside, I have a new minor stable release:

New in this latest version release-132:

1.) The Kopernicus widget now only appears in the spacecenter to reduce toolbar clutter.

2.) We now include a small .cfg file attatched to each release to work around potential terrain color issues with old mods (like JNSQ in particular). Download if needed, and place anywhere in gamedata. It is called "ColorFix.cfg"

3.) Removed some debug spam from the internal Kopernicus shadow manager in an effort to combat balooning logfile sizes.

Known Bugs:

1.) Not exactly a bug, but worth mentioning: The Kopernicus_Config.cfg file is rewritten when the game exits. This means any edits made while playing the game will not be preserved. Edit the file only with the game exited, please.

2.) At interstellar ranges, heat can sometimes behave strangely, sometimes related to map zoom (be careful zooming out). It is best to turn off part heating when traveling far far away.

3.) When zooming out all the way out in map view at interstellar ranges, the navball furthermore sometimes behaves oddly. We are working on this and monitoring all the interstellar bugs actively.

4.) Very Old craft files may complain about a missing module. This is a cosmetic error and can be ignored. Reload and re-save the craft to remove the error.

Known Caveats:

1.) The 1.12.x release series works on 1.12.x,1.11.x,1.10.x, and 1.9.x. The 1.8 release is for 1.8.x.

2.) Multistar Solar panel support requires an additional config file, attached to release.

3.) As of release-107, scatter density underwent a bugfix on all bodies globally that results in densities acting more dense than before on some select configs. Some mods may need to adjust. Normally we'd not change things like this, but this is technically the correct stock behavior of the node so... if you need the old behavior, see config option UseIncorrectScatterDensityLogic.

4.) As of Release-119, LandControl createColors is no longer obeyed, it is forced on to avoid another bug. Very few mods to my knowledge use this parameter, but a few do (JNSQ for example). You can work around this if affected by setting your LandControl color to be all zeroes. See attatched cfg for a mod that does this.

5.) The "collider fix" as it's called, which fixes the event in which you sink into the terrain on distant bodies, is off by default. If you have a system larger than stock, please see Kopernicus_Config.cfg option DisableFarAwayColliders, read about the fix/workaround, and set it as you feel appropriate.

Edited by R-T-B
Link to comment
Share on other sites

11 hours ago, R-T-B said:

Hello @G'th,

I'm a big fan of your work.  In particular, I use Ad Astra in my own playthrough.  I apologize for your experience on the Kopernicus discord server, despite being given admin, I don't moderate there because I'd quickly go insane (as you indeed found it's hard to deal with some of the locals) and likely be rendered unable to code, but I just want you to know if you need any support you are welcome tor reach out to me directly.  Please don't let the young kids there get you down.  FWIW I have instructed the mods we do have to try to establish more clear policies with regards to the toxicity there...

Much solidarity, very cool :D

I do have a general quesiton though in regards to height maps. From what I've been able to google-fu I've been able to improve the blockyness of the generated terrain pretty substantially, but I'm just wondering if how I'm doing it is the best course to just keep pushing until its satisfactory or if there's a more efficient route that has been found?

Basically I've been employing a combination of lowering the height maps resolution and employing various tools to blur the image at the pixel level to eliminate as much as possible (without ruining the larger macro details), and it is working though its getting quite tedious now. Short of going to an even lower resolution or just spending the time on it I'm not sure what else could be done. I have extremely high resolution and high quality maps as my source material so there's plenty of details to work with, its just a matter of getting KSP's terrain generation to cooperate, which as I understand is pretty crappy but its what we got. 

Link to comment
Share on other sites

28 minutes ago, G'th said:

Basically I've been employing a combination of lowering the height maps resolution and employing various tools to blur the image at the pixel level to eliminate as much as possible (without ruining the larger macro details), and it is working though its getting quite tedious now. Short of going to an even lower resolution or just spending the time on it I'm not sure what else could be done. I have extremely high resolution and high quality maps as my source material so there's plenty of details to work with, its just a matter of getting KSP's terrain generation to cooperate, which as I understand is pretty crappy but its what we got. 

Blockiness can indeed be an issue at times with heightmaps.  Other than doing what you can with the heightmaps, as you already are, the only other things I can suggest are, (1) reduce PQS maxLevel, and/or (2) add some low-level PQS height noise.  The lower the maxLevel, the more rounded and less blocky the terrain becomes.  In some ways it makes the terrrain look worse and less interesting, but it can be very effective at reducing blockiness.  (Reducing maxLevel also reduces scatter density, so you may have to compensate.)  Adding PQS height noise doesn't do anything to remove blockiness, but it can help obsure it and make it less noticeable.

Link to comment
Share on other sites

1 hour ago, OhioBob said:

Blockiness can indeed be an issue at times with heightmaps.  Other than doing what you can with the heightmaps, as you already are, the only other things I can suggest are, (1) reduce PQS maxLevel, and/or (2) add some low-level PQS height noise.  The lower the maxLevel, the more rounded and less blocky the terrain becomes.  In some ways it makes the terrrain look worse and less interesting, but it can be very effective at reducing blockiness.  (Reducing maxLevel also reduces scatter density, so you may have to compensate.)  Adding PQS height noise doesn't do anything to remove blockiness, but it can help obsure it and make it less noticeable.

Pretty much everything he said.  I'll just add that maxlevel is no longer tied to the PQS flicker bug so you can tweak it freely, other than the noted side effects.

Link to comment
Share on other sites

Hmm, so what would lead to FPS dropping while in flight on a planet but not on the surface? I can't imagine it being because of the height map being too busy, but thats all I've really tweaked aside from the normal and color maps, which I don't think would affect that much. Not getting any console spam and the log doesn't seem to be revealing any errors at all funnily enough. 

Link to comment
Share on other sites

7 hours ago, G'th said:

Hmm, so what would lead to FPS dropping while in flight on a planet but not on the surface?

Hmm, I've come across this too in GPP. Lowish frames in flight, then fps speeds up when I'm closer to the ground... I'll try take better notes next time I encounter it.

Link to comment
Share on other sites

12 hours ago, G'th said:

Hmm, so what would lead to FPS dropping while in flight on a planet but not on the surface? I can't imagine it being because of the height map being too busy, but thats all I've really tweaked aside from the normal and color maps, which I don't think would affect that much. Not getting any console spam and the log doesn't seem to be revealing any errors at all funnily enough. 

I don't know how much of an issue this is anymore, but GPP use to have FPS problems like you descibe because of all the colliders on the ground scatter.  You can try disabling the colliders to see if that fixes it.  To do so, delete the file, GPP/GPP_Configs/EnableColliders.cfg.  If that doesn't help then I don't know what the problem is.  (FYI, for the next release of GPP we're changing the colliders to optional with them turned off by default.)

Edited by OhioBob
Link to comment
Share on other sites

2 minutes ago, OhioBob said:

I don't know how much of an issue this is anymore, but GPP use to have FPS problems like you descibe because of all the colliders on the ground scatter.  You can try disabling the colliders to see if that fixes it.  To do so, delete the file, GPP/GPP_Configs/EnableColliders.cfg.  If that doesn't help then I don't know what the problem is.  (FYI, for the next release of GPP we're changing the colliders to optional with them turned off by default.)

Hmm interesting I'll have to check that. I don't use GPP but KSRSS might enable it somewhere. 

Link to comment
Share on other sites

1 hour ago, G'th said:

Hmm interesting I'll have to check that. I don't use GPP but KSRSS might enable it somewhere. 

Sorry, I got a little confused.  The other guy responding to you mentioned GPP, so somehow I got it in my head you were using GPP.  Clearly that's not the case.  But nonetheless, the issue could be the same.

(edit)

I just looked in the planet configs for KSRSS and it looks like colliders are turned off.  So unless there is some other config somewhere that turns them on, colliders are not likely to be your problem.  One way to be sure if they are on or not is the look at the scatters in the MM cache to see if colliders are enabled.

Edited by OhioBob
Link to comment
Share on other sites

5 hours ago, OhioBob said:

Sorry, I got a little confused.  The other guy responding to you mentioned GPP, so somehow I got it in my head you were using GPP.  Clearly that's not the case.  But nonetheless, the issue could be the same.

(edit)

I just looked in the planet configs for KSRSS and it looks like colliders are turned off.  So unless there is some other config somewhere that turns them on, colliders are not likely to be your problem.  One way to be sure if they are on or not is the look at the scatters in the MM cache to see if colliders are enabled.

Right I assume it would be this:

 

ScatterColliders
									{
									}
								}
							}

Yeah thats all I can find for that so it doesn't seem that's the issue. 

However, looking at my log again, I did find I overlooked this section:

 

[WRN 00:29:17.578] Cannot find preset 'High' for pqs 'Mars'
[LOG 00:29:17.593] [OD] --> OnDemandStorage.EnableBodyPQS loading Mars
[LOG 00:29:17.655] [Kopernicus] LoadRestOfReader reallocating buffer to 179306496
[LOG 00:29:19.246] [OD] ---> Map KSRSS/Textures/KSRSS/8k/PluginData/MarsColor.dds enabling self. Path = KSRSS/Textures/KSRSS/8k/PluginData/MarsColor.dds
[LOG 00:29:19.247] [OD] Enabling Body Mars: True
[EXC 00:29:20.987] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateEdges () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateQuads () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.DisableSubdivision () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateVisual () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS+<UpdateSphere>d__148.MoveNext () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <12e76cd50cc64cf19e759e981cb725af>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[EXC 00:29:21.070] NullReferenceException: Object reference not set to an instance of an object
	PQ.GetRightmostCornerPQ (PQ nextQuad) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.GetRightmostCornerNormal (PQ caller, PQ nextQuad) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateEdgeNormals (PQ q) (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateEdges () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateQuads () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.DisableSubdivision () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS.UpdateVisual () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	PQS+<UpdateSphere>d__148.MoveNext () (at <39c0323fb6b449a4aaf3465c00ed3c8d>:0)
	UnityEngine.SetupCoroutine.InvokeMoveNext (System.Collections.IEnumerator enumerator, System.IntPtr returnValueAddress) (at <12e76cd50cc64cf19e759e981cb725af>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)
[LOG 00:29:21.072] [TransferSimple]: startdV:399.717590949335 enddV:499.717590949335 initialClosestApproach 4811918.73034576
[LOG 00:29:21.074] [Scatterer][Debug] Ocean effects disabled from reflections Camera Reflection Probes Camera
[LOG 00:29:21.077] [OD] --> ScaledSpaceDemand.LoadTextures loading KSRSS/Textures/KSRSS/8k/PluginData/MarsColor.dds and KSRSS/Textures/KSRSS/8k/PluginData/Mars_NRM.dds
[LOG 00:29:22.505] setting new dominant body: Mars
FlightGlobals.mainBody: Mars
[ERR 00:29:22.538] PQS Kerbin: Restarted

Seems like may be this is the culprit? I'm going to upload the whole log. 

https://www.dropbox.com/s/7ollyhif5o8rsls/KSP.log?dl=0

Link to comment
Share on other sites

On 6/28/2022 at 9:50 PM, G&#x27;th said:

Hmm, so what would lead to FPS dropping while in flight on a planet but not on the surface? I can't imagine it being because of the height map being too busy, but thats all I've really tweaked aside from the normal and color maps, which I don't think would affect that much. Not getting any console spam and the log doesn't seem to be revealing any errors at all funnily enough. 

I'm guessing something with the scatter system, maybe...  I'll investigate this bug.  You can of course probably work around it by turning off ground scatters but I'd still like to see why it does it only under very select circumstances, and fix it properly.

Link to comment
Share on other sites

1 hour ago, R-T-B said:

I'm guessing something with the scatter system, maybe...  I'll investigate this bug.  You can of course probably work around it by turning off ground scatters but I'd still like to see why it does it only under very select circumstances, and fix it properly.

Okay yep can confirm that appears to have stopped the slowdowns. I couldn't begin to suggest why scatters would be doing that, as the settings I'm using are unchanged from stock KSRSS and to my knowledge it didn't have this issue prior. But I also haven't touched anything other than textures so IDK what precisely could have happened. 

In the meantime, any ideas on how to move up the horizon? I don't think this is normal behavior, and it seems like whatever it is that determines where the horizon is is way lower than my actual surface is, even when I'm at one of the lowest points I could land on.. 


1jai7BW.png

Link to comment
Share on other sites

47 minutes ago, G&#x27;th said:

Okay yep can confirm that appears to have stopped the slowdowns. I couldn't begin to suggest why scatters would be doing that, as the settings I'm using are unchanged from stock KSRSS and to my knowledge it didn't have this issue prior. But I also haven't touched anything other than textures so IDK what precisely could have happened. 

In the meantime, any ideas on how to move up the horizon? I don't think this is normal behavior, and it seems like whatever it is that determines where the horizon is is way lower than my actual surface is, even when I'm at one of the lowest points I could land on.. 


1jai7BW.png

The ground scatter system is just a very slow piece of code, but in general, it should not be significantly slower in flight than close up.  I will investigate this as it does sound like some kind of bug is at play.

Link to comment
Share on other sites

Posted (edited)
1 hour ago, G'th said:

In the meantime, any ideas on how to move up the horizon? I don't think this is normal behavior, and it seems like whatever it is that determines where the horizon is is way lower than my actual surface is, even when I'm at one of the lowest points I could land on.. 

I'm not aware of a way to do this, sorry.  Maybe a more experienced config user can help.

For the scatter performance issues, I have a bleeding edge build (because untested) that may help, if you're curious:

These changes are unlikely to be harmful, but our new policy is everything goes through at least two days of testing on the bleeding edge (unless really urgent or something), so yeah, we'll try to fix it there first.

Edited by R-T-B
Link to comment
Share on other sites

Hello! i would like some help please.

i keep trying to play After Kerbin (AK from now on), but it does not load, saying there was an exception, blah blah etc...

It used to work perfectly fine, but then it suddenly decided to just stop working... i will provide the logs so that you guys can check it out.

the version is 1.12.2, as from my experience,  AK was most stable. i use the most recent Kopernicus version, 132. I love playing AK and Beyond Home, so if i ever get a fix, my entire life will be happy!

https://drive.google.com/file/d/13xE2lQ5q1VZyKFOPWXmtwra6FkRvNSar/view?usp=sharing

https://drive.google.com/file/d/1sjdFG8SBJfmp5u5wOq_TZhbL6x6OSedt/view?usp=sharing

https://drive.google.com/file/d/1G4TURQ_RPm6EUT6d71HzeKpOb4AZr1vl/view?usp=sharing

Link to comment
Share on other sites

Posted (edited)

Kerbals have discovered evidence of a Lagrange point 6 just above the surface of Gilly...

jSdW9z2.png

I know this was reported before. It looks like issue #505? I have Kopernicus 132 on KSP 1.12.3. Using Spectra and Parallax and otherwise stock Kerbol system. Roughly 2% of the land scatter is floating like this and about equal amount is invisible below the surface, visible when the camera clips below the surface (which unfortunately stock KSP allows). It's not evenly distributed, clumped in certain areas. I don't see a pattern, like all near hills or flat areas or a periodic pattern. 

UPDATE: I relaunched KSP and jumped to this ship (landed) and everything is normal. Nothing floating. In the prior session above, the lander hopped from a different biome, staying fairly close to the surface, probably within physics range. 

And this may be greedy but I want donut planets :P

Spoiler

 

 

Edited by Krazy1
Update and donuts
Link to comment
Share on other sites

4 hours ago, NathlessOne said:

there was an exception, blah blah etc...

Actually there were 44,286 exceptions. :o That's impressive. 

I don't know if I can help much, I've never used AK. Right at the top of the KSP log are these warnings:

Log started: Sun, Jul 03, 2022 21:00:08


[LOG 21:00:08.340] ActionCanvas MASK: 3458764513820540928
[LOG 21:00:08.341] AppCanvas MASK: 3458764513820540928
[LOG 21:00:08.343] MainCanvas MASK: 3458764513820540928
[WRN 21:00:09.517] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\AfterKerbin\_Core00\AK_ReaperPQS.cfg'.
[WRN 21:00:09.656] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\DecouplerShroud\Textures\ShroudTextureConfigs.cfg'.
[WRN 21:00:09.775] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ExtraplanetaryLaunchpads\EL_CCK-tags.cfg'.
[ERR 21:00:14.302] Error: Empty part config file

[WRN 21:00:14.302] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\WarpPlugin\Parts\Engines\Wyvern\Upgrades.cfg'.
[WRN 21:00:14.533] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\WarpPlugin\Patches\EnginePlacement.cfg'.

So it can't find or access those 5 files... that's not a good start. I'd make sure the files are actually there.

The first exception is 

[LOG 21:00:18.356] [AddonLoader]: Instantiating addon '_BuildManager' from assembly '_BuildManager'
[EXC 21:00:18.363] NotSupportedException: The invoked member is not supported in a dynamic module.
	System.Reflection.Emit.AssemblyBuilder.get_Location () (at <9577ac7a62ef43179789031239ba8798>:0)
	_BuildManager._BuildManager+<>c__DisplayClass2_0.<logVersion>b__0 (System.Reflection.Assembly x) (at <caa8a9a07bbf48af914d3a76740b33a6>:0)
	System.Linq.Enumerable+WhereSelectArrayIterator`2[TSource,TResult].ToList () (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
	System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable`1[T] source) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
	_BuildManager._BuildManager.logVersion () (at <caa8a9a07bbf48af914d3a76740b33a6>:0)
	_BuildManager._BuildManager.Awake () (at <caa8a9a07bbf48af914d3a76740b33a6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.GameObject:AddComponent(Type)
	AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
	AddonLoader:StartAddons(Startup)
	<LoadObjects>d__90:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	<CreateDatabase>d__71:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	GameDatabase:StartLoad()
	<LoadSystems>d__11:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	LoadingScreen:Start()

I think BuildManager is for Extraplanetary Launchpads.

And standard advise... you shouldn't mod your Steam install. Much better to make a copy of the whole game and mod the copy. The "check file integrity" in Steam often doesn't work correctly for modded installs. It's easy to manage different KSP copies with CKAN.

 

Link to comment
Share on other sites

Posted (edited)
4 hours ago, Krazy1 said:

Actually there were 44,286 exceptions. :o That's impressive. 

I don't know if I can help much, I've never used AK. Right at the top of the KSP log are these warnings:

Log started: Sun, Jul 03, 2022 21:00:08


[LOG 21:00:08.340] ActionCanvas MASK: 3458764513820540928
[LOG 21:00:08.341] AppCanvas MASK: 3458764513820540928
[LOG 21:00:08.343] MainCanvas MASK: 3458764513820540928
[WRN 21:00:09.517] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\AfterKerbin\_Core00\AK_ReaperPQS.cfg'.
[WRN 21:00:09.656] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\DecouplerShroud\Textures\ShroudTextureConfigs.cfg'.
[WRN 21:00:09.775] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\ExtraplanetaryLaunchpads\EL_CCK-tags.cfg'.
[ERR 21:00:14.302] Error: Empty part config file

[WRN 21:00:14.302] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\WarpPlugin\Parts\Engines\Wyvern\Upgrades.cfg'.
[WRN 21:00:14.533] Cannot create config from file 'C:\Program Files (x86)\Steam\steamapps\common\Kerbal Space Program\GameData\WarpPlugin\Patches\EnginePlacement.cfg'.

So it can't find or access those 5 files... that's not a good start. I'd make sure the files are actually there.

The first exception is 

[LOG 21:00:18.356] [AddonLoader]: Instantiating addon '_BuildManager' from assembly '_BuildManager'
[EXC 21:00:18.363] NotSupportedException: The invoked member is not supported in a dynamic module.
	System.Reflection.Emit.AssemblyBuilder.get_Location () (at <9577ac7a62ef43179789031239ba8798>:0)
	_BuildManager._BuildManager+<>c__DisplayClass2_0.<logVersion>b__0 (System.Reflection.Assembly x) (at <caa8a9a07bbf48af914d3a76740b33a6>:0)
	System.Linq.Enumerable+WhereSelectArrayIterator`2[TSource,TResult].ToList () (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
	System.Linq.Enumerable.ToList[TSource] (System.Collections.Generic.IEnumerable`1[T] source) (at <351e49e2a5bf4fd6beabb458ce2255f3>:0)
	_BuildManager._BuildManager.logVersion () (at <caa8a9a07bbf48af914d3a76740b33a6>:0)
	_BuildManager._BuildManager.Awake () (at <caa8a9a07bbf48af914d3a76740b33a6>:0)
	UnityEngine.DebugLogHandler:LogException(Exception, Object)
	ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
	UnityEngine.GameObject:AddComponent(Type)
	AddonLoader:StartAddon(LoadedAssembly, Type, KSPAddon, Startup)
	AddonLoader:StartAddons(Startup)
	<LoadObjects>d__90:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	<CreateDatabase>d__71:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	GameDatabase:StartLoad()
	<LoadSystems>d__11:MoveNext()
	UnityEngine.MonoBehaviour:StartCoroutine(IEnumerator)
	LoadingScreen:Start()

I think BuildManager is for Extraplanetary Launchpads.

And standard advise... you shouldn't mod your Steam install. Much better to make a copy of the whole game and mod the copy. The "check file integrity" in Steam often doesn't work correctly for modded installs. It's easy to manage different KSP copies with CKAN.

 

the thing is i already copied the steam copy

CKAN dosent work from what i have tried in the past

 

so lemme try again, if it works, i thank you very much!

Edited by NathlessOne
So after looking around the files, i found the files are infact there
Link to comment
Share on other sites

1 hour ago, NathlessOne said:

the thing is i already copied the steam copy

CKAN dosent work from what i have tried in the past

 

so lemme try again, if it works, i thank you very much!

I got it to work! i reinstalled AK and deleted EPL, seems to do the trick! i thank you a million times!

 

Link to comment
Share on other sites

I'm trying to  figure out how to apply local HiRes decals to launch sites (like RSS Canaveral HD does) but I could use some help.

I downloaded a set of high res. images from USGS and stitched them to form a surface patch. Cropped it and scaled to 8192 x 8192 px and also created a lower res preview at 1024 x 1024 px for fiddling about with fine tuning the positioning.

I used the following MM patch to try to apply it to the surface but nothing is showing up (or at least not where I expect it to show up)

Spoiler
@Kopernicus:FOR[RSS-Launch-Sites]
{
  @Body[Kerbin] // Earth
  {
    @PQS
    {
      @Mods
      {
        // WSSH Colormap
        MapDecal
        {
		order = 9999996
		absolute = false
		absoluteOffset = 0
		angle = 0
		latitude = 32.949006915566102
		longitude = -106.42335932635828
		colorMap = RSS-Launch-Sites/PluginData/wssh_1k.png
		// KK group centre at runway centre @ 588 x 640 out of 1024 x 1024
		removeScatter = true
		radius = 55000
        }
      }
    }
  }
}

 

 

Link to comment
Share on other sites

Posted (edited)

Hello all, I've been hard at work with @Gotmachine(maybe him more than me) on some hot new changes that represent the biggest advance in performance in the scatter system to date, and for that matter, perhaps Kopernicus as a whole.  Find them on the bleeding edge, presently in testing, here:

If all goes well, these will be here in the stable branch in a few days.  We just want to test appropriately first. :)

Edited by R-T-B
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...