Jump to content

[1.8.0-1.12.4] Kopernicus Stable branch (Last Updated August 12th, 2022)


R-T-B
 Share

Recommended Posts

Hello,

is it possible to disable the zipping of logs at KSP startup?
It seems it takes a while  to compress 40MB ModuleManager.ConfigCache and the 25MB KSP.log file on each startup...
Would be nice to be able to disable the zipping as long the zip isn't needed... but I didn't found an option in Kopernicus_Config.cfg.

Edit: Nevermind... it seems the zip is generated in the  end... so that's not one of the things delaying the startup.

BR
Jebs_SY

Edited by Jebs_SY
Link to comment
Share on other sites

  • 2 weeks later...
  • 3 weeks later...

I'm sorry all, I know I've been somewhat absent lately.  To be frank, Kopernicus will likely be in "maintainence mode" for some time with bugfix support only due to increased workload at home.  That and a new puppy that is taking a lot of training (but is also a lot of fun!)

I would ask if others that are capable can look over support request log files for now, and where possible, spot the obvious things, that'd be a great contribution you can do to help this project.  I'll try to be back at it shortly.  I still want to do one final bugfix for a few fixable things before KSP 2 is upon us.

On 9/5/2022 at 1:42 PM, OhioBob said:

has @*,* ever been tested to assure that it works?  Perhaps you should do something like this just to cover all the bases:

It worked for me with a module manager as of a month ago.  I'd hazard a guess his is older, or maybe something newer broke it...  But perhaps I will change it in the next version just to be sure.

Edited by R-T-B
Link to comment
Share on other sites

 

This is a beta release of some planned fixes for distant heating bugs, amongst other heating system issues, please test.  Please note these fixes were contributed so testing is especially needed here.

Link to comment
Share on other sites

Hi everyone,
Having an issue with Kopernicus not loading rings other than faint/ghost images. Suggestions?
As a note, I do have my rendering quite low and textures on about 1/8th just in case it might be a graphical setting issue. 

Img link https://drive.google.com/file/d/1JOATpdSqMjixQBO1pXiZ4q1IoHa5qrTh/view?usp=sharing

Edited by FullOfStars
Link to comment
Share on other sites

On 10/31/2022 at 5:11 AM, FullOfStars said:

Hi everyone,
Having an issue with Kopernicus not loading rings other than faint/ghost images. Suggestions?
As a note, I do have my rendering quite low and textures on about 1/8th just in case it might be a graphical setting issue. 

Img link https://drive.google.com/file/d/1JOATpdSqMjixQBO1pXiZ4q1IoHa5qrTh/view?usp=sharing

That's odd.  What platform are you on?  It isn't an OpenGL one is it? (linux / mac)

Link to comment
Share on other sites

7 hours ago, R-T-B said:

That's odd.  What platform are you on?  It isn't an OpenGL one is it? (linux / mac)

Sorry forgot to update, looks like its only with an old Sentar pack. Must be a difference in textures or such, other rings are working. 

Link to comment
Share on other sites

On 11/2/2022 at 9:30 AM, FullOfStars said:

Sorry forgot to update, looks like its only with an old Sentar pack. Must be a difference in textures or such, other rings are working. 

They may be tiled rings.  IIRC those types have been broken for a bit, and I don't have the knowledge to fix it unfortunately.

 

Also, minor PSA here:

Please Please please if Kopernicus is not loading, check if you have RSS and Parallax installed together, it seems these are incompatible without a custom pack and/or a lot of work.  I've gotten way too many bug reports that end in that conclusion.

 

Edited by R-T-B
Link to comment
Share on other sites

26 minutes ago, Rutabaga22 said:

This is because you have Parallax and GU installed.  AFAIK, Parallax only supports the stock planets natively.  You'd need to find a support pack of some kind to use something else.

 

This goes for everyone installing Parallax, as I'm getting a lot of similar error reports like this:   Unless you know what you are doing, assume parallax works with stock planets only!

Link to comment
Share on other sites

Just now, R-T-B said:

This is because you have Parallax and GU installed.  AFAIK, Parallax only supports the stock planets natively.  You'd need to find a support pack of some kind to use something else.

 

This goes for everyone installing Parallax, as I'm getting a lot of similar error reports like this:   Unless you know what you are doing, assume parallax works with stock planets only!

Dang, you'd think parallax would have something that only applies it to supported planets.

Link to comment
Share on other sites

1 minute ago, Rutabaga22 said:

Dang, you'd think parallax would have something that only applies it to supported planets.

Oh wait, does GU only add planets?  Then maybe that's alright...  I'm still getting up to speed on parallax.  I know it fights with RSS and other system replacers though.

If that DOESN'T fix your issue post back here and I'll take a second look.

Edited by R-T-B
Link to comment
Share on other sites

4 minutes ago, R-T-B said:

Oh wait, does GU only add planets?  Then maybe that's alright...  I'm still getting up to speed on parallax.  I know it fights with RSS and other system replacers though.

I believe GU allows system switching, so that might be it.

Link to comment
Share on other sites

14 minutes ago, R-T-B said:

Oh wait, does GU only add planets?  Then maybe that's alright...  I'm still getting up to speed on parallax.  I know it fights with RSS and other system replacers though.

If that DOESN'T fix your issue post back here and I'll take a second look.

 

10 minutes ago, Rutabaga22 said:
15 minutes ago, R-T-B said:

Oh wait, does GU only add planets?  Then maybe that's alright...  I'm still getting up to speed on parallax.  I know it fights with RSS and other system replacers though.

I believe GU allows system switching, so that might be it.

This is because the parallax config of GU is written for older parallax, which means it doesn't support parallax 2. To fix the issue, either GU needs to update its parallax configs or you need to roll back to parallax 1.

Link to comment
Share on other sites

9 minutes ago, Jason Kerman said:

 

This is because the parallax config of GU is written for older parallax, which means it doesn't support parallax 2. To fix the issue, either GU needs to update its parallax configs or you need to roll back to parallax 1.

Couldn't I delete GU's parallax configs?

Link to comment
Share on other sites

1 hour ago, Rutabaga22 said:

Couldn't I delete GU's parallax configs?

As long as it's not a hard dependency for GU then yes, that should work.

Link to comment
Share on other sites

Hello @R-T-B

A question to about the Kopernicus Shadows. Upon zooming out Kopernicus switches to a more simplistic shadow creation (it's kinda a sphere around the camera. This results in some slightly unpleasant effects on big vessels, whose parts partially leave this detail-sphere. Can I increase the spheresize by a parameter, eg. double the camera distance upon the shadows switch to simple mode? I tried fiddeling with the shadowvalue (default 25000) in the config, but apparently it was not the value i was looking for. Can I increase the detail-sphere somehow without changing the distance of casted shadows? I think, I have enough computing power, to render the detailed shadows also when zooming out a bit more.

Please don't missunderstand: No complaint, just a question if I can optimize my visuals a little bit more.

Edited by Rakete
Link to comment
Share on other sites

1 hour ago, Rakete said:

Hello @R-T-B

A question to about the Kopernicus Shadows. Upon zooming out Kopernicus switches to a more simplistic shadow creation (it's kinda a sphere around the camera. This results in some slightly unpleasant effects on big vessels, whose parts partially leave this detail-sphere. Can I increase the spheresize by a parameter, eg. double the camera distance upon the shadows switch to simple mode? I tried fiddeling with the shadowvalue (default 25000) in the config, but apparently it was not the value i was looking for. Can I increase the detail-sphere somehow without changing the distance of casted shadows? I think, I have enough computing power, to render the detailed shadows also when zooming out a bit more.

Please don't missunderstand: No complaint, just a question if I can optimize my visuals a little bit more.

The shadows are based on stock unity shadow cascades, and indeed, more tuning can be done than just the distance parameter I expose.  This is planned for the next upcoming release, in the next few weeks.  That release will contain a few new solar flux options (more realistic flux vs stock gameplay with a toggle to turn on the more scientifically acurate ones, you can see the new model on the bleeding edge right now), a few bugfixes, and a bunch of new shadow parameters similar to what scatterer offers (but without the heavy atmo scatterer part).

Edited by R-T-B
Link to comment
Share on other sites

3 hours ago, R-T-B said:

The shadows are based on stock unity shadow cascades, and indeed, more tuning can be done than just the distance parameter I expose.  This is planned for the next upcoming release, in the next few weeks.  That release will contain a few new solar flux options (more realistic flux vs stock gameplay with a toggle to turn on the more scientifically acurate ones, you can see the new model on the bleeding edge right now), a few bugfixes, and a bunch of new shadow parameters similar to what scatterer offers (but without the heavy atmo scatterer part).

Will it be possible in a future kopernicus release to increase the detailed-shadow-sphere around the camera? Or is this locked behind unity's stock shadow cascade mechanisms? 

Link to comment
Share on other sites

1 hour ago, Rakete said:

Will it be possible in a future kopernicus release to increase the detailed-shadow-sphere around the camera? Or is this locked behind unity's stock shadow cascade mechanisms? 

Unity's shadow cascade system can do something like that but I'm no expert on the exact settings to get there.  You'll have the tools to experiment though.  I must caution you though it is possible, nothing is "free" here.  It will likely come at the expense of shadow casting distance, performance, or both.

Link to comment
Share on other sites

  • 2 weeks later...

Hello

I have a problem with Kopernicus in 1.12.4, planets and other planetary systems that are not part of the stock game are not displayed, I tried with JNSQ and then with GU but nothing is displayed, no planet or system is displayed outside the stock kerbal system, kopernicus is however well installed in the game data.

gYAx77b.png7zyMRtW.pnghPCUNbG.png

Link to comment
Share on other sites

20 hours ago, astro-french-fries said:

I have a problem with Kopernicus in 1.12.4

I think the warning explains your problem well enough.  Also, I think you'll find JNSQ is not confirmed to be compatible with the latest versions of Kopernicus.  You should probably downgrade to the appropriate version described in that thread.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...