Jump to content

[1.8.1-1.11.1] Kopernicus Stable branch (Last Updated March 14th 2021)


Recommended Posts

On 2/20/2021 at 12:22 AM, Taco Salad said:

Same exact bug as before too.

I am honestly unsure what causes this.  I usually only see it with incomplete parallax installs.

Does anyone know if MPE works with the latest Kopernicus?

Edited by R-T-B
Link to post
Share on other sites

You mean minor planets? 

Not sure of I have the latest version of kopernicus, can' t check right now, but  in the version I use minor planets works. 

Link to post
Share on other sites
On 2/23/2021 at 1:36 AM, R-T-B said:

I am honestly unsure what causes this.  I usually only see it with incomplete parallax installs.

Does anyone know if MPE works with the latest Kopernicus?

According to following thread some  planets which uses Gilly as template don't work until changing the template to Minmus thus changing the apearance of them (last pages should have it): 

 

Link to post
Share on other sites

Apologies if this isn't the right thread to ask, but how would I go about changing the color of terrain grass (i.e. outside of KSC) on Kerbin using Kopernicus? I see other mods are supplying their own grass texture for custom bodies or Kerbin overhauls but they are all grayscale maps. Which value of the Material node sets the diffuse color?

Link to post
Share on other sites

Just FYI, I'm still alive and development is ongoing.  Just been busy lately.  Real life work comes and goes in massive spurts, it seems.

Link to post
Share on other sites
Posted (edited)

Heads up, got some time to do some work:

There is going to be a stable release this weekend (probably today) integrating some of the new changes from bleeding edge.  What this means:

1.)  Version support restructuring.  Like bleeding edge, we will now support a wider range of versions, including minor releases like 1.10.0, etc.  The dll for the most part automatically adapts to what it's running on.  Only 1.8.x requires a seperate dll.  This has been well-vetted and works fine.  No, it won't automatically update to 1.12 when it comes out, but hey, it's still pretty neat.

2.)  Multistar Solar panel math refactoring.  This corrects broken multistar math but may not work with solar packs and is at the moment, very experimental.  Of all the changes, this is the most dramatic, and it will be off by default (meaning the game will be running in single-star support mode, and multiple stars will be glitchy).  Mainly, it has the potential to break existing in flight vessels, though we've done our best to avoid that, but just to be safe we make YOU toggle it on so you are sure you backed up your save first, and/or grounded all flights.  The instructions on how to toggle it on will follow with the release.  If you turn it on and find your vessels glitched, you should be able to toggle it back off and recover them.

3.)  Other bugfixes both major and minor, I'll document them in full at release time.

Edited by R-T-B
Link to post
Share on other sites
Posted (edited)

New in this latest version (release-35)

1.) Release bundling has changed. There are now two releases, the legacy release series 1.8.1 that supports all 1.8.x releases and the modern release series whose version number stays in sync with the latest KSP. The modern series supports all releases post 1.9.0, including 1.9.0, with the same dll. Like magic. Please download the right version.

2.) Disabled new multistar EC math calculation by default, as some modded inflight vessels may not behave well with it (limited testing honestly). To enable it, please back up your save, and download the .cfg linked with this release, and place it in GameData/Kopernicus/Config.  It may work fine, we really need additional data.

3.) Added a new parameter to Kopernicus_Config.cfg called SolarRefreshRate, which controls the amount of time in seconds between calculations of the multistar solar EC math (when enabled, see above). Raise it if you suffer performance issues from the multistar math.  Must be an integer, and the default of 1 second is slower than stock but should be fine for most all instances and strike a balance between performance and speed.

4.) A bug in which freshly generated config files were not loaded has been fixed.

5.) Some minor scatter related bugs have been corrected.

6.) Updated MFI build included in zip where possible (not legacy) to latest version (1.2.10.0).

7.) Nyan cats are no longer used to signify an error, we use a simple error message now (we were using reflection to activate them and that's bad practice).

Known Bugs:

1.) Old craft files may complain about a missing module.  This is a cosmetic error and can be ignored.  Reload and re-save the craft to remove the error.

2.) At interstellar ranges, heat can sometimes behave strangely, sometimes related to map zoom (be careful zooming out). It is best to turn off part heating when traveling far far away.

3.) When zooming out all the way out in map view at interstellar ranges, the navbal furthermore sometimes behaves oddly. We are working on this and all the interstellar bugs actively.

Especially note the bold points above!

This is now available at CKAN, but without these release notes due to CKAN's nature.  Please direct fellow users to these notes if they are confused regarding the solar math config file.

Edited by R-T-B
Link to post
Share on other sites

I got an error "Unknown part KopernicusSolarPanel" on existing craft files in the VAB after updating with CKAN so I  went back to the previous version.

Link to post
Share on other sites
Posted (edited)
1 hour ago, jost said:

I got an error "Unknown part KopernicusSolarPanel" on existing craft files in the VAB after updating with CKAN so I  went back to the previous version.

Thanks for the report.  Are you planning on playing with multistar support?  Either way, that error can be safely ignored and the craft re-saved without that module.  I’ll add a note about this.  The error you experienced is cosmetic and harmless.

Edited by R-T-B
Link to post
Share on other sites
10 minutes ago, R-T-B said:

Thanks for the report.  Are you planning on playing with multistar support?  Either way, that error can be safely ignored and the craft re-saved without that module.  I’ll add a note about this.  The error you experienced is cosmetic and harmless.

Nope I don't plan this. I' mostly playing with OPM. Used to play with MPE too, but since it's broken at the moment I don't use it. And none of them has multiple stars.
. Thanks for the answer :) Will try saving the craft  tomorow and report whether it works as expected

Link to post
Share on other sites
3 hours ago, jost said:

Nope I don't plan this. I' mostly playing with OPM. Used to play with MPE too, but since it's broken at the moment I don't use it. And none of them has multiple stars.
. Thanks for the answer :) Will try saving the craft  tomorow and report whether it works as expected

In your case then you can 100% ignore the error with no bad result.  If you were going to use the multistar .cfg file, I would say the odds are more like 90% that there'll be no issue, but you are certainly fine given you are just single star.

Link to post
Share on other sites
Posted (edited)
1 hour ago, oniontrain said:

Now that the main version is 1.11 compatible should I switch to it over the bleeding edge version I've been using?

Generally I advise that yes.  It's got a tendency to break less going forward. ;)

Edited by R-T-B
Link to post
Share on other sites

I've noticed that on the newest version the number of module manager ppatcheson my game has increased significantly (over a thousand more than before). Will this impact performance?

Link to post
Share on other sites
Posted (edited)
3 hours ago, Apelsin said:

I've noticed that on the newest version the number of module manager ppatcheson my game has increased significantly (over a thousand more than before). Will this impact performance?

It won't once the game loads, but I should probably look into optimizing the way it handles the solar math upgrade a bit more (this is what you are witnessing).

But no, it should only slow you down at all during load, and even then probably only on the first run.

Actually, if anyone wants to provide feedback on the MM part of this update, I fully admit I am a novice there.  Relevant part that could be optimized:

https://github.com/Kopernicus/Kopernicus/blob/master/build/KSP19%2B/GameData/Kopernicus/Config/MultiStarSolarPanels.cfg

@hemeac
any thoughts?

Edited by R-T-B
Link to post
Share on other sites
Posted (edited)

Figured out a better way to do all those module manager patches, fresh release with possibly faster load times, otherwise identical:

New in this latest version (release-36):

1.) A minor bugfix for the ModuleManager patches has been applied that prevents them from spawning over 1000 patches that do pretty much nothing, increasing load time. This release is otherwise identical, so the prior releases notes are included below as they are important:

New in last version (release-35):

1.) Release bundling has changed. There are now two releases, the legacy release series 1.8.1 that supports all 1.8.x releases and the modern release series whose version number stays in sync with the latest KSP. The modern series supports all releases post 1.9.0, including 1.9.0, with the same dll. Like magic. Please download the right version.

2.) Disabled new multistar EC math calculation by default, as some modded inflight vessels may not behave well with it (limited testing honestly). To enable it, please back up your save, and download the MultiStarSolarPanels.cfg linked with this release, and place it in GameData/Kopernicus/Config. It may work fine, we really need additional data.

3.) Added a new parameter to Kopernicus_Config.cfg called SolarRefreshRate, which controls the amount of time in seconds between calculations of the multistar solar EC math (when enabled, see above). Raise it if you suffer performance issues from the multistar math. Must be an integer, and the default of 1 second is slower than stock but should be fine for most all instances and strike a balance between performance and speed.

4.) A bug in which freshly generated config files were not loaded has been fixed.

5.) Some minor scatter related bugs have been corrected.

6.) Updated MFI build included in zip where possible (not legacy) to latest version (1.2.10.0).

7.) Nyan cats are no longer used to signify an error, we use a simple error message now (we were using reflection to activate them and that's bad practice).

8.) Kopernicus Asteroid Generator support no longer generates comets, which were being spawned in a buggy way anyhow. Use an external mod if you want these for now.

Known Bugs:

1.) Old craft files may complain about a missing module. This is a cosmetic error and can be ignored. Reload and re-save the craft to remove the error.

2.) At interstellar ranges, heat can sometimes behave strangely, sometimes related to map zoom (be careful zooming out). It is best to turn off part heating when traveling far far away.

3.) When zooming out all the way out in map view at interstellar ranges, the navbal furthermore sometimes behaves oddly. We are working on this and all the interstellar bugs actively.

Edited by R-T-B
Link to post
Share on other sites
9 minutes ago, R-T-B said:

1.) Old craft files may complain about a missing module. This is a cosmetic error and can be ignored. Reload and re-save the craft to remove the error.

Oh I’ve gotten that for a while. Probably from another mod. 

Link to post
Share on other sites

With the latest update to Kopernicus, Contract Configurator can choke on something related to the solar panel changes - this is perhaps something the contract pack in question needs to change, but thought it might be useful to bring it up here too:

(At least I don't THINK this happened with versions earlier than 35/36...)

Spoiler

[LOG 17:53:12.800] [INFO] ContractConfigurator.ContractType: Loading CONTRACT_TYPE: 'StationCore'
[ERR 17:53:12.881] ContractConfigurator.PartValidationFactory: CONTRACT_TYPE 'StationCore', PARAMETER 'PartValidationRTG' of type 'PartValidation': A validation error occured while loading the key 'partModule' with value 'System.Collections.Generic.List`1[System.String]'.

[EXC 17:53:12.886] ArgumentException: No PartModule class for 'KopernicusSolarPanels'.
    ContractConfigurator.Validation.ValidatePartModule (System.String name) (at <ef0243a06f2841fe9bf57034a334902e>:0)
    System.Linq.Enumerable.All[TSource] (System.Collections.Generic.IEnumerable`1[T] source, System.Func`2[T,TResult] predicate) (at <fbb5ed17eb6e46c680000f8910ebb50c>:0)
    ContractConfigurator.PartValidationFactory+<>c.<Load>b__3_6 (System.Collections.Generic.List`1[T] x) (at <ef0243a06f2841fe9bf57034a334902e>:0)
    ContractConfigurator.ConfigNodeUtil.ParseValue[T] (ConfigNode configNode, System.String key, System.Action`1[T] setter, ContractConfigurator.IContractConfiguratorFactory obj, T defaultValue, System.Func`2[T,TResult] validation) (at <ef0243a06f2841fe9bf57034a334902e>:0)
    UnityEngine.DebugLogHandler:LogException(Exception, Object)
    ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object)
    KSPe.Util.Log.UnityLogDecorator:UnityEngine.ILogHandler.LogException(Exception, Object)
    UnityEngine.Debug:LogException(Exception)
    ContractConfigurator.LoggingUtil:LogException(Exception)
    ContractConfigurator.ConfigNodeUtil:ParseValue(ConfigNode, String, Action`1, IContractConfiguratorFactory, List`1, Func`2)
    ContractConfigurator.PartValidationFactory:Load(ConfigNode)
    ContractConfigurator.ParameterFactory:GenerateParameterFactory(ConfigNode, ContractType, ParameterFactory&, ParameterFactory)
    ContractConfigurator.ParameterFactory:GenerateParameterFactory(ConfigNode, ContractType, ParameterFactory&, ParameterFactory)
    ContractConfigurator.ParameterFactory:GenerateParameterFactory(ConfigNode, ContractType, ParameterFactory&, ParameterFactory)
    ContractConfigurator.ContractType:Load(ConfigNode)
    ContractConfigurator.<LoadContractTypeConfig>d__31:MoveNext()
    ContractConfigurator.<FinalizeContractTypeLoad>d__30:MoveNext()
    UnityEngine.SetupCoroutine:InvokeMoveNext(IEnumerator, IntPtr)
[WRN 17:53:12.897] ContractConfigurator.ContractType: Errors encountered while trying to load CONTRACT_TYPE 'StationCore'

 

Link to post
Share on other sites
15 hours ago, R-T-B said:

Figured out a better way to do all those module manager patches, fresh release with possibly faster load times, otherwise identical:

New in this latest version (release-36):

2.) Disabled new multistar EC math calculation by default, as some modded inflight vessels may not behave well with it (limited testing honestly). To enable it, please back up your save, and download the MultiStarSolarPanels.cfg linked with this release, and place it in GameData/Kopernicus/Config. It may work fine, we really need additional data.

 

First, thanks for the continued amazing work on this most essential mod.

Do we need to/can we delete 'SolarPanels.cfg' if we're using 'MultiStarSolarPanels.cfg'?

Link to post
Share on other sites

Nyan Cat explosion in 1.11.2 go brrrrrrrrrrrrrr!

 

1.11.2 just went live, but seeing it's a hot fix with only five changes, it shouldn't affect Kopernicus much, right?

Is there a way to edit the versioning file before a patch comes out?

Link to post
Share on other sites
4 minutes ago, Emilius73 said:

Nyan Cat explosion in 1.11.2 go brrrrrrrrrrrrrr!

 

1.11.2 just went live, but seeing it's a hot fix with only five changes, it shouldn't affect Kopernicus much, right?

Is there a way to edit the versioning file before a patch comes out?

you can always go into betas and choose and older version to play with

Link to post
Share on other sites
10 hours ago, DirtyFace83 said:

First, thanks for the continued amazing work on this most essential mod.

Do we need to/can we delete 'SolarPanels.cfg' if we're using 'MultiStarSolarPanels.cfg'?

You can delete SolarPanels.cfg if using the MultiStarSolarPanels version, but you do not have to.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...