Jump to content
  • 0

How to repair in orbit?


Cilyan
 Share

Question

Hello there!

I have a contract to rendez-vous with a satellite in orbit around the Mun and repair a broken Gigantor XL panel. However, though I can see the broken part, I can do nothing on it. I cannot select or highlight it whatever I tried. I launched 2 times, as the first time I thought it was because I had only 3 repair kits onboard, and from what I could read the Gigantor needs 4. But the two times I was unable to do anything. Well... I was able to do things to be honest, but not what I expected...

How am I supposed to fulfill the contract, given also that I don't have Gigantor unlocked yet in the tech tree, so clearly this is a repair mission and not a replace mission... isn't it?

BR

Cilyan

 

Link to comment
Share on other sites

10 answers to this question

Recommended Posts

  • 0

Maybe try replacing it with one from the rocket you send up even though like you said this is a fix mission rather than a replace mission

 

Edited by theCAVE
Misread the question
Link to comment
Share on other sites

  • 0

Toying around to better understand, it seems that I also have an issue with detecting that an engineer is indeed onboard the spacecraft...

@theCAVE I cannot place a new Gigantor, as I don't have it unlocked yet. Besides, looking at the saved game, the part to repair is link with a unique ID from the contract inside the .sfs to the .craft file.

LvFRW1i.png

Edited by Cilyan
Link to comment
Share on other sites

  • 0

Continuation of the tweaking and hacking... to no avail.

I removed the "have an engineer on board" condition from the save file, but the part was still impossible to repair. I hacked the file a bit more to have the mission request to repair the opposite panel, in case there was something wrong with the parameters of the original one. This time, the "original panel" was clickable and hoverable, but the opposite panel, the one to repair was his turn unclickable and unselectable, exactly like the other one was. So it seems that there is an issue with the "RepairPart" parameter.

In the end, I hacked the save file once more to remove all parameters from the contract and replace them with a "Keep stability" parameter, copied from another contract. (Before that, I tried to copy other kind of parameters, such as the tourist contract I was trying to cover in the same mission, but this did not trigger the completion as expected.) Using this hack, when loading the save and after the 10 seconds of keeping a stable orbit, the contract was finally declared as done. So, not a real solution... It's a pity because these repair contracts are fun (RDZV + EVA).

BTW, this is the full list of my mods, but honestly I don't see which one could be interacting here. ReStock maybe? Or ClickThrough Blocker?

BreakingGround-DLC (BreakingGround-DLC (unmanaged))
Chatterer (Chatterer 0.9.99)
Chatterer Extended (ChattererExtended 0.6.2)
ClickThrough Blocker (ClickThroughBlocker 1:0.1.10.15)
CollisionFX-ReUpdated (CollisionFXReUpdated 1.1.0)
Crowd Sourced Science (CrowdSourcedScience v6.0)
Distant Object Enhancement Continued (DistantObject v2.0.2.0)
Distant Object Enhancement Continued default config (DistantObject-default v2.0.2.0)
Docking Port Alignment Indicator (DockingPortAlignmentIndicator 6.9.2.2)
Kerbal Alarm Clock (KerbalAlarmClock v3.13.0.0)
Kerbal Engineer Redux (KerbalEngineerRedux 1.1.8.3)
Making History (MakingHistory-DLC 1.11.0)
Module Manager (ModuleManager 4.1.4)
PlanetShine (PlanetShine 0.2.6.3)
PlanetShine - Default configuration (PlanetShine-Config-Default 0.2.6.3)
RCS Build Aid (RCSBuildAid v1.0.5)
Real Plume (RealPlume 2:v13.3.2)
Real Plume - Stock Configs (RealPlume-StockConfigs v4.0.5)
Reentry Particle Effect Renewed (ReentryParticleEffect 1.9.1.1)
ReStock (ReStock 1.1.2)
scatterer (Scatterer 3:v0.0723)
Scatterer Default Config (Scatterer-config 3:v0.0723)
Scatterer Sunflare (Scatterer-sunflare 3:v0.0723)
ScienceAlert ReAlerted (ScienceAlert 1.9.8.9)
SmokeScreen - Extended FX Plugin (SmokeScreen 2.8.14.0)
Spectra (Spectra v1.3.3)
TextureReplacer (TextureReplacer v4.3.1)
Toolbar Controller (ToolbarController 1:0.1.9.4)
Zero MiniAVC (ZeroMiniAVC 1:1.1.0.1)

 

Link to comment
Share on other sites

  • 0

To my knowledge, You can only repair items in stock with an engineer.
If you are using one Try moving the camera is its behind the panel and moving away.
When the broken part is highlighted Right click on it and repair it.
However, My stock knowledge is limited.
Alternatively, it could be restock resetting the offset on parts.

Link to comment
Share on other sites

  • 0

I'm having the same problem.  Just got the update and was excited to try these repair missions.  I've managed to get the engineer to weld a ladder to the satellite to hold onto.  But the option to repair the solar array doesn't come up when I right click on it.  Left clicking in EVA build mode removes it from the satellite.

Someone please help.

Link to comment
Share on other sites

  • 0

this is a bug with the part ID thingy

you can manualy complete the contract in the alt f12 menu

 

Edited by peridoot
Link to comment
Share on other sites

  • 0

I tried posting this a few days ago, but still don't see it here. I've got a very similar problem. However, I _can_ select the part to repair...it says I need (4?) repair packs. The engineer has the 4 repair packs and a power screw driver, but there is no way to apply the fix packs...it just tells me I need 4 of them.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...