Jump to content

EVO | Extreme Visual Overhaul for RSS | Beta 0.3 "Mostly Stable"


ItsJustLuci
 Share

Recommended Posts

7 hours ago, xian1 said:

It seems good

  Reveal hidden contents

RSSVE is licensed under a Creative Commons Attribution-NonCommercial-ShareAlike 4.0 (CC-BY-NC-SA 4.0) license.

 

You are my saviour, thank you   o7  . So, will you share it?

Link to comment
Share on other sites

9 hours ago, Jane Monroue said:

You are my saviour, thank you   o7  . So, will you share it?

 

8 hours ago, si2504 said:

what do I have to replace from these files to correct the shadows?

Just drop the GameData file in your ksp's file,make sure there is no RSSVE file in your GameData before insall,and delete the \GameData\RealSolarSystem\RSSKopernicus\Cache folder at the same time

link:

 

Link to comment
Share on other sites

1 hour ago, xian1 said:

 

Just drop the GameData file in your ksp's file,make sure there is no RSSVE file in your GameData before insall,and delete the \GameData\RealSolarSystem\RSSKopernicus\Cache folder at the same time

link:

 

Thank you so much!

Link to comment
Share on other sites

2 hours ago, xian1 said:

 

Just drop the GameData file in your ksp's file,make sure there is no RSSVE file in your GameData before insall,and delete the \GameData\RealSolarSystem\RSSKopernicus\Cache folder at the same time

link:

 

What is the difference between the configs in RSSVE and EVO that causes the shadows not to work though? It would be better to correct the configs in EVO rather than installing a dll that isn't needed.

Link to comment
Share on other sites

On 5/22/2021 at 6:20 AM, xian1 said:

I come across the same problem like Jane Monroue

Saturn's ring don't get the right shadow,but I do some modifiy on  Theysen's RSSVE and let it work with EVO. 

It's clear that this action violate  CC-BY-NC-SA 4.0 ,so I can't release it gLBSLF.png

no, it doesn't. More than half of EVO is based on configs derived from RSSVE, we use the same license on purpose. ALL mods credited in the OP are under the sharealike license or an equivalent, and the only parts of EVO that aren't are the SE assets (city lights, 0.3 mars textures and soon to be the new 64k clouds)

Link to comment
Share on other sites

5 minutes ago, ItsJustLuci said:

no, it doesn't. More than half of EVO is based on configs derived from RSSVE, we use the same license on purpose. ALL mods credited in the OP are under the sharealike license or an equivalent, and the only parts of EVO that aren't are the SE assets (city lights, 0.3 mars textures and soon to be the new 64k clouds)

How does Saturn behave in this way if Most of it's configs are actually from RSSVE?

Link to comment
Share on other sites

1 minute ago, si2504 said:

How does Saturn behave in this way if Most of it's configs are actually from RSSVE?

¯\_(ツ)_/¯ your guess is as good as mine... most of it's configs are from RSSVE, but they aren't all the same per say. I've gone in and fine tuned a ton of RSSVE by hand

 

Link to comment
Share on other sites

Posted (edited)
1 hour ago, ItsJustLuci said:

¯\_(ツ)_/¯ your guess is as good as mine... most of it's configs are from RSSVE, but they aren't all the same per say. I've gone in and fine tuned a ton of RSSVE by hand

 

@si2504aUmtN4k.png

I just went and looked, saturn does cast shadows... idk what's wrong with your install, but if nothing else 0.3 should fix this

 

Edited by ItsJustLuci
Link to comment
Share on other sites

10 hours ago, ItsJustLuci said:

@si2504aUmtN4k.png

I just went and looked, saturn does cast shadows... idk what's wrong with your install, but if nothing else 0.3 should fix this

 

I had RSSVE installed before this, do you think it may be necessary to delete a cache or something somewhere? 

Link to comment
Share on other sites

On 2/15/2021 at 2:41 PM, D0m1nu2 said:

It was tested only on 1.10 and I honestly dont think that it's gonna work on older version than 1.8.1. since also 1.8.1. might be broken so I reccomend you to get 1.8.1 or newer.

Yes, it works for 1.8.1, i have played on it and it doesnt have any problems. Also 1.10 wasnt any big update, so it didnt made any change to the modding code. (Modding style is still the same)

Link to comment
Share on other sites

On 5/5/2021 at 10:24 PM, fiderwolf said:

I had a similar problem.  This is how I managed to fix it.  If I used the files from the master I got the same problem that you have.  However, if I used the EVO folder that is downloaded from the 0.2a release page it works just fine.  No idea why that seems to work.  But when I did it this way, the clouds and the like loaded the way they are supposed to.  I don't know why this works.  However, it looks like the 0.2a release page is dated after the last date in the "master" zip folder so maybe one of the files got a minor update along the way.

 

 

Link to comment
Share on other sites

58 minutes ago, Galland1998 said:

I had a similar problem.  This is how I managed to fix it.  If I used the files from the master I got the same problem that you have.  However, if I used the EVO folder that is downloaded from the 0.2a release page it works just fine.  No idea why that seems to work.  But when I did it this way, the clouds and the like loaded the way they are supposed to.  I don't know why this works.  However, it looks like the 0.2a release page is dated after the last date in the "master" zip folder so maybe one of the files got a minor update along the way.

 

 

downloading the master is NEVER recommended as it is almost always unstable, and serves more as a place for me to store files, rather than a "latest version". Due to github LFS I can only update the master once a month, as I have bandwidth caps on that github repo

Link to comment
Share on other sites

1 hour ago, Palmput said:

Would you ever have plans to support Real Exoplanets? Gotta find some use for those late game Nertea engines.

this is just a visual overhaul for RSS so i dont see why they would need to add support for it.

Link to comment
Share on other sites

12 minutes ago, TruthfulGnome said:

this is just a visual overhaul for RSS so i dont see why they would need to add support for it.

They owe us nothing of course, just throwing it out there because I think it'd be cool.

Link to comment
Share on other sites

I've tried setting this up in a new 1.11 game, but I'm not seeing clouds or any other EVE features. When I open EVE's config panel I see "Invalid Name!" errors everywhere.

Capture-d-cran-2021-05-26-170727.png

Anybody has any idea why this would happen ? I'm using the latest build of EVE, Kopernicus etc installed via CKAN. Thanks!

Link to comment
Share on other sites

2 hours ago, Kinniken said:

I've tried setting this up in a new 1.11 game, but I'm not seeing clouds or any other EVE features. When I open EVE's config panel I see "Invalid Name!" errors everywhere.

Capture-d-cran-2021-05-26-170727.png

Anybody has any idea why this would happen ? I'm using the latest build of EVE, Kopernicus etc installed via CKAN. Thanks!

Invalid name has nothing to do with it; EVE is simply saying that you can't make a new cloud layer with the same name as another or, in the case of your photo, no name at all... regarding your issue, RSS does not even support 1.11, so EVO is not planned to support 1.11 anytime soon.

On 5/25/2021 at 1:16 AM, Palmput said:

They owe us nothing of course, just throwing it out there because I think it'd be cool.

:)

On 5/25/2021 at 7:40 AM, hypervelocity said:

I would definitely love some support for Real Exoplanets, and looking at CH4, it would be a great addition to potential near-future endgames.

so, as far as real exoplanets are concerned, my answer is that we are not likely to get support. Plainly put I don't use any other planet packs, so I have no interest in adding support. However EVO is an open source project, and if someone were to submit a pull request with files they've made, I would not be opposed to adding them to a "EVO-EXO" bonus download (or something like that)

Link to comment
Share on other sites

RSS does not officially support 1.11, but from what I've read on the topic it's supposed to work fine with the latest Kopernicus build. In my quick testing it did, I sent a rocket around Earth without any issues.

For EVO, if I click on one of the layer it does have a name but the issue remains the same:

Capture-d-cran-2021-05-26-195200.png

Link to comment
Share on other sites

2 minutes ago, Kinniken said:

RSS does not officially support 1.11, but from what I've read on the topic it's supposed to work fine with the latest Kopernicus build. In my quick testing it did, I sent a rocket around Earth without any issues.

For EVO, if I click on one of the layer it does have a name but the issue remains the same:

Capture-d-cran-2021-05-26-195200.png

I'm using RSS,RO,RP-1,EVO all on 1.11.1 with the Kopernicus BE. I guess what was meant is that it's not "officially" supported and bugs may occur on unsupported builds. The only issue I've had on mine is Saturn shadows but others have had that too, albeit I'm not entirely sure what version they are on.

Link to comment
Share on other sites

24 minutes ago, si2504 said:

I'm using RSS,RO,RP-1,EVO all on 1.11.1 with the Kopernicus BE. I guess what was meant is that it's not "officially" supported and bugs may occur on unsupported builds. The only issue I've had on mine is Saturn shadows but others have had that too, albeit I'm not entirely sure what version they are on.

Ok thanks for the answer, I'll try switching to Kopernicus BE then. 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...