Jump to content

EVO | Extreme Visual Overhaul for RSS | Beta 0.3 "Mostly Stable"


ItsJustLuci
 Share

Recommended Posts

8 hours ago, Spaceman.Spiff said:

Do you have Real Solar System?

This mod is only for that mod.

If you have RSS then you must have Kopernicus. 

And yes, without Scatterer and EVE, this mod would not function. That is why they are listed as dependecies.

Please read the OP before asking questions like this.

It answers all of them

yeah i have rss, i also have scatterer and kopernicus, i also have scatterer and eve configured to my rss savefile, all i have to do is replace rssve with evo right?

Link to comment
Share on other sites

Another quick update on what's to come in 0.2:

I fixed titan's atmosphere(idk if I've said that thus far) and I am looking into adding low altitude fog to it and to venus.

In other news, this: 

It's based on KSRSSVE's sandstorm configs but color, volume, opacity and a few other variables have been tweaked to make it look better w the new mars maps.  :)

Link to comment
Share on other sites

2 minutes ago, ItsJustLuci said:

Another quick update on what's to come in 0.2:

I fixed titan's atmosphere(idk if I've said that thus far) and I am looking into adding low altitude fog to it and to venus.

In other news, this: 

It's based on KSRSSVE's sandstorm configs but color, volume, opacity and a few other variables have been tweaked to make it look better w the new mars maps.  :)

¨First , btw that looks awesome

Link to comment
Share on other sites

Posted (edited)

Update: Good and bad news everyone...

8JIE19q.png

I got fog working on Titan and Venus, and it looks really good in my opinion
A2HELRR.jpg9E8JSNo.jpgrFKTzKT.png6O0LW7M.jpg

 

However in the process I also managed to get earth's land textures working and oh boy are they problematic... I have contacted @pingopeteand am trying to get them fixed, in the meantime they will be disabled (though, I don't think they were enabled to begin with) Here is a link to a gallery with a pair of images showing the current situation.

 

That said, I am using space engine assets now that I have permission to, meaning I might go ahead and make new earth textures, along with 64k clouds. Please don't hold your breath though, as this will not come until Alpha-v0.3 or later which will be a month or so out as I am in university right now . However in the meantime, I will slowly begin adding more and more content to this pack, thank you everyone for your patience :) it is thoroughly appreciated, and a huge confidence boost. my plan is to touch up a few more things and release 0.2 in the next week or two... This update will be far more stable and tested than 0.1 btw.

Edited by ItsJustLuci
Link to comment
Share on other sites

Luci, you are doing an absolutely gorgeous work! Take your time and let your creativity and ispiration play out! We are all grateful for this mod and rooting for you! Thank's a million for sharing with us!

BTW: that Titan fog is looking fiiiiiiiiiiine!!!

Edited by hypervelocity
Link to comment
Share on other sites

22 hours ago, ItsJustLuci said:

Update: Good and bad news everyone...

8JIE19q.png

I got fog working on Titan and Venus, and it looks really good in my opinion
A2HELRR.jpg9E8JSNo.jpgrFKTzKT.png6O0LW7M.jpg

 

However in the process I also managed to get earth's land textures working and oh boy are they problematic... I have contacted @pingopeteand am trying to get them fixed, in the meantime they will be disabled (though, I don't think they were enabled to begin with) Here is a link to a gallery with a pair of images showing the current situation.

 

That said, I am using space engine assets now that I have permission to, meaning I might go ahead and make new earth textures, along with 64k clouds. Please don't hold your breath though, as this will not come until Alpha-v0.3 or later which will be a month or so out as I am in university right now . However in the meantime, I will slowly begin adding more and more content to this pack, thank you everyone for your patience :) it is thoroughly appreciated, and a huge confidence boost. my plan is to touch up a few more things and release 0.2 in the next week or two... This update will be far more stable and tested than 0.1 btw.

The meme made me forget the bad news but looking godd cant wait (i dont rlly care about land textures much cuz i got katiss cape Canaveral which is a littly buggy with evo installed ) 

Link to comment
Share on other sites

13 hours ago, Rocketry101 said:

The meme made me forget the bad news but looking godd cant wait (i dont rlly care about land textures much cuz i got katiss cape Canaveral which is a littly buggy with evo installed ) 

I think Katniss' Cape Canaveral mod is of obligatory use when EVO is installed to avoid getting the city lights texture at night right over the KSC :D

Link to comment
Share on other sites

3 hours ago, hypervelocity said:

I think Katniss' Cape Canaveral mod is of obligatory use when EVO is installed to avoid getting the city lights texture at night right over the KSC :D

yeah... gonna go in and touch up the new 0.2 lightmaps and remove the cape before release probably

 

Link to comment
Share on other sites

On 2/15/2021 at 2:50 PM, ItsJustLuci said:

 

it works in 1.8.1 for some, my recommendation is to download the latest scatterer and EVE,  along w kopernicus bleeding edge and give it a shot but backup first... 1.10 is officially supported, but it should be back compatible according to some testers

as far as the sunflare, it's a known issue, I need to replace a file (I forgot to fix when renaming the main folder, used rssve as a base)  but for now if you want to you can replace RSSVE with EVO in the EVO/Configs/Scatterer_Configs/Sun/Sunflares/Sunflare.cfg file :) as far as the lights are concerned, I need to touch up the map a bit, and I am going to likely have a new city day texture thanks to @Katniss218 soon-ish

PS: sorry for the delayed response, livestreaming on twitch today

 

Any suggestions or ideas you could provide for this issue? the clouds just look odd and city lights are showing up during the day. I have already tried using the trick of pressing left alt+0 then going to the city lights section and hitting apply but that unfortunately didn't help.  At night the city lights do look incredible though.  Here is a screenshot showing what i mean. https://imgur.com/a/bVr4XCg

Which log file did you need to see exactly? I know there is a few and I'm not sure which one you'd need, so maybe you can tell me where that  would be in my KSP directory if you don't mind. Just let me know if there is anything else you need to know about my mod setup. Thanks a bunch in advance. I'd really love to get this working as it really does look pretty incredible

Edited by Unknown_Linux
addition to post
Link to comment
Share on other sites

1 minute ago, Musker Busker said:

mhm that happens in my mod too , still havent figured out how to fix it.

think I may have found my solution, but it is leading to problems with auroras... I had to set preserve cloud colors to false in scatterer

 

Link to comment
Share on other sites

Just now, ItsJustLuci said:

think I may have found my solution, but it is leading to problems with auroras... I had to set preserve cloud colors to false in scatterer

 

dm me more on discord

Link to comment
Share on other sites

On 3/18/2021 at 3:49 PM, Rocketry101 said:

I do not have cube map problem. Also when will Version 0.2 come out.

EDIT: please fix bootprints problem where the dont show up on any body, not even body they work on.

1. when it is ready.
2. this problem is likely because you don't have the required mods... review the install instructions and make sure you have kopernicus expansion continueder

On 3/18/2021 at 11:36 PM, planeguy868 said:

This looks incredible! Absolutely loving using it so far.

One question, though: I haven't been able to locate the TUFX profile mentioned in the changelogs - was it removed?

no, it is in an optional folder in the latest release

 

Link to comment
Share on other sites

On 3/16/2021 at 4:22 PM, ItsJustLuci said:

think I may have found my solution, but it is leading to problems with auroras... I had to set preserve cloud colors to false in scatterer

 

I had to do that to make it work on my install. Setting the aurora's transparency to a higher number in the cloud config file fixed the invisible auroras for me, though.

Edited by Hayhaa
Link to comment
Share on other sites

3 hours ago, ItsJustLuci said:


2. this problem is likely because you don't have the required mods... review the install instructions and make sure you have kopernicus expansion continueder

 

 

Um yes i do maybe i install kopernicus expansion contuineder incorrectly 

Link to comment
Share on other sites

5 hours ago, Hayhaa said:

I had to do that to make it work on my install. Setting the aurora's transparency to a higher number in the cloud config file fixed the invisible auroras for me, though.

the auroras in my working 0.2 install aren't invisible, they're black.... I have them disabled bc it just looks bad :(

 

4 hours ago, Rocketry101 said:

Um yes i do maybe i install kopernicus expansion contuineder incorrectly 

Double check. it only works on kopernicus bleeding edge btw (again, read the install guide for more details) so make sure you have that too. only planets officially supported as of right now are mars and the moon.

3 hours ago, Julian_S said:

https://imgur.com/a/LXxHNH0

Absolute Gamechanger this is! My KSP install has never looked better! :D

Glad to see it! when it works it works, sadly it's a bit of a stubborn toddler right now :P

Link to comment
Share on other sites

5 minutes ago, Minmus Taster said:

Bug:

Titan's atmosphere is just a THIC white line.

I think that’s due to a typo in Titan’s EVO scatterer config, referencing RSSVE instead of EVO. Found that myself a while ago and fixed it, with the correction it looks great.

Link to comment
Share on other sites

5 minutes ago, jimmymcgoochie said:

I think that’s due to a typo in Titan’s EVO scatterer config, referencing RSSVE instead of EVO. Found that myself a while ago and fixed it, with the correction it looks great.

Thank you.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...