Jump to content
  • 0

Main menu buttons not working because of the Kopernicus mod(bis)


Go to solution Solved by 4x4cheesecake,

Question

Hi, I have a problem with Kopernicus Bleeding Edge : the game lauches normally but when arriving on the main menu  all the buttons are not working. They change color when hovering or clicking like usual but nothing happens at all. I did try to remove my mods one at a time but it doesn't help I can't find the compatibility issue. Here's my list of mods :

-Chatterer

-Scaterrer

-IDFlags

-EVE with Boulder Co

-Astronomer's Pack

-Sigma (all I know is it's a dependency) 

-Parallax

-The Module Manager gave with the dl of Kopernicus

I believe all the mods are up to date exept AVP and IDFlags. I'm sure it's Kopernicus because of my testings. Can somebody help me with this or do I have to give up on Parallax ? Thanks for the support.

 

This post is a copy of a topic from december, I fear that nobody sees my recent reply on it so I permit myself to repost it. Here's the original link  :

 

Link to post
Share on other sites

13 answers to this question

Recommended Posts

  • 0
  • Solution
27 minutes ago, zazata990 said:

Here are the logs ; I didn't know what to put exactly so I put them all I think. If you need a pecular file not in the archive just ask me.

Absolut perfect, thank you :)

With you log, I was able to replicate the issue and found the solution pretty quick :)

I have a wild guess: you played this game like 6 years ago already or you used to run an old version of it? ;) Well, there is a mod .dll in your game which doesn't belong there:

D:\Programme Files\Steam\steamapps\steamapps\common\Kerbal Space Program\Plugins\CleverBobCat.dll

Remove it and the main menu buttons will work again. It belongs to a mod which is outdated since probably 6 years and shouldn't be in this directory anyway. This will not affect any of the mods you've installed.

To address some other issues:

1) Like I already said, you still got a conflict between BoulderCo and AVP. I assume you want to run AVP so just remove BoulderC, that should fix issues with the atmosphere and clouds.

2) There is a version discrepancy regarding kopernicus: you run the latest version of kopernicus (1.11.1-34) but not the latest version of ModularFlightIntegrator (1.2.9.0 instead of 1.2.10.0). This doesn't seem to cause any issues but you may want to reinstall it anyway, just to be sure :)

Link to post
Share on other sites
  • 0

First of all: BoulderCo and AVP are conflicting... probably not the reason for your issue but still, you should remove one of them.

I've got a question though: first you say, you cannot find the incompatibility issue by removing mods one at a time, but then you also say the reason must be kopernicus because of your test results... so what exactly are your test results? Do the buttons start working again if you remove kopernicus? Do they stop working when you install JUST kopernicus (+ module manager but at least without parallax)?
Which mod configurations lead you to the conclusion that kopernicus must be the culprit of your issue?

And, as always, a log file is much appreciated:

 

Link to post
Share on other sites
  • 0

Ok I was doing some other testings in order to answer Cheesecake and I think I fixed the issue. It was ModularFlightIntegrator gave with Kopernicus, I removed it from GameData and it was solve. What is this addon for ? Can I play whitout or will it make some problems ?

 

Link to post
Share on other sites
  • 0
2 hours ago, zazata990 said:

Hi, I have a problem with Kopernicus Bleeding Edge : the game lauches normally but when arriving on the main menu  all the buttons are not working. They change color when hovering or clicking like usual but nothing happens at all. I did try to remove my mods one at a time but it doesn't help I can't find the compatibility issue. Here's my list of mods :

-Chatterer

-Scaterrer

-IDFlags

-EVE with Boulder Co

-Astronomer's Pack

-Sigma (all I know is it's a dependency) 

-Parallax

-The Module Manager gave with the dl of Kopernicus

I believe all the mods are up to date exept AVP and IDFlags. I'm sure it's Kopernicus because of my testings. Can somebody help me with this or do I have to give up on Parallax ? Thanks for the support.

 

This post is a copy of a topic from december, I fear that nobody sees my recent reply on it so I permit myself to repost it. Here's the original link  :

 

1. Why are you using Bleeding Edge? Use this:

Parallax no longer needs Bleeding Edge now that the Stable branch of Kopernicus is now compatible with the latest versions, BE is now (paraphrasing @R-T-B here): Bug Testers Only! Do not use it unless you are particularly adventurous/careless/a trained QA tester. Use the version linked above. Also download the right Kopernicus version for your version of KSP,  using an incorrect version will result in Nyan Cat and possibly game breaking problems. If you're still using KSP version 1.10 (not 1.10.1) or 1.11 (not 1.11.1), get the the patcher from the KSP store and run it to update KSP. Kopernicus only supports bugfix releases of KSP now.

2. Why do you have both BoulderCo and AVP? As other posters have said, AVP conflicts with BoulderCo. AVP supplies its own textures and configs for EVE, so you don't need the default pack.

Edited by OrdinaryKerman
Link to post
Share on other sites
  • 0
1 hour ago, 4x4cheesecake said:

First of all: BoulderCo and AVP are conflicting... probably not the reason for your issue but still, you should remove one of them.

I've got a question though: first you say, you cannot find the incompatibility issue by removing mods one at a time, but then you also say the reason must be kopernicus because of your test results... so what exactly are your test results? Do the buttons start working again if you remove kopernicus? Do they stop working when you install JUST kopernicus (+ module manager but at least without parallax)?
Which mod configurations lead you to the conclusion that kopernicus must be the culprit of your issue?

And, as always, a log file is much appreciated:

 

So what exactly are your test results?

I ran the game with one mod removed at a time and I did all the list. The only mod that resolves the issue when removing it is Kopernicus (or ModularFlightIntegrator). Plus, it was working fine until I installed Parallax and Kopernicus at he same time. Also I did try random things like running in Admin or debugging the inputs with the f12 menu but nothing helped. When I launch with just Parallax and without Kopernicus the buttons work but obviously the game is bugged.

Do the buttons start working again if you remove kopernicus?

Yes.

Do they stop working when you install JUST kopernicus (+ module manager but at least without parallax)?

Yes.

Which mod configurations lead you to the conclusion that kopernicus must be the culprit of your issue?

Did I already answer ? If not what do you want exactly like info ?

Which log might help you exaclty ? Where can I find them ?

Link to post
Share on other sites
  • 0
7 minutes ago, OrdinaryKerman said:

Why are you using Bleeding Edge? Use this:

Parallax no longer needs Bleeding Edge now that the Stable branch of Kopernicus is now compatible with the latest versions, BE is now (paraphrasing @R-T-B here): Bug Testers Only! Do not use it unless you are particularly adventurous/careless/a trained QA tester. Use the version linked above. Also download the right Kopernicus version for your version of KSP,  using an incorrect version will result in Nyan Cat and possibly game breaking problems. If you're still using KSP version 1.10 (not 1.10.1) or 1.11 (not 1.11.1), get the the patcher from the KSP store and run it to update KSP. Kopernicus only supports bugfix releases of KSP now.

Actually I tried this version of Kopernic before BE, and it caused exactly the same problem. Also I realized that the scene of the menu was always the one in orbit (I never had the one on the Mun with this bug) and Kerbin behind has no athmosphere and really black clouds in the night side. I don't know how it can be useful but maybe it's a hint.

Link to post
Share on other sites
  • 0
32 minutes ago, zazata990 said:

Do the buttons start working again if you remove kopernicus?

Yes.

Do they stop working when you install JUST kopernicus (+ module manager but at least without parallax)?

Yes.

Okay, that's unexpected to be honest. Kopernicus doesn't do anything on it's own, it's actually parallax which tells kopernicus to apply new textures to the planets surfaces so running just kopernicus should not cause any issues at all.

30 minutes ago, zazata990 said:

Kerbin behind has no athmosphere and really black clouds in the night side. I don't know how it can be useful but maybe it's a hint.

Missing atmospheres and black clouds are usually an issue related to EVE and/or scatterer. Do you run the old EVE version for KSP 1.8 or the redux version for KSP 1.9 and above? Actually: which KSP version do you run?

I would still love to see the log file...that would answer all questions to versions of the game and mods, points out install and mod issues, and help just a lot in general to get a better understanding what's going wrong in your game :)

Link to post
Share on other sites
  • 0
42 minutes ago, 4x4cheesecake said:

Do you run the old EVE version for KSP 1.8 or the redux version for KSP 1.9 and above? Actually: which KSP version do you run?

I use the EVE Redux 1.11.2.1 running on KSP 1.11.3066x64 I believe. I downloaded the mod there :

 

Here are the logs ; I didn't know what to put exactly so I put them all I think. If you need a pecular file not in the archive just ask me.

http://www.mediafire.com/file/f8jm6l9ir92kwqe/Logs.zip/file

Link to post
Share on other sites
  • 0

Do you a have ModularFlightIntegrator in your GameData as well? It is a dependency, usually bundled with Kopernicus. Just asking, but I don't think this would be your issue.

Edited by KawaiiLucy
Link to post
Share on other sites
  • 0
3 hours ago, 4x4cheesecake said:

There is a mod .dll in your game which doesn't belong there.

It worked ! I don't know how tf this file ended up here. I removed it and everything is fine. Thanks a lot !

3 hours ago, 4x4cheesecake said:

You run the latest version of kopernicus (1.11.1-34) but not the latest version of ModularFlightIntegrator

I used the folder gave with the dl of Kopernicus. It's weird.

Link to post
Share on other sites
  • 0
19 minutes ago, zazata990 said:

It worked ! I don't know how tf this file ended up here. I removed it and everything is fine. Thanks a lot !

Glad to hear :)

19 minutes ago, zazata990 said:

I used the folder gave with the dl of Kopernicus. It's weird.

if it is the bundled version, it should be fine. I'm using CKAN to handle my mods and it installs a newer version of MFI for me.

Anyway, have fun playing some KSP :)

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...