Jump to content
  • 0

Contracts are disappearing at game restart.


Question

Please help. I'm loosing all contracts every time I restart the game. St the game startup, there are no contracts in the Mission Control. Neither available nore taken. All my taken tontracts just wipe away. I have to take control over any craft to make new contracts appear.

Game version 1.11.1

My mods:

Spoiler

FFSQiUh.jpg

 

Edited by [email protected]
Link to post
Share on other sites

2 answers to this question

Recommended Posts

  • 0
On 3/3/2021 at 9:53 PM, [email protected] said:

Please help. I'm loosing all contracts every time I restart the game. St the game startup, there are no contracts in the Mission Control. Neither available nore taken. All my taken tontracts just wipe away. I have to take control over any craft to make new contracts appear.

Game version 1.11.1

I am having the same issue. This includes starting new games, but even if I take control of things, contracts don't appear at all. Also, there are no strategies in the admin building, either.

My modlist is VERY simple, which helps narrow this down I hope: 
000_ClickThroughBlocker
KerbalEngineer
KerbalJointReinforcement
PreciseNode
TriggerTech

Of these, I strongly suspect the issue is with 000_ClickThroughBlocker, since it and PreciseNode were the two mods I installed just before the issue began, and [email protected] doesn't have PreciseNode on their modlist.

My issue began with PreciseNode's node editor window vanishing on me, not responding to the key to toggle it, and so I attempted to reinstall it.  After finding that it now hand a bunch of dependencies, including ClickThroughBlocker, I grabbed ClickThroughBlocker, which mentioned having its own dependencies updated through CKAN, so I installed CKAN as well.

Some or all of CTB, CKAN, and PreciseNode is almost certainly the culprit here, as I had a perfectly fine time until I tried to fix PreciseNode via the other two.

Meanwhile, KSP is now unplayable for me with those mods.

I deleted 000_ClickThroughBlocker, and contracts and strategies came back for me, however, the contracts I had accepted are still gone and cannot be recovered.  I will also post this information to the CTB thread.

Link to post
Share on other sites
  • 0
5 hours ago, qoonpooka said:

 

This was fixed by uninstalling KSP and starting over with a new install, using CKAN for mod managment. It meant the loss of PreciseNode, which no longer appears on the install list, but everything else worked.  The dev for CTB suggests that the issue stems from having manually installed mods and CKAN installed mods on the same KSP install. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...