Jump to content
  • 1

EVA Jet Pack not refilling w/ monopropellant


Question

I came across an odd event last night and wanted to see if anyone else has seen it. 

I believe this was the first EVA since starting 1.11.2; I had a kerbanaut run out of monoprop only moments after starting EVA. I restored and tried again, and this time checked the monoprop level immediately after sending her out. The resource showed only 0.26 units, instead of the usual 5. Boarding and returning to EVA didn't change the amount of monoprop in the pack - I had to change out her EVA pack with another kerbanaut on board.

I confirmed that there was plenty of monoprop available for the entire ship, including the Lander Can that she was exiting from, as well as electrical power. And as I recall, using the new pack, when I had her board (after jetting around a bit) and exit again, the monoprop resource showed it was full again (5.00 units). 

My impression was that EVA packs refill the moment the kerbanaut boards the vessel. Am I wrong? Or did this just change with 1.11.2 and I can't find it in the notes? 

Edited by maddog59
Link to post
Share on other sites

9 answers to this question

Recommended Posts

  • 1

It's a KSP bug that started in 1.11.0 I believe. It certainly did it in 1.11.1.  Sometimes the EVA pack refills automatically, sometimes not. I ran out of fuel myself once and have seen it happen several times. Now I try to remember to check when I leave. The workaround is to remove the pack and put it in another cargo slot, and then put it back in the kerbal's slot. That has always worked for me. 

That reminds me - we need to make sure this is in the KSP bug tracker. I didn't check yet. Entering those reports and voting them up might get them fixed eventually - discussing it here won't. 

Well, first we need to confirm it does it without mods but I'm sure it will.

Edited by Krazy1
Link to post
Share on other sites
  • 0
37 minutes ago, FruitGoose said:

Doesn't explain why it didn't refill but had you used it previously and had persistent loadout for kerbal inventory activated?  What about refilling with an Eva tank?

I'd definitely used her and her for several EVA's before, so that would explain why the level was so low on this excursion. I never thought to check the amount of monoprop each time, since they were very short excursions, and I thought the pack was refilling each time she came back aboard.   

I do have KIS, but I'm not familiar with 'persistent loadout' ... can you tell me where I can check for that? And I've never had occasion to look into refilling a pack from an EVA tank, so if you  don't mind telling me about that, I'd appreciate it. 

Link to post
Share on other sites
  • 0
12 minutes ago, maddog59 said:

I'd definitely used her and her for several EVA's before, so that would explain why the level was so low on this excursion. I never thought to check the amount of monoprop each time, since they were very short excursions, and I thought the pack was refilling each time she came back aboard.   

I do have KIS, but I'm not familiar with 'persistent loadout' ... can you tell me where I can check for that? And I've never had occasion to look into refilling a pack from an EVA tank, so if you  don't mind telling me about that, I'd appreciate it. 

"Persist kerbal inventory loadouts" is a thing in the difficulty settings. I think it's in the "advanced" section. AFAIK, it's from 1.11, not KIS.

Link to post
Share on other sites
  • 0
38 minutes ago, flyingshark said:

"Persist kerbal inventory loadouts" is a thing in the difficulty settings. I think it's in the "advanced" section. AFAIK, it's from 1.11, not KIS.

That persistent load out options just ensures that your Kerbals always carry the same equipment every time you use them.

Otherwise it always switches it back to an EVA/Parachute.

Link to post
Share on other sites
  • 0
1 hour ago, MechBFP said:

That persistent load out options just ensures that your Kerbals always carry the same equipment every time you use them.

Otherwise it always switches it back to an EVA/Parachute.

Ok, then I was wrong. Sorry. :)

Link to post
Share on other sites
  • 0
10 hours ago, Krazy1 said:

<snip> ...we need to make sure this is in the KSP bug tracker. I didn't check yet. Entering those reports and voting them up might get them fixed eventually - discussing it here won't. 

Looks like it's been entered: https://bugs.kerbalspaceprogram.com/issues/26944 ... as of a couple of months ago they thought it was fixed, and it's currently showing "80% done." I'm wondering if it snuck back in with 1.11.2. I added my comments to the bug report along with a link to this thread. 

Link to post
Share on other sites
  • 0

It's not exactly the same description but very close. They're talking about mods that change monoprop to another resource like nitrogen. I added a comment that this is happening in stock with monoprop. Thanks. 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...