Jump to content

[Min KSP 1.12.X] Sandcastle: 3D printing for parts and vessels


Angel-125
 Share

Recommended Posts

18 hours ago, Angel-125 said:

Please give 1.0.2 a try, that should clear up the description issues and let non-engineers drop the survey cones.

That all looks good to me, thanks.

Re: the cone explosion. I'd not used EL before (my brief dalliance with off Kerbin building was with Global Construction, which uses a significantly different method of targeting) and started with the simplest method to test, which is with a single origin marker. Without reading through the whole EL forum thread, I suspect that the reason you can use multiple markers to indicate the build location (an thus not have a marker directly under the vessel being built) was to prevent the issue I was having when building things that touch the ground at the centre. Using 2 (+X and -X) cones definitely solved the issue during my testing.

Link to comment
Share on other sites

On 1/27/2022 at 9:58 PM, flart said:

SandCastle + B9PS and no EL make B9 to have fatal error

MCtr0nL.png

ksp.log https://1drv.ms/u/s!Alncj27YxKc-iByV5zlPAkzj6nh_

Confirmed.  Also if you happen to be running BDB as well the B9 errors multiply by the hundreds.  I may be wrong but I think the B9PS cfg is trying to put an undefined resource type on every tank that has a B9PS module.

Link to comment
Share on other sites

18 hours ago, Friznit said:

Confirmed.  Also if you happen to be running BDB as well the B9 errors multiply by the hundreds.  I may be wrong but I think the B9PS cfg is trying to put an undefined resource type on every tank that has a B9PS module.

I should have a fix later this week.

4 hours ago, SkyFall2489 said:

Why do the ultra high capacity cargo containers have such a low heat tolerance. Makes putting them in SSTOs really annoying, especially in JNSQ...

Are you using them as parts of an SSTO, or as payload?

Link to comment
Share on other sites

13 hours ago, SkyFall2489 said:

Why do the ultra high capacity cargo containers have such a low heat tolerance. Makes putting them in SSTOs really annoying, especially in JNSQ...

Given their purpose (merely to hold cargo) it makes sense not to build them from costly, reentry-grade material. They're clearly not meant to be part of the exposed SSTO fuselage.

Now, granted their heat tolerance is 1000K, I do wonder what Angel was thinking, lol.

Link to comment
Share on other sites

Just now, JadeOfMaar said:

Given their purpose (merely to hold cargo) it makes sense not to build them from costly, reentry-grade material. They're clearly not meant to be part of the exposed SSTO fuselage.

Now, granted their heat tolerance is 1000K, I do wonder what Angel was thinking, lol.

MM Patch Time?

Link to comment
Share on other sites

On 2/1/2022 at 7:10 AM, JadeOfMaar said:

Given their purpose (merely to hold cargo) it makes sense not to build them from costly, reentry-grade material. They're clearly not meant to be part of the exposed SSTO fuselage.

Now, granted their heat tolerance is 1000K, I do wonder what Angel was thinking, lol.

Max temp matches that of the stock Hitchhiker. I did add in the missing "skinMaxTemp = 2000" in the latest patch to match that of the Hitchhiker as well. I also fixed the B9PS issue that happens when you don't have Extraplanetary Launchpads installed.

Here's the 1.0.5 patch:

- Fixed issue where B9 Part Switch would generate fatal errors if it is installed but Extraplanetary Launchpads isn't installed.
- Added missing skinTempMax to various parts.

Link to comment
Share on other sites

Does it work correctly with the KSPPartVolume?

The KSPPartVolume have :FINAL on all of its patches for adding ModuleCargoPart, but the WBIPrinterRequirements is depends on that and added before :FINAL

@PART[*]:HAS[@MODULE[ModuleCargoPart],!MODULE[WBIPrinterRequirements]]
{
    MODULE
    {
        name = WBIPrinterRequirements
    }
}

 

for example the part has ModuleCargoPart, but Sandcastle gave it some placeholder

vpKwvw1.png

Edited by flart
Link to comment
Share on other sites

@Yuubari_ SandCastle simply requires Ore, so can be easily patched to require any combinations of resources (and other allowed conditions), even per part (like with EL recipes). Most parts can require only MaterialKits, and others can require MaterialKits + SpecializedParts, and others still can require other parts + a minimum gravity threshold + a minimum atmo pressure threshold... And printers can have tech node limits (parts with certain tech requirements will demand another resource--forcing you to prepare tankage for that), print volume limits (a printer this size can print no bigger than this volume...) or part/category whitelist or blacklist (it can or cannot do only these...).

If you have a part modder friend who loves USI and Satisfactory (or you are this person), the gateway is wide open for you to develop an actual Satisfactory-like part+resource conversion chain gameplay.

The sky is the limit, now read the wiki and burst through into orbit.

Angel-125 isn't going to produce USI compatibility, before anyone asks.

Link to comment
Share on other sites

On 1/20/2022 at 12:46 PM, Hohmannson said:

76xGZdY.jpg

Wow, those panels are very versatile! Could you please make a thin-gridded or simply solid(like colliders of it) variant, so airstrips, colony's pads and stuff won't look strange?

Yeah, solid panels would be great! A few more colors would be nice too, but if there is no time for that, its OK/

Link to comment
Share on other sites

Sandcastle 1.0.6 is now available:

- Updated support for the latest version of Extraplanetary Launchpads.
- Added new ModuleMeshGrid part module (see below). This is in the experimental stage. Warranty void if used in your favorite save. You can find some parts to try out in the Sandcastle/Parts/Experimental folder. Just rename then to .cfg to give them a look.

RE solid panels: I'm looking into how to best do that. I've added some experimental parts using the yard frame models. You can check them out, but there are some bugs still, especially with the angled frames. If nothing else I can use the existing part grid module and build solid panels the reliable way, but I'd like to figure out how to get ModuleMeshGrid working well- it gives you unlimited grid size.

Link to comment
Share on other sites

im getting a weird sudo crash on latest version when useing the cone dispenser on a "conebot" (a micro rover made to drop cones) the first cone deploys correctly but when i place a 2nd one the game loads like you are loading in from VAB with the camera cliped under the KSC's launchpad (or runway if you originally used SPH) and if you load in to a vessel or spawn a new craft from editor (so use VSB/SPH) the game gets stuck (newest version of sandcastle and EL)

Edited by TOMMY (JEB 2.0)
needed more info
Link to comment
Share on other sites

2 hours ago, TOMMY (JEB 2.0) said:

im getting a weird sudo crash on latest version when useing the cone dispenser on a "conebot" (a micro rover made to drop cones) the first cone deploys correctly but when i place a 2nd one the game loads like you are loading in from VAB with the camera cliped under the KSC's launchpad (or runway if you originally used SPH) and if you load in to a vessel or spawn a new craft from editor (so use VSB/SPH) the game gets stuck (newest version of sandcastle and EL)

Does this happen without EL installed? If so, we may need @taniwha's help to diagnose.

Link to comment
Share on other sites

31 minutes ago, TOMMY (JEB 2.0) said:

ok so its not leting me load the save as the cone and cone deployer are disabled without EL

https://drive.google.com/file/d/1JtOTpGKqWjLlZtGZEmIUuO2azqKDZx3L/preview

hm, ok. I'd try reinstalling EL, and going to parts/Cargo/elSurveyCone and removing

    MODULE
    {
        name = ELSurveyStake
    }

See if that fixes the game loading issue. If that works and you can dispense survey cones, then the issue is in EL.

Link to comment
Share on other sites

12 minutes ago, Angel-125 said:

hm, ok. I'd try reinstalling EL, and going to parts/Cargo/elSurveyCone and removing

    MODULE
    {
        name = ELSurveyStake
    }

See if that fixes the game loading issue. If that works and you can dispense survey cones, then the issue is in EL.

yes, the cones spawn as intended with that removed

Link to comment
Share on other sites

On 2/14/2022 at 2:18 AM, TOMMY (JEB 2.0) said:

im getting a weird sudo crash on latest version when useing the cone dispenser on a "conebot" (a micro rover made to drop cones) the first cone deploys correctly but when i place a 2nd one the game loads like you are loading in from VAB with the camera cliped under the KSC's launchpad (or runway if you originally used SPH) and if you load in to a vessel or spawn a new craft from editor (so use VSB/SPH) the game gets stuck (newest version of sandcastle and EL)

I'll need the FULL KSP.log file (because knowing what to look for takes a lot of experience, and without the log file, even I couldn't say just what to look for). However, having the debug console up and typing something into the command line (so it shows in the log) just before causing the problem is a big help, especially for a "this one works, this one doesn't" situation.

Link to comment
Share on other sites

On 2/15/2022 at 6:47 AM, taniwha said:

I'll need the FULL KSP.log file (because knowing what to look for takes a lot of experience, and without the log file, even I couldn't say just what to look for). However, having the debug console up and typing something into the command line (so it shows in the log) just before causing the problem is a big help, especially for a "this one works, this one doesn't" situation.

https://github.com/taniwha/Extraplanetary-Launchpads/issues/182#issuecomment-1042068380

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...