Jump to content
  • 0

CommNet breaking in GPP


Jebediah Kerman Jr.
 Share

Question

A lot has changed since I last posted here. I've now set myself up with a PC and installed a number of mods, including Galileo's Planet Pack (which is terrific, by the way). The pack adds many new outer planets, unreachable with stock antennas, so one of the R&D nodes adds antenna upgrades for the Communotron 88-88 (the umbrella one) and the largest of the relay dishes, which are now rated for 1.00T instead of just 100G. Ever since I researched this node, the CommNet just breaks every time I launch a vessel from the VAB. The craft on the launchpad has no connection to the space center whatsoever. I go to the Tracking Station and the CommNet lines are gone. The logs are absolutely filled with spam, but here's one section:

[EXC 19:26:17.574] ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection. Parameter name: index System.ThrowHelper.ThrowArgumentOutOfRangeException (System.ExceptionArgument argument, System.ExceptionResource resource) (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0) System.ThrowHelper.ThrowArgumentOutOfRangeException () (at <ad04dee02e7e4a85a1299c7ee81c79f6>:0) PartModule.ApplyUpgradeNode (System.Collections.Generic.List1[T] appliedUps, ConfigNode node, System.Boolean doLoad) (at <2afc64dea36946459d4707808bdac511>:0) ModuleDataTransmitter.CommPowerUnloaded (ProtoPartModuleSnapshot mSnap) (at <2afc64dea36946459d4707808bdac511>:0) CommNet.CommNetVessel.UpdateComm () (at <2afc64dea36946459d4707808bdac511>:0) CommNet.CommNetVessel.OnNetworkPreUpdate () (at <2afc64dea36946459d4707808bdac511>:0) CommNet.CommNode.NetworkPreUpdate () (at <2afc64dea36946459d4707808bdac511>:0) CommNet.Network.Net4[_Net,_Data,_Link,_Path].PreUpdateNodes () (at <2afc64dea36946459d4707808bdac511>:0) CommNet.Network.Net`4[_Net,_Data,_Link,_Path].Rebuild () (at <2afc64dea36946459d4707808bdac511>:0) CommNet.CommNetwork.Rebuild () (at <2afc64dea36946459d4707808bdac511>:0) CommNet.CommNetNetwork.Update () (at <2afc64dea36946459d4707808bdac511>:0) UnityEngine.DebugLogHandler:LogException(Exception, Object) ModuleManager.UnityLogHandle.InterceptLogHandler:LogException(Exception, Object) UnityEngine.Debug:CallOverridenDebugHandler(Exception, Object)

The post linked below details a similar issue, but doesn't give a solution to the problem.

Can anyone help me fix the problem?

Edited by Jebediah Kerman Jr.
Link to comment
Share on other sites

1 answer to this question

Recommended Posts

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...