Jump to content

Protractor - Rendezvous Plugin - Under New Management!


Recommended Posts

Questions about how to use protractor.

Once you have selected a planet, you are on circular orbit, inclination 0°, heading 90 or 270, You are suppose to wait till Théta (1st column) comes to 0°, Then if you have click on "Adjust Phi", you should burn when Phi is at 0, if you don't have selected "adjust Phi", you have to arrange your burn so that When Phi is at 0 you have burnt 2/3 of the DV required. Is that correct?

For me that runs for Duna, Dress, Eve. For the other planets, When Theta comes to 0°, my Phi angle is between 340° and 300° so that I have to wait a long time before beginning burn, which means that at beginning of burn The Theta angle is less than 0°, let's say around 359,5 sometimes far less than that, it decreases rapidly and the result is that I don't come close enough the planet I aimed and the intercept needs many many DV more....

So the question is in this case, do I burn when Theta is 0°, no matter how is Phi?

Link to post
Share on other sites

I'm sad. I've done two transfer burns to Duna, and yet the always end up 2 GM away at closest.

I don't know why. Protractor works just fine every time, except now. Both stock and mods.

And another thing, Eeloo I can't seem to get to. I burn, but I need another 4 km/s before an encounter.

Link to post
Share on other sites
I'm sad. I've done two transfer burns to Duna, and yet the always end up 2 GM away at closest.

I don't know why. Protractor works just fine every time, except now. Both stock and mods.

And another thing, Eeloo I can't seem to get to. I burn, but I need another 4 km/s before an encounter.

Still working great for me...you shouldnt leave an encounter up to the transfer burn alone. One you transfer wait till your about 1/3 along your new orbital path, and do a little course correction.

Link to post
Share on other sites
It seems to be having difficulties. Some moons and planets don't even appear in the list any more. Not sure why though.

Seems the same planets and moons don't show in Kerbal Alarm Clock when setting alarms for transfer windows.

Link to post
Share on other sites
  • 2 weeks later...

Sorry guys, for some reason I stopped getting e-mail updates when the thread got posts. Coupled with a busy work schedule, I haven't checked back in a while.

RenatsMC: Yes it works in career mode. See the previous three pages for more details.

Kass: The planets are not exactly hard coded. It pulls a list of bodies from the game. The only thing that is hard coded are the colors, but it defaults to white for bodies that aren't in a pre-generated color list. However, depending on how RSS (I think that's the real solar system mod? I'm not really up on mods anymore) works, it might make changes to that list or use a separate list that the mod is not querying properly, hence Protractor not showing all the bodies. I can't say for sure without knowing how RSS does whatever it does.

KerbMav: I'm not quite clear on what your question is. Can you clarify?

Link to post
Share on other sites

KerbMav: It shouldn't, unless you have loads of pods and probes all in one place at the same time, in which case you have bigger concerns with resources than Protractor.

diomedea: I'd love to. I can't make any promises though. Real life demands have put constraints on development of the plugin outside of keeping it patched with new KSP versions. New features are, unfortunately, on the back burner for now. Consequently, it could be quite some time before I get around to implementing that, unless someone else wants to take a crack at it first.

Link to post
Share on other sites

diomedea: I'd love to. I can't make any promises though. Real life demands have put constraints on development of the plugin outside of keeping it patched with new KSP versions. New features are, unfortunately, on the back burner for now. Consequently, it could be quite some time before I get around to implementing that, unless someone else wants to take a crack at it first.

Thanks for your kind answer. Understand, RL always takes precedence.

I would like to have a look towards implementation of the toolbar with your mod (just trying to see if the approach used by other mods works, I can't figure yet most things with modding for KSP), however it seems GitHub has a problem (page not found, 404) with showing me the page where your source code should be (yes, I have an account there).

Link to post
Share on other sites
Thanks for your kind answer. Understand, RL always takes precedence.

I would like to have a look towards implementation of the toolbar with your mod (just trying to see if the approach used by other mods works, I can't figure yet most things with modding for KSP), however it seems GitHub has a problem (page not found, 404) with showing me the page where your source code should be (yes, I have an account there).

https://github.com/mrenigma03/protractor

Link in the OP was outdated, sorry.

Link to post
Share on other sites

I'm still around but out of town without access to my machine to patch anything. I didn't have time to update and test before leaving, but initial accounts pointed to the mod still working as usual post KSP update. For you guys having problems, can you describe what is happening? Are you certain you have unlocked it in the tech tree if you are trying to use it in campaign?

Link to post
Share on other sites

UAL002: The plugin is open source and features a very generous license. Accordingly, I welcome patches to implement the community toolbar. Unfortunately, other real life commitments at the moment prevent me from having the time to add new features myself right now.

I just rebuilt Protractor with the KSP 0.23 references and confirmed that it is working in the latest version of 0.23. If you were having problems before, try a clean install with the latest version from SpacePort.

Link to post
Share on other sites
This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...