Jump to content
  • 0

Rover just floats in place when decoupled[Solved with MM patch]



The bug turns out to be with cubic/octaginal struts since the eva building update. Will have to wait for a fix from the community or an official patch.

Problem: I am trying to make a more compact rover which has the small long hinge as its base(the G-01L) and when the root part is not on the rover it will just hover in the air after decoupling. The craft file was made on an older save with mods but still shows the bug. Even once I remade the rover after completely uninstalling my game, reinstalling it, verifying the integrity of files, and on a new save file I still have the same problem.  


I believe that the hinge is what is causing the problems as most of the robotic parts from Breaking Ground are buggy.


Video of Problem: 



CraftFile: https://drive.google.com/file/d/1kbWxFVAL32fbiE6-nxCN8hSyw01YPC84/view?usp=sharing


When checking the ingame console I saw that the following was being repeated indefinitely until I reverted flight or quit the game, this of course is in the player.log.

dT is NaN! tA: NaN, E: NaN, M: NaN, T: NaN
  at System.Environment.get_StackTrace () [0x00000] in <ad04dee02e7e4a85a1299c7ee81c79f6>:0 
  at Orbit.GetDTforTrueAnomaly (System.Double tA, System.Double wrapAfterSeconds) [0x00000] in <06f13185617646e5bc801baeab53ab75>:0 
  at PatchedConics._CalculatePatch (Orbit p, Orbit nextPatch, System.Double startEpoch, PatchedConics+SolverParameters pars, CelestialBody targetBody) [0x00000] in <06f13185617646e5bc801baeab53ab75>:0 
  at PatchedConicSolver.Update () [0x00000] in <06f13185617646e5bc801baeab53ab75>:0 
(Filename: C:\buildslave\unity\build\Runtime/Export/Debug/Debug.bindings.h Line: 35)



Edited by RYU AZUKU99
Solved with an unofficial MM patch, still bugged in main game.
Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

A user by the name of OHara recently commented on the bugtracker with a temporary solution in the form of a module manager patch. He wrote:

"We can avoid this problem with a Module Manager patch

@PART[*]:HAS[#PhysicsSignificance[1],#attachRules[*,*,1,*,*]] {
    @PhysicsSignificance = 0

On four parts that could become root parts (FL-A5 adapter, cubic strut, octagonal strut, and BZ-52 radial attachment) but which got special treatment, this removes the special treatment.
'PhysicsSignificance' seems backwards as a name; when it is set to 1 for a part, KSP lumps that part's mass into the parent part, and doesn't simulate physics for the PhysicsSignificance=1 part. For thermometers, that means new players don't need to worry about balancing the mass of every thermometer, which is nice for a game. But I would have expected the structural pieces have their own mass."

I used Notepad++ , copied and pasted the bold text into a new file and saved as a .cfg, then placed it into my gamedata folder. Worked like a charm!

Link to comment
Share on other sites

  • 0

This could be a bug that appeared with EVA construction (bug-tracker link) where a decoupled sub-craft doesn't get its physics simulated, if the root of the decoupled sub-craft is a cubic strut or hexagonal strut.  (Those two structural parts, like thermometers and small surface-mount parts, are excluded from the physics simulation,)h So far the only suggestion in the bug-tracker about avoiding the bug is to re-arrange parts around the decoupler so some other part ends up the root of the sub-craft.

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...