Jump to content
  • 0

Multiple Game-Breaking Issues with JNSQ Install (through CKAN, 1.11.2 modded)


BadModder54
 Share

Question

Good day! I've been putting together a nice customized install for my newest JNSQ playthrough. My system has 16GB of RAM, and is technically able to handle everything. However, the issues soon arise. First off, the game will not load without a database reload, as the loading itself stops with a System.Reflection.ReflectionTypeLoadException. After the database reload which only takes a few minutes, the game can continue to the main menu... kind of. The game loads, but all you can see is Kerbin and the three Kerbals, without any Scatterer features or the main menu buttons and title ever popping up. The music also stutters badly, and my entire PC has actually locked up before due to this. It required a hard restart. I found this error in the logs, which may be related to this. However, if at all relevant I must mention that all of these mods were installed by CKAN, which is not exactly known for allowing incompatibilities.

[LOG 22:26:50.143] EVEManager: Issue loading PQSManagerClass! Error: UnityEngine.UnityException: Unable to apply node! ---> System.NullReferenceException: Object reference not set to an instance of an object

This is so far, the extent of the major, game-breaking issues. I have here the KSP.log and the ModuleManager logs from my final session while troubleshooting. I also have a screenshot of the full modlist, if it helps at all. Thank you for your time, please get back to me if possible!

 

KSP.log: https://www.dropbox.com/s/q0w8hjrl07u5soy/KSP.zip?dl=0

ModuleManager Log: https://www.dropbox.com/s/9humx2cttby5864/ModuleManager.zip?dl=0

Mod List: https://www.dropbox.com/s/57i534iip6zf3it/image (1).png?dl=0

Link to comment
Share on other sites

3 answers to this question

Recommended Posts

  • 0

Too many mods could be a factor- cut anything you don’t absolutely have to have to ease the load on your PC.

Maybe, instead of trying to force the game to load after an exception is thrown, you should find the cause of the exception and remove the mod(s) responsible.

Link to comment
Share on other sites

  • 0

Unfortunately I can’t open the log on my phone as too big but had a quick look through MM one. 

Obviously there’s a lot of memory intensive mods there which might be causing the lagging. However you do have a few patches that can’t be applied because you are missing dependencies. I also saw 4 x MiniAVC mentions (these are to do with version checking) but this is known to be buggy now. There is a mod that disables them all by default (or i just delete them manually).

The EVE nre and lack of Scatterer obviously points to issues with those although looking at your mod list it doesn’t look like you have EVE installed? Just EveEngines. If it’s bundled in something else, that may have not been updated.

Link to comment
Share on other sites

  • 0

Hi there! 

 

1. I actually had to do that, as the game just does not seem to like that many things installed. Didn't help the errors though, I actually abandoned the install entirely as JNSQ was no longer loading.

2. I did have both EVE and Scatterer funnily enough, but the planet pack stopped loading altogether. I'm a very busy person, and I simply do not have time to debug such a mess of an install. But thank you anyway!

Link to comment
Share on other sites

This thread is quite old. Please consider starting a new thread rather than reviving this one.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...